Jump to content

Recommended Posts

Bonjour, pour faire fonctionner pokemongo sur mon  S4 mini, il faut android 5.0... hors samsung n'a pas été plus loin que 4.4.2...

Quelles solutions pour faire fonctionner cette application du coup ?
Tout en sachant que l'appareil ne peut pas être rooté pour y jouer...

J'ai vu des tutos, mais j'ai pas trop confiance du tout car les gens affiche un S4,  alors que moi c'est un mini S4
 

Share this post


Link to post
Share on other sites

De quel modèle précis est-ce qu'on parle (voir dans paramètres > à propos) : GT-I9190 ? GT-I9195 ? autre ?

Le modèle le plus répandu (GT-I9190) a des firmwares non-officiels (LineageOS) jusqu'en Android 9.0

LineageOS n'est plus rooté d'origine comme l'était Cyanogenmod. Donc après installation cela ne posera pas de problème.

En revanche pour l'installer il faudra sans doute rooter ton firmware actuel, ou du moins faire des actions qui feront passer le flag Knox à 0x1 (si cela existait déjà sur le S4 Mini ? pas sur). Est-ce que Pokemon Go accepte de fonctionner sur un appareil avec Knox à 0x1 ? je l'ignore.

De même est-ce qu'il fonctionne sur LineageOS ? je l'ignore aussi, mais une simple recherche Google "Pokemon Go LineageOS" doit donner la réponse assez rapidement je pense.

Share this post


Link to post
Share on other sites

Alors il y a aussi des LineageOS pour ce modèle, mais plus en "officiel" (relativement parlant, puisque par définition LineageOS n'est pas le firmware officiel, le seul officiel venant de Samsung). Voir https://wiki.lineageos.org/devices/serranoltexx qui donne quelques infos mais pas de liens de téléchargement.

Ce site https://www.lineageosrom.com/2018/09/download-lineage-os-16-for-samsung_47.html donne des liens de téléchargement vers ici https://www.mediafire.com/folder/o4cxf3pl2ibax/lineage-16.0

Il y a aussi un sujet sur XDA qui couvre les différents modèles ici https://forum.xda-developers.com/galaxy-s4-mini/orig-development/rom-lineageos-16-0-s4-mini-t3833063

Mais avant de se lancer, il faudrait déjà savoir si Pokemon Go accepte de tourner sur une LineageOS + Google Apps. Et ça je l'ignore.

Share this post


Link to post
Share on other sites

Au pire je peux me lancer ,  si pokemongo ne fonctionne pas,  pas je reviens en etat d'usine :)

Mais concernant le root,  cela se passe comment ?
Car pokemongo n'accepte pas les tel rooté :/

Concernant le Gapps,  je dois prendre lequel sur cette page ? 
https://www.lineageosrom.com/2018/08/download-gapps-for-android-pie-9.html

Edited by neojoey

Share this post


Link to post
Share on other sites

Il n'est même sans doute pas nécessaire de rooter ton appareil pour y installer LineageOS. Il suffit d'y flasher un recovery custom (TWRP ou équivalent) ce qui peut se faire avec Heimdall (cf. le wiki cité plus haut) ou Odin  (voir un autre guide ici https://www.cyanogenmods.org/forums/topic/download-lineage-os-16-for-galaxy-s4-mini-lte/)

Et après installation, LineageOS n'est pas rooté par défaut.

En revanche le problème v-a-v de Knox existe bien sur le S4, voir https://forum.xda-developers.com/showthread.php?t=2750744

Knox passera forcément à 0x1 après installation de TWRP et LineageOS. Est-ce un problème pour Pokemon Go ? je ne sais pas.

Attention c'est totalement irréversible, même repasser sous firmware Samsung ne remettra pas Knox à 0x0. Donc autant en être sûr avant !

Share this post


Link to post
Share on other sites

Knox est un "fusible" logiciel que met Samsung dans ses smartphones. Ce fusible "saute" (passe à la valeur 0x1) lorsque tout o/s ou portion d'o/s (recovery) d'origine non-Samsung est installé sur le smartphone. C'est irréversible.

Il est possible pour une application de savoir si ce fusible est à 0x0 ou 0x1. Certaines refusent de fonctionner sur un appareil avec Knox à 0x1 car elles considèrent que l'appareil n'est plus "fiable". J'ignore si c'est le cas de Pokemon Go ou pas.

Pour les Gapps, il faut la version ARM (pas ARM64) en Pico ou Nano.

 

 

 

Share this post


Link to post
Share on other sites

merci, 
enfin... je suis pas plus avancé,  les liens pour les gapps ne fonctionnent plus on dirait , =>  "error 404"
---
 

Share this post


Link to post
Share on other sites

twrp installé, mais je suis bloqué :

partition système non modifiée.
Conserver le systeme de fichier en lecture seule ?
twrp peut laisser votre partition systeme non modifiée pour rendre plus facile les mise a jour officielles
twrp sera incapable d'empecher la rom d'origine de remplacer twrp et ne pourra pas vous proposer de rooter votre appareil

que faire ?  
j'ai en dessous de ce texte un rectangle gris avec titre "conserver la lecture seule" (qu'on sais appuyer dessus) car à sa droite, il y a le meme pour changer la langue
et en dessous du rectangle gris, j'ai  un rectangle bleu et triangle blanc qu'on sais faire glisser vers la droite pour autoriser les modifications

Mon idée serait d'autoriser les modifcations,  pour qu'il me propose de rooter,  si j'ai bien compris ...
Mais je préfère demander avant de faire une bétise

Edited by neojoey

Share this post


Link to post
Share on other sites

Autorise les modifications. Encore une fois le but n'est pas de rooter mais d'installer LineageOS dont tu as mis le zip sur la carte SD, n'est-ce pas ?

 

Share this post


Link to post
Share on other sites
1 hour ago, neojoey said:

Le zip de ?
twrp  ou le zip de lineage ?

De LineageOS comme je le disais plus haut.

1 hour ago, neojoey said:

ant qu'a faire je met le lineage et gapps sur carte SD ,  non ?

Effectivement, c'est la bonne façon de procéder, décrite dans les dizaines de tutos d'installation de LineageOS que tu trouveras en ligne

Exemple parmi tant d'autres en vidéo, s'applique à un autre modèle mais la procédure est la même :

 

 

Share this post


Link to post
Share on other sites

Echec
erreur 7
aucun fichier md5 trouvé
no file context
this package is for device serranolte serranoltetebmc serranolttektt  serranoltexx

Share this post


Link to post
Share on other sites

Comme ça au pifomètre je dirais que ton TWRP est trop ancien pour un LOS 16.0

Lequel as-tu installé ? (lien)

Ca ne sert à rien d'essayer tous les zips de LOS. Ce n'est pas eux le problème.

Share this post


Link to post
Share on other sites

j'ai installé le LTE  ( erreur)

https://androidfilehost.com/?fid=24499762636003167
 

je viens d'installer le 3G variant : (meme erreur)

https://androidfilehost.com/?fid=24499762636003165
 

Après il reste celui ci : https://androidfilehost.com/?fid=24499762636003166 

 

D'apres ce site  galaxy s4 mini (serranoxx) https://www.cyanogenmods.org/twrp-recovery-download-for-samsung-devices-list-of-supported-devices/ 

il ne m'en reste plus qu'un à tester,  si ca va pas,  ben c'est mort en fait ?

 

 

Edited by neojoey

Share this post


Link to post
Share on other sites

aucun des 3 ne fonctionnent,  apres...  en suivant la video, formater le systeme...  ben j'ai plus rien mdr,..  je ne comprend pas trop pourquoi faire cela.

Heureusement que j'ai une rom officiel samsung.... I9195XXUCNE6

Share this post


Link to post
Share on other sites
21 hours ago, neojoey said:

GT-I9195
je l'ai remis etat usine avec wipe data et reset factory

Tu m'as annoncé ce modèle qui est le modèle 4G (LTE c'est pareil)

Share this post


Link to post
Share on other sites

bon voila,  c'est réussi...

lineage installé,  pas rooté...

pokemongo fonctionne,

ca chauffe,  mais je pense que cela est a cause du jeu,  donc faudra éviter d'y jouer en été mdr...

JE te dis un grand merci pour ta patience...

Y a t'il des choses à faire attention ,  à eviter dans l'avenir ?

Share this post


Link to post
Share on other sites

A la bonne heure, tu y es arrivé sans que je te prenne par la main plus que cela. Félicitations. La prochaine fois tu sauras faire :biggrin:

Et de rien.

1 hour ago, neojoey said:

Y a t'il des choses à faire attention ,  à eviter dans l'avenir ?

Comme ça, je ne vois pas trop. J'avoue ne pas très bien savoir comment LOS se met à jour (patches de sécurité). Une petite recherche rapide semble montrer que ça fonctionne en OTA (online, automatique).

Je pense que le matériel ancien du S4 mini est vraiment poussé à ses limites par LOS 16.0 (= Android 9.0). Ne pas essayer d'aller au-dela (si jamais ça devait sortir)

Bons jeux...

Edited by Ultrix

Share this post


Link to post
Share on other sites

Est-ce que le téléphone accroche le signal opérateur ou pas ? tu peux téléphoner ?

Si oui, c'est sans doute juste une question de reconfiguration des APN pour ton opérateur.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...