Jump to content

[TUTORIAL] Installer le Firmware Global Generic 2.1 [Toutes versions]


Recommended Posts

Je conseille a tous ceux qui sont tombés sur ce tuto d'utiliser flashtools, ce tutoriel est un peu vieux dorénavant!!! :)

La 2.1 GENERIC GLOBAL!!!

>>> http://www.multiupload.com/9N5BJ7II13 <<<

C'est le firmware officiel, sans aucune customisation de pays!!! :)

Il est plus rapide, et, au moins, "propre"!!!

En 1.6, j'ai testé au moins 8 firmware différents et fait des tests pour savoir lequel marchait le mieux, et c'est le global généric qui restait le mieux!!!

J'ai alors depuis dimanche la 2.1 nordique, et depuis qq jours, la global generic, gros changements j'ai trouvé, plus de custom bizarre (avec des produits suédois :D), et j'ai veritablement l'impression qu'elle est plus réactive!!!

Méthode:

Comme habituellement, décompressez le fichier dans C:/, et lancez "X10flash.bat"...

Puis suivez les instructions!!! ;)

PS: le "flash mode" consiste a retreindre le X10, et appuyer sur la touche retour en le connectant au pc... :)

En cas du célèbre problème du Deviceid, copiez le votre dans le fichier texte appelé: "DeviceID.txt" (remplacez le mien, déjà éxistant!!!)

Pour trouver le Deviceid :

Le DeviceID est l'identification du téléphone sur l'ordinateur.

Il permet à windows, ou autre logiciels, de trouver le X10 quand il est branché.

Pour le trouver, executez "regedit", et allez dans édition > et recherchez "USB\VID_0FCE&PID_ADDE"

Il va trouver un résultat du type: "USB\VID_0FCE&PID_ADDE\6&37308c9c&0&1" (si il ne le trouve pas, cliquez sur rechercher le suivant...)

Copiez la clé en gras, et collez la dans le fichier DeviceID.txt présent dans le dossier.

ATTENTION, il peut y avoir plusieurs DeviceID, testez les autres si le premier ne marche pas... :)

Pour les erreurs JAVA :

Vous avez ce problème récurent dû à 80% au moins à votre système d'exploitation : Vista ou 7 !

JAVA : https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Developer-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef=jre-6u22-oth-JPR@CDS-CDS_Developer (version windows, prenez 32bits!!!)

(Lien direct: http://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Developer-Site/en_US/-/USD/VerifyItem-Start/jre-6u22-windows-i586.exe?BundledLineItemUUID=37KJ_hCw_0sAAAEsGvoAHLtj&OrderID=EAGJ_hCwkcgAAAEs9vkAHLtj&ProductID=mCuJ_hCyot8AAAEri7RGXQzG&FileName=/jre-6u22-windows-i586.exe)

Télécharge directement la version commune aux systèmes 32bits et 64bits.

Vous devez IMPÉRATIVEMENT désactiver l'UAC, aussi appelé "contrôle de compte utilisateur".

Pour ceux en Vista ou Win 7 IL FAUT DÉSACTIVER L'UAC, le contrôle de compte utilisateur afin qu'on soit tout le temps en administrateur !

Pour cela, il faut aller dans : Panneau de configuration, Comptes d'utilisateurs, Modifier les paramètres de contrôle de compte utilisateur. Il faut baisser la réglette à fond, c'est-à-dire NE JAMAIS AVERTIR !

Ensuite redémarrer

Pour ceux qui possèdent Windows 7 64bits:

Vous devez ajouter ceci à la fin de ce que vous avez dans votre "path" :

;C:\Program Files (x86)\Java\jre6\bin

N’oubliez pas de valider l’opération !

Le path s’obtient comme cela :

« Panneau de configuration \ Système et sécurité \ Système » puis dans la colonne de gauche cliquez sur « Paramètres système avancés », une fenêtre s’ouvre, cliquez en bas à droite sur « Variables d’environnement… ».

Une nouvelle fenêtre s’ouvre avec 2 fenêtres internes, ne vous occupez que de la deuxième. Faites défiler l’ascenseur jusqu’à ce vous obteniez « Path », il est généralement entre « OS » et « PATHEXT ».

N’oubliez pas de valider l’opération !

Pour les erreurs JAVA de type:

java.io.IOException: Unable to open channel, GetLastError=0
       at com.sonyericsson.cs.usbflashnative.impl.USBFlashNativeImpl.openChanne
l(Native Method)
       at X10flash.main(X10flash.java:410)
Exception in thread "main" java.lang.NullPointerException
       at java.lang.String.<init>(Unknown Source)
       at X10flash.testPluged(X10flash.java:103)
       at X10flash.run(X10flash.java:375)
       at X10flash.main(X10flash.java:417)

Merci de renseigner le DeviceID adéquate dans le fichier DeviceID.txt,

Pour ceci, il faut avoir au moins une fois fait reconnaitre votre Xperia en FLASH MODE par SEUS!!!!!

Source: XDA!!! (Et Merci à OddEssA et Eagle4 ;) )

Edited by malabarth
Link to comment
Share on other sites

  • Replies 583
  • Created
  • Last Reply

Top Posters In This Topic

C'est la 2.1 que j'ai installée et nickel, elle marche du tonnerre :lol:

par contre le root, j'ai pas réussit, j'ai fait avec la méthode superoneclick v1, le root se lance, me met rooted et ensuite me dit root failed à la fin :mad:

si vous avez une solution ;)

Edited by calou68
Link to comment
Share on other sites

Installation nickel sans soucis, merci :)

Alors dès le début franchement j'ai le menu qui est nickel fluide alors que même 3 jours après avoir mis le Nordic il laguait encore ...

Donc ça déjà c'est positif :)

Mais j'ai encore et toujours ce problème "d'envoi impossible" de sms sans arrêt ... Suis-je le seul ? Ça devient vraiment pénible là ...

Edited by Magni
Link to comment
Share on other sites

Merci ça a marché du premier coup pour moi.

Ne pas flipper si le téléphone met quarante ans à demarrer :)

Il faut préciser aussi :

Attention, surtout ne paniqué pas si un « appareil photo » venait à apparaitre, il suffit juste de le laisser travailler pendant environ 5 minutes puis le téléphone va reboot / redémarrer tout seul comme un grand ;)

Parce que moi j'ai un peu paniqué.

Edited by Miscine
Link to comment
Share on other sites

C'est la 2.1 que j'ai installée et nickel, elle marche du tonnerre :lol:

par contre le root, j'ai pas réussit, j'ai fait avec la méthode superoneclick v1, le root se lance, me met rooted et ensuite me dit root failed à la fin :mad:

si vous avez une solution ;)

Perso à voir les messages d'erreurs je pense que tu as soit oublié d'activer le mode débogage (possible qu'il se désactive une fois l'usb branché, le réactivé avec l'usb branché), soit tu as "monté" la SD card, perso j'ai mis en mode alimentation et j'ai plus rien touché après même si il me le re-demandait après.

Link to comment
Share on other sites

:rolleyes: il suffit juste de lancer le x10flash.bat... c'est aussi simple que ça ? :rolleyes: :rolleyes: :rolleyes: :rolleyes: c'est vraiment un progrès :D par contre il faut aussi désactiver L'UAC ou pas maintenant ? (perso pas envie j'ai la flem de redémarrer mon pc xD )

Edited by mouths91
Link to comment
Share on other sites

Merci ça a marché du premier coup pour moi.

Ne pas flipper si le téléphone met quarante ans à demarrer :)

Il faut préciser aussi :

Parce que moi j'ai un peu paniqué.

Idem, je me suis dit c'est quoi le rapport appareil photo avec une flèche qui vas sur l'appareil :rolleyes: Et en réfléchissant un peu je me suis dit c'est simple : ça veut dire que ça flash la rom (appareil photo/flash toussa...)

Link to comment
Share on other sites

:rolleyes: il suffit juste de lancer le x10flash.bat... c'est aussi simple que ça ? :rolleyes: :rolleyes: :rolleyes: :rolleyes: c'est vraiment un progès :D par contre il faut aussi désactiver L'UAC ou pas maintenant ? (perso pas envie j'ai la flemem de redémarrer mon pc xD )

Sous win7 64bits je l'ai désactivé sinon ça bug un peu ^^" Genre ça te demande des droits en plein script donc ça plantait le script chez moi :/

Link to comment
Share on other sites

je suis noob , quel est la procedure exact pour mettre mon xperia en 2..1 generic grace a ta methode?

Bah noob c'est pas un argument pour dire je sais pas lire un tutorial... Si tu lis tout les tutorials ici => , tu seras plus un noob, et surtout ça te permet aussi de mieux connaitre ton téléphone.

Il n'y as aucuns intérêt à réécrire un tutorial en réponse, alors qu'il existe déjà.

Link to comment
Share on other sites

Si, on t'a dit qu'il suffit juste de lancer le ".bat" et laisser faire ...

Tu save toutes tes données, tu active le mode Debug usb de ton X10 (paramètres => développement => débogage usb), tu l'éteind, tu lances le ".bat", tu choisi ton OS de ton ordi, et tu branche ton X10 en mode flash (c'est à dire tu restes appuyer sur la touche retour, tu le branche, et quand le led s'allume, tu laches retour et t'appuies sur une touche de ton clavier), et le flash se lance.

Sinon, personne a le bug d'envoi impossible de sms comme moi ? Je ne trouve aucune solution ...

Link to comment
Share on other sites

Non il est allumer je l'utilise j'aime pas redémarrer mon pc xD sauf quand je m'ennuie sur mon pc... (ce qui est très rare !! vraiment :D) bref si on sent vraiment la différence je le fais juste apèrs ma série ^^.

Ce qui me fou les nerfs c'est que je dois re rooté et réinstaller le JIT mais bon c'est simple donc je prendrais 10 minutes et pis c'est tout xD

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...