Jump to content

Root Samsung Spica


t-vk

Recommended Posts

Merci beaucoup pour ce tuto.

Mais, chez moi, pas moyen, Odin détecte le téléphone mais reste bloqué à l'étape de connexion....

J'ai essayé avec ou sans la carte SD, avec ou sans les croix cochées de "mode debug", "stockage de masse", et est réinstallé plusieurs fois le pilote..........

Peut être est ce à cause de mon Os: Windows Seven X64 ?

Je n'ai malheureusement que des ordis sous ce système sous la main....

D'autres ont aussi ce problème?

Je viens juste d'éditer le tuto, reprends le tout et relances le tout en mode administrateur pour Odin (clic droit > lancer en mode admin)

^^ Normalement cela devrait sufire

Link to comment
Share on other sites

  • Replies 90
  • Created
  • Last Reply

Top Posters In This Topic

Je viens de tester sous windaube séveune 64.

Démarche à suivre donc : désinstaller tout. Oui, TOUT.

1) Commencer par redémarrer le pc. Ensuite, n'installer que NPS 1.4.

2) Reboot du pc

3) Désactiver le contrôle des comptes utilisateurs (UCA), reboot en mode administrateur

3) Connecter le téléphone, il installe les drivers. Reboot en mode admin encore.

4) Re prendre le tout à l'étape où il faut allumer le toaster en flash mode.

Pensez bien à lancer Odin en mode admin, et désactivez tout ce qui ressemble à un windaube defender/Antivirus actif...

Si cela ne fonctionne pas, on retente (enlever la batterie, rallumer en mode normal, re-éteindre, rallumer en flash mode, etc...) au moins une dizaine de fois (c'est ce que j'ai fait).

Si au bout de dix fois cela ne fonctionne toujours pas, mettez-vous à genoux, levez les mains vers le ciel et pleurez. Ou installer windows xp ou seven x86 ? (franchement le nombre de gens sous OS x64 sans même savoir pourquoi ils sont sous architecture 64bits, ça devient hallucinant, même si là je suis complètement hors sujet)

Au pire vous pouvez aussi demander à votre grand-mère qui tourne encore sous windows xp de vous prêter l'ordi deux minutes, non ?

Link to comment
Share on other sites

J'y ai pensé, mais c'est un portable Dell très glossy........ Si je peux m'éviter des traces dessus :p

Sinon, je viens de tester le widget pour over/downclocker le processeur. Il a pas l'air d'aimer le double processeur du binz....

Wifi tether ne fonctionne pas non plus.......

Pas encore très utile ce root(age) ^^

Dernier point, il me semblait que le mode root permettait de supprimer les logiciels installés de base dans le téléphone. Quelqu'un sait comment le faire?

J'arrive pas à dégager Myspace et la vieille version de Facebook.......

Link to comment
Share on other sites

En ce qui concerne le widget d'over/down clock, il fonctionner très bien pour moi. Le wifi tether je ne l'ai pas encore testé mais j'ai un problème avec l'application quickboot qui ne reconnais pas le root du toaster. Après, pour supprimer les logiciels pré-installés, je suis en train de rechercher, s'il n'y a pas de tuto déjà présent sur le forum, j'en ferais ptêt un ici ^^

Sans quoi, je sais pas ce que vous en pensez, mais il serait bien d'avoir des modos ici, histoire d'épingler ce post en tant que Tuto, pour le spica, à moins d'en faire un tout nouveau tout beau tout neuf avec marqué en gros "Tuto" en lettres clignotantes ?

Link to comment
Share on other sites

Apparemment les applications de tethering ne fonctionnent pas, mais j'ai trouvé une alternative plutôt pas mal (on peu aller sur le net au moins via le toaster quoi ^^) :

Proxoid.

Je pense qu'il doit manquer un truc soit au spica de base, soit à notre méthode de root. Je vous tiens au courant.

Bien à vous.

Link to comment
Share on other sites

Bonjour,

est ce que quelqu'un a essayé toute cette procédure via Odin à partir d'un Linux+Wine ??

je trouve la méthode assez hasardeuse en fait...mais devant l'insuccès du lancement de TerminalEmulator (une erreur de signature) sur le Spica (un blocage de BT ???) et le même insuccès de le faire reconnaitre par adb sur Linux...je ne sais comment m'y prendre afin d'avoir enfin cet accès root sur mon Spica...

En ce qui concerne la suppression des applications par défaut (qui est ce que je recherche), mes moultes égarements sur le net m'ont amené à ca (les utilisateurs linux ne devraient pas être dépaysés):

.Rechercher l'appli à enlever, pour cela, vous pouvez passer par un file manager (style ASTRO) et lancer une recherche sur tout le phone (à partir de /sdcard, cliquez sur l'icône "UP") avec le mot clé ".apk"

.Repérer le chemin d'accès (du style /system/app/appli_a_enlever.apk)

.Lancer une console (via TerminalEmulator, que je n'arrive pas à installer sur le Spica cause erreur de signature)

.Prendre les droits ROOT (commande "su")

.Monter la partition avec les droits d'écriture -> "mount -o rw,remount /system"

.Et suppression du programme via la commande "rm" -> "rm -r /system/app/appli_a_enlever.apk"

Edited by tecknhub
Link to comment
Share on other sites

Le risque le plus évident est le brick du téléphone (un peu comme les très agréables blue screens de windaube), rendant le toaster inutilisable.

Ceci dit, j'ai déjà vu personnellement beaucoup de galaxy rootés et brickés partir en SAV (je bosse chez BT) et ils sont tous revenus "réparés". La bonne nouvelle c'est que Samsung remet tout le logiciel de base. La mauvaise c'est qu'ils envoie un joli petit papier disant en gros "on est pas dupe on sait que vous avez tenté de bidouiller, mais comme on peut rien prouver on vous le répare quand même".

La mauvaise c'est qu'un de mes clients a déjà tenté de le renvoyer deux fois pour un brick suite à tentative de root (à mon avis il s'y prenait avec des moufles), et que la deuxième fois Samsung lui a facturé ladite réparation dans les 150 euros...

Donc ça marche une fois, mais pas deux.

Link to comment
Share on other sites

Désoler du double message mais j'ai un petit problème Odin ne détecte pas du tout mon spica!

Donc je l'ai mis en flash mode (sur l'écran y une petite disquette bleu et écris Download...).

J'attends un petit peu, mon pc sous vista reconnait le spica il installe les drivers, je lances Odin mais rien!

Edit:

Il a fini par le reconnaitre mais j'ai ce message:

Download Start...

<0> Create File...

<1> StartThread Detected : 1

<2> StartThread Detected : 0

<3> StartThread Detected : 0

<4> StartThread Detected : 0

<5> StartThread Detected : 0

<6> StartThread Detected : 0

<7> StartThread Detected : 0

<8> StartThread Detected : 0

<1> Begin Thread..

<1> Engine RUN!!!

<1> e - dll cannot open the usb serial port. code: 87

Screen (plus parlant):

1262180673727.jpg

Merci de votre aide

Edited by oandroid
Link to comment
Share on other sites

en faite il y a quelques fichiers interressants

init.rc

init.spicia.rc

recovery.rc

factorytest.rc

fota.rc

Personnellement pour le moment je ne préfères pas toucher à ces fichiers.

@oandroid :

Ce que je trouves bizarre, c'est que tu aies toutes ces lignes, sur les pcs pour lesquels j'ai installé les drivers (sur 4 OS différents). Je serais toi, je désinstallerais tout, mais vraiment TOUT, et je recommencerais de manière propre en installant NPS 1.4, puis en reprenant tout le tuto depuis le début.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...