LoïcLeDuault

Android x86 custom build

Recommended Posts

dans ce sujet je vais partager mes compilation custom de android x86

je par des sources et ajoute patch pour prendre en charge d'autre matériel

si vous compiler vous même des version custom de androix86 vous pouvez aussi les poster ici

j'ajoute également le market et quelque application utile a l'utilisation d'android sur PC

ok pour prochain build :

travail en cours/a faire : prise en charge des clavier azerty, prise en charge du sons et wifi sur dm1

DERNIER BUILD

hp_dm1 20120203

amd_brazos 20120122

eeepc 20120122

asus_laptop 20120122

____________________________________________________________________

BUILD 20120203

changements : le langage est régler par Default en français, le clavier virtuel est en azerty

hp_dm1

BUILD 20120129

changements : mise en veille regeler sur 30 minutes par défaut, nouvelle devices (hp_dm1), le clavier physique fonctionne maintenant

hp_dm1

BUILD 20120122

changements : suppression des apps en double, ajout de l'application "rotation locker" pour blocker l'affichage en mode paysage

amd_brazos

eeepc

asus_laptop

BUILD 20120120

depart des sources + patch ethernet + patch wifi (prend plus de matériel en charge mais pas encore tout)

amd_brazos

eeepc

____________________________________________________________________

BUG CONNUT:

-plantage l'ors de la mise en veille sur certainnes les machinne

pour reduire ce probleme allez dans parametre>affichage>veille>apres 30 minutes d'inactiviter

puis dans option pour les developeur cocher rester activé

____________________________________________________________________

Tutoriel d'installation:

la meilleur methode pour installer android-x86 et la plus simple est d'utiliser une clé usb et le logiciel "lili"

télécharger lili sur sont site officiel http://www.linuxliveusb.com/

télécharger le fichier android de votre choix

executer "lili" l'interface ressemble a sa http://www.linuxliveusb.com/images/stories/screenshots/2.jpg

configurer comme ceci :

-step 1 choisissez votre clé usb

-step 2 clicker sur img/iso/zip et selectionner le fichier iso

-step 3 rien a toucher ici la pertinance n'est pas comatible avec android

-step 4 cocher seulement la case "format the key in FAT32 ..."

-step 5 clicker sur l'eclaire et laisser faire

quand votre clee est prete le navigateur ce lance sur une page du site de "lili"

il ne vous reste plus qu'a booter sur la clé

vous pouvez alors choisir de tester android depuis votre clé usb (sans rien changer sur votre PC)

ou d'installer android a coter de windows en multiboot

ou meme a la plasse de windows en temps qu'OS unique

Modifié par sololonnais

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai testé tes build j'ai reussie a faire marché la version eeepc sur marchine viruel je teste demain sur mon pc.

si non elle marche bien il y a quelque bug mais c'est peut etre parce que je suis sous machine viruel

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai pas de son , probleme avec les video mais peut etre que c'est parce que je suis sous machine vituel

parcontre imposible a lancé sur mon pc

Partager ce message


Lien à poster
Partager sur d’autres sites

pour le sons sous virtualbox c normale, pour l'install sur pc tu a bien suivit le tuto?

tu sait booter sur une clee usb avec ton pc? (il faut souvent faire F2 F8 F9 ou encor echap selon le pc lorsqu'on l'alume)

Partager ce message


Lien à poster
Partager sur d’autres sites

le pc boot sur la clé je clique pour lancé l'os sa charge et apres plus rien

en tout cas de se que j'ai testé il est vraiment mieux que les autre version

Partager ce message


Lien à poster
Partager sur d’autres sites

dans ce cas tu doit pas avoir le bon iso essaye avec les autes

la version asus_laptop est celle qui est compatible avec le plus de pc

Modifié par sololonnais

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour à tous!

cela fait un petit moment que je suis tes avancées et je dis bravo pour ton travail sololonnais.

j'ai un hp dm1 4033SF et j'ai testé ton avant dernière build brazos qui marche relativement bien (j'arrive pas downloader la dernière).

dommage que le wifi et le son ne fonctionnent pas.

je ne suis pas assez calé en linux & co pour compiler ou autre, mais j'avais tester la version android x86 honeycomb (3.2) sur mon dm1 et si le wifi ne marchait pas non plus, la camera quant à elle fonctionnait contrairement à ICS !

il y a a peut être un truc à regarder de ce coté là pour ton éventuelle prochaine build.

Bon j'espère qu'un jour le wifi d'android marchera sur cette machine.

@+

Partager ce message


Lien à poster
Partager sur d’autres sites

dans ce cas tu doit pas avoir le bon iso essaye avec les autes

la version asus_laptop est celle qui est compatible avec le plus de pc

je les est déja testé mais la seul qui fonctione c'est la eeepc

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

pour ceux qui recherchent une image Android sous VirtualBox, ils peuvent utiliser celle-ci :

http://www.buildroid.org/Download/android-x86-vm-20120125.iso.gz

Qqs fonctions qui marchent en plus par rapport à une version "générique" :

- Le son

- L'état de la batterie se met à jour (bon OK pas super utile mais bon...)

- Le timeout de l'écran est à 30 mins par défaut (même pb que cité plus haut)

Il n'y a pas le patch "ethernet ICS" qui circule mais une config DHCP par défaut.

Le post sur mon blog qui présente ça : http://www.buildroid.org/blog/?p=86

Partager ce message


Lien à poster
Partager sur d’autres sites

bien jouer pour ta version VB dfages c'est une bonne alternative au multiboot et bien plus interessant que le live

tu doit connaitre un peut peutetre peut tu aider pour les probleme de sons et de wifi sur hpdm1 4033sf (encor faut t'il que tu est ce matos)

pour l'instant pas de nouvelle build car rien de nouveau que ce soit du coter des sources ou du coter des groupe de discutions google, rien de nouveau! de mon coter je fait quelque teste mais rien de bien intéressant pour l'instant

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

je n'ai pas le matos concerné...

Par contre voici qqs idées pour voir à régler le pb du son.

1. Qu'est-ce que donne la commande "cat /proc/asound/cards" ?

Si la carte son n'apparaît pas il manque le driver noyau.

2. Si la carte son apparaît bien, que donne la commande "cat /etc/asound.conf" ?

Il faut que la bonne carte (card0, card1, ...) soit référencée en fonction de ce qu'a donnée "cat /proc/asound/cards"

3. Si OK, que donne la commande "alsa_amixer" ?

Il est possible (c'était le cas pour vbox) qu'un des "mixer control" important soit désactivée (pour VBox, il s'appelait PCM).

Si c'est le cas qqchose comme ce qui suit devrait régler le pb :

alsa_amixer set PCM on

alsa_amixer set PCM 100

Pour le Wifi, de quel chipset il s'agit ?

Dan.

Partager ce message


Lien à poster
Partager sur d’autres sites

ok je vais regarder sa merci

pour le wifi je sait pas trop j'ai poster la config detailler du pc ici => http://forum.frandro...-hp-dm1-4033sf/

cat /proc/asound/cards donne

0 [generic]: HDA-intel - HD-Audio Generic

HD-audio generic at 0xf0340000 irq 42

1 [sB ]: HDA-intel - HDA ATI SB

HDA ATI SB at 0xf0340000 irq16

et alsa_amixer dit no found!

Modifié par sololonnais

Partager ce message


Lien à poster
Partager sur d’autres sites

OK bonne nouvelle le driver audio est là.

Par contre le support ALsa nesemble pas compilé.

Est-ce que tu as quelquechose comme "BOARD_USES_ALSA_AUDIO := false" dans le fichier BoardConfig.mk ?

Ou alors un "BOARD_USES_GENERIC_AUDIO := true" ?

Dan.

Partager ce message


Lien à poster
Partager sur d’autres sites

non j'ai

BOARD_USES_ALSA_AUDIO ?= true" et "BOARD_USES_GENERIC_AUDIO ?= false"

bizar dans le mien c'est pas : mais ? je'ai remplasser et je teste

la sa al'aie de compiller bizard j'ai plein de ? la ou devrai avoir des :

Modifié par sololonnais

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est bon.

Tuà as des ? au lieu des : ça veut juste dire que la variable est positionnée seulement si elle n'existe pas déjà. Donc ça devrait marcher...

Tu veux partager le contenu de ton répertoire device/xxx/yyy (remplacer xxx/yyy) pour que je jete un outil ?

Partager ce message


Lien à poster
Partager sur d’autres sites

le voila en fichier join mais il utilise les fichier du generic

la je compil pour un ptit moment j'ai eu la mauvaise idée de faire un make clean !

plutot que dutiliser amd_brazos j'ai cree un HP_DM1 sa serra plus simple au passage je vais faire de new teste donc nouvelle build dans le weeck end

sinon pour le wifi dans android pour le wifi j'ai sa

firmware/rtlwifi/

rtl8192cfw.bin

rtl8192cufw.bin

rtl8192defw.bin

rtl8192sefw.bin

rtl8712u.bin

pour ubuntu (la ou le wifi marche)

j'ai sa

rtl8192sfw.bin

rtl8192sfw74.bin

rtl8192sfw492.bin

j'ai copier les fichier de ubuntu dedan mais je trouve rien qui referrence les ancien fichier dans la config dans le but de changer

Modifié par billcat74

Partager ce message


Lien à poster
Partager sur d’autres sites

bonsoir

je viens de telecharger la version tegra pour mon dell inspiron duo.

j'ai telechrge lili

j'ai dezippe

je lance lili mais je dois choisir le fichier. j'ai 3 images :

initrd

install

ramdisk

et un dossier isolinux

j'ai essaiye les 3 images mais a chaque fois l'etape 5 me marque une erreure

je suis sous windows 7

merci

Partager ce message


Lien à poster
Partager sur d’autres sites

le fichier que tu "dezip" sa neserrait pas un fichier iso???

c'est lui qu'il faut choisir avec lili faut pas le dezipper!

pour ma compil de cette nuit c'est bizar apres un make clean et une recompilation l'iso fait 198MO au lieu de 300 et quelque la derniere fois!

sinon j'ai un peut avancer le clavier physique fonctionne enfin (il est encor en qwerty mais je suis dessu)

le clavier physique est maintenan configurable en azerty

toujours pas de news sur le sons et le wifi malgres plusieur tentative

Modifié par sololonnais

Partager ce message


Lien à poster
Partager sur d’autres sites

je viens de tester android 4 sur le dell duo

ca se lance sans probleme

le clavier physique n'est pas reconnu

le market fonctionne

la navigation internet ne fonctionne pas

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

Ca projet m'a l'air intéressant, j'imagine que ca fonctionne également sur eeepc 900 ?

Mais est-ce que le wifi fonctionne aussi avec ce matériel ?

Et est-il possible de n'avoir que ics comme "os" je veux dire sans dual boot, ou de "live-boot" ?

D'avance merci

Partager ce message


Lien à poster
Partager sur d’autres sites

avec la version eepc sa devrai marcher au top

oui tu peut te passer du multiboot pour garder en OS unique

il te suffi de formater ton disque dur en ext3 sans besoin de cree d'autre partition

tu peut le faire pendan l'install

Modifié par sololonnais

Partager ce message


Lien à poster
Partager sur d’autres sites

c'est une bonne nouvelle !

Mais un petit tuto serait le bienvenu... Ne fut-ce que pour le formater en ext3 (en ce moment il est sur xp), après j'imagine qu'on boot sur une clé usb ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant