Aller au contenu
lebartman

[Tuto] Rooter son XPERIA P sous ICS (bootloader vérouillé)

Recommended Posts

ok, il faut flasher un kernel inférieur

puis rooter via un fichier bat

puis reflasher le dernier kernel

____________

2 questions:

Avec FLASHTOOL, on doit utiliser la méthode de flash "FLASHMODE" ?

Et en flashant ces KERNEL, on perds les data des programmes ?

Partager ce message


Lien à poster
Partager sur d’autres sites

ok, il faut flasher un kernel inférieur

puis rooter via un fichier bat

puis reflasher le dernier kernel

____________

2 questions:

Avec FLASHTOOL, on doit utiliser la méthode de flash "FLASHMODE" ?

Et en flashant ces KERNEL, on perds les data des programmes ?

Rien perdu, tout va bien

En fait j'ai fait la mise à jour avec Sony Update service puis

Flash 6.1.B.0.599_Kernel via FlashTool

- Reboot then run Root_with_Restore_by_Bin4ry

- Flash 6.1.1.B.1.54_Kernel via FlashTool

Au top, 30 min chrono

Partager ce message


Lien à poster
Partager sur d’autres sites

est-ce qu'il faut cocher ou decocher le "wipe data" a chaque fois que l'on flash le kernel ?

Partager ce message


Lien à poster
Partager sur d’autres sites

WIPE DATA--> décoché

WIPECACHE--> décoché

WIPE app log->> décoché

tout les exclude coché SAUF le KERNEL ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

ok merci, avec ma febrilité, je n'avais pas selectionné le kernel en question dans flashtool, et il n'y a rien à par "KERNEL" qui n'est pas coché...

Donc j'ai flashé en 3s le kernel inférieur ; ok

je redémarre le téléphone, et là PAF l'écran d'accueil qui bug et donc je ne peux pas lancer le fichier BAT pour appliquer le ROOT car je ne peux pas lancer le programme APP&RESTAURE...

j'ai remis le bon kernel via PCCompagnon, recommencé 3 fois, et toujours le même resultat

j'ai même re-télécharger les fichiers...

Jcomprend pas et là jvais mcoucher car il se fait tard... ou tot

bonuit

Partager ce message


Lien à poster
Partager sur d’autres sites

installe provisoirement un autre launcher et met le par defaut avant de flasher l'ancien kernel...peu etre que lui ne posera pas de problème :)

Partager ce message


Lien à poster
Partager sur d’autres sites

ouf, bonne idée ;)

J'ai déjà eut ce soucis lors du dernier rootage en aout.

Imaginez, un cadre tout noir, et faut taper à l'aveuglette le code PIN, mais la, le launcher plantai.

Même avec un launcher alternatif, c'était tout noir.

Puis une fois le ROOT terminé, tout est redevenu normal

Merci et have fun

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est peut-être parce que tu as des applications sur l'une des pages du Home qui nécessite le root ?

Partager ce message


Lien à poster
Partager sur d’autres sites

ok merci, avec ma febrilité, je n'avais pas selectionné le kernel en question dans flashtool, et il n'y a rien à par "KERNEL" qui n'est pas coché...

Donc j'ai flashé en 3s le kernel inférieur ; ok

je redémarre le téléphone, et là PAF l'écran d'accueil qui bug et donc je ne peux pas lancer le fichier BAT pour appliquer le ROOT car je ne peux pas lancer le programme APP&RESTAURE...

j'ai remis le bon kernel via PCCompagnon, recommencé 3 fois, et toujours le même resultat

j'ai même re-télécharger les fichiers...

Jcomprend pas et là jvais mcoucher car il se fait tard... ou tot

bonuit

J'ai le même soucis que toi

As-tu reussi a le rooter ?

A++

Modifié par tigrou51

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai eu le même problème, mais pas eu de besoin de lancer le restaure depuis le téléphone.

Tout le monde doit arriver là avec Bin4ry:

"Please take your device, open Backup and Restore App from Menu. Select the backup named RootMe and restore it!

If all is successful i will tell you, if not this shell will run forever.".

J'avais le même problème que vous, ça m'a gavé :) j'ai forcé un reboot du téléphone "vol+" + "power" (sans fermer la fenêtre DOS)

Lors du reboot Bin4ry a repris la main, a affiché plein de truc dont :

"You can close all open command-prompts now!

After reboot all is done! Have fun with Root!

Bin4ry

Press any key to continue . . ."

Tout est nickel

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai pas compris t'as pas eu besoin de lancer l'application de restauration sur ton téléphone ?

au reboot, il a fait le nécessaire tout seul ?

t'es sûr que le root fonctionne ?

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai pas compris t'as pas eu besoin de lancer l'application de restauration sur ton téléphone ?

au reboot, il a fait le nécessaire tout seul ?

t'es sûr que le root fonctionne ?

Oui c'est ça, c'était pas volontaire à l'origine mais gavé j'ai rebooté et voila. Oui oui root ok pas de problème.

J'avais rien à l'écran donc impossible de le faire manuellement. juste la barre d'icone en haut.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut

J'ai également suivi le premier tuto avec Bin4ry et tout à l'air de fonctionner comme c'est écrit sur celui-ci, mais il n'y aucune trace de l'application superuser après le reboot... Je ne pense donc pas qu'ils soit rooté. De plus, lorsque je clique sur "restauration" le chargement n'effectue pas vraiment (la jauge ne se remplie pas) mais au bout de quelques secondes le téléphone reboot quand même.

Mon numéro de build est 6.1.1.B.1.54 est-ce que le problème pourrait venir de là ?

Je n'ai juste pas envie de perdre mes données en routant mon XP :emo_im_undecided:

Partager ce message


Lien à poster
Partager sur d’autres sites
Salut

J'ai également suivi le premier tuto avec Bin4ry et tout à l'air de fonctionner comme c'est écrit sur celui-ci, mais il n'y aucune trace de l'application superuser après le reboot... Je ne pense donc pas qu'ils soit rooté. De plus, lorsque je clique sur "restauration" le chargement n'effectue pas vraiment (la jauge ne se remplie pas) mais au bout de quelques secondes le téléphone reboot quand même.

Mon numéro de build est 6.1.1.B.1.54 est-ce que le problème pourrait venir de là ?

Je n'ai juste pas envie de perdre mes données en routant mon XP :emo_im_undecided:

Tu perd rien en rootant ton mobile, cest juste un acces administrateur sur ton mobile, d ailleur cela devrait etre dispo en option dans les options dev...

Bin4ry fonctionne bien mais sur le kernel de la build 110 va voir ma chaine youtube jai fait un post ou tuto dans ma signature idem que sur sola

tapatalked

Partager ce message


Lien à poster
Partager sur d’autres sites

Ma méthode pour le root pour la version 6.1.1.b.1.54 :

- être avec le build 6.1.1.b.0.544

- faire le root avec la méthode Bin4ry ou Flashtool

- faire la mise à jour OTA avec le centre de mise à jour de Sony et vous gardez le root

Méthode testée et approuvée par moi :)

PS : Pour Dragnxt, il existe pas le build 6.1.1.b.1.10 pour le Xpéria P ;)

Modifié par LeFab

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok tanpi, bon courage, je sors -_-

tapatalked

Partager ce message


Lien à poster
Partager sur d’autres sites

Non, ne sors pas c'est juste une petite précision, la méthode reste la même et ta vidéo est trés bien pour le P aussi.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

J'essaie depuis 3 jours de rooter mon Xperia P avec la méthode de Bin4ry et ca ne marche pas ! Mon portable ne redémarre qu'une seule fois et ca me marque "mount : permission dernied <are you root ?>"

Pourtant le débogage USB est connecté, les sources exterieures a l'Android Market sont autorisées, et j'ai installé PC Companion et Update service

Pour info :

Version d'Android 4.0.4

Version du noyau 3.0.8+

Numéro de build 6.1.1.B.1.54

Pouvez vous m'aider assez rapidement s'il-vous-plais ?

Merci d'avance

Partager ce message


Lien à poster
Partager sur d’autres sites

Relire a partir d'ou ? Parce que ca m'affiche le haut de la page. Je dois tout relire ?

Et enfait le but c'est de remttere quel build ? Le 6.1.1.B.1.10 ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Désolé je n'ai pas d'accès à mon PC c'est ici:

Et pour l'utilisation de flashtool c'est là:

Chapitre1 :)

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour , j ai suivie le tuto pour rooter mon xperia p avec RunMeFR et ca marchait, mais des que j ai fait la mise a jour avec PC companion j ai plus Supersuse donc je refais la manipe pour le rooter mais ca n'a pas marché et j ai donc vérifié avec Root Checker il me dit que je suis pas rooté.

tu peux me dire quoi faire stp

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoignez la conversation

Vous pouvez poster maintenant et vous enregistrez plus tard. Si vous avez un compte, connectez-vous maintenant pour poster.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.






×
×
  • Créer...