Jump to content
timdu13

[TUTO][ROOT] Améliorer le fix GPS

Recommended Posts

je reviens de faire un test rapide a priori cela refonctionne avec tes fichiers fix moins d'une minute (a froid)

là je vais aller refaire un peu de route je vais retenter.

Share this post


Link to post
Share on other sites

ouais,FIX sans bouger pas trop de soucis mais en mouvement (dans le bus) pas terrible pour moi...

Share this post


Link to post
Share on other sites

Clairement, est-ce que l'un d'entre vous qui arrive a avoir un fix gps rapide peut nous fournir ces fichiers ? gps;conf & le xml, parce-que moi je ne fixe plus rien :(

Merci d'avance

Share this post


Link to post
Share on other sites

comme je le dis plus haut, si je pense que, demain, le teste est concluant je redonne les fichiers que j'utilise

  • Like 1

Share this post


Link to post
Share on other sites

Alors voici mon retour mitigé après 300Km aujourd'hui,

donc pour vous situer les conditions , 300Km partagé entre route et autoroutes, pas de grandes villes (rue étroites et grand bâtiment, pas de ville comme Marseille lyon paris...) que de la campagne entre Istres Orange Avignon,

un téléphone sur support mobile dans mon trafic et pas de pare-brise athermique.

donc pour résumé des conditions parfaite pour une réception parfaite.

Avec Icoyote:

Quasi à chaque redémarrage, j'avais une alerte de signal perdu et si j'attendais le logo du GPS en notif disparaissait (arrêt du GPS).

Donc arrêt de l'appli et relancement sur le champs, et paf ca fait des chocapic, Fix en moins d'une minute.

Par la suite pas un seul décrochage, et pas de valeur de vitesse erronée comparé a l'affichage de mon TomTom.

C'est là que ça se gatte, avec navigation de google maps:

testé sur un parcours d'une heure que, heureusement, je connais par coeur!

Fix hyper long voir impossible, finalement j'arrive a avoir le fix, je roule une minute puis décrochage (logo clignotant)

3 min pour refixer, je roule une minute puis décrochage..... cela en boucle....tant que le logo ne disparaissait pas!

Dans les 2 cas je n'ai pas vu de différence notable avec ou sans l'option AGPS cochée

Donc je peux quand même fournir les fichiers qui m'ont permis de faire ce test.

Pour les Devs et manipulateurs de fichiers du GPS, j'ai l'impression que le téléphone ne garde pas en mémoire les éphémérides, et qui les re télécharge à chaque fois.

Depuis que j'ai ce téléphone les meilleurs résultats que j'ai pu avoir avec le GPS, c’était en V7 et une optimisation avec fasterfIX.

C'est peut etre une piste a creuser

Share this post


Link to post
Share on other sites

Moi je suis perdu... j'ai jamais pu avoir quoi que ce soit. La je teste ce qu'il y a dans le premier post (gps.conf + gps.xml). mais je coche A-GPS ou pas dans mes parametres?

Share this post


Link to post
Share on other sites

A gps ne pas coché si pas forfait data, sinon comme tu veux.je n'ai pas vraiment vu de différence.

Bugdroid qu'en est il de tes fichiers du 1er message avec la V17?

Tu as mis a jour ou il n'y a pas besoin et il suffit de les remettre?

Edit:

En refaisant un petit tour des divers topic et forum, je pense avoir trouvé le combo Idéal des XML et CONF.

A tel point que je viens de réussir un fix en moins de 20 secondes a l’intérieur de ma maison. "icoyote et Maps"

Pour être sur que ce n'est pas de la chance, demain je refais un test complet comme celui d'aujourd'hui, et je mettrais en ligne le fichiers utilisés.

Pour info le conf que je viens de mettre et le XML est si je ne dit pas de betise celui d'origine de la V7 fourni par ellney

NTP_SERVER=1.fr.pool.ntp.org
NTP_SERVER=2.fr.pool.ntp.org
NTP_SERVER=3.fr.pool.ntp.org
XTRA_SERVER_1=http://xtra1.gpsonextra.net/xtra.bin
XTRA_SERVER_2=http://xtra2.gpsonextra.net/xtra.bin
XTRA_SERVER_3=http://xtra3.gpsonextra.net/xtra.bin
# DEBUG LEVELS: 0 - none, 1 - Error, 2 - Warning, 3 - Info
# 4 - Debug, 5 - Verbose
DEBUG_LEVEL =0
# Intermediate position report, 1=enable, 0=disable
INTERMEDIATE_POS=1
# Accuracy threshold for intermediate positions
# less accurate positions are ignored, 0 for passing all positions
ACCURACY_THRES=1000
# Report supl ref location as position, 1=enable, 0=disable
REPORT_POSITION_USE_SUPL_REFLOC=1
# Wiper (wifi positioning), 1=enable, 0=disable
ENABLE_WIPER=1
################################
##### AGPS server settings #####
################################
# FOR SUPL SUPPORT, set the following
SUPL_HOST=supl.google.com
SUPL_PORT=7276
SUPL_TLS_HOST=supl.google.com:7276
CURRENT_CARRIER=common
DEFAULT_AGPS_ENABLE=TRUE
DEFAULT_SSL_ENABLE=FALSE
# TRUE for "User Plane", FALSE for "Control Plane"
DEFAULT_USER_PLANE=TRUE

Edited by yanosh1
  • Like 1

Share this post


Link to post
Share on other sites

donc je viens de refaire 300Km avec XML V7 et conf avec le code ci-dessus, cela marche super bien mais qu'en AGPS.

Mais je vais essayer un autre code pour le conf, que j'ai vu sur un autre forum!

Share this post


Link to post
Share on other sites

En effet, c'es top si on met les fichiers que tu dit !!

Merci :)

j'ai parlé trop vite, j'étais en wi-fi du coup il m'a repéré comme ça, mais en 3g pas moyen d'avoir un truk précis, et pire, en utilisant juste la puce GPS je n'ai rien, comme avant...

Share this post


Link to post
Share on other sites

Bonjour,

Ayant acheté récemment un cink slim, il était déjà en v13.

Donc comment récupérer le xml en V7 pour essayer la méthode à yanosh1 ?

Merci

Share this post


Link to post
Share on other sites

page 3, 2eme message, celui de ellney

Edited by yanosh1
  • Like 1

Share this post


Link to post
Share on other sites

Je viens de faire la manip avec xml en V7 + gps.conf de yanosh1 :

en sortant de la maison et après moins de 20 secondes, j'ai un fix et mon Sygic est OK pour le guidage. :)

Avant cette manip : 10 minutes à 30 minutes.

Demain je me déplace sur 200 km, je vous tiendrai au courant.

Share this post


Link to post
Share on other sites

Test dans la voiture pas vraiment concluant.

fix au bout de 15 km.

au retour pas mieux.

positionné au même emplacement que mon ancien nexus s qui lui fixait toujours en 30 s maxi.

Share this post


Link to post
Share on other sites

Pour ma part avec gps test et un galaxy S1 et S3 à côté faisant le même test, moi aucun fix même au bout de 10 min alors que le S1 20s et le S3 sensiblement pareil !!

Edited by goxes

Share this post


Link to post
Share on other sites

Bon finalement avec tout ces fichiers de config modifié qui trainent ici et sur le forum hfr , lesquelles sont les plus efficace ?

Share this post


Link to post
Share on other sites

Si je ne me trompe pas, aucuns pour l'instant.

Voilà le gps.conf d'un galaxy S III:

NTP_SERVER=fr.pool.ntp.org

XTRA_SERVER_1=http://xtra1.gpsonextra.net/xtra.bin

XTRA_SERVER_2=http://xtra2.gpsonextra.net/xtra.bin

XTRA_SERVER_3=http://xtra3.gpsonextra.net/xtra.bin

SUPL_HOST=supl.google.com

SUPL_PORT=7276

Au cas ou ça puisse s'utiliser...

Share this post


Link to post
Share on other sites

Pour ma part : V13 toute fraiche.

Pas de fix avant la modification des fichiers (Essayé 3 ou 4 fois pendant 15 mn de trajet (Navigation google))

Essai avec les fichiers du debut du post. Qu'en GPS (pas de wifi ni 3G)

Résultats :

- GoogleMaps Navigation aucun fix (Essayer une fois pendant 15mn).

- Une amélioration (Ou un coup du hazard) avec MappyGPSFree (2 essais : fixe (en 2mn) sur 15mn d'essai ).

Essai 1 : fix en 2mn - ok sur les 15 mns de trajet

Essai 2 : Plus de voyant clignotant gps au bout d'une minute, relance du gps et fix en 2mn ok sur le reste du trajet (10mn)

J'ai aussi GPS Status installé et qui recherche les satellites dés que je lance le GPS.

Je continue mes test...

Share this post


Link to post
Share on other sites

Test dans la voiture pas vraiment concluant.

fix au bout de 15 km.

au retour pas mieux.

positionné au même emplacement que mon ancien nexus s qui lui fixait toujours en 30 s maxi.

J'ai remarqué avec cette config que plus le temps hors connexion des sattelites est long, plus le fix suivant est long!!

Du coup je me pose une question, y'a t'il sur les éphémérides une durée, genre 1h de validité que l'on peut faire varier?

Est ce que si le fix ne fait au bout d'un temps donnée, le GPS se coupe?

Edited by yanosh1

Share this post


Link to post
Share on other sites

Re test GPS :

Nouveau test avec GoogleMaps Navigation (et GPS Status dérrière).

Plus de voyant clignotant gps au bout d'une minute, relance du gps et fix en 2mn puis ok pendant le trajet (25 mn).

Donc pour moi, la modif des fichiers donne de meilleurs résultats, même si c'est pas encore le TOP... (C'est [color=red]qd[/color] même mieux que rien du tout)...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...