Jump to content
Mikelejojo

[CDisplay Haier E701] Améliorer la réception wifi en ajoutant une antenne

Recommended Posts

j'ai déjà le cable et l'antenne en récup, le petit connecteur à souder sera neuf B)


question: est-ce que les drivers du wifi sont les mêmes dans la ROM V1 et V2? et est-ce que avec la V2 les problèmes sont les mêmes ou bien il n'est plus nécessaire de relancer le wifi???

Share this post


Link to post
Share on other sites

Ou voir la version de la ROM ? Il faudrait tester les 2 versions si elles sont disponibles en téléchargement.

 

Et question bête, est-ce que tout ceux qui ont des problèmes wifi ont une ROM modifiée ? Quelle version ?

 

Concernant un mod de l'antenne je n'y crois plus trop, je pense que le problème vient de l'adaptation du module Wifi à un signal atténué (< -70dB)

Edited by nicko500

Share this post


Link to post
Share on other sites

salut,

encore d'autres infos pour cerner le problème...

j'avais donc remarqué qu'avec wifi analyser l'aiguille du signal-metre ne bougeait plus lorsque je me connectais à ma box.

Or, en regardant la vue du graphique du signal dans lequel on voit tous les réseaux à proximité, j'ai constaté que l'indicateur de puissance bougeait pour tous les réseaux disponibles SAUF pour le réseau auquel j'étais connecté !!

je me dis: tient, ça vient peut-être de ma box... donc pour contrôler j'active le hotspot wifi de mon téléphone. Le hotspot de mon téléphone apparait bien dans wifi analyser sur la cdisplay et bouge en puissance mais toujours pas de mouvement pour ma box. Je me déconnecte du wifi de ma box et me connecte au hotspot: le signal de ma box se met à bouger!!! et le signal du hotspot se fige..... ça ne vient donc pas de ma box.

j'ai refait le test avec une tablette samsung: tous les réseaux wifi bougent en puissance, y compris celui où je suis connecté.

il y a clairement un problème de gestion. Le signal se fige lorsqu'on se connecte à un point wifi, mais bouge pour les autres point wifi détectables à proximité. Lorsqu'on change de point wifi c'est le nouveau connecté qui se fige et l'ancien se remet à bouger.

Si je ne me trompe pas, le wifi est géré par la ROM radio????? c'est bien ça ??? comment savoir la version de la ROM radio? est-ce que c'est possible de la mettre à jour? de l'éditer et la modifier???? ce n'est hélas pas dans mes compétences.

 

pour les deux versions de la ROM je crois que les premières tablettes étaient en 1.0.5 et la deuxieme fournée en 1.0.6 avec un partitionnement de la mémoire différent. il serait intérressant de savoir s'ils ont touché à la ROM radio entre les deux versions.

pour les versions ROM modifiées, il me semble que la ROM radio n'a pas été touchée.

  • Like 1

Share this post


Link to post
Share on other sites

L'histoire du wifi qui une fois tombé bas parce que loin de la box et qui ne remonte pas lorsque l'on s'en rapproche est hélas normal.

Et pas uniquement du à la Cdisplay mais au systeme meme de connection wifi.

Je m'explique mon fils ingénieur et dont c'est le métier, m'avait déjà conseillé de débrancher l'alimentation de ma box régulièrement, afin que la ligne renégocie la vitesse de transfer.

I m'avait expliqué que les vitesses de transfer se négociait entre la ligne et la box, et qu' il était conseillé de régénérer ces paramètres qui pouvaientt s'etre re-négociés plus bas à cause d'un problème de transfer ponctuel.

Pour des questions de sécurité de continuité de transfer ça restait toujours bas car une fois renégocié à la baisse il ne remontait pas tout seul.

Sa descend automatiquement pour s'ajuster mais ça ne remonte pas tout seul, vive le wifi!

il falait couper la box pour qu'un meilleur débit "vierge" soit renégocié.

Ce que tu observes c'est que manifestement le protocole de réception wifi entre box et Cdisplait fonctionne sur le meme principe qu'entre la ligne PTT et la box.

Les débits s'ajustent toujours à la baisse si les conditions de réceptions deviennent plus dificiles et y restent donc ensuite .

IL faut provoquer artificielement une nouvelle renégociation wifi box /  tablette en se rapprochant de la box pour valider la meilleur valeur possible et repartir sur une nouvelle base correcte.

Je suis tombé de l'armoire lorsque mon fils m'a expliqué ce principe mais tu viens de le remettre en évidence avec ta box.

Depuis cette information, de temps en temps je coupe 5s l'alim de ma box uniquement pour que les vitesses de transfer se renégocient au maxi.

CQFD

Miomio :P

V1 V2 rom wifi meme Pb, car meme logique de dialogue d'ajustement de vitesse de tranfer ainsi qu'expliqué au dessus c'est une caractéristique des dialogues radio EMETEUR/ RECEPTEUR...

Edited by Amiot

Share this post


Link to post
Share on other sites

Ce que tu observes c'est que manifestement le protocole de réception wifi entre box et Cdisplait fonctionne sur le meme principe qu'entre la ligne PTT et la box.

Les débits s'ajustent toujours à la baisse si les conditions de réceptions deviennent plus dificiles et y restent donc ensuite .

Bonjour,

je ne suis pas vraiment d'accord sur ce point.

Je m'explique: tous les appareils wifi de la maison (tablette, téléphones, ordi portable et Cdispay) perdent la connection Wifi lorsque je vais au bout de l'appartement car plusieurs murs béton.

lorsque je me rapproche de la box wifi, tous les appareils retrouvent leur débit en wifi sans désactiver/réactiver le wifi... sauf la Cdisplay qui a besoin de faire la manip manuellement.....

un appareil ne fait que ce qu'on lui demande.. et ne fait pas ce qu'on lui demande pas. Si dans le programme qui gère le wifi il y a un bug ça peut venir de là....

Share this post


Link to post
Share on other sites

Bon, pour info, j'ai ajouté une antenne de modélisme en 2,4Ghz (celle ci http://www.flashrc.com/frsky/10861-antenne_recepteur_150mm_24ghz_frsky.html)

-en soudant antenne et masse (j'ai un peu galèré pour faire tenir la soudure sur la masse),

-je n'ai pas décolé la pate de la carte wifi de la carte mère (l'antene d'origine est donc toujours en place)

-l'antenne descend sur la gauche du boitier, le long de la batterie, la partie antenne étant dans une zone 'plastique'.

 

Cela a considérablement amélioré la qualité du signal Wifi, et cela rend la tablette plus tolérente au pb de baisse de débit (qui existe toujours, mais qui devient moins systématique).

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

je ne suis pas vraiment d'accord sur ce point.

Je m'explique: tous les appareils wifi de la maison (tablette, téléphones, ordi portable et Cdispay) perdent la connection Wifi lorsque je vais au bout de l'appartement car plusieurs murs béton.

lorsque je me rapproche de la box wifi, tous les appareils retrouvent leur débit en wifi sans désactiver/réactiver le wifi... sauf la Cdisplay qui a besoin de faire la manip manuellement.....

un appareil ne fait que ce qu'on lui demande.. et ne fait pas ce qu'on lui demande pas. Si dans le programme qui gère le wifi il y a un bug ça peut venir de là....

Méprise,

je n'ai pas dit que lorsque le wifi s'était coupé parce que l'on était trop loin, il fallait le couper et le remettre.

C'est toi qui l'écrit or chez moi il se remet tout seul en se réapprochant de la box il faut lui laisser le temps vu sa réception faiblarde...

Car il se remet tout seul bien évidemment comme tous tes autres appareils.

J'ai dit et je maintiens que lorsque des pb de transmissions sont détectés le systeme baisse automatiquement son taux de tranfer!

Et qu' il ne le remonte plus tout seul!

Par contre s'il vient à perdre la liaison comme tu dis il la retrouve seul en se rapprochant, mais négocié en vitesse de transfer à la dernière valeurs connues qui fonctionnait sans pb.

Donc apres une perte de signal nul besoin de le débrancher rebrancher, Mais à ce moment là il n'est pas sur du tout que tu possèdes une liaison optimale de transfer.

Lance ton testeur de wifi et puis coupe et rebranche à coté de ta box et remesure.

Maintenant tu peux etre ou non daccord sur le fait que les débits sont négociés et ajustés par l'emeteur et le rcepteur afin de ne pas avoir de pertes de données, 

Mais c'est comme ça, et ça a été observé sur cette tablette par des utilisateurs se posant la question du pourquoi?

Ce à qoui j'ai répondu.

Mais ce que tu observes chez toi en plus, c'est que la réception de la Cdisplay est catastrophique mais nous n'apprenons rien de nouveau,

Miomio :D

 

 

 

 

J'ai dit que

Share this post


Link to post
Share on other sites

Amiot:

"or chez moi il se remet tout seul en se réapprochant de la box il faut lui laisser le temps vu sa réception faiblarde...

Car il se remet tout seul bien évidemment comme tous tes autres appareils."

 

bon, alors c'est sur ce point que nos deux tablettes ne semblent pas réagir de la même façon...

 

je schématise:

1m de la box: Samsung, HTC, Wiko: 20 à 30 Mbps, Cdisplay: 20 à 30 Mbps

10m de la box: tous perdent le signal, la Cdisplay perd le signal avant les autres (à 7m): l'antenne est un peu moins performante

je reviens à 1m de la box: Samsung, Wiko, HTC reprennent tous le 20 à 30 Mbps de suite sans rien toucher au wifi. La Cdisplay reprend à 0.45Mbps (et j'ai attendu près d'une heure, c'est resté à 0,45Mbps)  je désactive le wifi sur la Cdisplay (pas sur la box) et je le réactive: je retrouve instantanément les 20 à 30 Mbps.

 

mon interprétation (peut-être fausse):

- l'antenne est pour quelque chose dans la perte du signal à 7m au lieu de 10m pour les autres appareils, elle est moins performante c'est clair.

- l'antenne est pour rien dans le fait que le débit ne revient pas à 1m de la box alors qu'il revient sur tous mes autres appareils. c'est, a mon avis un bug dans la gestion du wifi au niveau de la ROM radio ou du driver de la carte wifi qui n'est peut-être pas le bon, voire inadapté à la version d'android.

CorpsKorus a mis une antenne plus performante: ça recule la distance de déconnection mais ça ne lui règle pas le problème de baisse de débit en se rapprochant.

 

en espérant faire avancer les pistes de recherches... je n'ai hélas absolument pas les compétences pour aller fouiller dans la ROM et les drivers

Edited by jmours

Share this post


Link to post
Share on other sites

@@jmours

je schématise:

1m de la box: Samsung, HTC, Wiko: 20 à 30 Mbps, Cdisplay: 20 à 30 Mbps

10m de la box: tous perdent le signal, la Cdisplay perd le signal avant les autres (à 7m): l'antenne est un peu moins performante

je reviens à 1m de la box: Samsung, Wiko, HTC reprennent tous le 20 à 30 Mbps de suite sans rien toucher au wifi. La Cdisplay reprend à 0.45Mbps (et j'ai attendu près d'une heure, c'est resté à 0,45Mbps)  je désactive le wifi sur la Cdisplay (pas sur la box) et je le réactive: je retrouve instantanément les 20 à 30 Mbps.

 

Regarde au dessus c'est strictement ce que j'ai dit

 

mon interprétation (peut-être fausse):

- l'antenne est pour quelque chose dans la perte du signal à 7m au lieu de 10m pour les autres appareils, elle est moins performante c'est clair.

- l'antenne est pour rien dans le fait que le débit ne revient pas à 1m de la box alors qu'il revient sur tous mes autres appareils. c'est, a mon avis un bug dans la gestion du wifi au niveau de la ROM radio ou du driver de la carte wifi qui n'est peut-être pas le bon, voire inadapté à la version d'android.

CorpsKorus a mis une antenne plus performante: ça recule la distance de déconnection mais ça ne lui règle pas le problème de baisse de débit en se rapprochant.

 

Je pense la aussi que tu te trompe voici mon hypothese.

Tes autres appareils ont une bonne antenne et une bonne réception!

Donc meme loin et juste avant de perdre le signal tu reçois encore à 20/30 Mb/s.

Mais hélas la CDisplay au fur et à mesure que tu téloignes perd des packets et donc renégocie un taux de transfer plus bas puis toujours plus bas avant de couper.

lorsque tu te rapproches tu retrouves le dernier taux négocié avant de couper qui était de 0.45 Mb/s sur la Cdisplay.

 

Tu peux interpréter comme tu veux, mais  le fait de négocier toujours à la baisse jusqu'a ce qu'un transfer se stabilise sans perte de packets est une constante des systemes meme entre la liaison PTT et ta box.

Et heuresement que c'est ainsi, sinon tout ce que tu téléchargerais comporterait fatalement des erreurs!!!!!!!!!!!!!!!!!!!!!!!

 

tu vois un pb de gestion, pour moi tout tourne autour d'une antenne de Mxxde qui chez moi bascule meme entre polar verticale et horizontal puisque mes deux sources wifi n'ont pas la meme polarisation.

Avecl le wifi tester je bascule ma tablette et l'intensité des signaux de couleur s'inverse, et la tablette change d'elle meme de source wifi, c'est spectaculaire et trés emxxbetant mais c'est ainsi.

La réception wifi est catastrophique. Pour la gestion du signal je supose quelle est académique et comme sur toutes les tablettes jusqu'a preuve du contraire.

Miomio

Edited by Amiot

Share this post


Link to post
Share on other sites

Je pense la aussi que tu te trompe voici mon hypothese.

Tes autres appareils ont une bonne antenne et une bonne réception!

Donc meme loin et juste avant de perdre le signal tu reçois encore à 20/30 Mb/s.

Mais hélas la CDisplay au fur et à mesure que tu téloignes perd des packets et donc renégocie un taux de transfer plus bas puis toujours plus bas avant de couper.

lorsque tu te rapproches tu retrouves le dernier taux négocié avant de couper qui était de 0.45 Mb/s sur la Cdisplay.

Miomio

Salut Miomio,

je reconnais que c'est pas facile de se comprendre par clavier interposé...

ce que je ne comprends pas alors, c'est que mes autres appareils, en s'éloignant progressivement de la box perdent du débit, j'ai testé jusqu'à avoir moins de 1Mbps et des coupures/reprises juste avant de perdre définitivement le contact en s'éloignant encore. Et suite à ça, mes appareils ont retrouvé les 20 à 30 Mbps en se rapprochant de la box sans rien faire de plus. ils n'ont pas retrouvé le dernier taux négocié (moins de 1Mbps) avant de couper mais le taux original (20 à 30 Mbps)...

La Cdisplay ne gère pas comme ça.

 

j'ai plusieurs interrogations en fait: dans le dossier system/lib/modules et il y a plusieurs fichiers...

8188eu.ko

8189es.ko

8192cu.ko

8723as.ko

8723au.ko

qui semblent être des "drivers" de carte wifi, or nous avons une carte 8188 et pas les autres... est-ce que le "noyau" vient bien charger le driver 8188 et pas un autre driver présent dans ce dossier???? (erreur dans l'écriture du programme??)

d'autre part, quelques recherches sur le net m'indiquent que le driver 8188 est pour les versions d'android de 4.0 à 4.2. or nous sommes en 4.4.4..

ce driver semble (sur des forums Linux en anglais que je comprends qu'à moitié :lol: ) mal fonctionner selon les versions des noyaux Linux...

Edited by jmours

Share this post


Link to post
Share on other sites

@@jmours

alors il est clair que tes autres appareils ont une autre gestion du wifi.

c'est à approfondir, je me renseigne.

A suivre donc.

Miomio

 

J'ai la réponse pour jmours et les autres.

 

Comme indiqué au dessus le systeme negocie un taux de transfer des données en wifi qui garantisse la fidelité de la transmission des paquets.

Mais:

Ce systeme est executé par le FIRMWARE de la puce Realtek sans besoin de gestion externe.

Mais:

Ce FIRMWARE possède des "portes" permetant une gestion externe pour le forcer à faire a intervales réguliers la manoeuvre inverse.

C'est à dire à chercher des vitesses plus élevées si le transfer est bon.

Cette gestion externe n'a pas été ou mal été prise en compte par haier...

l'antenne Wifi pourait faire un multiple suplémentaire de sa longueur d'onde pour amméliorer son GAIN.

(La grandeur du boitier le permettait.)

Le dos pourrait etre en plastique dur pour la sortir de sa cage de faraday et amméliorer sa RECEPTIVITE.

Voici les trois Pb majeurs et leurs solutions du WIFI de la CDisplay.

Merci Haier qui manifestement ne maitrise pas la reception wifi de ses matériels.

Comment alerter Cdiscount sur ces manques de maitrise du Wifi chez son constructeur...

@ suivre, car une fois les problèmes posés les solutions sont possibles on le voit pour des productions futures.

Pour les notres seule une gestion des portes du firmware realtek pourrait apporter un mieux dans certains cas.

miomio :P

Ici aussi on voit que certains s'interrogent sur la necessité d'un software externe en plus du firmware Realtek

 

http://www.arctablet.com/blog/forum/crewrktablets-rk3188-entwicklung-customroms-development-croms/cross-compiling-rtl8188-wifi-driver/?lang=fr

 

I suspect that the problem might be resolved by compiling rtl8188eu module against existing kernel source, however there are some differences between jellybean and kitkat kernels that I don’t understand. In JB sources folder drivers/net/wireless/rkusbwifi/rtl8188eu contains only Kconfig with the following lines:

config RTL8188EU
tristate “Realtek 8188EU USB WiFi Support”
select WIRELESS_EXT
select WEXT_PRIV
select IEEE80211
—help—
Help message of RTL8188EU & RTL8189ES

On the other hand, in KitKat same folder contains full source for rtl8188eu and the module is built into kernel. Now the question is: why is the kernel module 8188eu.ko still present in /system/lib/modules in the firmware if the module is built into kernel? If it’s built-in then there should be no need for an external module.

Another question is: if the external module is needed, then how do I compile it? I tried cross-compiling but I always ended up with “modpost 0 modules” for some reason.

Here is my defconfig, if it helps.

Edited by Amiot

Share this post


Link to post
Share on other sites

apres avoir lu les 5 pages, j'ai decidé de me lancer.

 

j'ai 3 de ces tablettes et les trois ont le meme probleme de mauvaise reception, j'en ai en v1 et v2

j'ai d'autres appareil qui captent tres bien mon wifi la ou les 3 tablettes ne captent rien

 

iphone4, wiko cink peax 2, pc portable......

donc il y a bien un problème de réception sur ce modèle de tablette !

 

je vais donc acheter cette antenne:

http://www.ebay.fr/itm/A-Pair-of-2pcs-Antenna-for-Laptop-Wireless-Internal-Wifi-mini-PCI-PCI-E-Card-/281485986599?pt=AU_GPS_Accessories&hash=item4189df4b27

(c'est un lot de 2) et la souder a la tablette, j'espere juste ne pas tout bousiller et la mettant en place.

Share this post


Link to post
Share on other sites

3 tablettes problématiques :/ c'est vraiment pas de chance. :'(

Share this post


Link to post
Share on other sites

Salut à tous,

Pour information, j'ai 2 tablettes Cdisplay, l'une pose moins de problème que l'autre.

Celle etant problématique, j'ai soudé un morceau de fil tout simple sur la connexion "ANT" du module WiFi, je l'ai scotché sur la batterie en faisant une petite boucle.

Resultat:

ça marche beaucoup mieux, moins de décrochage, par contre, quand le débit baisse, il faut quand meme activer / desactiver le mode avion. (mais c'est moins fréquent).

Share this post


Link to post
Share on other sites

Celle etant problématique, j'ai soudé un morceau de fil tout simple sur la connexion "ANT" du module WiFi, je l'ai scotché sur la batterie en faisant une petite boucle.

Resultat:

ça marche beaucoup mieux, moins de décrochage, par contre, quand le débit baisse, il faut quand meme activer / desactiver le mode avion. (mais c'est moins fréquent).

attention a l'ecran de blindage sur la coque arriere !

je pense que si l'antenne courrait sur le coté de la tablette, la ou il n'y a pas le blindage, la reception serait meilleur

 

voir le post 56 et 57 en page 3

Edited by bavaria

Share this post


Link to post
Share on other sites

@@bavaria

Les deux antennes ebay ne me semblent pas convenir du tout pour nos tablettes.

Ce n'est pas une antenne cadre ou circuit imprimé qui va etre dans une cage de faraday comme la première qu'il faudrait.

(Pour le prix tu peux essayer et nous donner ici le retour)

Ou alors la sortir et la coller à l'extérieur sur le fond ca peut etre le top si c'est faisable.

Mais une simple antenne filaire disposée sur le bord juste là ou il n'y a pas de blindage devrait etre l'ideal.

Attention en ouvrant la bete à sortir la carte SD. Plus haut quelqu'un a plié sa carte.

Miomio :P

Edited by Amiot

Share this post


Link to post
Share on other sites

sans_t10.png

 

 

je compte la coller a un de ces endroits:

 

210.jpg

 

si il le faut, je decoupe un peut le blindage au cutter...

 

je ferais des screenshot des graphique de wifi analyzer avant et apres et une photo du montage.

bien entendu si j'ai pas tout defoncé avec le fer !!!!

Edited by bavaria
  • Like 1

Share this post


Link to post
Share on other sites

@ Bavaria:
Si tu compte vendre une antenne tu me fait signe (j'ai pas trop confiance a Ebay... déjà que sur Cdiscount cela vient de m'arriver...).

Édit: c'est des antennes souple ?
Édit 2: si ça interresse une personne, je vend une housse réversible pour la Cdisplay.
Édit 3: ainsi qu'un dock/housse modifié par mes soins (travail propre). Et aussi qu'une protection d'écran plus petite que celle de notre Cdisplay, et un stylet. Le tout a petit prix.

Edited by fifouner

Share this post


Link to post
Share on other sites

attention a l'ecran de blindage sur la coque arriere !

je pense que si l'antenne courrait sur le coté de la tablette, la ou il n'y a pas le blindage, la reception serait meilleur

 

voir le post 56 et 57 en page 3

 

Je l'ouvre ce weekend et j'essayerai ta méthode voir si il y'a une amélioration ;-)

 

Après utilisation poussée, même si c'est un peu mieux, ça reste pénible ..

Share this post


Link to post
Share on other sites

Ca devient de plus en plus interessant merci aux essayeurs et bidouilleurs.

@@bavaria

Avant de la coller à l'intérieur essaye de faire quelques mesures en la laissant le long du fond (mais à l'opposé) coté extérieur,

Ceci permettra de juger de l'effet négatif ou non du blindage du fond en alu.

Si les résultats sont proches ceci voudra dire que ce n'est pas tant la cage de faraday qui pose probleme que l'antenne d'origine trop petite et de gain médiocre.

J'oubliait comment arrivez vous à ouvrir la bete à quel endroit et avec quel outil?

Merci de l'info, j'ai essayé sans forcer et ca résiste.

Miomio

Share this post


Link to post
Share on other sites

Avec un médiator par le côté et non par le dessus (en oubliant pas d'enlever la carte sd avant ;)).

Comme le souligne mikelejojo en page 1/1ère étape : ouvrir la Cdisplay

Edited by fifouner

Share this post


Link to post
Share on other sites

@@fifouner il y a une sorte de joint entre la dalle tactile et le bord du dos en aluminium. Faut il glisser l'outil entre le joint et la dalle ou entre le joint et le bord du dos en aluminium ?

Share this post


Link to post
Share on other sites

Ca devient de plus en plus interessant merci aux essayeurs et bidouilleurs.

@@bavaria

Avant de la coller à l'intérieur essaye de faire quelques mesures en la laissant le long du fond (mais à l'opposé) coté extérieur,

je ne vais pas la coller de suite, je vais la disposer a different endroit et la coller la ou j'aurais les meilleurs perfs

mais pour ce qui est de la mettre en exterieur, je vais quand meme pas trouer le back panel !

mais j'essayerais avec la tablette non fermée, le cable a l'air d'etre long

 

pour ce qui est de l'ouvrir, j'ai fauché une carte de fidelité dans le sac de ma femme (elle en a tellement de ces conneries la) et j'ai poncé l'un des bord pour etre un peut moins épais... c'est nickel !

@ Bavaria:

Si tu compte vendre une antenne tu me fait signe

Édit: c'est des antennes souple ?

 

- c'est un lot de 2, et j'ai 3 tablettes, au pire j’achèterais un autre lot et il m'en restera 1 sur les bras, on verras a ce moment la

sinon c'est 3.50€ fdp-in pour le lot de 2 sur ebay, faut compter 3 semaines pour les recevoir de chez les nouaches

- oui, elle sont souples avec une face autocollante !

Edited by bavaria

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...