ichpa

[Application] Kit - gestion automatique de profils

Recommended Posts

Bonjour Ldo,

Merci de ton retour.

Concernant le Force-close, normalement, il se produit occasionnellement. Je l'ai corrigé dans la prochaine version.

Pour l'enregistrement de la configuration qui ne fonctionne pas c'est très bizarre, on ne m'a jamais remonté ce problème. Le rencontres-tu avec tous les plugins ou juste celui de temps ? Merci d'avance pour ta réponse.

Bonne journée,

ichpa

Share this post


Link to post
Share on other sites

Salut je reviens vers toi car, je n'avais pas fait attention mais j'avais déjà fait en sorte que sur le profil de base le Bluetooth soit off. Donc mon problème, connexion OK, déconnexion pas OK ^^

Je suis sur Legend 2.05.405.2

Merci à toi.

Edit: En posant ma question j'ai pensé à quelque chose et il semblerait que ça soit ça.

En fait, J'ais 2 actions qui ont lui dans le mm laps de temps.

Couper le bluetooth mais garder le WIFI activé. Et j'ais un test en virant l'action WIFI et le Bluetooth s'est bien coupé.

Je vais faire d'autres tests, je te tiendras au courant.

@+

ReEdit:

Bon bah perso ça marche quand ça veut je suis deg parce que j'ai vraiment envie d'une appli comme celle là...

Edited by olive1612

Share this post


Link to post
Share on other sites

avec tous oui

et pour l'édition du profil par défaut, exact il ne FC pas à chaque fois, mais comme sur les profils rien n'apparait

Merci

Share this post


Link to post
Share on other sites

Olive1612,

Le profil par défaut est réactivé lorsqu'aucun autre profil n'est activé. Donc par exemple, si deux profils A et B sont activés et que B se désactive alors le profil par défaut ne sera pas activé (car A est toujours actif).

Si c'est bien de cela dont tu parles, je connais effectivement le problème. Mais je n'ai toujours pas décidé comment le traiter car réactivé le profil par défaut lorsqu'un autre profil est encore activé poserai plus de problème.

J'espère avoir été clair.

ichpa

Share this post


Link to post
Share on other sites

Désolé mais j'ai un peu de peine à régler l'apply.

J'aimerais par exemple que de 8:00 à 17:00 mon portable se mette en mode vibreur.

J'ai mis le profil par défaut comme étant volume 7/7 et wifi off.

J'ai rentrer mon profil vibreur que de 8:00 à 17:00 (j'ai fais des test de 5min) et comme action j'ai mis volume silencieux, vibreur et j'attends

Seulement à l'heure donné rien ne se passe :(

Qu'est ce que je fais de faux ?

Merci.

Share this post


Link to post
Share on other sites

Salut,

moi j'ai un problème juste un petit soucis pour régler le volume, je ne peux pas pousser le curseur a 7/7, il se bloque à 6/7.

Sinon très utile cette appli et facile à configurer, merci au developpeur !!!

Share this post


Link to post
Share on other sites

Bonjour,

tres bonne appli d'un point de vue general. Je n'ai aucun soucis avec. Je pense que pour le futur un plugin pour eteindre/allumer le GPS et eteindre/allumer la 3G serai un plus.

Sinon rien a redire pour le moment sur HTC Desire 2.1

Merci au devn, continu comme ca.

Share this post


Link to post
Share on other sites

Bonjour à tous.

Mikael,

Rencontres-tu encore le problème ? Si oui, as-tu bien sélectionné les jours car par défaut aucun n'est sélectionné (correction apportée dans la prochaine version) ? Quels terminal et version d'Android as-tu ?

vitruve,

Merci de ton soutien. Ton problème est étonnant, es-tu sûre que c'est n'est pas la bordure de l'écran qui t'empêche d'aller au bout ? Si non, quels terminal et version d'Android as-tu ?

kimu,

Merci de ton retour et de ton soutien. De nombreux modules supplémentaires sont sur les rails, dont ceux que tu cites, ce n'est qu'une question de temps.

Share this post


Link to post
Share on other sites

J'avais aussi pensé à la bordure qui empechait de pousser à fond le volume, j'ai donc insisté lourdement mais rien n'y fait, le volume ne dépasse pas 6/7. Mon phone est un Galaxy S de chez SFR non modifié en android 2.1.

Share this post


Link to post
Share on other sites

Le problème pour le passer en vibreur est résolu. Je mets tout simplement que par exemple à 18h00 le smartphone passe en mode silencieux/vibreur. Par contre il ne repasse pas en mode volume 7/7 à l'heure de fin. Il suffit qu'un autre profil soit en fonction et le mode défaut ne s'active pas et du coup il reste en vibreur.

Comment faire pour que le volume revienne au maximum même si un 2ème profil est enclenché.

Si j'ai bien compris, le rafraîchissement est surtout valable pour la localisation. Donc si dans une zone précise mon wifi doit se connecter est ce que dès la zone quitté il va se désactivé ou faut il aussi le mettre dans le mode par défaut ?

Edited by Mikael

Share this post


Link to post
Share on other sites
J'avais aussi pensé à la bordure qui empechait de pousser à fond le volume, j'ai donc insisté lourdement mais rien n'y fait, le volume ne dépasse pas 6/7. Mon phone est un Galaxy S de chez SFR non modifié en android 2.1.

Meme problème que toi.

Share this post


Link to post
Share on other sites

Bonjour,

Je vais tenter de corriger le problème pour le volume qui ne peut pas être poussé au maximum.

Mikael, comme effectivement expliqué ici le profil par défaut ne s'active que quand plus aucun autre profil n'est activé.

Bon dimanche,

ichpa

Share this post


Link to post
Share on other sites

Bonsoir,

Nouvelle mise à jour de Kit :

  • disponible pour Android 1.6+ ;
  • suppression de l'icône de lancement dans la barre de notification ;
  • les modules Temps et Volume sont maintenant directement inclus ;

A noter également que le module Agenda est également disponible.

Bonne semaine,

ichpa

Edited by ichpa

Share this post


Link to post
Share on other sites

Bonjour;

Je suis sous Samsung Galaxy S, et je viens de faire un test d'un mode Dodo.

Conditions:

Temps:22h30-09h(J+1) sur tous les jours de la semaine.

Actions:

Volume: Silentieux

Wifi: désactivé:

Notifications: -Nom du profil-

Luminosité 1%

**************

Le wifi ne se désactive pas et le volume reste actif, j'ai toujours le beep des touches lorsque je navigue.

D'après l'aide fournit dans l'appli, le nom en gras est le profil activé en cours.

Moi il reste sur le profil défaut.

Une idée ?

je viens de voir sur le market que des mises à jours sont présente que je n'avais pas, et que le plugin temps n'est plus a utilisé ? Idem pour Volume, que j'ai encore et qui me met que j'ai une mise à jours de disponible, donc je pense qu'il est installé et qu'il me met la grouille.

Comment puis-je supprimer tous les plugins et ne réinstaller que les dernier et les fonctionnels ?

J'ai désinstallé le plugin Temps via le market, mais lorsque je souhaite mettre une condition, j'ai deux conditions qui s'appelle "Temps"

Bizarre

Edit:

En supprimant le plugin temps, et en utilisant une des nouvelles conditions Temps (Je ne sais pas d'ou elles viennent ni pourquoi j'en vois deux ?) bah tout marche. Le wifi se coupe.

Par contre via l'action Volume, je ne sais pas ce qu'elle gère (je pense le volume des sonneries d'appels) mais si elle pouvais aussi couper le volume du retour appuie clavier ca serait un énorme plus. Ca éviterai que si on utilise le téléphone au lit pour raison X ou Y, madame soit réveiller par le retour d'appuie clavier.

Edited by cortx

Share this post


Link to post
Share on other sites

Bonjour cortx,

Le module Temps et Volume sont maintenant directement intégrés à Kit. Si tu as laissé les modules indépendants installés, cela explique les doublons. Pour résoudre ce problème il suffit donc de d'installer les modules indépendants Temps et Volume.

Pour ce qui est du module Volume, je suis d'accord avec toi, le nom n'est peut être pas assez précis puisqu'il ne concerne que le volume de la sonnerie et des notifications. Je vais essayer de rectifier le tir.

Pour les autres réglages de volume (musique, sons systèmes, ...) un module supplémentaire plus complet (et probablement payant) devrait bientôt voir le jour.

Bonne après-midi,

ichpa

Share this post


Link to post
Share on other sites

Bonjour,

Je me permet d'intervenir car, j'ai exactement le même souci que cortx.

Kit reste toujours bloqué sur le profils défaut

j'ai actuellement de profil marqué actif, utilisant l'ex plugin de temps (que j'ai désinstallé suite à la mise à jour), le plugin de volume (idem, que pour le plugin de temps), et celui de notification.

mes profils sont configurer de la sorte :

Travail

08h00 - 13h00 lun, mar, mer, jeu;

09h00 - 13h00 ven;

14h00 - 17h00 lun, mar, mer, jeu, ven;

volume (tous) 0/7, vibreur on

Nuit

23h30 - 07h00 lun, mar, mer, jeu, ven;

volume sonnerie 6/7 (impossible de mettre à 7/7, le problème étant déjà rencontré par vitruve, et Mikael) , volume notifications 0/7, vibreur on

le reste du temps (module défaut), volume (tous) 7/7, vibreur on

Cordialement

PS. Configuration dans ma signature

[Edit] Par acquis de conscience j'ai fait un test simpliste, un profil de test qui met la sonnerie à 0/7 a 15h00 - 16h00, et la ça à fonctionner... Serait-ce que l'on ne peu pas mettre plusieurs condition de temps dans un seul profil ?

Edited by Eleyone

Share this post


Link to post
Share on other sites

Vérifie sur le market que tu sois bien à jour.

Moi ca a résolu mon problème et j'ai bien le changement de profil une fois à jours, et une fois supprimé le plugin Temps.

Share this post


Link to post
Share on other sites

Bonjour Eleyone,

Tout d'abord merci pour ton retour.

Il faut savoir qu'un profil ne s'exécute qui si toutes les conditions sont satisfaites. Donc ton profil Travail ne peut jamais s'exécuter car il est impossible d'avoir une heure commune à tes trois conditions de temps. Tu doit donc découper ton profil en trois profiles (par exemple : Travail matin, Travail aprèm, Travail vendredi).

Pour ton profil Nuit, as-tu pu le tester ou il ne fonctionne vraiment pas ?

Pour le problème du volume qui ne peut pas être poussé au maximum, je suis toujours à la recherche du bogue.

J'espère avoir été clair.

Cordialement,

ichpa

Share this post


Link to post
Share on other sites

Re-bonjour,

Tous d'abord, merci pour la réponse rapide... :D

Effectivement, j'ai fais un édit de mon premier poste dans lequel j'étais arrivé à la conclusion de ne pas pouvoir avoir plusieurs conditions de temps dans un même profils... (ce qui me gènes un peu par ailleurs... )

Sinon, pour le profil "Nuit", j'avais aussi plusieurs condition de temps, que j'ai oublié de noté... (mea culpa ^^' ), donc il ne fonctionner pas...

Du coup, je me demandé si il serait possible dans une version prochaine de pouvoir intégré plusieurs conditions de temps pour un même profil... ? Comme je viens de faire, en faite ? Ou le cas échéant, mettre un avertissement afin de prévenir l'utilisateur que ce n'est pas possible...

De plus, j'en profite pour te demandé si tu a prévu une fonctionnalité de sauvegarde des profils ? (un fichier à stocker sur carte SD.. :) )

Cordialement

Share this post


Link to post
Share on other sites

J'en profite pour une petite intérrogation sur les profil de temps.

Est ce que c'est possible d'avoir un profil:

de 08h00 à 17h00 faire xx

de 08h00 à 17h00 et Si je suis dans une certaine zone GPS -> faire yy

On à alors 2 profils identiques mais dont un à une option en plus, la couverture GPS, et qui détermine l'action finale à faire.

Exemple concret.

Tout les jours du lundi au vendredi je travail dans ma société, j'ai donc un profil sonnerie précis.

Par contre certain jour de la semaine, je dois me déplacer chez des clients et là il me faut un autre profil de sonnerie.

[HS] Qu'est ce que fait le mode Avion concrètement ? [HS]

Share this post


Link to post
Share on other sites

Eleyone,

Plusieurs conditions de temps dans un profil signifie mettre en place des règles ET et OU entre chaque condition. C'est techniquement possible, j'y ai déjà pensé, mais ce n'est pour l'instant pas au programme car cela risque d'amener une trop grande complexité pour l'utilisateur final.

La sauvegarde n'est pas non plus au programme pour l'instant, mais j'y pense très fortement.

cortx,

Les profils sont totalement indépendants entre eux (sauf celui par défaut), il peut donc y avoir aucun, un ou plusieurs profils d'activés. Ainsi, ton exemple est tout à fait possible.

Le mode avion permet de couper toutes les communications de terminal (GSM, 3G, GPS, Wifi, ...). Le nom vient du fait qu'il est interdit d'émettre des ondes dans un avion.

ichpa

Share this post


Link to post
Share on other sites

J'imagine bien que t'as du y pensé ;)

Cependant, ne serait il pas opportun de mettre une alerte ou d’empêché la saisie d'une autre condition de temps, dans un premier temps ?

Par la suite, je pense, ce n'est que mon avis (libre à chacun d'en faire ce qu'il veut), que dans le cas ou l'ont souhaite avoir de condition de temps pour le même profil, il s'agirait alors d'un test de conditions OU par défaut ? pour reprendre mon exemple :

Travail :

( 8h00 - 13h00 : lun, mar, mer, jeu ) OU ( 09h00 - 13h00 : ven ) OU (14h00 - 17h00 )

=> vibreur (tous) on + volume (tous) 0/7

Après, je ne vois pas quelle pourrait être un test de condition ET pour le même type de condition (temps, localisation), cependant dans mon esprit, encore une fois, le test de condition ET serait pour moi applicable uniquement entre plusieurs types de conditions et toujours pour le même profil, par exemple :

Travail :

(( 8h00 - 13h00 : lun, mar, mer, jeu ) OU ( 09h00 - 13h00 : ven ) OU (14h00 - 17h00 )) ET ((Xa, Ya) ou (Xb, Yb))

=> vibreur (tous) on + volume (tous) 0/7

En espérant que ça puisse t'aider dans ton raisonnement.

Dans tous les cas, j'attend impatiemment le système de sauvegarde ( je flashe relativement régulièrement et, je doit admettre que c'est assez relou de devoir tous reconfiguré a chaque fois... :P ).

Edited by Eleyone

Share this post


Link to post
Share on other sites

la fonction gps n'est pas pratique à cause du rafraîchissement. J'ai voulu me mettre en mode vibreur quand j'étais en cours, sauf que le rafraîchissement à eu lieu à peine trop tard et bam un coup de fil loool.

Share this post


Link to post
Share on other sites

Tu peux baisser le taux de rafraîchissement et augmenter un peu la taille de la zone GPS à gérer ca devrait je pense réglé ton probleme.

Share this post


Link to post
Share on other sites

Oui mais c'est recommandé 30min, pour ça que je me suis pas permis de mettre moins, mais je vais tester.

Merci.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.