Jump to content

[TUTO] LeEco Le Max 2 (X820,X821,X822,X829)


Zeigadis

Recommended Posts

Salut tout le monde. J'envisage d'acheter le modèle gris le x822. Ma question le x822 est le modèle identique du x820 avec juste la couleur qui change ?
Et donc toutes les rom (mokee / lineageos..) Root du x820 sont adaptables au x822 ?
Par avance merci

Link to comment
Share on other sites

Il y a 1 heure, Zayatoshi a dit :

Salut tout le monde. J'envisage d'acheter le modèle gris le x822. Ma question le x822 est le modèle identique du x820 avec juste la couleur qui change ?
Et donc toutes les rom (mokee / lineageos..) Root du x820 sont adaptables au x822 ?
Par avance merci

Oui tout pareil ;)

Link to comment
Share on other sites

  • 3 weeks later...

Bonsoir

 

Je viens d'avoir ce smartphone (il est en anglais méme si j'ai mis français

 

Et je vous demande de l'aide s'il vous plait.

quand je fais Lien concernant le terminal

 

Tout semble fonctionné sauf que twrp n'est pas installé quand je fait recovery , c'est le meme que j'ai mais pas twrp

comme j'ai déja brické un vernee apollo x donc je prefere demander conseil auprés de vous

 

sinon en version j'ai

le x820

android 6.0.1

EUI 5.8

kernel : 3.18.20

build FGXOSOP580191121S

 

Merci de votre aide

Link to comment
Share on other sites

Je ne connais pas ce terminal mais je suppose que comme pas mal d'appareil il a peut-être un script exécuté pendant le reboot qui vient reflasher le recovery avec l'image par défaut.

Il faut donc que tu termines par un 

fastboot reboot recovery

après le flash pour redémarrer directement dans le recovery TWRP que tu viens de flasher.

Autre explication possible : tu es bien sûr que ce fichier recovery.img est celui de TWRP et pas le recovery stock ?

Link to comment
Share on other sites

Merci je vais essayer ce que tu me dit

 

Merci

par contre j'ai dl logiquement le twrp sur le 1er post

 

J'ai du faire ça sous Linux (archlinux) car sous windows8 adb ne reconnait pas le smartphone option de débogage activé mais même adb usb  ne fait pas apparaitre de message (pour faire confiance a l'ordinateur)

 

Merci

Link to comment
Share on other sites

lors de la première instal de twrp j'ai juste rebooter  et twrp avait été zapper... 

Suffit juste après le flash via adb de relancer en manuel le recovery sans le laisser rebooter sur la rom. 

Pour adb sous Windows essai  un killer adb, sous linux je suis perdu. 

lien officiel twrp= https://twrp.me/devices/leecolemax2.html

Link to comment
Share on other sites

Il y a 6 heures, Ultrix a dit :

Je ne connais pas ce terminal mais je suppose que comme pas mal d'appareil il a peut-être un script exécuté pendant le reboot qui vient reflasher le recovery avec l'image par défaut.

Il faut donc que tu termines par un 

fastboot reboot recovery

après le flash pour redémarrer directement dans le recovery TWRP que tu viens de flasher.

Autre explication possible : tu es bien sûr que ce fichier recovery.img est celui de TWRP et pas le recovery stock ?

 

[color=red]sa[/color] fonctionne pas sa met

$ fastboot reboot recovery
usage: fastboot [ <option> ] <command>

commands:
etc

 

Link to comment
Share on other sites

Il doit y avoir un fichier à effacer dans /system/etc

Un nom comme boot-from-recovery... je n'ai pas ça en tête.


EDIT : peut-être install-recovery.sh


EDIT 2 : mais attention, certaines versions de SuperSU installent leur propre script sous ce nom, et renomment l'existant en install-recovery_original.sh que leur script appelle. C'est donc ce dernier qu'il faut effacer sinon SuperSU ne fonctionnera plus.


EDIT 3 : ou bien install-recovery-2.sh plutôt, d'après le script que je viens de regarder

 

EDIT 4 : si fastboot reboot recovery ne fonctionne pas, il faut que tu trouves un moyen de redémarrer directement en recovery. Donc pas de commande fastboot reboot, extinction du téléphone par appui prolongé sur le bouton power puis allumage avec la combinaison de boutons ad-hoc pour démarrer en recovery.

Edited by Ultrix
Link to comment
Share on other sites

il y a 38 minutes, Ultrix a dit :

Il doit y avoir un fichier à effacer dans /system/etc

Un nom comme boot-from-recovery... je n'ai pas ça en tête.


EDIT : peut-être install-recovery.sh


EDIT 2 : mais attention, certaines versions de SuperSU installent leur propre script sous ce nom, et renomment l'existant en install-recovery_original.sh que leur script appelle. C'est donc ce dernier qu'il faut effacer sinon SuperSU ne fonctionnera plus.


EDIT 3 : ou bien install-recovery-2.sh plutôt, d'après le script que je viens de regarder

 

EDIT 4 : si fastboot reboot recovery ne fonctionne pas, il faut que tu trouves un moyen de redémarrer directement en recovery. Donc pas de commande fastboot reboot, extinction du téléphone par appui prolongé sur le bouton power puis allumage avec la combinaison de boutons ad-hoc pour démarrer en recovery.

 

Les script sont disponible ou ?

 

merci de ton aide

 

Ceux que tu me dit  , concernant le fichier a effacer , comment je peux le faire alors que j'ai pas accés a la racine / ?

 

C'est bon j'ai enfin accés a twrp par contre j'ai besoin de ton aide (c peux etre comme sa que j'ai tuer mon vernee apollo x)

 

conserver le systeme de fichier en lecture seule ?

il y a conserver la lecture seule (le choix de language) et glisser pour autoriser les modfications

 

que doi je faire merci (j'aurais tendance a dise glisser pour autoriser) mais j'aimerais ton avis

 

Il n'en parle pas dans le tuto merci de ton aide

Edited by wilfried18
Link to comment
Share on other sites

Quand je boot en recovery

je fait install et il trouve aucun des fichier (il indique 0mb)

 

Mais quand il redemarre normalement [color=red]sa[/color] fonctionne mais mes fichiers sont toujours la

 

La rom serais en français je pourrais essayer de passer outre le root et twrp mais la ce n'est pas possible

Link to comment
Share on other sites

La c'est trop spécifique à ce modèle, je ne peux pas répondre. Il faut voir avec les spécialistes de l'engin qui causaient dans ce fil...

A propos de ta question sur les scripts "disponibles" : il n'y a besoin de rien de "disponible", il faut au contraire supprimer de /system/etc le script qui force la réinstallation du recovery d'origine. Mais cela nécessite un terminal rooté, redémarré sous Android après l'installation de SuperSU, et un explorateur root qui permet d'aller modifier des fichiers dans /system.

Donc la première étape, c'est de le rooter...

Link to comment
Share on other sites

il y a 28 minutes, Ultrix a dit :

La c'est trop spécifique à ce modèle, je ne peux pas répondre. Il faut voir avec les spécialistes de l'engin qui causaient dans ce fil...

A propos de ta question sur les scripts "disponibles" : il n'y a besoin de rien de "disponible", il faut au contraire supprimer de /system/etc le script qui force la réinstallation du recovery d'origine. Mais cela nécessite un terminal rooté, redémarré sous Android après l'installation de SuperSU, et un explorateur root qui permet d'aller modifier des fichiers dans /system.

Donc la première étape, c'est de le rooter...

Le rooter c'est se que je souhaite faire pour commencer a utilisé le téléphone

 

Link to comment
Share on other sites

Il y a 2 heures, wilfried18 a dit :

On fait comment pour le fixer (s'il repart a chaque fois (c'est pas le but)

il ne repartira pas... juste pour la première et biensure tu flash le zip supersu au 1 er lancement de twrp.

 

edit= fastboot reboot et tu fait au meme moment la  combinaison power +volume (+ou-)(je sais plus😕) 

Edited by herveonex
Link to comment
Share on other sites

il y a 36 minutes, herveonex a dit :

il ne repartira pas... juste pour la première et biensure tu flash le zip supersu au 1 er lancement de twrp.

 

edit= fastboot reboot et tu fait au meme moment la  combinaison power +volume (+ou-)(je sais plus😕) 

 

Merci de ton aide alors

au lancement de twrp il demande un mot de passe je fais annuler

mais quand je vais dans install le soucis c'est qu'il ne voit aucun fichier dans sdcard

connait tu le chemin d'accés a la mémoire internet (si ce n'est pas sdcard)

J'ai mémoire interne (0mb)

usb otg (0mb)

Une solution la communauté LeEco ?

Edited by wilfried18
Link to comment
Share on other sites

il y a une heure, herveonex a dit :

jamais twrp ne m'a demandé un mot de passe ...bizarre. 

Tu as fait toute les manip ds les paramètres avant flash et désactiver l'empreinte etc... 

 

edit =a1ae6b788a3e9e78334a01d26c840d61.jpg

Quel paramétres que je dois changer ?

Link to comment
Share on other sites

Si tu a un mot de passe des le démarrage de twrp et si tu l'as jamais configuré ainsi c'est bizarre je ne serai l'expliquer.
Si tu annule a chaque fois le mot de passe et que du coup tu n'as accès a rien dans twrp c'est logique sûrement.

reflash un coup twrp.
Tu l'as eu neuf et boite scellé sans intervention du vendeur sur la rom ?

Envoyé de mon ONEPLUS A3003 en utilisant Tapatalk

Link to comment
Share on other sites

Il y a 12 heures, herveonex a dit :

Si tu a un mot de passe des le démarrage de twrp et si tu l'as jamais configuré ainsi c'est bizarre je ne serai l'expliquer.
Si tu annule a chaque fois le mot de passe et que du coup tu n'as accès a rien dans twrp c'est logique sûrement.

reflash un coup twrp.
Tu l'as eu neuf et boite scellé sans intervention du vendeur sur la rom ?

Envoyé de mon ONEPLUS A3003 en utilisant Tapatalk
 

Bonjour

 

Non j'ai jamais toucher au mot de passe

J'ai quasiment pas toucher au smartphone autre que ce qu'il dise dans le tuto

A une époque j'avais aussi la demande du mot de passe sur le umi emax

mais il fonctionne toujours.

 

Si je reflash [color=red][b]sa[/b][/color] va pas le brické ? Car j'ai accès a la ROM en demarrant normalement.

oui boite scellé et bien protéger acheter sur tomtop

Link to comment
Share on other sites

slt, non réinstaller un twrp via adb comme dans le tuto ne risque pas plus que la première instal de twrp.

Mais chaque manipulation comporte un risque de brick....

1 installé la ADB sur windows (si bug utilisé un kill adb).
2 unlock le bootloader.
3 dans la foulée installé twrp sous adb toujours.
4 relancé avec power+volume + comme expliqué plus haut.
5 dans twrp flasher le zip supersu.

bien entendu toute manip comporte un risque pour le smartphone.


Envoyé de mon ONEPLUS A3003 en utilisant Tapatalk

Link to comment
Share on other sites

il y a une heure, herveonex a dit :

slt, non réinstaller un twrp via adb comme dans le tuto ne risque pas plus que la première instal de twrp.

Mais chaque manipulation comporte un risque de brick....

1 installé la ADB sur windows (si bug utilisé un kill adb).
2 unlock le bootloader.
3 dans la foulée installé twrp sous adb toujours.
4 relancé avec power+volume + comme expliqué plus haut.
5 dans twrp flasher le zip supersu.

bien entendu toute manip comporte un risque pour le smartphone.


Envoyé de mon ONEPLUS A3003 en utilisant Tapatalk
 

Kill adb ?

J'ai fait sa sous linux

Un risque de brick oui mais la [color=red][b]sa[/b][/color] va faire 2 téléphone tout neuf que je brick

donc on va éviter le brick

Tu l'explique comment le fait qu'il trouve 0mb dans le stockage alors que il fonctionne normalement ?

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...