Jump to content

probleme de fixe gps ?


thi3um
 Share

Recommended Posts

Salut pour ceux qui ont des problèmes de fixe gps, j'ai essayé ça pour moi ça semble fonctionner pas mal mais c'est encoreun peu tôt pour affirmer que c'est magique. Mais j'ai quand même plus que bon espoir.

J'ai simplement remplacé le fichier gps.conf ( dans système/ect ) par le gps.conf modifié et le tour est joué, pour l'instant je fixe en une vingtaine de seconde.

Edited by thi3um
Link to comment
Share on other sites

mais non, mais non...

après si tu veux tenter le coup la méthode dite " flaimard " me semble mieux marché chez moi

testé en blay0 et en cm7 sans problème, en voiture, en navigation je fixe en mois d'une minute ce qui est un réel progrès pour moi ( plus de 5 minutes parfois avant ). j'attend un peu avant de tirer des conclusions sur du plus long terme ( ça ne serait pas la première fois que j'ai de faux espoirs avec ce satané fixe )

Link to comment
Share on other sites

Bonjour,

ça fonctionnerait aussi sous Android 2.2 (3.15) ?

Parce que, je pense que je vais ressortir mon vieux sirf 3 et l'associer au tel en bluetooth. Là au moins ca fixait vite et bien et ça ne décrochait jamais.....

Dur dur le Legend en rando. :mad: :mad:

:emo_im_undecided:

Link to comment
Share on other sites

  • 3 months later...

Sous CM7 j'ai pas du tout de GPS, il n'accroche plus et j'ai pas l'icone. Je test le fichier .

Edit : Marche toujours pas :(

Problème dans l'écriture de ton cm, ça m'est déjà arrivé. Il te faut flasher ton cm sur du vide pour avoir une réécriture complète de ta rom et non pas un update.

Cette astuce est pour améliorer la vitesse du fix ( temps pendant lequel l'icône clignote) pas pour régler les problèmes de gps.

Link to comment
Share on other sites

  • 9 months later...

Bonjour,

(dois-je ouvrir un nouveau topic?)

Malgré de nombreuses recherches et pas mal de test, mon gps continue de me poser un paquet de problème: durant ce dernier mois, alors que j'ai testé différentes ROM (CM7 stables et nightlys) et différentes modifs (gps.conf / utilisation de fasterfix, de fastGPS / ...), au mieux, mon GPS fixé au bout de plusieurs minutes mais uniquement en zone extrêmement dégagée (type zone industrielle) et, au pire, comme actuellement, il ne fixe pas (je viens de refaire l'essai en zone dégagée, en ville).

J'ai vraiment besoin d'aide svp....

Ma config actuelle:

Legend Rooté, CM7 Nightly 253. ROM radio 7.08.35.21

Ce matin, je viens de retester la modif de gps.conf selon le post de philo64. Pour cela, j'ai copié le fichier gps.conf sur la sdcard, je l'ai modifié avec notepad (en faisant un copier/coller de la modif' de philo64), et je l'ai recollé dans /system/etc.

Au bout de 8 minutes, pas de fix. je chope de façon aléatoire 2 à 5 satellites.

Please... help

Matt

Edited by Matt06
Link to comment
Share on other sites

la configuration qui fonctionne le mieux pour le GPS pour moi :

rom, cyano 7.1 stable

radio, 7.13.35.13

appli, fasterfix avec bien sûr la france de cocher

quand j'ai tout cela d'installer sur mon legend le gps fonctionne comme une horloge suisse, pas plus de 30 sec d'attente pour le fix et j'habite en proche banlieue parisienne donc les zone dégagée par ici c'est rare !

avec les autres roms c'est plus aléatoire ...

en ce moment je suis sous CM9 beta 3 et j'ai du mal à avoir un gps stable :emo_im_undecided:

Link to comment
Share on other sites

Sous CM 7.1, j'avais essayé avec les 2 ROMS radios sans voir de différence. D'ailleurs, j'avais lu que la rom radio n'avait pas d'influence sur le fonctionnement du GPS.

J'ai également essayé fasterfix, et c'était pareil... pas d'amélioration ou de manière aléatoire.

Là, sous CM7.2, hier matin, j'ai fixé en 3 minutes (mais dès mon réveil, pour une raison que j'ignore, le GPS était déjà en recherche de signal).

Une heure plus tard, après 4' d'attente, je n'avais toujours pas fixé.

J'ai alors installé et configuré fasterGPS et après 6' je n'avais toujours pas de fix...

ça m'embête vraiment de ne pas avoir de gps, je l'utilise régulièrement... :-/

ne devrais-je pas ouvrir un nouveau topic pour avoir plus d'aide?

Matt

(et merci pour la réponse)

C'est pas grave s'il n'y a pas d'espace et de retours à la ligne dans les lignes du fichier gps.conf?

mini_694420screenshot1340107919450.png

Edited by Matt06
Link to comment
Share on other sites

il y a un moment où il faut se poser la question d'un problème sur le hardware

les différentes méthodes décrites ont fonctionnées pour la plupart d'entre nous

je suis revenu en CM7.1 hier pour tester et ça marche nickel

t'as testé GPS status ?

Link to comment
Share on other sites

est-ce fréquent les pbs de hardware?

Peut être que je devrais essayer de repasser sur une rom plus proche de froyo. En effet, lorsque j'avais froyo SFR, ça marchait niquel.

Je peux peut être essayer sur modaco ou blayo...

qu'en penses-tu?

quels tests devrais-je faire avant de mettre en question le hardware?

Link to comment
Share on other sites

Je t'en avais déjà parlé dans un autre topic mais j'ai résolu mes problèmes de fix GPS après plusieurs problèmes.

Déjà 2 version s Google MAPS étaient installées.

Mon fichier GPSconf est celui que je joins (à flasher en mode recovery, serveur Europe et pas France ...).

J'espère que tu y arriveras ....

Link to comment
Share on other sites

Merci Fredjou, c'est très aimable à toi de me joindre ton fichier.

Je viens de désinstaller et réinstaller gmap. Je n'avais pas vu de "doublon" dans "paramètres des applications", "gérer les applications". Je n'ai pas vu d'amélioration

Par ailleurs, j'ai parcouru ton fichier gps.conf, et je ne vois rien de particulier qui pourrait résoudre mon pb.

Ton fichier:

NTP_SERVER=0.europe.pool.ntp.org

NTP_SERVER=1.europe.pool.ntp.org

NTP_SERVER=2.europe.pool.ntp.org

XTRA_SERVER_1=http://xtra1.gpsonextra.net/xtra.bin

XTRA_SERVER_2=http://xtra2.gpsonextra.net/xtra.bin

XTRA_SERVER_3=http://xtra3.gpsonextra.net/xtra.bin

SUPL_HOST=supl.google.com

SUPL_PORT=7276

Matt

Edited by Matt06
Link to comment
Share on other sites

C'est exact, c'est le fichier d'origine (sauf Europe au lieu de America). Personnellement j'ai essayé le fichier sensé améliorer le fix (dont tu parles plus haut) mais chez moi ça ne fonctionnait pas. De même, mettre France à la place de Europe n'a pas l'air de changer grand chose.

Désolé si ça ne fonctionne pas pour toi, je ne maîtrise pas suffisamment pour t'aider plus.

Bon courage.

Link to comment
Share on other sites

  • 2 months later...

Bonjour,

Je relance le sujet, car chez moi, cela ne fonctionne pas génial.

Je sais que c'est un sujet traité des tas de fois, mais je suis dans l'impasse. Je trouve pas de solution.

Je suis en cyanogen 7.2 stable. J'utilise la radio 47.51.35.17_7.13.35.05

Le truc, c'est que lorsque je lance gps test, ou gps status, il met bien souvent plus de 10 minutes pour trouver ma position. Une fois la première position trouvée, si je relance 5 minutes après, il va retrouver ma position en un peu près 20 secondes.

Par contre au bout de 2 heures, ou si je me suis déplacé géographiquement, et que je relance le gps, je suis reparti pour plus de 10 minutes avant d'avoir ma position.

J'ai bien sur essayé l'histoire du fichier gps.conf, j'ai également testé avec une autre radio (mais j'ai envie de dire que la dernière fonctionne surement mieux que les autres). Bref, ça ne change rien.

Un truc qui me parait bizarre, c'est cette histoire d'agps. En effet, dans gps status, il indique combien de satellites sont utilisées via les infos agps, et à chaque fois je suis à "0 des données AGPS". J'en déduis que mon gps n'utilise pas l'AGPS (alors que gps status me dit qu'il a bien téléchargé les infos), et que donc il passe en mode je scanne au pif pour trouver des gps, ce qui expliquerait que ça prenne 10 minutes.

Donc pour ceux chez qui ça fonctionne, pouvez vous me fournir votre configuration (version de cyanogen, en stable, en rc, en nightly, la version de la rom) et surtout me dire si l'agps fonctionne ? Deuxième question, avez vous du remplacer la librairie .so du gps tel qu'expliquait sur http://forum.xda-dev...d.php?t=1567384

Merci d'avance.

Edited by Namour
Link to comment
Share on other sites

Salut,

Je n'ai aucune réponse a t'apporter... désolé!

Mais sur la rom CM9, la dernière, le gps fonctionne sans problème, et sans logiciel tiers... au niveau rapidité, c'est très correct et avec la dernière mise a jour maps, fluide.

Fait une sauvegarde complète, et teste là cette rom, avec tous les wipes, elle ne te posera aucun problème, même en usage quotidien.

Avatar.

Link to comment
Share on other sites

J'ai déjà essayé cette rom.

Ce que je lui reproche, c'est la partie photo/vidéo.

La première fois, l'appareil photo devient opérationnel au bout d'un certain temps. trop je trouve pour dire de pouvoir l'utiliser rapidement. Attendre 30 secondes la première fois pour pouvoir prendre une photo, je trouve ça pénalisant.

Et pour la partie vidéo pareil.

Le mode panorama quand à lui est je dirai inutilisable. J'ai vu qu'il fallait passer par une appli tierce pour la partie vidéo.

Tu parles bien de cette rom ? http://forum.xda-dev...d.php?t=1562595

et s2e semble ne pas marcher sur CM9.

Edited by Namour
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...