Jump to content
JoOoSs

[TUTORIEL] Rooter son tattoo, recovery, custom ROMs

Recommended Posts

@starrcab:

Alors...

On va encore essayer une (grosse) série de commande pour refaire le dossier bin.

Alors j'ai une autre erreur cette fois-ci. Ci-joint le printscreen:

screenshot005n.png

P.S: j'ai renommé le programme adb-windows.exe en adb.exe pour taper plus vite pendant mes essais d'hier. Je pense pas que ça ait une quelconque influence...

Edited by starrcab

Share this post


Link to post
Share on other sites

Moi, j'ai des erreurs quand je veux utiliser "su"

j'ai un jolie permission denied.

et je n'arrive pas non plus a faire /data/local/bin/flash_image boot /sdcard/Mainfram3.boot.02.img

failed opening boot...

failed writing boot...

Edited by doudoudou

Share this post


Link to post
Share on other sites

Si tu fais : chown root.root /data/local/bin/flash_image ?

Ca me soule... dans 10mn je flash une stock.

Share this post


Link to post
Share on other sites

@doudoudou: fais /data/local/bin/su à la place de simplement su. Ca ne marche pas non-plus chez moi si je fais juste su.

@JoOoSs: super ça a marché!

Dans mon désespoir j'ai testé de flasher le boot sans sauvegarder avant, pour voir si le problème venait de flash_image ou de recovery_amonra, et ça ne marchait pas non-plus.

Par contre après "chown root.root /data/local/bin/flash_image" voici ce que j'ai eu:

screenshot006ot.png

J'ai fait un recovery reboot, et suis arrivé sur le custom recovery. La suite est en cours, j'éditerai ce message :)

Share this post


Link to post
Share on other sites

Woh Woh t'as eu des erreurs pendant le flash fait gaffe !

Fait tout de suite un nandroid backup à partir du recovery c'est pas bon !

Share this post


Link to post
Share on other sites
Woh Woh t'as eu des erreurs pendant le flash fait gaffe !

Fait tout de suite un nandroid backup à partir du recovery c'est pas bon !

Voilà c'est fait. Le Nan backup il est sur la sdcard?

Et du coup maintenant je flash le boot ou je tente de reflasher le recovery avant? Sachant que j'ai pu faire un backup depuis recovery_amonra...

Share this post


Link to post
Share on other sites

mtd: erase failure at 0x00000000 (Input/output error)

mtd: erase failure at 0x00000000 (Input/output error)

mtd: skipping write block at 0x00000000

mtd: erase failure at 0x00020000 (Input/output error)

mtd: erase failure at 0x00020000 (Input/output error)

mtd: skipping write block at 0x00020000

mtd: erase failure at 0x00040000 (Input/output error)

mtd: erase failure at 0x00040000 (Input/output error)

mtd: skipping write block at 0x00040000

mtd: erase failure at 0x00060000 (Input/output error)

mtd: erase failure at 0x00060000 (Input/output error)

mtd: skipping write block at 0x00060000

mtd: erase failure at 0x00080000 (Input/output error)

mtd: erase failure at 0x00080000 (Input/output error)

mtd: skipping write block at 0x00080000

mtd: erase failure at 0x000a0000 (Input/output error)

mtd: erase failure at 0x000a0000 (Input/output error)

mtd: skipping write block at 0x000a0000

mtd: erase failure at 0x000c0000 (Input/output error)

mtd: erase failure at 0x000c0000 (Input/output error)

mtd: skipping write block at 0x000c0000

mtd: erase failure at 0x000e0000 (Input/output error)

mtd: erase failure at 0x000e0000 (Input/output error)

mtd: skipping write block at 0x000e0000

mtd: erase failure at 0x00100000 (Input/output error)

mtd: erase failure at 0x00100000 (Input/output error)

mtd: skipping write block at 0x00100000

mtd: erase failure at 0x00120000 (Input/output error)

mtd: erase failure at 0x00120000 (Input/output error)

mtd: skipping write block at 0x00120000

mtd: erase failure at 0x00140000 (Input/output error)

mtd: erase failure at 0x00140000 (Input/output error)

mtd: skipping write block at 0x00140000

mtd: erase failure at 0x00160000 (Input/output error)

mtd: erase failure at 0x00160000 (Input/output error)

mtd: skipping write block at 0x00160000

mtd: erase failure at 0x00180000 (Input/output error)

mtd: erase failure at 0x00180000 (Input/output error)

mtd: skipping write block at 0x00180000

mtd: erase failure at 0x001a0000 (Input/output error)

mtd: erase failure at 0x001a0000 (Input/output error)

mtd: skipping write block at 0x001a0000

mtd: erase failure at 0x001c0000 (Input/output error)

mtd: erase failure at 0x001c0000 (Input/output error)

mtd: skipping write block at 0x001c0000

mtd: erase failure at 0x001e0000 (Input/output error)

mtd: erase failure at 0x001e0000 (Input/output error)

mtd: skipping write block at 0x001e0000

mtd: erase failure at 0x00200000 (Input/output error)

mtd: erase failure at 0x00200000 (Input/output error)

mtd: skipping write block at 0x00200000

mtd: erase failure at 0x00220000 (Input/output error)

mtd: erase failure at 0x00220000 (Input/output error)

mtd: skipping write block at 0x00220000

mtd: erase failure at 0x00240000 (Input/output error)

mtd: erase failure at 0x00240000 (Input/output error)

mtd: skipping write block at 0x00240000

mtd: erase failure at 0x00260000 (Input/output error)

mtd: erase failure at 0x00260000 (Input/output error)

mtd: skipping write block at 0x00260000

error writing boot: No space left on device

:/

Share this post


Link to post
Share on other sites

DOUDOU : NE REDEMARRE SURTOUT PAS LE TATTOO !

Dis moi où tu en es dans le tuto, et tu m'avais pas dit que ton tattoo ne démarrait plus ?

starrcab : Non je pense que c'est bon, reboot et essaye maintenant de flasher le custom boot.img.

Share this post


Link to post
Share on other sites

du coup j'ai refait toute les étapes, rigoureusement les mêmes. Et le "su" n'a jamais marché

J'ai réussi a flasher le recovery correctement, et a faire une sauvegarde NAND

Edited by doudoudou

Share this post


Link to post
Share on other sites

Très bien ça :)

Comment ça le su n'a jamais marché ? tu aurais pas pu faire la partie II sans que le SU marche!

C'est quoi qui te fait dire que ça marche pas ?

Pour les erreurs que tu as eu là ça indique que ton flash a encore loupé, si tu redémarres ça va brick comme précédemment.

J'comprends pas pourquoi ça t'a remit des erreurs :/

Tu pourrais essayer de re-télécharger mon archive en haut du tuto et ré-essayer de flasher le custom boot.img ?

On dirait qu'il est corrompu parce que c'est pas normal que ça plante.

Share this post


Link to post
Share on other sites

OK donc moi j'ai essayé de flasher le boot ("/data/local/bin/flash_image boot /sdcard/Mainfram3.boot.02.img"), et j'ai eu la même chose que doudoudou, erreur de copie par manque de place.

Donc là je suis ennuyé... Je peux continuer ou je dois faire autre chose?

EDIT: j'essaie donc aussi de retélécharger l'archive et de le repush, etc.

Edited by starrcab

Share this post


Link to post
Share on other sites

Oo

doudoudou tu peux attendre un peu stp.

Starrcab, tu peux faire:

adb push tattoo-hack.ko ./data/local/bin/tattoo-hack.ko

adb shell

su

mount -o rw,remount /dev/block/mtdblock5 /data

mount -o rw,remount /dev/block/mtdblock3 /system

/data/local/bin/flash_image boot /sdcard/Mainfram3.boot.02.img

Dis moi le résultat.

(Ne redémarre surtout pas tu vas bricker je pense)

Share this post


Link to post
Share on other sites

Starrcab, tu peux faire:

Même erreur. Pourtant j'ai retéléchargé l'archive et repush l'image boot...

EDIT: J'ai essayé de push le fichier .xml quand même, et ça ne marche pas non-plus:

C:\tattoo>adb push boot_animation.xml /system/media/bootscreen

failed to copy 'boot_animation.xml' to '/system/media/bootscreen/boot_animation.

xml': Permission denied

Edited by starrcab

Share this post


Link to post
Share on other sites

Mais sérieux c'est quoi ce délire...

EDIT = han mais j'ai oublié de faire le insmod avant :

adb shell

su

insmod /data/local/bin/tattoo-hack.ko

mount -o rw,remount /dev/block/mtdblock5 /data

mount -o rw,remount /dev/block/mtdblock3 /system

/data/local/bin/flash_image boot /sdcard/Mainfram3.boot.02.img

Ca devrait marcher là :/

Edited by JoOoSs

Share this post


Link to post
Share on other sites

Oui j'avoue...

Autant flasher direct une modaco et pas se souler à mettre le root, même si je t'avoue que ça m'intrigue vos erreurs!

Share this post


Link to post
Share on other sites

Avec le insmod je n'ai pas eu d'erreur à la copie du custom boot. Par contre pas de confirmation positive.

J'ai donc rebooté. Pas de brick.

Par contre quand je fais adb shell je suis pas direct en root. Donc apparemment ça n'a pas fonctionné.

Modaco c'est quoi? Ya un tuto? Pas que ça me plaise pas de m'amuser avec le Tattoo, mais bon... je veux juste virer le son et libérer le market :)

Share this post


Link to post
Share on other sites

Tu as eu quoi quand tu as flashé le custom boot ?

Modaco c'est une ROM avec le root intégré, ça te permettrait d'avoir le root mais j'aimerais quand même pouvoir régler ton problème au cas-où quelqu'un d'autre ai le même...

Share this post


Link to post
Share on other sites
Tu as eu quoi quand tu as flashé le custom boot ?

Modaco c'est une ROM avec le root intégré, ça te permettrait d'avoir le root mais j'aimerais quand même pouvoir régler ton problème au cas-où quelqu'un d'autre ai le même...

OK pas de souci, simplement à 22h je devrai déco, obligations familiales... D'ici là à ta dispo pour essayer ce que tu veux.

Voici ce qu'il s'est passé:

screenshot008.png

Pas de message d'erreur. Donc j'ai rebooté et lancé adb shell. Je n'étais pas en root.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...