Jump to content
JoOoSs

[TUTORIEL] Rooter son tattoo, recovery, custom ROMs

Recommended Posts

Non mais...

adb ou adb-windows, ça n'a aucun rapport avec les commandes, c'est juste que dans ton dossier C:\tattoo, tu as un exécutable adb-windows.exe.

Je pourrais le renommer en lerootcsuper.exe, et aller dans un invit de commande et faire : "lerootcsuper shell" ça marcherait !

Donc tu fais les commandes par rapport au nom de ton exe, en l'occurence "adb-windows" si tu utilises mon archive.

Et tu pourrais m'indiquer ce que tu fais ?

Tu flash le recovery ? Tu fais la partie root permanent ?

Share this post


Link to post
Share on other sites

*se sent totalement nul*

Bon, je faisais la partie 'flash recovery' bien, que j'ai eu des problèmes au début pour la partie root permanent (rebootcomm -p|-n) mais j'ai réussit à passé quand même en écriture.

Share this post


Link to post
Share on other sites

Et donc c'est quoi ton soucis actuellement ? ^^'

Tu as essayé de flasher le boot.img, et ça te met des erreurs ?

Share this post


Link to post
Share on other sites

Mon soucis, c'est ceci

40720810.png

les erreurs au moment de la commande:

"insmod /data/local/bin/tattoo-hack.ko

mount -o rw,remount /dev/block/mtdblock5 /data

mount -o rw,remount /dev/block/mtdblock3 /system

/data/local/bin/flash_image boot /sdcard/Mainfram3.boot.02.img"

Share this post


Link to post
Share on other sites

Refait le insmod sans sortir du shell.

adb-windows shell

mount -o rw,remount /dev/block/mtdblock3 /system

/data/local/bin/flash_image boot /sdcard/Mainfram3.boot.02.img

Share this post


Link to post
Share on other sites

Merci Beaucoup pour l'aide, il n'a pas buté sur le flash du recovery cette fois... je fais le Backup et je continue, merci pour tes tutos qui sont très utiles ^^ et désolé pour l'embêtement :D

--Lince

Juste pour informer chez moi le 'su' n'est jamais passé pour l'instant seul le /data/local/bin/su passe

débridé, merci encore.

Edited by Lince Darkness

Share this post


Link to post
Share on other sites
Merci Beaucoup pour l'aide, il n'a pas buté sur le flash du recovery cette fois... je fais le Backup et je continue, merci pour tes tutos qui sont très utiles ^^ et désolé pour l'embêtement :D

--Lince

Juste pour informer chez moi le 'su' n'est jamais passé pour l'instant seul le /data/local/bin/su passe

Oui ça marche normal, c'est déjà marqué dans mon tuto qu'il faut recommencer le insmod ! Mais bon pas grave content que ça marche!

Quand il te demande de lancer via ADB le backup c'est à cause de deux choses :

- Soit tu as un niveau de batterie inférieur à 50% donc il te demande de le faire manuellement.

- Soit tu as pas assez d'espace sur ta µSD et il va te mettre le message d'erreur sur ADB. (Minimum 200mo de libre pour un BCK)

Si tu veux que le SU marche fait ceci :

adb shell

$ /data/local/bin/su

# cat /data/local/bin/su /system/bin/su

# chown root.root /system/bin/su

# chmod 4755 /system/bin/su

# exit

> adb shell

$ su

Et tu devrais obtenir un shell root. Je vais l'ajouter au tuto! (dis moi si tu as une erreur parce que j'ai fait de tête donc j'ai peut-être oublié quelque chose!)

Share this post


Link to post
Share on other sites

pardonne moi peut etre d'être bête/noob/débutant, mais je n'arrive toujours pas à faire les 'adb shell' cmd me renvoi toujours que ce n'est pas reconnu...

Share this post


Link to post
Share on other sites

Ah excuse moi, tu n'as pas compris ce que je t'ai expliqué tout à l'heure ?

Quand je te mets adb, dans ton cas il faut mettre "adb-windows" à la place, je met adb pour que ça soit plus rapide à taper!

Bref, en corrigé ça donne ça :

> adb-windows shell

$ /data/local/bin/su

# cat /data/local/bin/su /system/bin/su

# chown root.root /system/bin/su

# chmod 4755 /system/bin/su

# exit

$ exit

> adb-windows shell

$ su

Share this post


Link to post
Share on other sites

Plantage.... cmd s'est affolé, j'ai un bip, bip xD, je retest dès que j'arrive a stopper voir si j'ai fait une bêtise

Edit: après un redémarrage, je recommence....

Edited by Lince Darkness

Share this post


Link to post
Share on other sites

:P je sais pas ce que ca fait, mais ca fait bien tout planter :D

dès : cat /data/local/bin/su /system/bin/su une bonne 50aine de ligne mini défile super vite et cmd plante

hop, le screen nouvelleimagebitmap7.png

Share this post


Link to post
Share on other sites

Oh bah tiens c'est mignon ça!

Han je suis bête !

J'ai oublié le ">" :

cat /data/local/bin/su > /system/bin/su

Share this post


Link to post
Share on other sites

mmmh.... ca devrait fonctionner, aucune des commande ne m'a fait de bug... mais après réflexion, je suis en root persistant.... dès que je met le shell, je suis direct en auto-root donc, je ne passe plus par le stade $ mais direct #, les commandes n'ont donc peut être plus d'intérêt, vu qu'elle vise la mise en place du raccourcis 'su'

Edit: je vais manger, une petite question, on à une rom modifiée du tattoo sous 2.1?

Share this post


Link to post
Share on other sites

Ah bah oui si tu as flashé le boot.img tu en as plus besoin ^^'

Je suis vraiment à la rue moi des fois :/

Oui : http://forum.xda-developers.com/showthread.php?t=644373

Mais si tu veux la tester, avant fait un backup de ta ROM actuelle avec le recovery.

Et pour flasher cette ROM tu dois faire un wipe (remise à zéro) tu peux le faire via le recovery.

Les accéléromètres et l'APN ne marche pas sur cette ROM !

Share this post


Link to post
Share on other sites

Salut JoOoSs,

Je tente depuis hier de rooter mon tattoo mais je n'y parviens pas.

Alors hier j'ai réussi à aller jusqu'à l'étape II mais cela a toujours foirer pour la dernière commande "/data/local/bin/flash_image recovery /sdcard/recovery_amonra.img" j'avais sois un "permission denied" soit un no "souch file or directory" et aussi j'ai jamais réussi via le cmd de copier "recovery_amonra.img" dans la carte sd car "permission denied" mais je l'ai fait à la mano.

J'ai donc recommencer plusieurs fois et en appliquant les commande que tu as donner à "starrcab" afin de refaire le dossier "bin" et lu toute les pages de ce sujet pour trouver une solution mais nada.

J'ai donc abondonner pour recommencer aujourd'hui car ça commencer grave à me saouler et le tattoo aurait fini par la fenêtre lol.

Donc ben aujourd'hui je recommence donc à partir de la première étape

Etape 1 : Tout se passe bien jusqu'à la I)1)7) quand je rentre "while ./m7 ; do : ; done" cela me met des "usage: reboot [-n] [-p] [rebootcommand]" en boucle mais le quelque ligne attendu viennent quand même et je suis quand même en root donc je pense que c'est bon mais j'ai préférer le mettre au cas où.

Donc je continu mon "périple" et au I)1)8) quand j'entre "id" cela me met (et hier aussi) "uid=0(root) gid=2000(shell) groups=1003(graphics),1004(input),1007(log),1011(adb

),1015(sdcard_rw),3001(net_bt_admin),3002(net_bt),3003(inet)"

donc ca je sais pas si c'est grave ou pas mais je continu quand même! (ca se trouve c'est à cause de ça que sa foire depuis hier...).

Je suis donc maintenant rendu à la I)2)

Tout se passe bien jusqu'à la I)2)5) pour "while ./m7 ; do : ; done" où cela me remet aussi des "usage: reboot [-n] [-p] [rebootcommand]" mais je fini quand même en root...

Et donc là ce qui me bloque depuis tout à l'heure et qui me remet dans le même état qu'hier c'est au moment de "cat /data/local/bin/su > /system/bin/su" cela me met "cannot create /system/bin/su: not enough memory" donc ben là j'ai décider de demander de l'aide car je sais plus quoi faire et à mon avis c'est parce que j'ai essayer pas mal de fois depuis hier donc à force ça à du faire de la m**** dans le portable... Et j'ai pas voulu supprimer des fichier sans savoir...

Si tu pourrais m'aider ca serait cool ^^

Merci d'avance

Tchao

Edited by V1ce

Share this post


Link to post
Share on other sites

Oh mon dieu le post... ^^

"Alors hier j'ai réussi à aller jusqu'à l'étape II mais cela a toujours foirer pour la dernière commande "/data/local/bin/flash_image recovery /sdcard/recovery_amonra.img" j'avais sois un "permission denied" soit un no "souch file or directory" et aussi j'ai jamais réussi via le cmd de copier "recovery_amonra.img" dans la carte sd car "permission denied" mais je l'ai fait à la mano."

-> Tu as pas suivi mon tuto correctement t'as loupé des trucs.

"J'ai donc recommencer plusieurs fois et en appliquant les commande que tu as donner à "starrcab" afin de refaire le dossier "bin" et lu toute les pages de ce sujet pour trouver une solution mais nada."

-> t'aurais du venir poster avant de tester ça parce que ça venait pas de là.

"Etape 1 : Tout se passe bien jusqu'à la I)1)7) quand je rentre "while ./m7 ; do : ; done" cela me met des "usage: reboot [-n] [-p] [rebootcommand]" en boucle mais le quelque ligne attendu viennent quand même et je suis quand même en root donc je pense que c'est bon mais j'ai préférer le mettre au cas où."

-> je l'ai déjà dit, quand y'a ces lignes qui s'affichent tu as juste à appuyer sur entrée et ça va s'arrêter.

"Donc je continu mon "périple" et au I)1)8) quand j'entre "id" cela me met (et hier aussi) "uid=0(root) gid=2000(shell) groups=1003(graphics),1004(input),1007(log),1011(adb"

-> Pas grave, le gid shell est variable entre les différents téléphones.

"Et donc là ce qui me bloque depuis tout à l'heure et qui me remet dans le même état qu'hier c'est au moment de "cat /data/local/bin/su > /system/bin/su" cela me met "cannot create /system/bin/su: not enough memory" donc ben là j'ai décider de demander de l'aide car je sais plus quoi faire et à mon avis c'est parce que j'ai essayer pas mal de fois depuis hier donc à force ça à du faire de la m**** dans le portable... Et j'ai pas voulu supprimer des fichier sans savoir..."

-> -_- la partie "Script Super Utilisateur", elle est à faire une fois, pas plusieurs.

Bref, ça me dit pas ton soucis exact, ça me dit pas à quelle partie tu es exactement, et quelle partie tu as déjà fait à part la I) :/

Edited by JoOoSs

Share this post


Link to post
Share on other sites

Ben en gros j'ai été jusqu'à la fin de l'étape 2 mais ça n'arrivait pas à flasher le recovery.Et aujourd'hui je n'est pas été plus loin que la commande "cat /data/local/bin/su > /system/bin/su" et puis j'ai été voir directement dans mon portable voir si il y avait quand même le fichier su dans /system/bin/ mais il n'y ai pas donc je peux pas avancer sans cela,non? Désolé si je dis faux mais à vrai dire je connais pas grand chose...

Donc pour le "usage: reboot [-n] [-p] [rebootcommand]" j'ai lu le message où tu en parler mais bien que je fasse entrer cela ne s'arrêter pas ou du moins pas tout de suite.

Et puis ben j'ai pas poster plus tôt car j'ai cru que je pourrais y arrivais car des gens avait les même problème que moi sur le sujet donc je me suis servi de tes réponses en croyant que ça allait marcher, je ne voulais pas poster pour rien alors que j'avais des réponses sous les yeux...Mais bon j'aurais dû en fait!!

Dû coup ben je sais pas si j'ai mis assez d'argument pour t'aider à trouver mon prob, dis moi s'il t'en faut d'autre je ferais de mon mieux.

Et puis pourtant j'ai fait le tutop dans l'ordre hier donc ben c'est bizarre mais bon ça se trouve j'ai louper une commande sans le remarquer...

Le mieux serait de reflasher mon tel,non? Car oui j'ai oublier de le préciser j'ai flaser mon tatto pour mettre la ROM de HTC afin d'enlever toute les merdes d'orange.

Share this post


Link to post
Share on other sites
Tu peux faire :

adb-windows shell

$ su

et dit moi le résultat.

Alors :

-$su : permission denied

-$/data/local/bin/su : permission denied

Je le fait avec /data/local/bin/su car "su" tout seul ne marchait pas hier.

Et puis de toute façon depuis aujourd'hui je peux pas me co en root comme cela ça marche que avec "while ./m7 ; do : ; done"

Share this post


Link to post
Share on other sites

Oui t'as loupé des trucs quoi...

adb-windows shell

while ./m7 ; do : ; done

chown root.root /data/local/bin/su

chmod 4755 /data/local/bin/su

Tu fais CTRL + C pour sortir du shell.

Et essaye de refaire /data/local/bin/su.

Share this post


Link to post
Share on other sites

pff rolala je sais pas ce que j'ai oublier mais j'ai vraiment du faire de la m****.

Donc ben pour tes commande je sais pas pourquoi mais quand j'ai taper "while ./m7 ; do : ; done" il me disait qu'il ne trouve pas "m7" alors que ya 10 min ça marchait donc ben j'ai fait :

adb-windows push m7 /data/local/bin/m7

adb-windows shell "cd /data/local/bin && chmod 755 ./m7"

Donc ca a marcher mais quand je fait :

chown root.root /data/local/bin/su il me met chown : not found alors qu'il est bien présent dans /system/bin, et pour le chmod aussi je pige rien,si ca te saoule on arrête si tu veux.

Merci

Edited by V1ce

Share this post


Link to post
Share on other sites

Je me demande ce que tu as fait...

La meilleure chose à faire c'est de reflasher la ROM et le refaire correctement.

Share this post


Link to post
Share on other sites

Ben je ne sais pas ce que j'ai fait mais pourtant il me semble que j'avais bien tout fait et tout avait marcher niquel jusqu'au moment de flasher le recovery.

Je vais donc le reflasher avec la rom HTC et refaire le tuto à la lettre et cette fois dès le 1er soucis je reposterer mais j'espère que je n'aurais pas à le faire.

En tout cas merci pour ton aide, bonne soirée.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...