Aller au contenu
cableethernet

[TUTO] Nouveau Firmware (screens)

Recommended Posts

Tutoriel aussi présent sur le wiki : http://wiki.frandroid.com/wiki/Flasher_le_Samsung_Galaxy_Spica dans la section Samsung Galaxy Spica

Bon, je fais ce topic pour tout simplement montrer comment installer un firmware tout simplement avec screen pour aider.

FACULTATIF - Faire un backup permettant de pouvoir retrouver tout vos messages, applications... Télécharger MyBackup sur le market, c'est gratuit pour 30 jours (mais l'appli vaut le cout) ;).

1 - Enlever le stockage de masse dans paramètres > A propos du téléphone > Paramètres supplémentaires

2 - Cocher le mode déboggage (paramètres > Application > Développement)

3 - Enlever la carte sim et la carte SD

4 - Faire un hardreset *2767*3855#

5 - Téléchargez votre firmware désiré, je vais faire ici avec pour exemple le 3.0.1

6 - Téléchargez ODIN ICI

6 - Éteindre votre spica mais le branchez à rien

7 - Appuyez sur simultanément sur " volume bas + appareil photo + touche raccroché " vous devriez voir apparaitre une disquette.

8 - Connectez votre portable avec le cable USB

9 - Lancez la version 4.03 de ODIN avec les droit d'admin (clique droit puis executez en tant qu'administrateur)

Voila ce que vous devriez avoir :

odiny.jpg

10 - Préparez ODIN avec les fichiers téléchargé : Cochez bien les mêmes cases que moi ;) :

odin2f.jpg

11 - Maintenant vous n'avez plus qu'a cliquer sur "Start" et c'est parti

12 - Après que votre Spica est rebooté seul, éteignez le et redémarrez le et y insérer votre carte SD et votre carte SIM

Voila, vous n'avez plus qu'à réinstaller vos paramètre avec MyBackup si vous l'avez fait et voila.

Je sais qu'il y a déjà le topic épinglé mais apparemment certaines personnes désirés un tuto simple et rapide.

Modifié par cableethernet

Partager ce message


Lien à poster
Partager sur d’autres sites

Quand je retire ma carte sim il reboot tt seul le spica ...

EDIT: Je suis sous seven 64, lors de l'installation du pilote, il tourne en boucle l'installateur .. de pilote ... :mad:

EDIT2: "Périphérique inconnu" en redémarrant ... dans le gestionnaire de périphérique.

Modifié par XdanX

Partager ce message


Lien à poster
Partager sur d’autres sites

Normal qu'il redémarre quand tu enlève la carte SIM, ne t'inquiète pas ;). Pour les pilotes c'est à dire ? Est-il détecté par ODIN ?

Partager ce message


Lien à poster
Partager sur d’autres sites

@cableethernet: +1 pour le tuto.

Par contre tu pourrais mettre les liens des screens dans des balises image (lien), ça serait plus sympa à lire ;)

Modifié par LauCass

Partager ce message


Lien à poster
Partager sur d’autres sites

@XdanX

As-tu bien éteint NPS, il faut enlever le lancement auto.

Sinon, met un dossier avec les drivers du spica sur le bureau.

@+

Partager ce message


Lien à poster
Partager sur d’autres sites
@XdanX

As-tu bien éteint NPS, il faut enlever le lancement auto.

Sinon, met un dossier avec les drivers du spica sur le bureau.

@+

Je viens même d'essayer sous XP 32 bit, pas reconnue ... Quelqu'un aurait-il les drivers ? :|

Partager ce message


Lien à poster
Partager sur d’autres sites

Personnellement je suis sous windows 7 32 bits, je n'ai jamais eu à installer les drivers, odin me l'a détecté direct mais avec xp ...

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est parce que tes liens ne sont pas les bons.

Par exemple:

odiny.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Limpide!

Genial!

Merci cableethernet!

Edit: bah nan en fait je cale sur le "mode deboggage"

Dans les listes de applications classé par ordre alphabetique il a bien "mode deboggage" mais rien a cocher....

Modifié par nath95

Partager ce message


Lien à poster
Partager sur d’autres sites

Question bête : avant de se lancer dans toute la procédure, est-ce qu'il y a une batterie de tests préalable qu'on pourrait faire pour s'assurer que tout fonctionnera bien par la suite ?

Genre :

- S'assurer qu'on a le bon câble et qu'il se connecte bien

- Un test pour voir si Odin reconnait le mobile

- ...

Je pose la question par ce que j'ai le chic pour à chaque fois que j'me lance dans un truc comme ça ça m****...

Autre question bête : comment fait-on pour tapper le code de hard reset sur un mobile tactile sans clavier (j'me doute de la réponse, mais... ça peut servir à d'autres;))

En tout cas, bravo pour le tuto : il est bien détaillé.

J'attends avec hate la rom officielle :)

Modifié par djipe

Partager ce message


Lien à poster
Partager sur d’autres sites
Limpide!

Genial!

Merci cableethernet!

Edit: bah nan en fait je cale sur le "mode deboggage"

Dans les listes de applications classé par ordre alphabetique il a bien "mode deboggage" mais rien a.cocher....

C'est dans développement, pas dans gérer les applications! ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour le clavier, faut allumer le tel. Pour savoir si tes bien connecté a odins faut qu'il y ait un truc comme com4 avec un fond jaune.

Partager ce message


Lien à poster
Partager sur d’autres sites

Comme sur la 1er image pour voir si il est bien détecté ;). Fond jaune avec 1 (COM) 4 et en bas marqué "detected"

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon tuto, mais je bloque quand même. J'ai essayé avec le dernier firmware mis en ligne par samsung firmwares et la deuxième version du fichier ops, mais quelque soit le port USB utilisé et la version d'Odin, ça ne va pas plus loin que "setup connection". Le logiciel n'écrit rien et le téléphone reste invariablement sur son firmware d'origine... Quelqu'un a t il réussi à utiliser ledit firmware ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Bon tuto, mais je bloque quand même. J'ai essayé avec le dernier firmware mis en ligne par samsung firmwares et la deuxième version du fichier ops, mais quelque soit le port USB utilisé et la version d'Odin, ça ne va pas plus loin que "setup connection". Le logiciel n'écrit rien et le téléphone reste invariablement sur son firmware d'origine... Quelqu'un a t il réussi à utiliser ledit firmware ?

j'ai eu le soucis hier soir.

Le hard reset supprime le mode débugage, il faut le sélectionner après ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Je l'ai sélectionné, j'ai tout bien revérifié, et malgré ça, ça bloque toujours.

Partager ce message


Lien à poster
Partager sur d’autres sites

Odin est parfois capricieux, pour ma part je suis souvent obligé de recommencer la manip suivante pour qu'il me flashe enfin mon toaster.

1/ j'éteins le mobile, je débranche tout, je ferme Odin

2/ je lance Odin en mode admin

3/ je démarre mon Spica en download mode

4/ je branche

5/ je flashe

EDIT: je précise que "j'éteins le mobile" signifie dans le cas présent, j'enlève la batterie.

Modifié par kendael

Partager ce message


Lien à poster
Partager sur d’autres sites

Lorque Odin reste bloqué sur <1> setup connection, ça ne marchera pas inutile d'attendre.

Ce que je conseil c'est redémarrer Odin en administrateur et mode compatibilité XP SP3 et de retirer la batterie du spica. Débrancher l'USB, redémarrer le Spica en Download Mode, brancher l'USB et recommencer.

Moi ça à marcher au deuxième essai

Partager ce message


Lien à poster
Partager sur d’autres sites
Lorque Odin reste bloqué sur <1> setup connection, ça ne marchera pas inutile d'attendre.

Ce que je conseil c'est redémarrer Odin en administrateur et mode compatibilité XP SP3 et de retirer la batterie du spica. Débrancher l'USB, redémarrer le Spica en Download Mode, brancher l'USB et recommencer.

Moi ça à marcher au deuxième essai

Merci il est en train de le faire la...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon bah comme beaucoup Odin refuse de voir le Spica démarré en mode Download

Ce qui est étrange c'est quand mode normal les drivers on l'air de le prendre en compte mais en mode download j'ai le petit triangle dans le "gestionnaire de périphérique"

capturefq.jpg

J'ai desinstallé et reinstallé rebooter...etc ...tout cei sans effet:

New_PC_Studio_1.3.0.IJ1

New_PC_Studio_1.4.0.IL4

Samsung_USB_Driver_Installer

J'ai même tenté avec ces drivers speciaux pour notre toaster

http://www.megaupload.com/?d=68ZP7411

et installé manuellement via "mettre a jour le pilote dans le gestionnaire de peripherique"

Vu les posts précédemment lus je ne m'attendais pas a une procédure les doigts dans le nez mais un challenge comme ca

Modifié par nath95

Partager ce message


Lien à poster
Partager sur d’autres sites

@nath95

as tu bien desactiver la surveillance de connection de NPC dans les tache de fond...

moi non plus il ne l'as pas reconnue tous de suite, alors j'ai viré la batterie, redemarré le tel en mode download et rebranché la il l'as pris (je l'ai fais sans redemarré odin)

Autre question bête : comment fait-on pour tapper le code de hard reset sur un mobile tactile sans clavier (j'me doute de la réponse, mais... ça peut servir à d'autres;))

le hard reset est a faire avant de le mettre en mode download donc tu auras acces au clavier

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoignez la conversation

Vous pouvez poster maintenant et vous enregistrez plus tard. Si vous avez un compte, connectez-vous maintenant pour poster.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.






×
×
  • Créer...