Jump to content

[TUTO] Guide d'installation de CyanogenMod 9


Cop1 Gris

Recommended Posts

Re, merci , Restauration de / data ?

Pour info c'est "backup and restore" -> "advancerd restore" -> "restore /data", mais n'en tiens pas compte. C'est une erreur de ma part, puisque réinstaller la ROM n'efface pas les données de toutes façons.

Link to comment
Share on other sites

Oui en théorie, mais non en pratique. Dans 99% des cas ça causera des problème du fait de la différence entre les ROMs.

Et la plupart du temps la restauration des données avec Titanium Backup pose aussi problème, il vaut mieux restaurer les applis seulement.

Link to comment
Share on other sites

Bonjour,

Tout d'abord, merci pour ce super tuto.

Je n'ai pas encore mis CM9, mais il a l'air très détaillé et c'est ce qui m'a décidé de passer à ICS avec CM9 !

Cependant, j'ai quelques questions avant de commencer.

Il est précisé qu'il faut la nouvelle basebande v20 avant de commencer, et il est pluiseurs fois question de la v20g.

Sur mon P500, j'ai la v20e (Si il faut bien regarder dans "A propros du tel" -> "Version du logiciel" -> "LG-P500-V20e")

Cette version suffit, où il faut mieux passer à la v20g ?

Si on a choisi d'utiliser une partition sur la carte µSD afin d'installer ses applications, l'espace supplétaire qui sera disponible sera directement comptabilisé dans la mémoire de stockage interne du téléphone ou pas ? Car actuellement, c'est ce qui me fait plus défaut, je dois supprimer souvent le cache des applis pour avoir un peu de place. (J'ai déjà Link2SD, mais peut-être qu'il n'est pas bien configuré, j'ai pas toutes les partitions...)

Une question peut-être un peu bête: la configuration pour la réception et l'envoie de SMS/MMS se fait automatiquement ?

Où il faut tout faire à la main ?

Après ça je pourais commencer :)

Merci !

Edited by Moi91
Link to comment
Share on other sites

Si on a choisi d'utiliser une partition sur la carte µSD afin d'installer ses applications, l'espace supplétaire qui sera disponible sera directement comptabilisé dans la mémoire de stockage interne du téléphone ou pas ?

Non, la mémoire interne reste telle quelle, et la mémoire interne dispo est de 200 Mo avec CM9.

Pour les fonctionnalités et choses à savoir sur Link2SD:

- Les applications déplacées sur la carte restent utilisables lors du transfert de fichiers via USB.

- On est pas obligé de déplacer toutes les parties d'une application, on peut déplacer juste l'appli elle même, ses librairies, ou son cache.

- On peut déplacer sur la SD les applications qui ne le permettent normalement pas, à l'exception des applis intégrées à la ROM.

- On peut choisir ou installer les nouvelles applis par défaut, c'est à dire dans la mémoire interne, sur la SD, ou de manière automatique. Pour le mode automatique, si l'appli peut aller sur la SD en temps normal, c'est à dire sans Link2SD, elle ira dessus. Sinon elle ira dans la mémoire interne.

- Pour optimiser au maximum les performances, il vaut mieux déplacer en priorité les applis qui prennent beaucoup de place et/ou celles qu'on utilise moins souvent. En effet lancer une appli depuis une carte SD est un poil plus lent que depuis la mémoire interne. Et une carte SD rapide (Classe 6 ou +) est toujours un petit plus.

  • Like 1
Link to comment
Share on other sites

Ça y est, je suis passé sous CM9 avec ICS sur mon P500 !

Durant l’installation, tout s'est bien passé, le tutoriel était très bien détaillé, aucune hésitation. Merci !

Par contre, c'est après que les problèmes commencent....

1) Gros problème avec l'A2SD et Link2SD... Au démarrage de l'appli, elle me demande de choisir le système de fichier de la seconde partition, je prends "ext4" comme décris dans le tuto, mais je tombe sur "Impossible de créer le script de montage". J'ai essayé avec "ext2", là j'ai en plus "mont: Invalid argument - ext2 est peut-être non supporté par votre appareil. Essayez FAT32 pour la seconde partition". J'essaye donc FAT32, et là j'ai mont: Invalid argument"... Que faire pour régler ce problème ?

Dans le tuto, j'ai bien créé la partition EXT de 512Mo et une SWAP de 64 Mo. Je ne sais pas comment on pourrait voir si elles ont bien été créées. J'ai une Sandisk microSDHC classe 4 de 8Go, je ne sais pas si ce détaille est important. Dans le recovery, dernière ligne, j'ai "E: Bad boot message", je ne sais pas si c'est lié.

Dès que j'installe une appli, elle est lié à la Carte SD "Auto-liage", mais qu'est ce que ça signifie réellement ? Lors d'un reboot, Gmail et Facebook ont planté et j'ai eu un message de Link2Sd m'indiquant que la carte n'était pas encore montée et que ces 2 applis n'apparaissaient pas dans le menu. Mais pourtant, elles sont installées sur la mémoire interne. Il est peut-être préférable de ne pas lier ce genre d'application à la SD?

J'ai déplacé d'autres applis sur la carte SD, mais comment sait on si l'apk, ses lib et son cache sont déplacés ? C'est ce que j'aimerais, pour pouvoir installer de nombreuses applis et ne pas manquer de place. (Il y aussi Dex, je ne sais pas ce que c'est?)

2) L'appli Movie Studio ne veut pas créer de projet, et se ferme juste après. J'ai fait un reboot et un Wipe cache partition & Wipe /dalvik-cache, mais aucun changement...

3) La recherche vocale ne fonctionne pas. Lors du premier lancement, j'ai eu les explications, puis j’appuie sur le micro pour parler... et rien ne se passe... Au bout d'un moment, l'appli se ferme, mais sans message d'erreur. Pareil si je touche aux paramètres, Safesearch, langue, l'appli se ferme après.... J'ai reboot et fait Wipe cache partition & Wipe /dalvik-cache, mais aucun changement.

J'ai installé les Gapps et la langue française juste après avoir installé la ROM.

4) Je n'arrive pas à synchroniser mes contacts avec Facebook... Ceux de Gmail apparaissent bien, mais aucune infos des contacts Facebook fusionnent avec, je n'ai pas les photos, date d’anniversaire et tel de certains. Dans "Comptes et synchro", j'ai bien mon compte Facebook avec la synchro activé. Et si je fais "Ajouter un compte Facebook", rien ne se passe, je reste bloqué sur l'écran d'accueil de l'application Facebook...Et dans l'appli elle-même, je ne vois pas les options de synchro, genre synchroniser qu'avec les contacts existants, ou des choses comme ça...

Désolé de vous embêter avec tous mes problèmes...

J'ai bien cette nouvelle interface et les options qu'offre CM9, mais si je n'arrive pas à résoudre ces problèmes, je vais devoir repassé avec mon ancienne ROM officiel pourrie...

Link to comment
Share on other sites

J'ai un problème pour mettre à jour deux applications : il télécharge l'application et arrivé au moment de l'installation il met un popup "Stockage disponible insuffisant" alors que l'application fait 2mo et que j'ai 20mo de libre. Les autres applications arrivent à se mettre à jour mais pas ces 2 la.

Link to comment
Share on other sites

Plop,

J'ai un problème pour mettre à jour deux applications : il télécharge l'application et arrivé au moment de l'installation il met un popup "Stockage disponible insuffisant" alors que l'application fait 2mo et que j'ai 20mo de libre. Les autres applications arrivent à se mettre à jour mais pas ces 2 la.

Problème déjà rencontré et résolu en désinstallant les mises à jour du market, et en laissant la dernière version (3.7.13) se réinstaller.

Gros problème avec l'A2SD et Link2SD... Au démarrage de l'appli, elle me demande de choisir le système de fichier de la seconde partition, je prends "ext4" comme décris dans le tuto, mais je tombe sur "Impossible de créer le script de montage". J'ai essayé avec "ext2", là j'ai en plus "mont: Invalid argument - ext2 est peut-être non supporté par votre appareil. Essayez FAT32 pour la seconde partition". J'essaye donc FAT32, et là j'ai mont: Invalid argument"... Que faire pour régler ce problème ?

Le fait que ça ne fonctionne pas avec "ext2" et "FAT32" ça cest normal. Est ce que Link2SD a bien les droits roots en permanence ? A vérifier via l'appli SuperUser. En profiter pour la mettre à jour l'application SuperUser via le market. Et mettre à jour le binaire su au passage, via l'onglet "info" de l'application SuperUser, puis en clickant "tap to check for updates".

Dans le tuto, j'ai bien créé la partition EXT de 512Mo et une SWAP de 64 Mo. Je ne sais pas comment on pourrait voir si elles ont bien été créées. J'ai une Sandisk microSDHC classe 4 de 8Go, je ne sais pas si ce détaille est important. Dans le recovery, dernière ligne, j'ai "E: Bad boot message", je ne sais pas si c'est lié.

Le message "E: Bad boot message" c'est normal, ça l'a toujours fait. Pour vérifier ou modifier les partitions, un live CD tel que GParted fait l'affaire.

L'appli Movie Studio ne veut pas créer de projet, et se ferme juste après. J'ai fait un reboot et un Wipe cache partition & Wipe /dalvik-cache, mais aucun changement...

L'appli ne peut se lancer à cause d'une lib manquante. Soit "/system/lib/libvideoeditor_jni.so", soit "/system/lib/libvideoeditorplayer.so". Quelle méthode employée pour installer l'appli ? En utilisant le zip flashable ou autrement ?

Pour le reste des problèmes, vu que le tel est dans un état instable à cause de Link2SD qui ne fonctionne pas correctement, il vaut mieux attendre de voir.

----------------------------------------------------------------------------------------------------------------------------

Une info au passage, je modifierai le tuto plus tard. Ca fait un moment que je teste ça, utiliser la stratégie CPU SmartassV2 a totalement fait disparaitre les quelques rares blackscreens qui pouvaient subsister. Comme par exemple en éteignant / rallumant l'écran très rapidement.

Edited by Cop1 Gris
Link to comment
Share on other sites

Problème déjà rencontré et résolu en désinstallant les mises à jour du market, et en laissant la dernière version (3.7.13) se réinstaller.

Comment tu fais réinstaller la dernière version du market ? Le mien reste en 3.5.15 depuis que j'ai supprimé les mises à jour.

Link to comment
Share on other sites

De mon côté j'ai le même problème que moi91 pour la recherche vocale mais j'ai aussi un autre problème c'est quand je regarde une vidéo sur YouTube ou un autre site, quelque minutes après le téléphone reboot...

Link to comment
Share on other sites

Et moi ? il y a pas de solutions ? Merci

A part un souci matériel avec la prise jack du téléphone, je vois pas :/

Comment tu fais réinstaller la dernière version du market ? Le mien reste en 3.5.15 depuis que j'ai supprimé les mises à jour.

Il doit se mettre à jour seul comme d'habitude, mais pour accélérer le truc, forcer l'arrêt, supprimer les données de l'applications, et le relancer. Après avoir accepté les conditions d'utilisations il va chercher la MàJ (De manière transparente).

quand je regarde une vidéo sur YouTube ou un autre site, quelque minutes après le téléphone reboot...

Tester en supprimant les préférences de l'appli YouTube, et s'assurer que la HD n'est pas activée.

Link to comment
Share on other sites

Merci Cop1 Gris pour ton aide !

Ça s'arrange un peu pour moi.

J'ai réussi à bien faire fonctionner Link2SD.

J'ai utilisé MiniTool Partition Wizard comme expliqué dans d'autres tutos du forum et ça marche !

J'ai aussi réglé mon problème de synchronisation de contact, j'ai utilisé l'appli "Facebook Contact Sync"

Mais deux autres problèmes: envoi de MMS impossible et enregistrement de vidéo tout noir.

Je vais repasser en ROM officiel quelques temps car je pars, puis retenterai le coup après.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...