Jump to content

[TUTO] Réinitialisation Usine du Nexus 4


Minux

Recommended Posts

Bonsoir,

je tente de suivre ce tuto, mais je bloque au flash-all.bat.

 

voici ce que j'ai fais : 

j'ai téléchargé la dernière image donnée (4.4).

or, quand je lance une invite de commande, direct fastboot ne marche pas.

 

j'ai donc installé SDK manager, et là si je lance une invite de commande du dossier android sdk, fastboot fonctionne.

sauf que du coup il m'erase bien tout, mais impossible d'installer la nouvelle image..

 

du coup, je me retrouve en mode bootloader, et je n'ai rien d'autre...

 

j'ai tenté de passer par NRT, mais adb devices ne reconnait rien.

je suis alors passé, dans les "advanced utilities" de NRT par fastboot, en lui donnant chaque chemin de fichier (bootloader, radio, et system) (du fichier téléchargé).

 

mais mon nexus est toujours bloqué en mode bootloader, rien d'autre ne marche...

 

Je suis comme qui dirait bloquée ... et j'ai besoin d'aide .. :/

 

Merci

 

Edit : alors en fait pour être plus précise, voici comment j'avance :

il faut mettre l'image téléchargé et dézippée dans le dossier platform tools du dossier android sdk. et là le fichier .bat fonctionne !

bon j'attends... mais du coup ca peut etre à rajouter dans le tuto ?

 

C'est bon c'est résolu, assez simple au final ;)

Edited by auryn111
Link to comment
Share on other sites

Salut,

décompresse deux fois l'image google pour avoir comme là :

pkae.jpg

sélectionne tout , copier , et dans le dossier platform-tools du SDK , colle y tout

et lance l'invité de commande :

pour ouvrir une fenêtre d'invité de commande , clic droit sur le dossier avec là touche majuscule enfoncé , puis , "ouvrir une fenêtre de commande ici" ;)

4qtu.png

https://forum.frandroid.com/topic/127559-tuto-réinitialisation-usine-du-nexus-4/?p=2744370 Edited by flo//
Link to comment
Share on other sites

Bonjour,

 

J'ai eu le méme probléme suite a la mise a jour 4.4.2 elle fonctioner corectement puis au soir j'ai eteind mon téléphone depuis imposible de le ralumer il reste bloquer sur le logo :/ .

J'ai esayer le wipe/cache et wipe/data dans le menu recovery   =>  ça na rien changer
J'ai esayer la restauration d'usine au début de ce tuto               =>  ça na rien changer ^^"
J'ai esayer avec le script de Tetsumaki adapter pour la factory image kot49h  => et la aussi le probléme persiste :'(

Je ne sais plus quoi faire ...

Link to comment
Share on other sites

Voici ce que j'ai fais:

 

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot erase boot

erasing 'boot'...

OKAY [  0.016s]

finished. total time: 0.016s

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot erase cache

******** Did you mean to fastboot format this partition?

erasing 'cache'...

OKAY [  0.031s]

finished. total time: 0.031s

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot erase recovery

erasing 'recovery'...

OKAY [  0.016s]

finished. total time: 0.016s

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot erase system

******** Did you mean to fastboot format this partition?

erasing 'system'...

OKAY [  0.703s]

finished. total time: 0.703s

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot erase userdata

******** Did you mean to fastboot format this partition?

erasing 'userdata'...

OKAY [  0.797s]

finished. total time: 0.797s

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot flash bootloader bootlo

ader-mako-makoz30d.img

sending 'bootloader' (2203 KB)...

OKAY [  0.078s]

writing 'bootloader'...

OKAY [  0.297s]

finished. total time: 0.375s

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot reboot-bootloader

rebooting into bootloader...

OKAY [  0.000s]

finished. total time: 0.000s

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot flash radio radio-mako-

m9615a-cefwmazm-2.0.1700.48.img

error: cannot load 'radio-mako-m9615a-cefwmazm-2.0.1700.48.img': No error

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot flash radio radio-mako-

m9615a-cefwmazm-2.0.1700.98.img

sending 'radio' (45537 KB)...

OKAY [  1.500s]

writing 'radio'...

OKAY [  2.505s]

finished. total time: 4.005s

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot reboot-bootloader

rebooting into bootloader...

OKAY [ -0.000s]

finished. total time: -0.000s

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot -w update imae-occam-ko

t49h.zip

error: failed to load 'imae-occam-kot49h.zip': No error

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot -w update image-occam-k

ot49h.zip

archive does not contain 'boot.sig'

archive does not contain 'recovery.sig'

archive does not contain 'system.sig'

--------------------------------------------

Bootloader Version...: MAKOZ30d

Baseband Version.....: M9615A-CEFWMAZM-2.0.1700.98

Serial Number........: 018a2bf5e15621bd

--------------------------------------------

checking product...

OKAY [  0.016s]

checking version-bootloader...

OKAY [ -0.000s]

checking version-baseband...

OKAY [ -0.000s]

sending 'boot' (6340 KB)...

OKAY [  0.203s]

writing 'boot'...

OKAY [  0.344s]

sending 'recovery' (6888 KB)...

OKAY [  0.266s]

writing 'recovery'...

OKAY [  0.375s]

erasing 'system'...

OKAY [  0.031s]

sending 'system' (713960 KB)...

OKAY [ 23.439s]

writing 'system'...

OKAY [ 39.605s]

erasing 'userdata'...

OKAY [  0.422s]

formatting 'userdata' partition...

Creating filesystem with parameters:

    Size: 14129561600

    Block size: 4096

    Blocks per group: 32768

    Inodes per group: 8144

    Inode size: 256

    Journal blocks: 32768

    Label:

    Blocks: 3449600

    Block groups: 106

    Reserved block group size: 847

Created filesystem with 11/863264 inodes and 95427/3449600 blocks

sending 'userdata' (137438 KB)...

writing 'userdata'...

OKAY [ 13.014s]

erasing 'cache'...

OKAY [  0.031s]

formatting 'cache' partition...

Creating filesystem with parameters:

    Size: 587202560

    Block size: 4096

    Blocks per group: 32768

    Inodes per group: 7168

    Inode size: 256

    Journal blocks: 2240

    Label:

    Blocks: 143360

    Block groups: 5

    Reserved block group size: 39

Created filesystem with 11/35840 inodes and 4616/143360 blocks

sending 'cache' (10984 KB)...

writing 'cache'...

OKAY [  1.047s]

rebooting...

finished. total time: 78.882s

Link to comment
Share on other sites

Je l'ai fais et ça na rien changer

edit : je viens de recomence juste les 5 erase puis j'ai double click sur le fichier Flash-all.bat

il s'exécute coretement, mon téléphone redémare et reste sur le logo :/

Edited by Zyrkum
Link to comment
Share on other sites

Je l'ai fais et ça na rien changer

edit : je viens de recomence juste les 5 erase puis j'ai double click sur le fichier Flash-all.bat

il s'exécute coretement, mon téléphone redémare et reste sur le logo :/

patiente bien car le premier Boot est long ;)

Link to comment
Share on other sites

5 mn environs , si il reste sur le logo , tu as un souci , il te faut recommencer du début , re dl là factory 4.4.2

et recommence : /

édit : sinon , j'avais eu un souci un peut pareil , test verrouille le bootloader et déverouille le ;)

fastboot oem lock

fastboot oem unlock

fastboot erase xxxx

et lance le fichier .bat

édit2 : tu as reussi ?

Edited by flo//
Link to comment
Share on other sites

Voila, j'ai re dl le factory et avant de recomencer la manip j'ai verrouiller/déverrouiller le bootloader, je me suis aussi mis en Admin pour l'invite de commande ( on ne sais jamais).

Un changement apres le rebootage final j'ai eu le petit android de mise a jour et mon téléphone a encore redémarer maintenant j'atend ...

Edite : 10minutes et je suis toujours sur le logo je commence a détester ces 4 couleur *_*.

Edited by Zyrkum
Link to comment
Share on other sites

c'est pas normal ça !

tu n'as pas flasher un truc pas pour le Nexus 4 j'espere ? sinon , c'est mort

édit:

instal le SDK complet c'est mieux que le minimal comme tu as là

pour Windows 64 Bits/32bits

installe le JDK sur ton pc en 1er : http://dls2.androidgen.fr/J/jdk-windows_1297428600.zip

puis le SDK : installer_r22.0.5-windows.exe

et tu recommence installe le pilote adb et go

 

décompresse deux fois l'image google pour avoir comme là :

pkae.jpg

sélectionne tout , copier , et dans le dossier platform-tools du SDK , colle y tout

et lance l'invité de commande :

https://forum.frandroid.com/topic/127559-tuto-réinitialisation-usine-du-nexus-4/?p=2744370

Edited by flo//
Link to comment
Share on other sites

  • 4 weeks later...

Bon, après avoir passé une heure à me battre avec mon N4, je confirme qu'un lock/unlock préliminaire du bootloader peut suffire à régler les problèmes de bootloop.

 

Merci pour ce super tuto qui m'a remis d'équerre un N4 bousillé par le gestionnaire de mises à jour auto tout pourri de CyanogenMod.

Link to comment
Share on other sites

  • 3 months later...

J'ai toujours suivi ce tuto pour remettre d'origine mon n4 mais j'ai remarqué qu'a chaque fois j'avais "archive does not contain 'boot.sig'

archive does not contain 'recovery.sig'
archive does not contain 'system.sig'

Qui apparaît dans le log.. Alors je me demande si c'est normal sachant que ça a toujours fonctionné comme ça.

Link to comment
Share on other sites

Bonjour,

 

Désolé pour la longueur de ce post mais je suis bloqué et j'essaye de détailler pour ne pas vous faire perdre de temps.

 

Mon Nexus4 m'a fait une mauvaise blague aujourd'hui. Des processus Google ont commencé à planter tout seuls. J'ai donc fait un redémarrage.

Ce dernier restait sur le logo avec les ronds rebondissants. J'ai donc essayé de faire un factory reset avec les commandes indiquées dans ce tuto.

 

J'ai lancé ces commandes en root :

 



# fastboot devices
00456a520b49562c 


fastboot erase boot
erasing 'boot'...
FAILED (remote: not supported in locked device)
finished. total time: 0.002s


# fastboot erase cache
******** Did you mean to fastboot format this partition?
erasing 'cache'...
FAILED (remote: not supported in locked device)
finished. total time: 0.002s


# fastboot erase recovery
erasing 'recovery'...
FAILED (remote: not supported in locked device)
finished. total time: 0.002s


# fastboot erase system
******** Did you mean to fastboot format this partition?
erasing 'system'...
FAILED (remote: not supported in locked device)
finished. total time: 0.002s


# fastboot erase userdata
******** Did you mean to fastboot format this partition?
erasing 'userdata'...
FAILED (remote: not supported in locked device)
finished. total time: 0.002s


Bon ok, je dois délocker le bootloader :

 



# fastboot oem unlock
...
OKAY [  5.185s]
finished. total time: 5.185s


> Yes sur le téléphone LOCK STATE passe à unlocked 

 

relançons les commandes maintenant :

 



# fastboot erase boot
erasing 'boot'...
OKAY [  0.343s]
finished. total time: 0.343s


# fastboot erase cache
******** Did you mean to fastboot format this partition?
erasing 'cache'...
OKAY [  0.021s]
finished. total time: 0.021s


# fastboot erase recovery
erasing 'recovery'...
OKAY [  0.343s]
finished. total time: 0.343s


# fastboot erase system
******** Did you mean to fastboot format this partition?
erasing 'system'...
OKAY [  0.027s]
finished. total time: 0.027s


# fastboot erase userdata
******** Did you mean to fastboot format this partition?
erasing 'userdata'...
OKAY [  0.934s]
finished. total time: 0.934s


OK ça semble fonctionner, on passe à la suite avec le flash 


 



# md5sum occam-kot49h-factory-02e344de.tgz 
c9d96bbcc0d1edf50011bb4f0d23d36d  occam-kot49h-factory-02e344de.t


Ça correspond OK

 

On décompresse :

 



tar zxvf occam-kot49h-factory-02e344de.tgz
occam-kot49h/
occam-kot49h/radio-mako-m9615a-cefwmazm-2.0.1700.98.img
occam-kot49h/flash-base.sh
occam-kot49h/image-occam-kot49h.zip
occam-kot49h/flash-all.bat
occam-kot49h/bootloader-mako-makoz30d.img
occam-kot49h/flash-all.sh


OK on peut lancer flash-all.sh

 



# cd  occam-kot49h
# ./flash-alll.sh
sending 'bootloader' (2203 KB)...
OKAY [  0.071s]
writing 'bootloader'...
FAILED (remote: flash write failure)
finished. total time: 0.075s
rebooting into bootloader...
OKAY [  0.001s]
finished. total time: 0.001s
sending 'radio' (45537 KB)...
OKAY [  1.436s]
writing 'radio'...
FAILED (remote: not supported in locked device)
finished. total time: 1.437s
rebooting into bootloader...
OKAY [  0.001s]
finished. total time: 0.001s
archive does not contain 'boot.sig'
archive does not contain 'recovery.sig'
archive does not contain 'system.sig'
--------------------------------------------
Bootloader Version...: MAKOZ30d
Baseband Version.....: M9615A-CEFWMAZM-2.0.1700.98
Serial Number........: 00456a520b49562c
--------------------------------------------
checking product...
OKAY [  0.002s]
checking version-bootloader...
OKAY [  0.002s]
checking version-baseband...
OKAY [  0.002s]
sending 'boot' (6340 KB)...
OKAY [  0.204s]
writing 'boot'...
FAILED (remote: not supported in locked device)
finished. total time: 0.219s


Là on peut voir que mon téléphone ne reste pas unlocked après un reboot du bootloader.

J'ai tenté de redémarrer après un unlock mais il repasse quand même en locked.

On peut voir que dès la première commande, j'ai un  FAILED (remote: flash write failure)

 

Mon téléphone est maintenant dans l'état où je n'ai même plus le logo Google, le rétroéclairage s'allume mais rien de plus. Si je le branche sur mon PC, il passe directement au bootloader. Dès que j'essaye d'écrire quoique ce soit une fois le bootloader débloqué je me retrouve avec des FAILED (remote: flash write failure)

 

Auriez-vous une idée ? Ma flash serait elle morte ?

Merci !

Link to comment
Share on other sites

  • 1 month later...

Salut j'ai tout éffacé sur ma nexus 7 =( et je n'arrive pas à executer les commandes pour restaurer la rom d'origine depuis le bootloader (fastboot)

 

Que faire ??

 

J'ai réussi, il y a un problème dans le zip DL sur le site de Google car j'avais des fichiers d'une autre version que celle de la nakasi.

Edited by marty69500
Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...