Jump to content
Lannig

[MPDC88BT] Discussion, échange d'expériences, root, Google Play

Recommended Posts

Grand Merci Lannig !

 

J'avais acheté des MPDC 8BT pour les brancher sur des videos-projecteurs mais il me manquait andropen pour afficher les fichiers odg;

J'avais installé google play à l'arrache avec un apk mais sans succés !

Avec ton fichier bat l'installation s'est faite en 30 secondes et j'ai enfin accés à toutes les applications dont j'ai besoin ce que ne permettait pas cette bouse d'opéra !

Edited by Lannig
Citation inutile supprimée - en principe on ne doit citer intégralement ni le post #1 d'un sujet, ni celui situé juste avant le sien. Merci d'avance pour l'encombrement des pages du forum :)

Share this post


Link to post
Share on other sites

De rien - attention, l'abus de citations est mauvais pour la santé du forum :)

Share this post


Link to post
Share on other sites

J'ai sorti ma MPDC88 BT IPS de sa pochette dont elle n'était pas sortie depuis quelques mois...

Toujours aussi instable, freezes temporaires (on en sort en la mettant en veille en insistant bien, puis en rappuyant sur le bouton) ou bien définitifs, encéphalogramme plat même en ADB, il faut passer par le long appui pour l'éteindre :(

Je vais donc me lancer dans des tentatives de flashage.

 

Avant cela j'ai voulu faire un vrai dump propre de la tablette c-a-d avec rkflashtool sous Linux, pour avoir le fichier parameter, entre autres. Pas de problème si ce n'est la grosse surprise au rallumage : le fameux halo blanc tout autour de l'écran déjà signalé par certains. En fait il semble que plus longtemps la tablette reste en mode flashage (reboot bootloader) plus on a de chances de récupérer ce halo.

Heureusement, il semble s'estomper avec le temps. Là ça fait 1/2h que la tablette est en marche, écran maintenu allumé, et il a presque disparu.

Quelle daube cet écran, quand même. Je me souviens que quand je l'avais sortie de la boîte, il était bien marqué avec le logo de la charge batterie ! (ça avait disparu aussi).

 

Je vais déjà essayer de flasher le firmware 4.1.1 trouvé sur le site de MPMAN, il est plus récent que le mien : 20130304 contre 20121211.

Ensuite je ferai des tentatives avec le firmware I-Muz, mais je l'ai décortiqué et il semble bien y avoir des différences importantes au niveau du hardware, donc je ne suis pas très confiant.

Share this post


Link to post
Share on other sites

Bonsoir a tous j'ai acquis une tablette mpman mpqc804 et voilà deux jours que je m'arrache les poils de la tête car je n`arrive pas a installer play store... j`ai vu que c`etait pourtant faisable mais je trouve pas de solutions et les forums que j`ai fait ne disent jamais les même choses où leurs propositions ne fonctionnent pas...

Ça commence a me courir sur le haricot :'( a cette allure là je vais finir chauve et c'est pas très féminin lol

Il y a t-il une âme charitable pour m'aider? Ça serait gentil... :-) merci!

Share this post


Link to post
Share on other sites

Bonsoir,

Mauvais sujet, celui-ci ne traite que de la MPDC88BT et des modèles très similaires, ce qui n'est pas le cas des MPQCxxx. :) La démarche pour celles-là est résumée ici : https://forum.frandroid.com/topic/180285-mpqc1004-comment-installer-le-play-store/#entry2888317. Si tu as besoin d'aide pour l'appliquer, merci d'en faire la demande dans le sujet traitant de l'installation du Play Store pour la MPQC804 (il y en a un, de tête).

  • Like 2

Share this post


Link to post
Share on other sites

Instructions :

- extraire le zip quelque part, je dis bien extraire tous les fichiers du zip dans un dossier, ne pas se contenter de cliquer sur runme.bat directement depuis le "dossier" virtuel que présente Windows quand on clique sur un zip. Utiliser Winzip, WinRAR, 7Zip etc. ou bien juste l'assistant d'extraction de Windows.

- mettre la tablette en mode débogage USB dans les options des développeurs

- la brancher sur le PC

- forcer une installation manuelle du pilote, et quand Windows demande de trouver le pilote, l'amener vers le sous-dossier usb_driver du zip extrait pour installer le périphérique détecté

- ouvrir le dossier qui contient le zip extrait dans l'explorateur de fichiers

- double-cliquer sur runme.bat

- ne pas fermer la fenêtre noire (cmd.exe) à la fin de l'opération : si quelque chose ne s'est pas passé comme prévu, il sera indispensable de faire un copier/coller ce ce qu'il y a dans la fenêtre pour que je vous aide

Une fois le script runme.bat exécuté, Google Play doit apparaître dans la liste de vos applications.

Si le script bloque après "--- waiting for device" c'est que la tablette n'est pas détectée.

Verifier :

- qu'elle est bien en mode débogage USB

- qu'elle est bien branchée (!)

- que le pilote s'est bien installé à l'étape précédente

- qu'il y a bien un dossier .android (oui, oui, le nom commence par un point) dans un des dossiers suivants suivant votre version de Windows :

C:\Documents and Settings\votre-nom-utilisateur

C:\Users\votre-nom-utilisateur

C:\Utilisateurs\votre-nom-utilisateur

Ce dossier .android doit contenir adb_usb.ini que vous pouvez ouvrir avec le bloc-note pour vérifier qu'il contient une seule ligne :

0x2207

Si Google Play n'apparaît pas c'est qu'une des commandes a échoué. Il y a sans doute eu un message d'erreur, recopiez-le depuis la fenêtre cmd.exe dans un post ici.

 

 

Bonjour,

 

J'ai tenté votre méthode sur ma tablette MP MAN MPDC112. Lors de l'éxecution de runme.bat une erreur se produit :

 

--- installing the .android folder into your profile
 
C:\Users\Maxence\Desktop\Kit_Play_MPDC88\Kit_Play_MPDC88>xcopy ".android" "C:\Us
ers\Maxence\.android" /s /i /y
.android\adb_usb.ini
1 fichier(s) copié(s)
If next command hangs, then your MPDC88 is not detected
- make sure it is in USB debug mode
- make sure that you have installed the provided driver
- make sure that there is a copy of the provided .android folder in:
  C:\Documents and Settings\yourname          OR
  C:\Users\yourname                           OR
  C:\Utilisateurs\yourname
  ...depending on your version of Windows
--- waiting for device
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
--- remounting /system read-write
remount failed: Read-only file system
--- copying Phonesky.apk to /system/app
failed to copy 'Phonesky.apk' to '/system/app/Phonesky.apk': Read-only file syst
em
--- correcting ownership
Unable to chown /system/app/Phonesky.apk: No such file or directory
--- correcting permissions
Unable to chmod /system/app/Phonesky.apk: No such file or directory
DONE.
Appuyez sur une touche pour continuer...
 
Que dois-je faire ?
 
Merci d'avance

Share this post


Link to post
Share on other sites

Bonjour,

 

Voici ce que donnent les commandes : 

 

C:\adb>adb shell id
uid=0(root) gid=0(root)
 
C:\adb>adb shell mount -o remount,rw /system
mount: Read-only file system
 
C:\adb>adb shell mount
rootfs / rootfs rw 0 0
tmpfs /dev tmpfs rw,nosuid,relatime,mode=755 0 0
devpts /dev/pts devpts rw,relatime,mode=600 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,relatime 0 0
tmpfs /mnt/secure tmpfs rw,relatime,mode=700 0 0
tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
tmpfs /mnt/obb tmpfs rw,relatime,mode=755,gid=1000 0 0
none /dev/cpuctl cgroup rw,relatime,cpu 0 0
/dev/block/system /system ext4 ro,nodev,noatime,user_xattr,barrier=0,data=ordere
d 0 0
/dev/block/data /data ext4 rw,nosuid,nodev,noatime,user_xattr,barrier=0,journal_
checksum,data=ordered,noauto_da_alloc 0 0
/dev/block/cache /cache ext4 rw,nosuid,nodev,noatime,user_xattr,barrier=0,journa
l_checksum,data=ordered,noauto_da_alloc 0 0
/dev/block/vold/93:72 /mnt/sdcard vfat rw,dirsync,nosuid,nodev,noexec,relatime,u
id=1000,gid=1015,fmask=0702,dmask=0702,allow_utime=0020,codepage=cp437,iocharset
=ascii,shortname=mixed,utf8,errors=remount-ro 0 0
/dev/block/vold/93:72 /mnt/secure/asec vfat rw,dirsync,nosuid,nodev,noexec,relat
ime,uid=1000,gid=1015,fmask=0702,dmask=0702,allow_utime=0020,codepage=cp437,ioch
arset=ascii,shortname=mixed,utf8,errors=remount-ro 0 0
tmpfs /mnt/sdcard/.android_secure tmpfs ro,relatime,size=0k,mode=000 0 0

 

 

Qu'est-ce que cela doit m'apprendre sur l'erreur rencontrée précédemment ?

Share this post


Link to post
Share on other sites

Cela nous apprend que tu ne peux pas remonter /system en écriture (nécessaire pour y installer Google Play) malgré le fait que tu aies un shell root (ce qui devrait le permettre). Malheureusement, c'est un problème qui s'est déjà montré sur diverses tablettes sur le forum et dont la cause est incertaine. Quant à la résolution, il n'y a eu ici qu'une longue opération délicate sur une tablette précise (), donc pas vraiment de solution accessible dans l'immédiat, désolé.

Pour info, sur d'autres tablettes, le problème était parfois erratique et pouvait se résoudre spontanément après multiples tentatives de remontages, reset usine ou autres.

Share this post


Link to post
Share on other sites

Flasher un firmware sur une tablette qui tourne 'correctement', je serais toujours un poil sceptique. Pas à l'abri de l'incompatibilité et de se retrouver avec une tablette plus ou moins non fonctionnelle.

À part ça, c'est peut-être une façon de régler ce problème, oui. C'est le cas sur la Logicom S1024 qui a exactement la même chose.

 

Il me semble par contre qu'il y a (au moins) deux versions très différentes de la MPDC112, à vérifier avant tout.

Edited by zrt22

Share this post


Link to post
Share on other sites

D'accord, merci pour cet éclairage ! Je vais parcourir un peu plus le forum histoire de m'imprégner de ces manip' (relativement nouvelles pour moi) et je verrais ensuite ce qui me semble être le plus judicieux, d'autant que cette tablette ne m'est pas indispensable...

Share this post


Link to post
Share on other sites

Bonjour , voila je rencontre un soucis avec une Mpman888 .

 

J'ai changé l"ecran mais j'ai prit l'ecran d'une Mpdc8 BT et depuis ma Mpm888 fonctionne mais les couleur sont bizar ( un peu comme els windows style 16 couleurs ou en negatif )

 

le soucis peut il venir du faite que mon écran soit un IPS ? ( du moins il me semble que sur les MPDC8BT cest un écran IPS )

 

 

Edit2 : bon bas ma tablette est HS :/ aprés avoir voulu testé une rom , ma tablette s'allume blanc 2 sec pour se coupe et se rallume blanc '( l'ecran clignote blanc en gros ) et je ne peu rien faire je n'ai meme pas acces au recovery :/ tanpis

Edited by Madx45

Share this post


Link to post
Share on other sites

Tu es un amour un ange un dieu ,, ma tablette dormait dans mon placard depuis plusieurs mois et grace a toi elle revit , et ma fille aussi

 

je t envois des millions de merci  :emo_im_kissing:  :emo_im_kissing:  :emo_im_kissing:  :emo_im_kissing:  :emo_im_kissing:  :emo_im_kissing:  :emo_im_kissing:  :emo_im_kissing:  :emo_im_kissing:  :emo_im_kissing:  :emo_im_kissing:

Share this post


Link to post
Share on other sites

A mon tour de faire des louanges à Lannig 🙏

J'ai réussi à installer le Play Store sur ma Mpman MPDC77 grâce à tes instructions, sois-en remercié pour toutes tes informations et ton zip 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...