Jump to content
Andronymous

[RUU] Référencement de RUUs et OTAs

Recommended Posts

Bonjour je crois que l'erreur que tu obtiens, c'est parce que la version de ton tel est pas la même que la RUU que tu as téléchargé, si je dis pas de bêtise :)

Share this post


Link to post
Share on other sites

Merci pour ta réponse.

 

la version de mon tél ? tu veux dire la version d'android ?

Ca voudrait dire qu'il faut que je mette absolument la rom de la meme version d'android que mon tél ? à savoir la 4.2.2 ?

et ca veut donc dire que la version de la rom que j'ai trouvée est inférieure à la 4.2.2 ?

 

J'avoue avoir un peu cherché avant et j'ai pensé à cette incompatibilité de version d'android, mais quand je vois que certains ici ont réussi à mettre la rom stock au mois d'aout, je me suis dit que ce n'était peut etre pas forcément lié à la version d'android

 

Si quelqu'un pouvait m'aider je lui en serais infiniment reconnaissant :)

Share this post


Link to post
Share on other sites

Situ n'es pas S-OFF, tu ne peux pas dowgrader la build. Il faut au minimum installer une RUU de la même build que celle actuellement présente dans ton HTC.

Share this post


Link to post
Share on other sites

Merci pour ta réponse. Ça m'amène à poser 2 nouvelles questions :

 

- Si je reste S-ON, où trouver la RUU officielle Europe correspondant à ma build ? d'ailleurs existe-t-elle ?

- Est-ce que je peux passer S-OFF ? sachant que j'ai lu qu'il n'était pas possible de passer S-OFF avec le Hboot 1.54.000, et comme je le disais j'ai eu 6 tentatives en échec avec revone.

 

Merci d'avance

Share this post


Link to post
Share on other sites

Désolé quand j'ai dis version je voulais dire le firmware, par exemple ta RUU est en 1.28 alors ton firmware doit aussi être en 1.28, mais actuellement avec les récentes mise à jour la version est 2.24 pour moi.

Je sais pas si j'ai été assez clair :)

Après c'est de ce que moi j'ai compris car j'ai un peu lutter à m'en sortir de cette histoire de RUU (sans savoir si j'ai vraiment réussi lol).

Pour ce qui est du S-OFF je crois qu'il est pas compatible avec les One qui ont un HBOOT de 1.54 car la procédure bloque au fichier revone.

 

J'espère ne pas dire de bêtise, si une personne plus calé que moi peut nous éclairer ça serai good :p

Share this post


Link to post
Share on other sites

J'ai du mal à comprendre les soucis. Je suis en 2.24 également mais la RUU 1.28 fonctionne parfaitement. La RUU fait le downgrade automatiquement et part la suite il faut refaire les MAJ c'est tout.

Après au niveau des détails je suis Root, S-Off, et Debrand.

Envoyé depuis mon HTC One en utilisant Tapatalk 4

Share this post


Link to post
Share on other sites

Quand on est S-OFF, on peut faire un downgrade, sinon non, c'est aussi simple que ça.

Ha oui et quand on est S-ON, il faut reverrouiller le bootloader avant d'installer une RUU.

Share this post


Link to post
Share on other sites

ah ! je vais tenter çà alors !

Par contre 2 questions bêtes

 

1/ je dois aussi remettre un recovery stock ? (je suis actuellement en twrp)

2/ comment reverouiller le bootloader ? :o

 

J'ai trouvé cette manip sur un site pour le relock :

C'est bien çà ?

fastboot erase cache
fastboot reboot-bootloader
fastboot oem lock
Edited by ultraviolet

Share this post


Link to post
Share on other sites

Donc je dis n'importe quoi alors >.<

Je vais tenter alors à nouveau de passer via la RUU, donc si j'ai bien compris je suis en unlocked avec twrp en recovery.

Il faut que je verrouille à nouveau le bootloader après avoir installer un recovery stock, ensuite je lance la RUU 1.28? Donc si je suis sous une custom ROM actuellement sa dérange pas l'installation de la RUU?

Share this post


Link to post
Share on other sites

Le recovery stock se met automatiquement lors du flash de la RUU et la Rom Custom ne dérange pas.

Envoyé depuis mon HTC One en utilisant Tapatalk 4

Share this post


Link to post
Share on other sites

Sur les One S et X S-ON il fallait également remettre le recovery stock avant de flasher une RUU. Et effectivement on verrouille le bootloader avec une simple commande fastboot.

Share this post


Link to post
Share on other sites

Donc voilà, j'ai laissé le recovery tel quel comme le flash de la RUU le remplace tout seul, j'ai bien la mention "relocked" sur le bootloader mais j'ai une erreur "140: erreur de version bootloader"...

Je suis sous HBOOT 1.54 en S-On, j'ai pris la RUU 1.28 et je suis en 2.24

Je sais pas où ça coince...

Share this post


Link to post
Share on other sites

Tu le fais exprès ou quoi ?

Quand on est S-ON, on ne peut PAS downgrader ! Si tu ne sais pas ce que ça veut, ça signifie que tu ne peux pas descendre le numéro de build. Dans ton cas, tu dois installer une RUU de la build 2.24 ou supérieure.

Share this post


Link to post
Share on other sites

SEBI11, désolé mais je dois avoir du mal aujourd'hui, et je dois comprendre de travers comme LJFIRST

plus haut tu dis "Ha oui et quand on est S-ON, il faut reverrouiller le bootloader avant d'installer une RUU."

Et en mixant avec ce que dit Andronymous "J'ai du mal à comprendre les soucis. Je suis en 2.24 également mais la RUU 1.28 fonctionne parfaitement."

J'en avais déduit que je pouvais installer la RUU 1.28 tout en étant S-ON, mais à condition de relocker le bootloader, ce que j'ai fait, et l'install a planté, comme hier ...

 

tu confirmes que j'ai mal compris ? il faut absolument une RUU 2.24, c'est ca ? mais ou la trouver ? (je ne trouve que la 1.28)

Share this post


Link to post
Share on other sites

Donc c'est bien ce que je pensais à la base, quand j'ai dis que la RUU dois être de la même version que le tel, mais comme le dis "ULTRAVIOLET" en lisant le post de "Andronymous" j'avais cru comprendre que même en 2.24 on pouvait downgrade en 1.28, mais effectivement il est en "S-Off".

 

Mais ton post dis ensuite que si on est S-On il faut de nouveau verrouiller le bootloader, donc d'après mon échec je constate que c'est si la RUU est identique à la version du tel.

 

Donc non je le fais pas exprès, je pensais juste que ce que j'avais fais avant était pas bon ^^

Merci quand même du retour.

Share this post


Link to post
Share on other sites

LJFIRST, on a donc pensé la même chose et on se retrouve tous les 2 dans la même situation ... sans issue ...

et je n'arrive pas à trouver la RUU 2.24

Share this post


Link to post
Share on other sites

Oui à l'époque j'avais cherché mais je ne l'avais pas trouvé...

Du coup je me suis mis sur Insertcoin pour la tester ce soir ^^

Et quand une RUU sera dispo je tenterai le coup ;)

Share this post


Link to post
Share on other sites

Donc au final votre problème c'est le S Off qui n'est pas possible c'est ça ?

Envoyé depuis mon HTC One en utilisant Tapatalk 4

Share this post


Link to post
Share on other sites

Désolé de m'être emporté.

J'avais bien précisé avant qu'on ne pouvait pas downgrader en étant S-ON. Donc désolé pour vous...

Share this post


Link to post
Share on other sites

Ok donc j'ai vérifié c'est bien ça. Pas de RUU 2.24 ni de S-Off actuellement. Il va falloir patienter comme moi lorsque j'ai acheté mon One et qu'il n'y avait encore rien de tout ça.

L'avantage c'est que vous avez quand même la dernière version et que vous pouvez le Root.

Envoyé depuis mon HTC One en utilisant Tapatalk 4

Edited by Andronymous

Share this post


Link to post
Share on other sites

Il y a pas de mal "SEBI11", c'est juste que par moment c'est assez dur de comprendre surtout quand on a essayé de comprendre tout seul en lisant pas mal de topic, mais au moins la c'est bien sur et certain que y'a rien à faire pour le moment, en attendant le S-Off ou la RUU 2.24 ;)

Merci à tous :)

Share this post


Link to post
Share on other sites

Un question bête, j'avais lu que si on déverrouille le bootloader, plus moyen d'avoir les Maj OTA, c'est toujours vrai ?

Share this post


Link to post
Share on other sites

je ne voudrais pas dire de conneries mais normalement tu les reçois quand-même

c'est comme ça sur d'autre HTC en tout cas.

les conditions obligatoires sont:

 

pour les OTA

l'important est

  • d'avoir le recovery d'origine pour que lui puisse les installer (un recovery custom ne peux pas (normalement)
  • le CID correspondant aux OTA attendues

 

pour les RUU

  • le bootloader doit être verrouiller pour que l'opération n'échoue pas

flagelez moi si je me trompe

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...