Jcc13

[TUTO] Rooter facilement son HAM

Recommended Posts

Je dois dire que je n'y croyais pas trop et c'est avec une certaine appréhension que j'ai tenté l'expérience mais ça marche !!!!

Il s'agit d'une application PC qui se nomme Eroot.

Eroot a été développé par un chinois, d'après ce que j'ai compris (http://bbs.anzhi.com...1&orderby=heats), décidément je n'aurais jamais autant fréquenté les sites chinois que depuis que j'ai mon Mate.

L'application pèse 11,2 Mo dans sa version 1.0.14. C'est celle que j'ai utilisé en la téléchargeant à partir de xda, gage de sécurité : http://forum.xda-dev...d.php?t=2242749

Mode d'emploi :

- Télécharger le fichier exe qui est en fait un zip/exe.

Lancer-le et il décompressera l'application dans un dossier Eroot1014

- Brancher en mode USB débogué et Hisuite le HAM au PC (Fermer HiSuite sur le PC s'il s'est ouvert)

- Lancer ERoot-1.0.14.exe :

au départ l'application continue une installation ; dès qu'elle est finie, elle devrait reconnaître votre appareil en affichant son nom : HUAWEI MT1-06

- Cliquer sur le bouton vert Root

On peut alors voir 4 étapes se dérouler rapidement puis l'application affiche Root. C'est bon.

Vérifier que l'application SuperUser est bien installé sur le HAM.

Si ce n'est pas le cas, recommencer l'opération en cliquant sur Root, ça ne risque rien. C'est ce que j'ai fait.

En fait si ça ne marche pas... ça doit marcher car si on recommence on déroote. C'est ce qui s'est passé pour moi car j'ai recommencé 2 fois pour être sûr d'avoir le root.

donc IMPORTANT l'application permet aussi bien le rootage que le dérootage il suffit à chaque fois de recommencer l'opération et ça agit comme un switch.

Pour finir, J'ai testé en modifiant un commentaire du fichier /system/build.prop, c'est OK

J'ai redémarré ensuite pour voir si le root est durable, il l'est ! :)

Edited by Jcc13
  • Like 3

Share this post


Link to post
Share on other sites

Si c'est mieux que l'ancienne méthode, je l'épinglerai à la place.

Je vais attendre des confirmations, mais perso, je ne vais pas tenter l'aventure du root ^^

Share this post


Link to post
Share on other sites

Sans comparaison avec l'autre méthode qui semblait plus périlleuse et modifiait le dossier Cust. Avec Eroot le Dossier Cust n'est pas touché. :)

Share this post


Link to post
Share on other sites

Je confirme aussi beaucoup plus propre que l'autre méthode.

Cette version ne devrait plus provoquer de problème pour les maj.

Share this post


Link to post
Share on other sites

nickel , merci j'ai enfin pu rooter mon gros jouet :)

Share this post


Link to post
Share on other sites

Hello tout le monde :)

Je confirme aussi, manip faite sur la B116 fonctionne du premier coup :P

@Jcc13 Bien trouvé ^_^ un graaaand merci à toi !!!!

Edited by Yepyep

Share this post


Link to post
Share on other sites

Bonsoir,si qqun peut m'éclairer....En suivant le tuto de JCC13: après avoir cliqué sur le bouton root, à la 3° étape, sur mon HAM il y a restauration complete qui s'ouvre et cela empêche le root de se faire. Des idées... Merci

Share this post


Link to post
Share on other sites

Bonsoir,

J'ai suivi la manip à la lettre et pour moi, j'ai l'impression que ca n'a pas marché !

Mon numéro de Build est B109.

Merci de votre aide. Bonne soirée

Jean-loup

Share this post


Link to post
Share on other sites

Bonsoir,si qqun peut m'éclairer....En suivant le tuto de JCC13: après avoir cliqué sur le bouton root, à la 3° étape, sur mon HAM il y a restauration complete qui s'ouvre et cela empêche le root de se faire. Des idées... Merci

Je m'y suis pris à 2 fois pour avoir le root et il semble que ce soit normal j'ai cru comprendre que le root se fait en 2 passes.

De toute façon tu ne risques rien à recommencer l'opération, au pire il inscrira les mêmes données au même endroit.

  • Like 1

Share this post


Link to post
Share on other sites

bonsoir tous le monde.

pour moi du premier coup.

merci beaucoup Jcc13 .

Share this post


Link to post
Share on other sites

Je viens d'essayer et le logiciel ne se lance pas sous windows 8. Dommage:-(

Envoyé depuis mon A500 en utilisant Tapatalk 4 Beta

Share this post


Link to post
Share on other sites

Bonjour,

Décidément, je ne dois pas avoir un téléphone comme tout le monde !

Malgré plusieurs tentatives de root, cela ne fonctionne toujours pas ! Lorsque j'appuie sur le bouton vert ROOT, je vois bien qu'il ouvre une fenetre sur le telephone ou il veut restaurer puis une icone apparait "diaggetroot" puis elle s'enlève et plus rien !

Le Eroot me donne 2 icones sur la fenetre avec des numéros et me propose le bouton vert de nouveau !!!

Je suis un peu perdu !!!

Je précise que je suis passé en B113 (et que je n'arrive pas à passer la B216 !!!)

Edited by Johnwolf68

Share this post


Link to post
Share on other sites

oui, installé sur PC et à l'ouverture, je le ferme ... il est également installé sur le téléphone ...

Edited by Johnwolf68

Share this post


Link to post
Share on other sites

Oui, j'ai bien mon tél qui est reconnu ... Même photo !

Parcontre, comment savoir que le Eroot est a la bonne version ?

Share this post


Link to post
Share on other sites

C'est marqué en bas à gauche sur la photo. As tu bien coché "source inconnue" sur ton mate ? C'est dans "paramètre" puis "sécurité".

Share this post


Link to post
Share on other sites

Je viens d'essayer et le logiciel ne se lance pas sous windows 8. Dommage:-(

Envoyé depuis mon A500 en utilisant Tapatalk 4 Beta

bonjour

avec eroot 10.0.16 j'ai rooté mon HAM sous Windows 8 sans problème

Share this post


Link to post
Share on other sites

bizarre moi avec win 8, j'ai un popup avec inscrit "init()failed."

Mais bon c'est le logiciel eroot que j'avais récupéré qui était buggé, maintenant ça marche, j'ai trouvé un autre fichier eroot en fouinant un peu et je suis enfin root.

Edited by druchboy

Share this post


Link to post
Share on other sites

C'est marqué en bas à gauche sur la photo. As tu bien coché "source inconnue" sur ton mate ? C'est dans "paramètre" puis "sécurité".

Bonjour,

Tout est écrit en chinois !!! La source inconnue est bien cochée sur mon mate...

Ou puis je trouver un Eroot plus récent que celui proposé plus haut ? Merci d'avance ...

Share this post


Link to post
Share on other sites

Bonsoir Johnwolf68 .voila la dernière version v1.3 . 3. http://www17.zippysh...51666/file.html

Bonjour,

Ca y est, un Mate bien rooté !!! Merci à toi, Bioman07...

Cela s'est fait en 10 secondes !!! Incroyable !

Encore une petite question (peut être bête, mais je la pose quand même) :

Maintenant que mon téléphone est rooté, et se trouve en B113, que faut il ne pas faire ????

C'est à dire concernant les éventuels mises à jours ou j'ai vu que la réinitialisation n'était pas à faire non plus ?

Merci de tes conseils et encore mille fois merci pour le root ...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.