Jump to content
Yann Swano

[Résolu] Services Google : consommation de données en arrière-plan

Recommended Posts

Mon cher Yann,

 

Excuse moi de ne pas être passé plus tôt. Après avoir rapidement parcouru le thread, voici quelques choses que je peux te dire (et aux autres ayant des problèmes afférents of course):

  • On résout rarement durablement un problème fugitif en passant par des solutions bourrines (fotakill, disabling de services ...). Simuler la stabilité avec ce genre de bidouillages pousse vers d'autres problèmes. Dans ce sens, le mieux à faire reste d'installer l'application Greenify (gratuite sur l'appstore) qui permet de forcer les applications non utilisées activement à ne pas rester en 1er plan, et donc ne pas bloquer le deepsleep de l'appareil ou consommer de la data. C'est la version moderne (et bien plus réussie!) des odieux taskkillers. Il faut savoir que sur droid, quand un service pompe comme un cochon c'est parce-qu’une application y fait appel. Qu'il s'agisse d'une app système ou non.

 

  • Excuse moi si tu l'as déjà dit, mais est-ce que tu as vérifie si les conso relevées sont les mêmes chez ton opérateur ? Certaines ROMs basées sur AOKP ont longtemps eu un bug qui causait un affichage largement erroné de la data consommée.

 

  • Tu peux envisager de changer de ROM, surtout si tu dois encore passer en 4.3. Plusieurs posts évoquent SlimROM et c'est effectivement une très bonne ROM. Je te conseillerais plutôt la build officielle que les compilations tierces. Toutes sont intéressantes, mais la compilation en Linaro par exemple tient plus de l'effet placebo qu'autre chose et présente quelquefois des erreurs. Les menus de SlimROM sont très simples et les possibilités offertes sont intelligentes et variées sans jamais tendre à l'usine. Prévois quand même 2 redémarrages du téléphone lors de la manipulation pour remettre les DPI d'origine : Les concepteurs de la Slim ont en effet décidé que c'était écrit trop gros :-)

A propos du passage de la 4.2 vers la 4.3, cela nécessitera de faire un full wipe pour partir couvert. Et vraiment Yann, vu comme tu es numériquement poissard, je te le conseille ! Pour la sauvegarde de tes applications, tu peux passer par Titanium Backup ou mieux encore, par Helium. Toute l'opération (sauvegarde, full wipe, installation rom+gapps+franco dans le recovery, réinstallation des apps) tu en as pour une bonne heure si tu n'as pas l'habitude, moins si tu es coutumier.

Edited by Johnito

Share this post


Link to post
Share on other sites
Guest flo//

 la compilation en Linaro par exemple tient plus de l'effet placebo qu'autre chose 

 pourquoi les développeurs l'utilise ?  

 

édit : moi aussi je trouve que les DPI a 320 c'est trop gros (je ne suis pas myope), donc merci a la slim de mettre les DPI plus petit ;)

Edited by flo07//

Share this post


Link to post
Share on other sites

Salut,

 

 pourquoi les développeurs l'utilise ?  

 

Les dév utilisent ce toolchain comme ils en utilisent d'autres (cela dépend des choix retenus ou des habitudes), et il est d'ailleurs réputé comme l'un des meilleurs. Mais les différences d'un bon toolchain à un autre restent particulièrement infimes et cela à mon sens ne vaut pas un compromis sur la fiabilité ou la sécurité. Quand on prend une ROM compilée par un tiers, on s'expose à des erreurs de compilation plus fréquentes (comme vu ici il y a très peu de temps) et à un intermédiaire de plus entre l'utilisateur et son haribo. J'ai moi-même eu l'occasion d'échanger sur ce point avec l'un des développeurs de SlimROM, et leurs tests de compilation en utilisant deux versions différentes de Linaro n'ont pas été concluants. Rien de dramatique, mais autant commencer par la compilation officielle pour son 1er essai (quel que soit son toochain).

 

Pour les DPI c'est complètement subjectif il est vrai. Je précisais la procédure puisqu'une majorité y a recours, comme les développeurs de la ROM le reconnaissent eux-même sur leur thread principal. J'aime renseigner autant que possible quelqu'un à qui je conseille un changement :-)

Edited by Johnito

Share this post


Link to post
Share on other sites

Salut toi. HHeureux de te lire. Ouais enfin bon, cette faille data n'est pas le fait d'amateurs, cela concerne une majorité de rom en 4.2 dont Cyano et Aokp. Pas rien.

Share this post


Link to post
Share on other sites

le dpi je le met même à 240 ^^

 

pour le linaro, bah j'ai jamais été subjugué ^^

Share this post


Link to post
Share on other sites
Guest flo//

@ johnito

 

dire que les rom compilé par un "tiers" sont moins fiable  , c'est pas cool du tout pour les développeurs ....

 

ps: ton lien plus haut vas sur xda pas sur l'officiel de la slim : http://www.slimroms.net/  ;)

 

édit :

pour revenir au sujet du post , "perso" , je conseillerais le passage en 4.3 pour ne plus avoir de données dans le vide en arrière plan 

(pas la stock bien sur lol mais bien une custom ;) la stock 4.3 j'ai testé 5mn c'est tout) 

 

voila voila :)

Edited by flo07//

Share this post


Link to post
Share on other sites

J'ai une dernier question ou plutot un autre problème. La data a bien été utilisée pour telecharger quelque chose. Problème, j'ai perdu beaucoup de mémoire qui est "cachée"

 

Par exemple, je viens de passer sur la slim rom. J'ai 12,95Go de mémoire totale.

4,37Go de dispo (c'est là qu'est le problème)

200Mo utilisé par les data

357Mo utilisé par les images/vidéos

4,37Go utilisé par divers (les sauvegardes twrp et titanium backup)

et quelques méga (moins de 30) par le reste

 

soit environ 5Go d'utilisé et 4,37Go de dispo soit 9,37Go, j'ai donc plus de 3,5Go occupé  j'imagine par une MAJ 4.3 que mon telephone a telechargé en douce et qui est caché dans les fichiers systèmes. Une idée de la manière pour les récupérer ?

Edited by cyril5689

Share this post


Link to post
Share on other sites
Guest flo//

tu n'as pas fait un wipe system avant le flash de la slim ?

 

édit : sinon aussi , il y a la solution de faire une installation "propre" en "stock 4.3" via le SDK , puis , flash de la slim avec les wipes (une installe normal quoi)

comme ça , tu es sur que ton tel est bien vide 

pense a juste copier les fichiers qui sont dans sdcard (compressé ou pas au préalable) sur ton pc avant ;)

Edited by flo07//

Share this post


Link to post
Share on other sites

Si, j'ai fait tout les wipe sauf data (j'ai fait cache/dalvik , factory reset , wipe system)

Edited by cyril5689

Share this post


Link to post
Share on other sites

Je suis passé en 4.3, le problème est résolu :-)

Envoyé depuis mon Nexus 4 avec Tapatalk

Share this post


Link to post
Share on other sites

J'ai trouvé, finalement ce sont des fichiers du dossier android/obb et android/data qui prennaient de la place et qui n'étaient ni supprimés ni compatibilisés dans la partie stockage du menu parametre.

Share this post


Link to post
Share on other sites

Hello. Bon, il est temps de clore ce sujet-qui me les aura bien cassé. Donc, et pour résumer les dix pages de post : pour ceux qui veulent rester en 4.2, préférez la double sécurité qui ne m'a aucun wakelock (fotakill + disable service : décochez system update), sinon optez pour la 4.3.

Share this post


Link to post
Share on other sites

J'ai installé la Slimbean 4.3 beta 4 hier soir. Impeccable.

(C'est quand même long et pénible de faire ces manips. Je ne sais pas comment font ceux qui changent tout le temps de ROM, qui les testent toutes, etc.)

 

Merci YANN SWANO pour les solutions.

Share this post


Link to post
Share on other sites

Rodé, avec un full wipe, 15min pour reavoir un téléphone utilisable et règle plus les applications de retour ^^

Share this post


Link to post
Share on other sites

Dernier retex pour mon pb de fuite data services Google

Après 3 jours de test avec Systemupdateservice décoché, plus de fuite data des Services Google, consommation revenue à la normale... ;-)

Merci Yann !

Kenavo

Share this post


Link to post
Share on other sites

Rodé, avec un full wipe, 15min pour reavoir un téléphone utilisable et règle plus les applications de retour ^^

 

15 min !

J'ai de gros progrès à faire.

 

Je crois que jusqu'à présent je faisais une erreur, je coche l'option de Restauration via Google, et en fait, c'est long et ça empêche de choisir quelles applis installer en premier (Super SU et Titanium Backup).

 

Par contre, quand on fait un fullwipe, on doit forcément refaire toute la personnalisation offerte par les ROM custom.

Share this post


Link to post
Share on other sites

en gros,

 

- sauvegarde des apps via titanium backup + sms (mais pas des apps système)

- full wipe, flash, reboot + flash de l'application titanium backup (voir les options de l'application)

- je rempli le tutoriel de paramétrage de Google avec restauration

- je go sur le market annuler toutes les installations

- je lance titanium backup et refait les paramètres de la rom au même moment

 

voilà :D

Share this post


Link to post
Share on other sites

Moi ma sauvegarde titanium backup n'est pas passée, c'est la première fois que ça m'arrive. J'ai du tout réinstaller. Tanpis.

Share this post


Link to post
Share on other sites

Justement, je pensais que depuis qu'il existe la sauvegarde Google: on n'avait plus besoin d'apk comme Titanium...  :/

Share this post


Link to post
Share on other sites

Pour les donnés je l'utile et pour les apk je l'utilise aussi car ça va plus vite que le Google play :-P

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai le problème que vous avez eu, c'est-à-dire que "plateforme Android" est passé de 3Mo de conso en un mois il y a quelques mois à 260Mo le mois dernier. Mon crédit s'est remis aujourd'hui et ça m'a déjà bouffé 30Mo...

Sauf que moi je suis en ROM stock 4.3, et que j'ai vraiment pas envie de faire un wipe data... Je ne comprends pas très bien ta solution Yann (fotakill + disable service)...

Share this post


Link to post
Share on other sites

Oh putain ! T'es bien le premier cas que je vois en 4.3. L'OTA doit tenter de forcer le passage, c'est fou ça. Pourquoi n'utilises-tu pas ma méthode ? Que comprends tu pas ? Peut être est-ce une nouvelle maj, une seconde... T'as tenté ?

Share this post


Link to post
Share on other sites

Non, il est pas le seul. J'ai aussi une conso anormale de la "plateforme Android".

 

Et je suis sous rom custom, SlimBean 4.3 officielle et actuellement BeanStalk 4.3.

 

J'ai limité les données en arrière plan, la flemme de chercher une solution...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...