Jump to content

Problème de mémoire interne sur S SL [I9003]


Recommended Posts

Bonjour,

 

Depuis quelques temps, j'ai des soucis avec mon Galaxy S SL (I9003).

 

Les symptômes ont l'air identiques à ceux de S.GTI pour son GALAXY S (https://forum.frandroid.com/topic/108241-stockage-usb-impossible-deffacer-le-contenu/) : Fermeture des applis , reboot intempestif, applis qui reviennent alors qu'elles ont été désinstallées etc....

Jusqu'à présent je n'avais jamais rien installé dessus (18 mois), j'ai essayé les différentes méthodes des forums en installant plusieurs ROMS ( KPE, KPN, KPU), le ROOT UNIVERSEL. J'ai fait les différents formatage et WIPE, mais rien n'y fait....... ça bug plus ou moins ça reste toujours instable.

 

Je pense que le pb est hardware (SD CARD interne?) car certains de mes fichiers de bases n'ont jamais été supprimé et apparaissent toujours.

 

Je voudrais essayer la méthode de S.GTI en l'adaptant à mon I9003 en espérant que ce soit possible, mais je bloque dès le n°1 je n'ai pas LINUX et je ne vois pas comment utiliser GPARTED. De plus, sur d'autres forums ils disent de déconnecter la SD Interne pour faire la manip; or, c'est assez flou concernant son emplacement après démontage du téléphone.

 

Serait-il possible d'avoir votre aide svp?

 

Merci d'avance, Vincent.


NB : j'ai enlevé la photo vu que c'était hors sujet
Edited by Ptitvinz
Link to comment
Share on other sites

  • Replies 51
  • Created
  • Last Reply

Top Posters In This Topic

La SD-interne se démonte dans les paramètres du SGS. Comme ont le fait pour une clé USB sur un PC.

Tu ne pourras pas démontrer la SD-interne en ouvrant le SGS, c'est une micro puce souder directement sur la carte mère.

Après, même si ont pouvait la désouder de la carte mère en mode barbare (aiguille à coudre chauffé au rouge à l'aide d'une gaziniere, je sais je suis un sauvage quand j'ai pas d'autre solution pour la micro soudure). Sur ce genre de carte mère vue la taille, il est impossible de ressoudé un micro composant sans en cramé un autre à coté. Et oui tout est soudé pas des robots avec précision extrême et la température convient.

Envoyé depuis Tapatalk 4

Link to comment
Share on other sites

Je confirme: Enlever manuellement la carte sd, pour la remplacer par une neuve n'est pas une bonne idée. Certains ont essayé ... beaucoup y ont laissé leur smartphone!

 

Pouvez vous installer des appli sur votre GT i9003 ?

Link to comment
Share on other sites

Je confirme: Enlever manuellement la carte sd, pour la remplacer par une neuve n'est pas une bonne idée. Certains ont essayé ... beaucoup y ont laissé leur smartphone!

 

Pouvez vous installer des appli sur votre GT i9003 ?

 

Ne vous inquiétez pas, je ne compte pas jouer du fer à souder , je n'ai pas les compétences pour. C'est juste que sur un autre forum j'avais vu un tuto ou le gars "déconnecte" la carte SD interne; avec photos à l'appui. Mais c'est peu clair, et je pense avoir mal compris.

 

Je n'ai pas eu le temps cette semaine mais je pense réparer mon tel ce week-end. J'ai déjà installé ADB ce qui m'a pris une soirée complète :-O

 

Je n'ai pas réessayé d'installer des applis, je peux faire un test cet aprem.

Link to comment
Share on other sites

Apparemment, il a réussi 7 MAJ d'applis (Facebook, Messenger, Outlook.com, Meteofrance, Hangouts, Layar et Youtube)

Mais dès que j'en lance un message apparait "Désolé! Fermeture soudaine de l'application XXXXXX (du processus XXXXXXX). Merci de réessayer."

 

Et si j'insiste un peu trop, le tél se coupe avec apparition du Kernel debug mode.

Link to comment
Share on other sites

Ok,

Il faudrait peut être s'assurer d'abord que c'est bien un problème de /data et essayer de repartitionner le dev/block/mmcblk0 si c'est effectivement là le problème. Si ça ne marche pas, il faudra installer dev/block/mmcblk0 sur la carte externe.

 

première chose: sous ADB (avec tél rooté) aller voir les différentes partitions du tél:

voici la commande à rentrer (en gras) à la ligne de commande quand on est dans le répertoire ADB

C:\adb>adb shell

cela permet d'accéder au mobile on obtient alors

#

vous tapez

:# mount

pour monter les partitions qui seront alors listées dessous.

ce qui vous donnera la liste des partitions. Ecrivez ce que cela donne.

Edited by s.gti
Link to comment
Share on other sites

Moi j'ai pas # mais ceci en suivant la commande 

 

C:\Users\Vincent\AppData\Local\Android\android-sdk\platform-tools>adb shell

$ mount
mount
rootfs / rootfs ro,relatime 0 0
tmpfs /dev tmpfs rw,relatime,mode=111 0 0
devpts /dev/pts devpts rw,relatime,mode=600 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,relatime 0 0
none /acct cgroup rw,relatime,cpuacct 0 0
tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
tmpfs /mnt/obb tmpfs rw,relatime,mode=755,gid=1000 0 0
none /dev/cpuctl cgroup rw,relatime,cpu 0 0
/sys/kernel/debug /sys/kernel/debug debugfs rw,relatime 0 0
/dev/block/stl9 /system rfs ro,relatime,vfat,log_off,check=no,gid/uid/rwx,iocharset=utf8 0 0
/dev/block/stl3 /efs rfs rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,iocharset=cp437 0 0
/dev/block/mmcblk0p3 /data rfs rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,iocharset=utf8 0 0
/dev/block/stl10 /dbdata rfs rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,iocharset=utf8 0 0
/dev/block/stl6 /mnt/.lfs j4fs rw,relatime 0 0
debugfs /debug debugfs rw,relatime 0 0
/dev/block/stl11 /cache rfs rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,iocharset=utf8 0 0
/dev/block/vold/179:1 /mnt/sdcard vfat rw,dirsync,nosuid,nodev,noexec,noatime,nodiratime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro,discard 0 0
$

J'ai beau m'intéresser à l'informatique, là c'est du chinois pour moi tout ça  :(

Edited by Ptitvinz
Link to comment
Share on other sites

ça a l'air de faire les mêmes erreurs que mon SGS (dernière ligne: qui correspond à la partition /sdcard)

 

Vous êtes bien dans le recovery ?

 

que donne la commande:

 ls /dev/block

Edited by s.gti
Link to comment
Share on other sites

Non je ne suis pas dans le recovery. Dois-je refaire la manip "adb shell" en recovery?

J'ai taper "is /dev/block" et j'ai eu "Permission denied".


Ah non c'est "ls /dev/block" , j'ai eu ça :

 
$ ls /dev/block
ls /dev/block
vold
tfsr13
tfsr12
tfsr11
tfsr10
tfsr9
tfsr8
tfsr7
tfsr6
tfsr5
tfsr4
tfsr3
tfsr2
tfsr1
tfsr0!c
loop7
loop6
loop5
loop4
loop3
loop2
loop1
loop0
ram15
ram14
ram13
ram12
ram11
ram10
ram9
ram8
ram7
ram6
ram5
ram4
ram3
ram2
ram1
ram0
stl13
stl12
stl11
stl10
stl9
stl8
stl7
stl6
stl5
stl4
stl3
stl2
mmcblk0p3
mmcblk0p2
stl1
mmcblk0p1
platform
mmcblk0
bml13
bml12
bml11
bml10
bml9
bml8
bml7
bml6
bml5
bml4
bml3
bml2
bml1
bml0!c
$
Link to comment
Share on other sites

Ok toutes les partitions sont bien présentes.

Eteignez le tel et passez en mode recovery. refaites "adb shell"

 

puis

# parted /dev/block/mmcblk0

 

puis

(parted) print

ce qui permettra de voir les 3 partitions du block mmcblk0 (/data; /sdcard et la troisième, je ne sais pas vu que dans le SGS il n'y en a que 2)

 

ça donne ?

Edited by s.gti
Link to comment
Share on other sites

Votre tél n'est pas rooté ??

 

Qu'avez vous comme lignes (de commandes)  dans le CMW ?

 

Il doit être rooté pour pouvoir intervenir sur les fichiers système depuis le recovery.

Edited by s.gti
Link to comment
Share on other sites

Oui apparemment il n'était plus rooté, j'ai fait tellement de manips que j'en suis perdu. Je viens de réinstaller le CWN, mais il met énormément d'erreur et j'ai du mal à le tenir allumé.

Je tente les manips quand il sera plus stable.


C'est bon. Je suis dans le CWN recovery (v5.0.2.8) et quand je tape "adb shell" il me marque "device not found".


Dans les options j'ai (en résumé): reboot , apply update, wipe, install zip, backup, mounts, advanced, root, power off


Les commandes adb ne marchent pas en mode recovery.

Quand le tél est allumé (et stable surtout) j'ai réussi à faire les manips, voici ce que j'ai eu :

 

~ # parted /dev/block/mmcblk0
parted /dev/block/mmcblk0
GNU Parted 1.8.8.1.179-aef3
Using /dev/block/mmcblk0
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print
print
print
Model: MMC SEM04G (sd/mmc)
Disk /dev/block/mmcblk0: 3959MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
 
Number  Start   End     Size    Type     File system  Flags
 1      32.8kB  1634MB  1634MB  primary  fat16        lba
 2      1634MB  1946MB  312MB   primary  fat16        lba
 3      1946MB  3959MB  2013MB  primary               lba
 
(parted)
Link to comment
Share on other sites

 Ok, 2 partitions en fat, la 3ème pas indiquée (probablement la /data)

 

sous recovery faites "mounts" puis "mount usb" et là normalement si vous branchez le cable usb ADB devrait se loguer au tél.

 

refaites alors le

# mount

 

pour voir comment les partitions se montent, et en particulier la /data qui est sur le block/mmcblk0p3

 

 

ça donne quoi ? 

Quelle ROM avez vous ?

Edited by s.gti
Link to comment
Share on other sites

Voici

 

~ # mount

mount

rootfs on / type rootfs (ro,relatime)

tmpfs on /dev type tmpfs (rw,relatime,mode=111)

devpts on /dev/pts type devpts (rw,relatime,mode=600)

proc on /proc type proc (rw,relatime)

sysfs on /sys type sysfs (rw,relatime)

none on /acct type cgroup (rw,relatime,cpuacct)

tmpfs on /mnt/asec type tmpfs (rw,relatime,mode=755,gid=1000)

tmpfs on /mnt/obb type tmpfs (rw,relatime,mode=755,gid=1000)

none on /dev/cpuctl type cgroup (rw,relatime,cpu)

/sys/kernel/debug on /sys/kernel/debug type debugfs (rw,relatime)

/dev/block/stl9 on /system type rfs (ro,relatime,vfat,log_off,check=no,gid/uid/rwx,iocharset=utf8)

/dev/block/stl3 on /efs type rfs (rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,iocharset=cp437)

/dev/block/mmcblk0p3 on /data type rfs (rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,iocharset=utf8)

/dev/block/stl10 on /dbdata type rfs (rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,iocharset=utf8)

/dev/block/stl6 on /mnt/.lfs type j4fs (rw,relatime)

debugfs on /debug type debugfs (rw,relatime)

/dev/block/stl11 on /cache type rfs (rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,iocharset=utf8)

/dev/block/vold/179:1 on /mnt/sdcard type vfat (rw,dirsync,nosuid,nodev,noexec,noatime,nodiratime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro,discard)

~ #

Link to comment
Share on other sites

J'ai la KPE.

Voici ce que j'ai avec df :

~ # df
df
Filesystem           1K-blocks      Used Available Use% Mounted on
tmpfs                   248452        32    248420   0% /dev
tmpfs                   248452         0    248452   0% /mnt/asec
tmpfs                   248452         0    248452   0% /mnt/obb
/dev/block/stl9         329920    321716      8204  98% /system
/dev/block/stl3           6064      5164       900  85% /efs
/dev/block/mmcblk0p3   1963888    321728   1642160  16% /data
/dev/block/stl10         74008      1636     72372   2% /dbdata
df: /mnt/.lfs: Function not implemented
/dev/block/stl11         30792        16     30776   0% /cache
/dev/block/vold/179:1
                       1595136    358976   1236160  23% /mnt/sdcard
~ #
Link to comment
Share on other sites

Avez vous essayé depuis le recovery les wipe et format successifs ??

 

d'abord "wipe data /factory reset " est ce que cela fait un message d'erreur (rouge) et si oui lequel ??

 

si pas de message d'erreur aller dans "advanced" puis "show log"  ... ça dit quoi ??

Link to comment
Share on other sites

Oui j'ai bien tout fait dans l'ordre en suivant les tutos du site. J'avais tout remis à zéro avant ce topic ce qui explique pourquoi le CWN recovery était manquant.

 

Là j'ai refait un "wipe data/factory reset" et il marque "data wipe complete" sans erreur.

 

Ensuite dans "show log" j'ai tout ça :

 

"I:Erasing from device...

Formatting /cache...

I:Erasing from device...

rm: can't stat '/cache/.*': Invalid argument

Formatting /datadata

I:Erasing from device...

Formatting /sdcard/.android_secure...

I:Erasing from device...

mount: mounting /dev/block/mmcblk1p1 on /sdcard

failed: No such file or directory

rm: can't remove '.' or '..'

rm: can't remove '.' or '..'

Data wipe complete

 

Apparemment, quelques erreurs.

Link to comment
Share on other sites

ça a l'air bon, moi j'avais plein d'erreurs (rouge) et le wipe à la fin mettait "failed"

Là, l'erreur de format du cache à mon avis n'est pas le pb

L'autre erreur sur le /dev/block/mmcblk1p1 on /sdcard a l'air de concerner le stockage interne,

sur le sgs ce stockage interne était sur /dev/block/mmcblk0p1 et le /dev/block/mmcblk1 correspondait à la carte externe.

Vous avez bien enlevé votre carte externe du tél ?

 

 

Essayez de formater les partitions /data

dans le "mount"

- format /cache

puis

- format /data

puis

- format /sdcard

 

voir si messages d'erreurs et sinon voir dans "show log"

Link to comment
Share on other sites

Je n'ai jamais installé de carte SD externe sur ce tél.

J'ai fait les 3 format, le 2nd était plus long mais réussi quand même.

Quand je refais "show log" j'ai ça :

 

Formatting /cache...

I:Erasing from device...

Done.

Formatting /data...

I:Erasing from device...

Done.

Formatting /sdcard...                  (pour info /.android_secure a disparu)

I:Erasing from device...

mount: mounting /dev/block/mmcblk1p1 on /sdcard

failed: No such file or directory

rm: can't remove '.' or '..'

rm: can't remove '.' or '..'

Done.

Link to comment
Share on other sites

La partition /data est montée sur le block mmcblk0p3. qu'est ce qui est monté sur mmcblk0p1 et mmcblk0p2 ?

en tout cas pas la /sdcard qui correspond au mmcblk1p1

 

Avez vous une carte externe ?

Si oui mettez la, et depuis le recovery tapez

# mount

 

pour voir à quel bloc elle correspond.

 

 

puis enlevez la carte externe et

faites

# parted /dev/block/mmcblk1

puis

# (parted) print

 

pour voir quelles partitions il y a sur ce block mmcblk1 (la p1 qui semble être celle de la sdcard n'a pas l'air d'y être)

 

Après on peut tenter de (re)construire la p1 du block mmcblk1 sous ADB et si ça ne marche pas, inverser les stockages interne et externe (plus long et plus compliqué)

Edited by s.gti
Link to comment
Share on other sites

Euh, je ne sais pas ce qui est monté sur mmcblk0p1 et mmcblk0p2, comment puis-je le savoir?

Sinon j'ai mis une SD, voici ce que j'ai :

 

~ # mount

mount

rootfs on / type rootfs (ro,relatime)

tmpfs on /dev type tmpfs (rw,relatime,mode=111)

devpts on /dev/pts type devpts (rw,relatime,mode=600)

proc on /proc type proc (rw,relatime)

sysfs on /sys type sysfs (rw,relatime)

none on /acct type cgroup (rw,relatime,cpuacct)

tmpfs on /mnt/asec type tmpfs (rw,relatime,mode=755,gid=1000)

tmpfs on /mnt/obb type tmpfs (rw,relatime,mode=755,gid=1000)

none on /dev/cpuctl type cgroup (rw,relatime,cpu)

/sys/kernel/debug on /sys/kernel/debug type debugfs (rw,relatime)

/dev/block/stl9 on /system type rfs (ro,relatime,vfat,log_off,check=no,gid/uid/rwx,iocharset=utf8)

/dev/block/stl3 on /efs type rfs (rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,iocharset=cp437)

/dev/block/mmcblk0p3 on /data type rfs (rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,iocharset=utf8)

/dev/block/stl10 on /dbdata type rfs (rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,iocharset=utf8)

/dev/block/stl6 on /mnt/.lfs type j4fs (rw,relatime)

debugfs on /debug type debugfs (rw,relatime)

/dev/block/stl11 on /cache type rfs (rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,iocharset=utf8)

/dev/block/vold/179:1 on /mnt/sdcard type vfat (rw,dirsync,nosuid,nodev,noexec,noatime,nodiratime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro,discard)

/dev/block/vold/179:17 on /mnt/sdcard/external_sd type vfat (rw,dirsync,nosuid,nodev,noexec,noatime,nodiratime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)

/dev/block/vold/179:17 on /mnt/secure/asec type vfat (rw,dirsync,nosuid,nodev,noexec,noatime,nodiratime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)

tmpfs on /mnt/sdcard/external_sd/.android_secure type tmpfs (ro,relatime,size=0k,mode=000)

~ #

 

En gras, c'est ce qui change il me semble.

 

Ensuite, j'ai enlevé la SD et j'ai fait 

 

~ # parted /dev/block/mmcblk1

Error: Could not stat device /dev/block/mmcblk1 - No such file or directory

Retry/Cancel?

 

Apparemment, ça plante.

Link to comment
Share on other sites

Bon, cela semble différent de la panne que j'ai eu puisque il semble que ce soit seulement le stockage interne qui est atteint.

Il y a plusieurs posts sur Xda sur l'inversion des stockages internes et externes.

 

Déjà il faut une carte sd externe d'au moins 8 Go et au moins classe 4 (plus costaud) vous avez ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...