Jump to content
stephjago

[TUTO][4.1.2][4.3] Root avec Towelroot en one-clik

Recommended Posts

Peut-être un bug de la 4.3 tout simplement en faite. 

 

@Tifil : tu ne m'en dis pas assez : tu part de quelle base : 4.3 ou 4.1.2?

En ce qui concerne le mode fastboot, c'est un abus de langage de Slainou, c'est donc bien le recovery : il faut entrer en recovery avec la touche volume haut, volume bas ou caméra suivant le recovery installé.

Pour les wipes c'est dans le recovery qu'il faut le faire, idem pour l'installation de la rom. Flashtool ne te permet pas d'installer des fichiers en .zip. Idem pour le Supersu, ça se passe dans le recovery, pour la même raison.

 

De plus je ne veux pas dire, mais dans mon tuto j'ai bien précisé ce qui est à faire avec le recovery et ce qui est à faire avec flashtool ;)

Share this post


Link to post
Share on other sites

Je part avec la 4.3.

Une dernière question j'espère, pour flasher le kernel .266 via flashtool, le téléphone doit bien être éteint non ?

 

Et sinon, merci de toutes ces précisions, et désolé pour l'abus de questions :)

Share this post


Link to post
Share on other sites

Alors si tu démarre de la 4.3, tu peux commencer par l'étape 2 seulement si tu as déjà le root et le cwm recovery.

Sinon pas le choix que de commencer par l'étape 1.

Pour flashtool toute les manips se font tels éteint. Pour le toolkit de Doomlord c'est tél allumé.

Share this post


Link to post
Share on other sites

Hélas non, je n'avais pas le root (seulement quand j'étais en 4.1), ni le recovery.

Share this post


Link to post
Share on other sites

Quand je suis dans le recovery pour flasher la rom, une fois choisis d'installer, il m'affiche ceci:

 

- Checking device modele number

- Copying to /system

- Symlinking & correction permissions set_perm: some changes failed

 

E: Error in /storage/sdcard1/Ultimate Pure XSP v1.01.zip

(Status 7)

Installation aborted.

Edited by tifil

Share this post


Link to post
Share on other sites

Retélécharge la rom, elle doit être corrompu.

Édit: tu as utilisé quel recovery (tu as appuyé sur quel bouton au redémarrage)?

Edited by D4RKsteph

Share this post


Link to post
Share on other sites

Le bouton caméra.

 

Mais maintenant avec cette manip, je reste bloqué au logo sony.

 

Je vais recommencer à l'étape 1.

 

Je vais quand même re télécharger Ultimate V.1 comme tu le dis.

 

Edit: J'ai refait toute les étapes, mais j'ai toujours le même message quand je lance l'installation du zip dans le recovery.

 

Au moment du flash avec flashtool pour l'étape 1, tout a très bien fonctionné mais j'avais eu ce message: 

 

01/013/2014 15:13:27 - WARN  - This file is ignored : simlock.ta

 

Je pense que ce n'est rien.

Edited by tifil

Share this post


Link to post
Share on other sites

Essaye la purestockdeodex du coup.

Édit: oui le ta ignoré c'est rien ;)

Edited by D4RKsteph

Share this post


Link to post
Share on other sites

Mais il y a quoi comme différence entre une rom australienne et une rom eu ?

 

Et est-ce normal que l'une fasse 30mo et l'autre 780mo ?

Edited by tifil

Share this post


Link to post
Share on other sites

La quelle fait 30 mo?

 

Sinon pas de grandes différences entre la australienne et la CE : juste quelques applis en plus ou en moins.

 

Edit : ok c'est bon j'ai compris le problème... le Ultimate Pure XSP v1.01.zip est la maj a rajouté en plus de la rom... je vais modifier les liens dans le tutos.

 

Edit 2 : Tifil flash cette rom : http://www.mediafire.com/download/nt...te+PureXSP.zip, ensuite le supersu et c'est bon.

 

Une fois fait réinstalle le CWM recovery et flash le Ultimate Pure XSP v1.01.zip pour faire la maj de la rom ;)

Edited by D4RKsteph

Share this post


Link to post
Share on other sites

Donc, juste avant de passer à l'étape 9, je réinstalle le recovery, je flash la Ultimate Pure XSP v1.01.zip, mais par contre la je ne reflash pas supersu ?

 

Et une fois que la Ultimate Pure XSP v1.01.zip est flashé, la je peux passer à l'étape 9 ?

Share this post


Link to post
Share on other sites

Non, tu fais les 9 étapes normalement, tu allumes ton tel, tu réinstalles le CWM et enfin tu redémarres ton tel pour faire la maj en flashant le Ultimate Pure XSP v1.01.zip.

Share this post


Link to post
Share on other sites

Bonjour et merci pour la méthode, car étant passé à la 4.3 officielle et vouloir rooter son SP, c'était pas évident !

Tout fonctionne impec sauf une chose : je ne peux toujours pas déplacer mes apps sur la SD externe. Les applis comme Apps2SD ou autres me prosposent bien d'en déplacer certaines, mais lorsque je valide, l'option de déplacement n'apparait toujours pas... et j'en reste au même point.

Quelqu'un peut-il m'aider car la place commence à me manquer !!!

Merci d'avance.

Share this post


Link to post
Share on other sites

Non, tu fais les 9 étapes normalement, tu allumes ton tel, tu réinstalles le CWM et enfin tu redémarres ton tel pour faire la maj en flashant le Ultimate Pure XSP v1.01.zip.

est ce qu'on doit faire wipe pour installer la MAJ ?

 

ca fait 2 fois que j'essaye et ca reste bloquer sur copying to/systeme

Share this post


Link to post
Share on other sites

Normalement wipe cache partition et dalvik cache suffisent, tu as bien installé la V1 et tu utlises bien le recovery du bouton camera?

Edited by D4RKsteph

Share this post


Link to post
Share on other sites

Utilise le bouton camera, et wipe cache partition + dalvik cache.

Share this post


Link to post
Share on other sites

Est-ce aussi normal que le kernel soit australien tandis que la rom soit d'eu ? Ça risque pas de créer des conflits ?

Share this post


Link to post
Share on other sites

Non pas de problème tant que le kernel est du même build que la rom ;)

Edited by D4RKsteph

Share this post


Link to post
Share on other sites

Après avoir flashé la Ultimate Pure XSP v1.01.zip, pas besoin de reflasher le kernel .266 ?

 

Un reboot now suffit ?

Edited by tifil

Share this post


Link to post
Share on other sites

Ouep un simple reboot suffit vu que tu es déjà en 4.3.

Share this post


Link to post
Share on other sites

Une fois tout ceci fait, je lance super su, et j'ai ce message:

 

"Aucun binaire SU n'est installé, et SuperSu ne peut l'installer. C'est un problème !

Si vous venez de faire la mise à jour vers Android 4.3, vous devez re-rooter manuellement votre apapreil. Veuillez consulter les forums correspondants à votre appareil !"

Share this post


Link to post
Share on other sites

Cela veut dire que tu n'es plus root, ça me l'a fait aussi quand j'ai fait la maj vers la 1.01, il suffit que tu reflashes le super su en passant par le recovery (bouton camera) et c'est bon !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...