Aller au contenu
xander59

[LP][5.0.2][ZIP]14.5.A.0.242_FR_SuperSU_DualRecovery_4K

Recommended Posts

Je tiens tout d'abord à préciser que ni moi, ni frandroid, ne pourront être tenu pour responsables en cas de mauvaises manipulations ou problèmes avec votre portables suites à ces manipulations. :)
 
 
J'ai donc crée un Firmware prérooté de la 14.5.A.0.242 pour notre Z1C en prenant pour base le firmware CustomizedFR
La rom est rooté avec SuperSU 2.46 et j'ai utilisé le dualrecovery 2.8.14 de %5BNUT%5D du forum xda
J'ai rajouté

4K et Timeshift Video

Prérequis :
 
Avoir un recovery
Télécharger le .zip de la rom sur Google Drive ou sur Mega
Mettez ce .zip dans votre carte SD
 
Procédure :
 
0. FAITES UN BACKUP DE VOS DONNEES AVEC LE RECOVERY ET/OU AVEC TITANIUM BACKUP (ou une alternative)
1. Wipe all : Wipe factory reset + Wipe data + Wipe Cache + Wipe Davilk Cache + Wipe System
2. Flasher le .zip
3. Rebooter
4. enjoy ! Le premier démarrage prends environ 5 min
 
 
Quelques Screenshots :
 
390886Screenshot20150414100443.png      842485Screenshot20150414100613.png
 
 
705899Screenshot20150414100632.png      237506Screenshot20150414100644.png
 
 
 
 
Pour ceux désirant Xposed, rien de plus simple de suivre ces consignes : http://forum.xda-developers.com/showthread.php?t=3034811
Le .zip et .apk de Xposed pour Lollipop est à copier sur votre carte SD

 

N.B. : Depuis la version xposed-sdk21-arm-20150430.zip, les problèmes de bootloops ont été corrigés, pas de fichiers .zip supplémentaires à flasher
 
Procédure :
 
Après le premier reboot

1. Installer le .apk de Xposed
2. Rebooter en recovery
3. Flasher le .zip de Xposed pour Lollipop
4. Rebooter et normalement, c'est bon pour installer les frameworks compatibles ;)
 
898727Screenshot20150414173215.png
 
 
 
Merci à [NUT] pour son immense travail avec le DualRecovery
Merci à zxz0O0 pour son PRFCreator
Merci à Iagucool pour son travail avec XperiFirm
Merci à moly82 pour son script de debloating
Merci à rovo89 pour son dur travail avec Xposed
Merci à Tonio78r de m'avoir aidé à chercher l'origine du problème de Xposed avec Lollipop

Modifié par xander59
  • Like 2

Partager ce message


Lien à poster
Partager sur d’autres sites

Aucun j'ai rebooté environ 5 fois depuis tout à l'heure et pas de bootloop comparé à hier :)

Partager ce message


Lien à poster
Partager sur d’autres sites

salut

le .zip de la rom ne fait pas de wipe data en lui meme, n'est-ce pas?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je vois que tu veux vraiment garder ta data (pourquoi ne pas utiliser titanium backup?)... Honnetement, je ne sais pas si ca wipe automatiquement, mais en tout cas c'est hardement conseillé.. Au pire des cas, fait un backup de ta rom actuelle et flash LP sans wipe data, au pire tu reviens direct sur ton ancienne version

Partager ce message


Lien à poster
Partager sur d’autres sites

lol oui j'y tiens

je servirai de cobaye ^^

titanium j'ai pas la version pro et pour la restau c'est galere du coup

dans tous les cas j'ai biensur prévu de faire un backup avant, tout en sachant que je risque de tout perdre ou de bugger et que dans ce cas je devrai reflasher avec un wipe ;)

le wipe data ne vide pas la sd interne de 13Go environ ni la externe, mais juste la partie ou est intallée la rom c'est bien ca? (la je me rends compte que ca fait trop longtemps que j'ai plu touché à tout ca ^^)

Partager ce message


Lien à poster
Partager sur d’autres sites

merci pour tout, je vais tester ca dans la soirée et je ferai mon retour ;)

 

wow 5495MB le backup, rien que ca ca va etre long...

Partager ce message


Lien à poster
Partager sur d’autres sites

petit retour

l'update s'est tres bien faite sans le wipe data, j'ai juste une appli qui a disparu (kfreebox) et erreur 505 quans j'essaie de la retelecharger

voila, xposed ca sera demain, encore merci ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Pas de problème d'envoi et de reception de sms pour toi ? :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors petit retour suite à l'installation de ta Rom:

a cause d'un recovery pas à jour (ma faute), le zip ne s'est pas bien installé: toujours en 4.4.4 (.157).
Tentative de réinstallation d'un recovery = perte complète du recovery.

Après downgrade (.108), reroot, reinstall d'un bon recovery (twrp par le package Nut 2.8.10), c'est passé nickel !

 

Pas de problèmes de sms. Par contre, au premier lancement des applis réinstallées par Titanium Backup, j'ai en général un plantage ou des comportements étranges. En relançant le téléphone ou en killant l'appli, ca revient à la normale.

Sinon encore merci pour ton tuto !

 

Je testerais Xposed dans la journée (après un backup en recovery of course)

Modifié par gregosor78

Partager ce message


Lien à poster
Partager sur d’autres sites

Mon problème de SMS apparait après la restauration des données de l'application "stockage de téléphone"

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui je restaure via la sauvegarde XML mais c'est long ... très long parce que j'ai beaucoup beaucoup de SMS :p (depuis hier 22H30 ca tourne :p)

Mais je vais tenter à nouveau un truc tout à l'heure vis à vis des permissions mais cette fois ci je ferai un backup avant au cas où ca ne fonctionne pas ^^

Partager ce message


Lien à poster
Partager sur d’autres sites

Fausse manip de ma part ? Après le débloat (je suppose), je n'ai plus l'appli de mail d'origine de la Rom :(

Partager ce message


Lien à poster
Partager sur d’autres sites

Non pas de fausse manip, j'ai oublié de prevenir que ce sont certaines applications systèmes qui interfèrent avec Xposed donc elles sont supprimés mais peuvent etre remplacés facilement :)

Je corrige mon oubli dans le premier post

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

En effet, j'ai regardé ta liste : violent le debloating :(
On perd les menus Xperia Connectivity, les mini-apps et tout plein d'autres trucs plus ou moins importants.

Bref, j'ai reflashé le zip de la rom avec juste vidage cache + dalvik.
Reboot -> ok mais Xposed m'annonce que le framework n'est pas installé (normal)

Retour en recovery et flash du zip Framework Xposed.
Reboot -> tout es ok. Donc je confirme que les étapes 1,2 et 3 ne sont pas forcément nécessaires  B)

Partager ce message


Lien à poster
Partager sur d’autres sites

et après d'autres reboot, toujours pas de bootloops ? :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Malin, ca. J'ai rebooté pour test. Et hop bootloop....

 

Ca passe avec un wipe dalvik / cache. Je soupçonne néanmoins GravityBox car j'ai pu rebooter plusieurs fois sans bootloop avant son activation. Je teste et je te dis.

Sinon va falloir faire du sur-mesure sur le debloat pour pas trop perdre de fonctionnalités ou abandonner Xposed pour le moment.

Modifié par gregosor78

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui avec d'autres membres sur XDA, on essaie de trouver le ou les apps qui provoquent ca :)

  • Like 2

Partager ce message


Lien à poster
Partager sur d’autres sites

Pas de problème d'envoi et de reception de sms pour toi ? :)

dsolé pour le retard

l'appli sms ne se lançait pas, j'avais juste la barre de tache et au bout d'un moment un mesage pour attendre ou sortir.

je suis passé par hangout, puis re client sms et c'est passé impecc :)

Partager ce message


Lien à poster
Partager sur d’autres sites

par contre j'ai quand meme quelques applis qui ont disparu pendant la mise a jour avant meme de mettre xposed, (kfreebox, hushsms, acr, kami, pour ce que j'ai pu constater jusque la, surement d'autres)

Partager ce message


Lien à poster
Partager sur d’autres sites

Fort probable, certaines applis sont installé dans le fichier /system et non /data ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoignez la conversation

Vous pouvez poster maintenant et vous enregistrez plus tard. Si vous avez un compte, connectez-vous maintenant pour poster.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.






×
×
  • Créer...