Jump to content

Recommended Posts

Ok, merci pour vos retours mais c'est agaçant de ne pas trouver de solution définitive. Je trouve quand même bizarre lorsque j'arrive à récupérer la 4g, chez moi, si je fais 2 mètres je repasse en H et si je me remets au même endroit la 4g ne revient pas avant plusieurs minutes. Le pire c'est au boulot, avec mon S3 LTE j'avais tout le temps la 4g et là pareil je reste en H toute la journée et quand je rentre chez moi, assis sur mon canapé j'ai la 4g... Pff ça me saoule. J'espère qu'on va trouver quelque chose.

Envoyé de mon Redmi Note 3 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Ce weekend , je vais flashé en mode fastboot, pour voir. Ça ne devrait pas poser de problème sur le PC avec W.XP 32bit

Dans le tuto de Kuan :

Tuto installation ROM RN3 Pro via Fastboot (sans MiFlash) pour bootloader déverrouillé

Share this post


Link to post
Share on other sites

@@Dream-eco

Tiens nous au courant. Quelle rom vas-tu installer ?

Edited by rudyjo33

Share this post


Link to post
Share on other sites

Salut,

Je me suis incrusté dans un forum miui où un gars a reçu son tél avec la 7.1.9.0.0 et il s'est avéré que lui aussi avait le soucis de la 4G. Dailleur, suite à mon message, plusieurs personnes se sont manifestés suite à la perte ou problème de la 4G:

 

Lien forum: http://en.miui.com/thread-275123-1-1.html

 

Cependant, Ii dit avoir trouvé une solution que je vous cite ci-dessous (traduction google)

 

Voici un tutoriel étape par étape:

Sauvegardez vos applications et données de Paramètres> Paramètres supplémentaires> Backup & Réinitialiser> Sauvegardes locales> sauvegarder.

Il permettra d'économiser tous vos paramètres (réglages homescreen, mots de passe Wi-Fi, etc.), les données d'application (SMS, journaux d'appels, l'historique des chats, etc.) et des applications (de sorte que vous ne devez re-télécharger tout ce qui suit), à la carte SD. L'emplacement de sauvegarde est externe SD / MIUI / backup / AllBackups /

Flashez le plus récent MIUI mondial Stable 7.2.3.0 utilisant MiFlash en mode ADB EDL utilisant Windows 64 bits. Vous pouvez essayer dong une usine remise à zéro à la place, il peut travailler.
    
Choisissez l'anglais (États-Unis) comme votre langue au premier démarrage. Vous pouvez essayer une autre langue, il peut travailler.
    
Ceci est la clé. Vous devez choisir Singapour comme votre Locale. Vous pouvez essayer d'autres endroits, il peut travailler.
    
Laissez le téléphone lui-même mis en place comme d'habitude. Vous pouvez connecter votre téléphone à une connexion Wi-Fi, connexion pour compte Google, compte Mi, et définir des empreintes digitales (tout cela est pas nécessaire, comme vous pouvez le faire plus tard).
    
Lorsque le démarrage du système, consultez Paramètres> Cartes & Mobile SIM Réseaux> SIM 1> Type de réseau préféré. Vous trouverez LTE là.
    
Changez votre dos Locale preferred par Paramètres> Paramètres supplémentaires> Locale. Également modifier votre langue à travers Paramètres> Paramètres supplémentaires> Langue et entrée> Langue, si vous avez besoin.
    
Restaurer toutes vos applications et données en allant dans Paramètres> Paramètres supplémentaires> Backup & Reset> sélectionnez votre sauvegarde> Restaurer.

 

Après, lui son soucis était que dans la gestion de la SIM, il n'avait pas l'option 4G Préférée, moi perso je l'ai mais même en le sélectionnant, je reste en H/H+.

Je vais essayer demain de reflasher mon tél et tester de passer de la 6.4.21 à la 7.2.3.0 et suivre la manip qu'il donne pour voir, mais je reste pessimiste.


@@MAtos_22

Entre temps j'ai mis le même lien que toi...

  • Like 1

Share this post


Link to post
Share on other sites

;-)

 

Ton post etait surtout mieux que le mien, car j'ai vu ca du tel au bureau et j'avais pas trop le temps de mettre en forme.

Mais moi aussi j'ai bien l'option 4g alors que lui ne l'avait pas.

  • Like 1

Share this post


Link to post
Share on other sites

Sur la ROM revendeur moi je pouvais pas accéder au menu où l'on peut modifier les empreintes digitales. C'est pas le même bug mais ça doit être relier

Edited by jdosson

Share this post


Link to post
Share on other sites

@@xiaomifan, pourquoi tu passes par Fastboot ? Tu n'en as plus besoin.

 

Va dans le TWRP :

- Wipe Cache/Data/System/Dalvik

- Reboot / Recovery

- Installation de la ROM suivi de Supersu

- Wipe Cache et Dalvik

- Reboot / System

 

La dernière Dev [6.4.14] est sortie ce matin sur ce lien

 

Désolé pour cette réponse tardive !

 

Merci Kuan mais en fait avec mes différents changements de rom, je n'ai plus twrp et du coup j'ai été obligé de repasser par fastboot.

 

Pour résumer, suite au flash des fichiers radios de la ROM AOSP, je n'ai pas récupéré de 4G et j'ai même perdu les fonctions téléphonies de mon REDMI NOTE 3 PRO. J'ai donc essayé de chnager de rom pour récupérér cela mais mon ordi ne voit plus mon téléphone lorsque je tape les commandes adb devices en mode fastboot. Aurais-tu une idée pour pouvoir récupérer au moins mes fonctions radios (téléphonies..) à défaut de 4G ?

 

Sinon concernant la procédure wipe all, je l'avais suivi mais sans succès ( :-( ).

 

Ciao !

Share this post


Link to post
Share on other sites

@@xiaomifan, salut, essaye d'installer une ROM Fastboot (Global Dev / Global stable ou autre ROM fastboot au choix) de cette manière :

 

Tuto installation ROM RN3 Pro via Fastboot (sans MiFlash) pour bootloader déverrouillé

 

  • Téléchargez et décompressez la ROM Fastboot (au choix - voir chapitre ROM officielles ou le précédent) sur votre PC
  • Téléchargez et décompresser sur votre PC les drivers adb.zip qui sont sur ce lien
  • Créez un dossier à la racine de C: de votre PC que vous appellerez global (par exemple)
  • Dans ce dossier global (C:\global), vous mettez la ROM Fastboot décompressée + les 4 fichiers adb (fastboot.exe/adb.exe, etc)
  • Tout doit être dans le même dossier. Ca ressemble à cela  

     714339411.png   

 

  • Éteignez votre RN3 Pro
  • Appuyez simultanément sur Vol - et Power afin qu'il rentre en mode Fastboot (petit bunny apparaît)
  • Connectez votre RN3 Pro à votre ordinateur en USB
  • Attendez quelques secondes que la connexion se fasse entre le PC et votre smartphone
  • Lancez le fichier batch souhaité

Flash all.bat : réinitialise totalement l'appareil et supprime vos données

flash_all_except_data.bat - flash tout sauf la partition données (vos données personnelles sont conservées).

  • Like 1

Share this post


Link to post
Share on other sites

@@Dream-eco

 

Edit : merci pour le rajout des solutions dans le premier post.

Edited by kuan

Share this post


Link to post
Share on other sites

Salut tout le monde ,

Je viens de recevoir mon RN3 PRO cette semaine.

Il m'a été livré avec la ROM 7.98.9.0 stable.

Je l'utilise depuis hier , j'ai bien la 4G sur le slot 1 avec Bouygues et Free. Ça a l'air de fonctionner.

De peur d'avoir des pb de 4G, me conseillerai vous de changer de ROM en xiaomi.eu full FR ??

Merci

Edited by jafax

Share this post


Link to post
Share on other sites

Bonjour à tous, 

 

Alors concernant la 4g j'essaie d'avancer de mon côté. 

 

Est ce que quelqu'un qui est chez Orange ou Sosh, et qui à une 4G fonctionnelle à chaque redémarrage,  pourrez me communiquer ses APN.

 

J'ai rentré les APN que j'avais de configurer sur mon Oneplus qui sont différents de ceux communiquer par SOSH et j'ai du mieux mais ce n'est pas encore çà.  

 

Je serai preneur aussi d'avoir les APN SFR pour ceux qui ont une 4G fonctionnelle. 

Edited by Saxo

Share this post


Link to post
Share on other sites

@@jafax, tu peux faire la mise à jour en suivant le tuto de @, tu n'as pas la mauvaise rom 7.1.9.0.0

@@Saxo, honnêtement je ne penses pas que ce soit un problème d'apn si tu as eu ton tel avec la rom 7.1.9.0.0. Moi j'ai fait plein de manip, installation super propre, tous les wipes possible et installation de plusieurs rom, rien n'y fait.

Envoyé de mon Redmi Note 3 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

merci @rudyjo33.

je vais essayer le tuto de @

  • Like 1

Share this post


Link to post
Share on other sites

Non je ne l'ai pas eu avec cette rom. Je l'ai eu avec la 7.98.9.0. Et j'arrive à avoir la 4g. Le problème c'est qu'à chaque redémarrage, je dois recommencer les manipulations. Je suis sûr que ce n'est pas grand chose. La en mettant les APN que j'avais dans le one il se connecte plus facilement en 4g. Mais à chaque redémarrage. Je dois tout recommencer.

Share this post


Link to post
Share on other sites

@@Saxo, pour SFR, il faut régler sur "SFR webphone" (sl2sfr).

Ma puce était automatiquement sur "SFR Mobile" et pas de 4G.

En réglant sur SFR webphone, la 4G fonctionne nickel

APN : sl2sfr

Share this post


Link to post
Share on other sites

Peux tu me faire un screenshot de tes APN. Car j'ai bien les bons noms pour les APN.... Mais je remarque qu'à l'intérieur ils ne sont pas toujours remplis pareils.

Edited by Saxo

Share this post


Link to post
Share on other sites

@@Saxo

Nom : SFR wephone

APN  sl2sfr

MCC 208

MNC 10

type d'APN  defaut,supl

Protocole APN IP4/IPv6

Réseau : non spécifié

Le reste est sur : Non défini

 

Les APN de tous les opérateurs du monde sont dans le fichier apns-config.xml qui est dans racine / system /etc

  • Like 1

Share this post


Link to post
Share on other sites

Merci de l'info @

bon je vais récupérer celui de mon OnePlus et le mettre à la place de celui du Xiaomi. Car si je regarde sur le One la taille de ce fichier est de 584.20 ko et sur le Xiaomi 435,52ko. Je verrai bien ce que çà va donner. 

 

 

EDIT: çà marche ....j'ai enfin de la 4G chez SOSH après chaque redémarrage.

 

J'ai comparé vite fait les 2 fichiers apns-config.xml (celui du One et du Xiaomi): concernant Orange, je me suis vite aperçu qu'il y avait plus d'APN orange dans celui du One, que dans le fichier du Xiaomi ... et surtout celui qui me permettait d'avoir de la 4G chez Sosh sur le One sans aucun problème: orange internet.

 

J'avais bien configuré manuellement et enregistré manuellement sur le Xiaomi orange internet, mais apparemment il s'en fout   :P . 

A chaque redémarrage, il me disait aucun service, je sélectionnais donc manuellement 3G préférée et dès qu'il accrochait de la H+, je pouvais le remettre en 4G.

 

En copiant le fichier du OnePlus dans   / system /etc  et en refaisant une réinitialisation des APN, j'ai sélectionné Orange internet (celui qui marche sur le OnePlus) et là au miracle ... là 4G est là ... et elle reste après chaque redémarrage.  

 

Pour ceux qui sont chez ORANGE ou SOSH et qui ont des problèmes (si t'as pas de problèmes ne change rien  :))  ... je mets à dispo le fichier du OnePlus 

Il suffit de copier et renommer ce fichier à la place du fichier d'origine qui se trouve dans / system /etc. N'oubliez de faire une sauvegarde de votre fichier d'origine en cas de problème. Car si tu fais n'importe quoi je ne veux pas être responsable.

 

Ensuite vous allez dans paramètres / gestion sim / la sim concernée (celle qui vous sert par internet) /Noms des points d'accès / réinitialiser > choisissez celui qui marchera pour vous ...... :P    

 

Je tiens particulièrement à te remercier @, tu es vraiment très pro. ;). Je savais que la solution n'était pas loin ... Je pouvais avoir de la 4G après quelques manipulations, donc qu'elle était bien là, le problème était le redémarrage. Il fallait tout recommencer. Foutu APN de m....   

 

Je vais pouvoir profiter maintenant pleinement du Xiaomi en complément du OnePlus One. 

 

Pour résumer si vous avez des problèmes de 4G: essayer de récupérer le fichier apns-config.xml  sur un téléphone qui n'a pas de problème en regardant quels sont les APN par défaut sur celui-ci. Copiez ensuite ce fichier sur votre Xiaomi et réinitialiser ceux du Xiaomi et sélectionner ceux qui fonctionnait sur l'autre téléphone.  

Edited by Saxo
  • Like 5

Share this post


Link to post
Share on other sites

@@Dream-eco

Salut, alors tu as installé ta rom via fastboot sur xp ? Du nouveau pour toi concernant la 4g?

Moi hier, j'ai voulu essayer de récupérer la 4g sur le slot 1 ou 2 mais impossible... Ça m'a gonflé, j'ai fais plein de test redémarré, désactiver les sim, je suis allé dans les paramètres dans mémoire interne, j'ai cliqué partout, quitte à tout perdre, mais impossible de récupérer la 4g. Du coup, j'ai remis ma micro sim sur le slot 1 + ma carte mémoire. Et j'ai laissé mon tél tranquille. Puis je le reprend et que vois-je... 4G en haut à gauche..? Par contre si je passe un appel, elle ne revient pas avant une bonne 20ène de minutes. Des fois, ça repasse en H/H+, sans bouger. Au final ça n'est pas stable du tout. Je verrais demain au boulot car l'antenne 4g de Bouygues est très proche.

@

Il n'y a pas moyen de récupérer un fichier RIL pour faire des tests ?

Test débit 4G effectué chez moi ce matin :

c4c5ca469a86ff72d187782bb528301b.jpg

Envoyé de mon Redmi Note 3 en utilisant Tapatalk

Edited by rudyjo33
  • Like 1

Share this post


Link to post
Share on other sites

@@Saxo,  ;)

Même si tu n'a pas eu de souci, tu as oublié de préciser qu'il faut régler les autorisations du fichier apns-config.xml en 644 (-rw-r--r--).

 

@, quand ton RN3P est en 4G et que tu passes un coup de fil (ou en reçoit un), c'est complètement normal que ton smartphone bascule en 3G le temps de l'appel. Je l'avais déjà signalé sur un autre post

Quand votre smartphone est en 4G, il va basculer automatiquement en 3G ou 2G le temps de l'appel.

Il se remettra tout seul dans la fréquence 3G/4G dès que vous avez raccroché. La 4G ne permet pas la voix, sauf la VoLTE !

 

C'est vrai que 20 minutes pour retrouver la 4G, c'est un peu (très) long. A moins que tu sois en limite de réseau ; il  y a une valeur à modifier dans un fichier pour changer le db maximal sur lequel le RN3P bascule de la 4G vers la 3G si le db 4G est trop élevé (db élevé = signal trop faible).

C'est dommage, il me semble que j'avais trouvé le fichier a modifier avec notepad (1 seule valeur à modifier: db) mais je ne me souviens plus où. Il faudrait que je me repenche dessus.

 

Le db c'est la force du signal ; la 4G sera accepté jusqu'à une seuil maximal du db : par exemple 122db. Plus le chiffre du db est grand, plus le signal réseau est faible (et inversement). Dans mon exemple seuil maximal du db pour la 4G = 122db ; si celui ci passe à 123db, bye bye la 4G (sauf en la forçant manuellement) et retour sur la 3G automatiquement.

Edited by kuan
  • Like 1

Share this post


Link to post
Share on other sites

@

Ci-joint capture d'écran :

e5ca13c01ce60bf405c526235877424e.jpg

dae5a43f8fb05a9d3e40b13eb121c644.jpg

7fc9793854d23019170bff3238b89fdb.jpg

Edited by rudyjo33

Share this post


Link to post
Share on other sites

@, tu es un peu en limite de réseau (116db).

Il faudrait trouver le fichier (dont je parlais plus haut) où il y a le seuil maximal autorisé avant que la 4G bascule en 3G car signal trop faible (db trop élevé).

Je ne sais pas à combien il est réglé d'office sur le RN3Pro. On peut surement un peu augmenter la valeur. Même avec 0 barres db133 (en forçant manuellement la 4G - attention on ne peut pas appeler ou recevoir un appel dans ce mode car LTE only) il est possible de télécharger des fichiers.

Si on trouve le fichier et que l'on augmente un peu la valeur maximale du db pour que la 4G "reste", on n'aura pas besoin de la forcer. En réglant en 4G privilégiée, elle resterait en place assez facilement. J'ai "l'impression" (?) que c'est vers 122db que la bascule se fait...mais sous réserve. 

 

Sur la capture d'écran ci-dessous (cliquez dessus), j'ai forcé la 4G. Le signal db est vraiment très faible (128db) et il ne serait jamais passé avec cette valeur si je ne l'avais pas forcé manuellement. Même avec 128db, je peux aller sur le net et télécharger des fichiers ^^

mini_286606Screenshot20160508120858comwi


Network Cell Info  https://play.google.com/store/apps/details?id=com.wilysis.cellinfolite

Edited by kuan
  • Like 1

Share this post


Link to post
Share on other sites

89eccbcc2034b00d54f435b7b853dea9.jpg

3563261a4236121a2b1901fd3a3bb10d.jpg

e1546faa6279e2504a5696fb41c7acdd.jpg

En fait, j'ai l'impression que l'accroche réseau est très faible ou se fait mal, en faisant les tests là pour les captures d'écran, mon tél est repassé en H, sans bouger puis j'ai fais 3 mètres, je me suis mis en WiFi pour me mettre au canapé et 5min après la 4g est revenue.

Sur mon S3 LTE j'avais effectivement 1 barre quasi tout le temps mais je ne perdais pas la 4g comme là. Je vais essayer de trouver le fichier à modifier pour forcer la 4g.

Envoyé de mon Redmi Note 3 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...