Jump to content

Redmi 4X MTP USB ne fonctionne pas


BastienBastien
 Share

Recommended Posts

Bonjour à tous,

 

Je suis le possesseur d'un 4X depuis une petite semaine et je rencontre déjà un problème (avec un téléphone à 100€ fallait pas trop en demander ?). 

En effet, lorsque je branche mon téléphone à un ordinateur (Windows 7 et 8, Ubuntu 16.04 et 17.10) ce dernier n'est pas reconnu

Le téléphone se met en charge (et fait un petit bruit lorsque je le branche et le débranche). Mais je n'ai pas accès au MTP.

J'ai plus ou moins fait le tour du net et essayé diverses solutions plus ou moins fantasques : cliquer de manière à devenir développeur, permettre le débogage USB, téléchargé diverses appli censées réglées le problème(USB Driver, USB detect, etc). 

Je pense avoir trouver une solution crédible (rentrer des commande dans le fichier “system/build.prop”. Sauf que pour modifier ce fichier, il faut être root et pour rooter son téléphone il faut le connecter à un PC qui le reconnaisse... et le serpent se mort la queue (Ouroboros si tu nous lis).

 

C'est pourquoi, je me retourne vers la communauté francophone, la plus compétente et la plus nombreuses (un peu de brosse à reluire) pour savoir si vous n'avez pas une idée lumineuse.

 

Merci beaucoup.

 

Bastien 

 

ps : j'ai changé de cable mout fois sans succès

Link to comment
Share on other sites

- le PC fait-il le bruit de détection de périphérique Windows quand tu le branches ou pas ?

- y a-t-il un périphérique qui apparaît dans le gestionnaire de périphériques de Windows ? en erreur (panneau jaune) ou pas ?

- dans les notifications du téléphone, as-tu un message quelconque qui s'affiche quand tu le branches sur le PC ? si oui, lequel ?

 

Link to comment
Share on other sites

Salut Ultrix, 

 

- le PC fait-il le bruit de détection de périphérique Windows quand tu le branches ou pas ?

Aucun bruit, ni windows ni linux

- y a-t-il un périphérique qui apparaît dans le gestionnaire de périphériques de Windows ? en erreur (panneau jaune) ou pas ?

Non, Rien du tout...

- dans les notifications du téléphone, as-tu un message quelconque qui s'affiche quand tu le branches sur le PC ? si oui, lequel ?

Oui, le téléphone fait un petit bruit (mignon) indiquant qu'il est connecté et un message affichant le temps de chargement restant apparaît.

Link to comment
Share on other sites

Ca ressemble fort à une coupure sur les lignes data de la connexion USB et donc un smartphone qui ne détecte qu'une connexion de charge. Tu dis que tu as changé de câble, es-tu certain que ce sont bien des câbles data et pas des câbles de simple recharge ?

Si oui et si tu as essayé sur plusieurs ports USB / plusieurs PC le problème est coté smartphone et cela pointe vers un problème de connectique sur le port Micro-USB du téléphone. Interne ou bien au niveau des broches du port.

Je doute que la cause soit logicielle. Je n'ai jamais entendu dire qu'il faille bidouiller build.prop sur aucun smartphone pour activer le mode MTP. C'est standard.

 

Link to comment
Share on other sites

J'ai essayé avec au moins 3 câbles différents et tous ont fonctionné avec d'autres portables. 

Pour les ports et USB, je dirais que j'ai testé sur 5 PC différents au boulot et chez moi sous win 7, win 8, Ubuntu 16.04 et 17.10

Ça sent le pâté si c'est un problème hardware, je le sens assez moyennement le SAV gearbest en Chine.

Link to comment
Share on other sites

 

bonsoir,

sur le mien,redmi 4 standard,ainsi que sur celui de ma femme,redmi 4x,après avoir connecté le smartphone il faut faire une descente en partant du haut;apparaît "recharge par usb,cliquer et sélectionner transfert des fichiers ou mtp suivant version;en ésperant que ça fonctionne... 

Link to comment
Share on other sites

Grandspouces, Ultrix, Looping, ça ne fonctionne malheureusement pas. Lorsque je clique sur recharge USB après avoir branché mon téléphone, aucune option n’apparaît et j'entre directement dans le menu batterie qui me donne la température, le %age de charge, etc.

 

Joh1303 --> Ok je vais voir si ça fonctionne, je crains pas grand chose je crois. Je vous fais un retour.

 

Pour info, hier soir j'ai essayé un factory reset ça n'a rien changé.

 

Merci à tous pour vos conseils.

Edited by BastienBastien
Link to comment
Share on other sites

Hélas, cela ne fait que confirmer ce que je disais. Si le smartphone ne t'affiche pas ces choix, c'est que pour lui il est connecté à un câble de charge simple (deux broches +5v et masse). Donc pas de contact sur les broches data.

 

Alors reflashage, oui, pourquoi pas ? de toutes façons il faut tout tenter avant d'envisager un retour en Chine... mais j'y crois moyen.

Link to comment
Share on other sites

Quelle est la rom installée dessus ?

 

@Ultrix la modif du build.prop a résolu un problème fréquent de reconnaissance du MTP après un root sur ce modèle de téléphone.

 

Il serait intéressant de savoir si le mode fastboot reste accessible néanmoins.

 

NB: Et avant de le rooter, il faut voir si le bootloader est déverouillé, selon où il a été acheté ce n'est pas forcément la cas. Et avec Xiaomi, la demande se fait via eux.

Edited by Thouraeg
Link to comment
Share on other sites

Je viens d'essayer le truc d'indien proposé par Joh mais ça ne marche pas.

Le logiciel Xiaomi Miflash ne trouve pas le téléphone donc impossible de le flasher...

Le problème est le même, ce téléphone est invisible pour les PC.

Malheureusement pour moi je crois que c'est Ultrix qui a raiso, il doit manquer une broche data sur le téléphone.

 

Thouareg, a toute fin utile, la rom installée sur le tél est celle d'origine (en tout cas celle que j'ai reçu) à savoir : MIUI Global 8.5 Stable (8.5.2.0)

Le fastboot n'est pas accessible donc pas de root ni d'autre joyeuseté de ce gout là.

 

Ca sent le retour a pied par la Chine...

Link to comment
Share on other sites

Arf, s'il n'est pas visible non plus en mode fastboot, l'hypothèse d'Ultrix se confirme.

Celui que j'ai acheté, l'a été via un site français, même si le SAV se fait en Chine. Mais au moins on a un interlocuteur en France.

Là si c'est du direct Chine, ca va pas être la joie j'en ai peur.

Bon courage, en espérant que tout se passe pour le mieux. Tiens nous au courant.

 

Link to comment
Share on other sites

Il y a 12 heures, BastienBastien a dit :

Ca sent le retour a pied par la Chine...

Elle a une grande barbe blanche, celle-là, mais elle est bien placée ! ^_^

C'est super de garder son sens de l'humour face à l'adversité.

Bonne chance avec Gearbest, comme l'a dit Thouareg tiens-nous au courant.

Edited by Ultrix
Link to comment
Share on other sites

@BastienBastien à tout hasard, essaye ceci :

  • Vous avez perdu la connexion MTP (le PC ne reconnait plus votre xiaomi) ? MIUI USB Settings 

 

  • Autre solution : aller dans l'explorateur Windows et installer manuellement le fichier wpdmtp.inf

C : / Windows / INF / chercher le fichier wpdmtp.inf et faire un clic droit dessus : installer (éventuellement rebooter l'ordinateur après installation).

Edited by kuan
Link to comment
Share on other sites

@kuan j'ai essayé que la première solution qui malheureusement n'a pas fonctionné.

 

Merci à tous, vraiment pour vos propositions, suggestions et avis.

 

J'ai déjà une réponse gearbest qui me propose 3 solutions :

- Renvoyer mon portable (en Espagne) et en recevoir un neuf ou

- Me rembourser en avoir ou sur mon compte (achat de moins de 45 jours)

- Garder le portable et me donner 20€ de bons d'achats

 

Le black friday arrivant à grands pas, j'ai demandé le remboursement des 110€. J'aurai perdu le prix de la coque et du film (3€) et le prix du retour en Espagne.

 

J'en profite pour vous poser une question à 1 000 $, quel portable de max 5' me conseillerez vous ?

 

Merci à tous.

 

Link to comment
Share on other sites

  • 2 months later...

Bonjour,

 

La solution vient du cable USB. En effet il doit être du type charge+synchro. Si vous ne l'avez pas voici le lien direct vers l'acheteur officiel :

 

 

Cela a été un peu difficile de se connecter ici. Mais afin d'aider la communauté cela en vaut la peine.

Ne pas tenter de flash, au risque de perdre les configurations préexistantes.

Le problème est résolue. Modo

 

Edited by indian65
publicité
Link to comment
Share on other sites

Bonjour,

 

La solution vient du cable USB. En effet il doit être du type charge+synchro. (n'en déplaise Gary Thuerk, Ultrix : voici un lien vers un vendeur (en effet Ultrix, j'ai utilisé le terme acheteur au lieu de vendeur, pourquoi ? je m'en fou) en guise d'exemple, libre de le choisir puis de l'acheter ailleurs moins chère ensuite, ou d'occasion sur leboncoin.)

 

 

Cependant, ce type de cable plus android file transfert permettent le bon fonctionnement d'un échange de données entre l'android en question et l'ordinateur.

Afin de telecharger, le logiciel, voici le lien officiel :

 

Cela a été un peu difficile de se connecter ici. Mais afin d'aider la communauté cela en vaut la peine.

Ne pas tenter de flash, au risque de perdre les configurations préexistantes.

Le problème est résolue. Modo

 

Edited by indian65
publicité, lien hors google play
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By Insoimidine
      j'ai un tablette Archos et j'ai voulu le reinitialiser puis j'ai oublier l'adresse email et le mot de passe 
      que doit-je faire
    • By Stema1964
      Bonjour,
       
      Je viens d'acheter une Samsung galaxy watch 4 classic.
      Le problème, 3 heures pour charger la batterie qui était à 0% et au bout de 12 à 13 heures, batterie à 0%. et tout ça sans sport avec des paramètres  de consommation minimum.
      Je l'ai donc fait changer par le vendeur. Et avec la nouvelle, toujours à 0%, toujours 3 heures environ pour la charger et au bout de 18 heures plus rien.
       
      Est ce un problème de la montre et donc je vais devoir demander un nouveau changement ou bien n'est pas lié à la mise a jour que j'ai fait sur les deux montres?
       
      Merci de votre aide.
       
      PS : la montre vient des EAU. Et je suis actuellement en Afrique.
    • By Bilibilou
      Bonjour, je viens de m'acheter le Google pixel 6 et ai installer le jeu rocket League sideswipe, mais problème !! avec ce jeu et quelques-uns d'autres, il se ferme tout seul après quelques secondes d'ouverture et d'interaction. Pourriez-vous m'aider à résoudre ce problème sachant que j'ai déjà essayé les astuces du type vider le cache de l'application, la réinstaller, redémarrer le téléphone rechercher les dernières mises à jour, etc. Dois-je attendre la prochaine mise à jour Google ? Est-ce le jeu qui est trop gourmand ? Voici mon problème j'espère que vous m'aiderez.
    • By Tovisiegfried
      Bonjour, 
      Suite à la mise à jour de mon S21 vers Android 12, de nombreux bugs sont apparus, parmi lesquels impossibilité d'ouvrir des applis (MyMail, appli bancaire, Waze, Hearthstone via le Amazon Store), un battery drain conséquent et une surchauffe. 
       
      Le plus handicapant demeure la double authentification auprès de ma banque pour les transactions. J'ai contacté mon banquier pour désactiver à distance cette option. 
       
      Comme solutions, j'ai essayé :
      - redémarrage, extinctions à plusieurs reprises, 
      - mise à jour des applis via le Play Store, 
      - clear cache dans le Recovery. 
       
      En vain. Je n'ai pas envie de refaire une remise à zéro. J'ai écrit à Samsung via Samsung Members en leur envoyant un log de diagnostic. 
       
      Quelqu'un subit les mêmes bugs suite à la mise à jour ? Des solutions à proposer ? 
       
      Merci ! Je suis aux abois. 
       
    • By Piero2918
      Bonjour ! 
      Je rencontre un sérieux problème avec le playstore sur mon Honor10, dès que l'application ouvre elle se ferme toute seule et se réouvre directement et ça en boucle jusqu'à ce que je force la fermeture de l'appli. C'est assez gênant car du coup je ne peux plus mettre à jour mes apps! J'ai déjà essayé les solutions classiques du cache ect.. Mais rien n'y fait, en espérant que quelqu'un ait une solution, merci d'avance ! 
×
×
  • Create New...