Jump to content
Pitivier

Tuto : Faire des captures d'écran d'un appareil sous Android

Recommended Posts

Ouais, pas de soucis.

Par contre, après une tentative désespérée de mise à jour des pilotes, même si je l'avais déjà fait, j'ai retenté et ça a marché. :|

Ca a rien installé vu qu'il m'a dit que c'était déjà la dernière version, mais maintenant, je le vois. oO'

Share this post


Link to post
Share on other sites

Bonjour,

j'essaie de suivre la procédure. Mais je suis sous linux ubuntu. J'ai chargé le sdk, mais quand je lance l'application, j'ai juste une page sans aucune indication :

dmm_android.jpeg

Si quelqu'un a une solution.

Share this post


Link to post
Share on other sites

T'as bien branché ton téléphone ? :lol:

Il est en mode debug ?

Il est reconnu par ubuntu ?

Share this post


Link to post
Share on other sites

c'est comme sous windows il faut installer le drivers pour accéder au mode debug du téléphone, mais par contre je n'ai pas encore regarder comment il fallait faire sous linux

Share this post


Link to post
Share on other sites

Ben a priori oui.... tu as bien téléchargé la version Linux du SDK ?

Regarde si là oui il y a les drivers windaube il n'y a pas un quelque chose pour Linux!

Share this post


Link to post
Share on other sites

Ben je suis pas un maniaque de Linux! Mais quand je vois que je devais à une époquer installer à la main mes drivers ATI, je me dis que tu peux peut-être avoir à installer ceux du téléphone! Parce que sous windaube, par défaut il n'est pas reconnu comme il faut! Alors pourquoi ça serait pas pareil sous linux???

Share this post


Link to post
Share on other sites

Le driver sert à reconnaitre le support usb. Sous linux udev détecte parfaitement le support. A partir de la, je vois pas ce que tu veux installer de plus.

Share this post


Link to post
Share on other sites

Ben c'est bien ce que je dis! Ce n'est pas le support dont tu as besoin mais bien un driver spécifique pour "communiquer" avec la bête! Donc ma remarque sur le driver est peut-être pas aussi idiote ;)

Pour détailler :

- mode 1 : le téléphone est vu comme un simple périphérique de stockage externe (celui dans lequel tu es)

- mode 2, en plus du périphérique de stockage apparait un "Android Phone" avec lequel l'ordinateur sait maintenant discuter :)

C'est le mode 2 dont tu as besoin!

Share this post


Link to post
Share on other sites

bon je corrige a première vu pas besoin de drivers sous linux

par contre si ton environnement java fonctionne mal il se peu que la liaison ne passe pas correctement

sous ubuntu tape

sudo apt-get install sun-java6-jre sun-java6-fonts

pour le java en dernière version

Edited by Manfraid

Share this post


Link to post
Share on other sites

Déjà installé tout ça. J'ai même ajouter une ligne dans /etc/udev/rules.d/90-android.rules

SUBSYSTEM=="usb", SYSFS{idVendor}=="0bb4", MODE="0666"

mais le code idvendor ne correspond pas au galaxy. j'en ai trouvé un sur un groupe de discussion android :

SUBSYSTEM=="usb", SYSFS{idVendor}=="04e8", MODE="0666"

mais ça ne fonctionne toujours pas.

Share this post


Link to post
Share on other sites

Chez moi ca fonctionne parfaitement (après quelques problèmes de détection et création des fichiers de périphériques avec udev..) android lancé, et en fastboot :

(0)[drakaz@PC:/etc/udev/rules.d]cat 50-android.rules (23 juil. 21:07)

SUBSYSTEM=="usb", SYSFS{idVendor}=="18d1", MODE="0666"

(0)[drakaz@PC:/etc/udev/rules.d]cat 51-android.rules (23 juil. 21:07)

SUBSYSTEM=="usb", SYSFS{idVendor}=="04e8", MODE="0666"

(18d1 est l'id en fastboot, 04e8 pour le noyau android du samsung)

N'oublit pas de relancer udev : /etc/init.d/udev restart

adb semble avoir un problème sur la detection des galaxy, nos amis allemand on trouvé la solution et ont posté un adb modifié.

Explication : http://www.android-hilfe.de/o2-samsung-galaxy-i7500-forum/4021-adb-jetzt-auch-auf-dem-galaxy.html#post38582

Liens direct vers adb modifié (à décompresser dans tools/ du SDK) : http://floe.butterbrot.org/external/adb.gz

Enfin si tu est sous la version 64bits d'ubuntu... : http://coffeecokeandcode.blogspot.com/2009/07/ddms-on-ubuntu-64bit.html

Et voilà les premiers screen de mon Galaxy : :D

homerwx.png1248411116_device.png1248411150_conso.png

Edited by drakaz

Share this post


Link to post
Share on other sites

L'appli conso se télécharge via la page "Conso" de la page Internet Mobile de Bouygues :)

Share this post


Link to post
Share on other sites

merci drakaz, mais ça aussi j'avais trouvé et testé.

Y'a rien à faire je reste toujours sur cet écran sans rien.

Je suis sous ubuntu Jaunty 32. J'ai testé sur 2 pcs différents, mais j'ai la même chose.

Share this post


Link to post
Share on other sites

Manfraid a raison, je crois que c'est la première fois que je dois relancer le pc pour qu'il tienne compte de modifs.

En fait, /etc/init.d/udev restart ne suffit pas. C'est bizarre, mais l'essentiel est que ça marche. :)

Share this post


Link to post
Share on other sites

Bizzare, je suppose qu'après avoir relancé udev tu avais debranché et rebranché ton tel...

Je pensais que la seule raison d'un reboot était la modification de kernel.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...