Jump to content
Pitivier

Tuto : Faire des captures d'écran d'un appareil sous Android

Recommended Posts

dmm_android.jpeg

j'ai voulu faire des capture d'écran également mais j'ai ca comme image quand je lance le SDK

je suis sous vista système 32 enfin je crois :D les pc et moi ca fait 12

merci :)

il existe pas un autre moyens ??? je m'y connais pas mais en faisant des recherches j'ai vu "Éclipse", c'est quoi ????

Edited by hlulue

Share this post


Link to post
Share on other sites

Eclipse c'est l'environnement pour développer! Donc ca va pas le faire ^^

Par contre, t'as installé les drivers ?

Sous vista faut désinstaller les anciens et installer les nouveaux!

Share this post


Link to post
Share on other sites

Pour rejoindre un des posts précédent, un moyen de faire des captures depuis windows ? Essayé sur Xp et Seven avec le dernier SDK et même après bidouille du pilote pour qu'il soit accepté par mon galaxy, rien dans ddms :(

Share this post


Link to post
Share on other sites

/troll

bon je vais être désagréable mais passez sous linux :D

/end troll

sinon comme le dit jorodan vous avez bien installé les drivers???

vous avez bien passé le tel en mode debug???

Share this post


Link to post
Share on other sites

Tout fait comme il faut :) ... Mode debug plus installé les pilotes même s'ils ne sont pas accepté quand il s'agit d'un samsung (ajout de quelques lignes en plus dans le inf pour que ça fonctionne).

Share this post


Link to post
Share on other sites

CA M'ENERVE!!!

Heu... pardon!

Que ce soit sous Ubuntu ou Vista en version 64, IMPOSSIBLE de faire des impressions écran! Alors que proxoid marche très bien!

Voici le message sous Ubuntu 9.04 64bits (je crois que sous vista j'avais pareil) :

julien@julien-laptop:~/Bureau/proxoid-adb/android-sdk-linux_x86-1.5_r3/tools$ ./ddms

Error Loading Preferences

02:54 E/ddms: shutting down due to uncaught exception

02:54 E/ddms: java.lang.UnsatisfiedLinkError: /home/julien/Bureau/proxoid-adb/android-sdk-linux_x86-1.5_r3/tools/lib/libswt-pi-gtk-3236.so: /home/julien/Bureau/proxoid-adb/android-sdk-linux_x86-1.5_r3/tools/lib/libswt-pi-gtk-3236.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1767)

at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)

at java.lang.Runtime.loadLibrary0(Runtime.java:840)

at java.lang.System.loadLibrary(System.java:1047)

at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)

at org.eclipse.swt.internal.gtk.OS.(OS.java:22)

at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)

at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)

at org.eclipse.swt.widgets.Display.(Display.java:126)

at com.android.sdkstats.SdkStatsService.getUserPermission(SdkStatsService.java:278)

at com.android.sdkstats.SdkStatsService.ping(SdkStatsService.java:126)

at com.android.ddms.Main.main(Main.java:89)

A savoir j'ai bien installé java 64 et j'ai meme testé avec java 32 avant... (peut être que ma version 64 a pas bien désinstaller la version 32 ?)

HEEEELP!

Share this post


Link to post
Share on other sites
julien@julien-laptop:~/Bureau/proxoid-adb/android-sdk-linux_x86-1.5_r3/tools$ ./ddms

En écrivant je viens de voir ça... je vais voir s'il y a une version 64 bits du SDK...

Share this post


Link to post
Share on other sites

Il faut impérativement utiliser la version 32 bits. Pour la forcer dans ddms, il faut editer ddms lui même, chercher la ligne :

java_cmd="java"
et la remplacer par
java_cmd="/usr/lib/jvm/ia32-java-6-sun/jre/bin/java"

Share this post


Link to post
Share on other sites

J'ai pas ia32-java-6-sun

J'ai

- java-6-openjdk

- java-6-sun

Et j'ai installé le sdk 64 à la main, mair le fichier .bin sur le site officiel! Ca peut poser un problème ?

Share this post


Link to post
Share on other sites

parfait, comme à la maison ;)

donc :

sudo apt-get install ia32-sun-java6-bin

Pour installé les binaire 32 bits java, et :

Il faut impérativement utiliser la version 32 bits. Pour la forcer dans ddms, il faut editer ddms lui même, chercher la ligne :

java_cmd="java"

et la remplacer par

java_cmd="/usr/lib/jvm/ia32-java-6-sun/jre/bin/java"

Pour forcer DDMS à utiliser cette version de java.

Tiens moi au courant si ca fonctionne :) Sinon hésite pas à venir sur le canal IRC ca sera plus facile pour te dépanner

Share this post


Link to post
Share on other sites

Je suis en train de télécharger ia32-sun-java6-bin

Et tu sais ce qu'il faut installer pour Vista 64 ?

Share this post


Link to post
Share on other sites
Je suis en train de télécharger ia32-sun-java6-bin

Et tu sais ce qu'il faut installer pour Vista 64 ?

Non désolé :(

Share this post


Link to post
Share on other sites
Je suis en train de télécharger ia32-sun-java6-bin

????

C'est pas windows, on télécharge pas un soft pour l'installer. :/

Share this post


Link to post
Share on other sites

donc pas de soluce pour Vista64 ? :(

edit : je vais tester ça et je reviens vers vous

Edited by Gerald

Share this post


Link to post
Share on other sites

Questions, quand je lance l'utilitaire ddms j'ai a chaque fois une fenêtre DOS derrière en arrière plan, c'est normal ? (voir screen)

droid2.th.jpg

@edit : Bon j'ai résolu mon soucis, fallait juste mettre a jour mes drivers usb avec ceux fourni dans le sdk, du coup je peux enfin prendre des screens :lol:

Edited by K-Lagan

Share this post


Link to post
Share on other sites
Je dois être le seul à avoir raté la manip' ^^

A quel niveau tu cales ?

Share this post


Link to post
Share on other sites

Salut!J'ai une question simple...mais à 2 millions d'€!

[color=red]pkoi[/color] ne peut on pas tout simplement faire une capture écran directement depuis l'appareil android ??

Installer des SDK des drivers des blibli des blabla juste pour prendre une image de son bureau je trouve ca [color=red]qd[/color] même énorme!!.... Alors y'a t'il une raison technique qui fasse qu'une telle application n'existe pas encore ?

Merci

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...