Jump to content
Caballero

[Beta-Test] aTrip - Tableau de bord

Recommended Posts

Etrange en effet. Hier, mon voisin a testé sur son Nexus-One, et pareil, le GPS a mis vachement de temps à s'initialiser, alors que sur mon Hero, c'était très rapide. Le truc, c'est que aTrip utilise UNIQUEMENT le GPS. Alors que Map utilise à priori une combinaison GPS + Triangulation avec les antennes réseaux. Peut-être une amélioration à apporter de ce côté là.

Merci pour le retour en tout cas ;)

Share this post


Link to post
Share on other sites

ça sert à ça les béta tests ;)

Tu confirmes qu'en bas à gauche de l'écran, il est affiché :

Satellites: -

Précision: -

?

Edited by Caballero

Share this post


Link to post
Share on other sites

bon ok. Tiens moi au courant quand tu réussiras à capter un signal ;)

Et sinon, les autres ? Ca se passe comment pour vous ?

Share this post


Link to post
Share on other sites

ah ouais, c'est pas bien de trafiquer sa bagnole ;)

Merci, je vais regarder ça.

Edited by Caballero

Share this post


Link to post
Share on other sites

Bon alors je n'ai pas eu le temps de tester en voiture mais déjà au niveau affichage cela me semble correcte.

Par contre tant que l'on a pas de signal gps ça met initialisation du gps et en appuyant sur la touche menu aucun men s'affiche donc aucun moyen de quittez c'est un peu embettant.

Je donnerai plus d'impression demain quand j'aurai pris la voiture et essayer avec un signal gps.

edit: en appuyant sur retour ça a l'air de quitter complètement l'application .

Edited by rafffel

Share this post


Link to post
Share on other sites

salut raf !

en fait, tant que la popup d'initialisation GPS est affichée, tu ne peux pas accéder au menu. Et donc, si tu fais retour, ça quitte effectivement l'application pour de bon. Par contre, une fois le GPS correctement initialisé, la popup disparait, et tu peux appuyer sur retour sans que ça quitte l'application.

Je pensais peut-être virer cette popup, mais il faut que je trouve quoi faire à la place.

Share this post


Link to post
Share on other sites

Ok,

A la place du popup il y a un truc tout simple un petit voyant en bas a droite genre un textview avec un point ( . ) en gros sur lequel tu change la couleur en vert si c'est initialiser.

Enfin ça c'est toi qui voit ^^.

Share this post


Link to post
Share on other sites

yep, pas bête ;) ou alors, ne rien mettre du tout, comme il a déja le nombre de satellites et la précision :|

Edited by Caballero

Share this post


Link to post
Share on other sites

Je vais tester l'appli dans quelques minutes, je ferais un feedback le plus complet possible par mail :D

Share this post


Link to post
Share on other sites

Premier feedback sur nexus one :

Point positif :

+fix très rapide des satellites

+Assez précis, mise a jour de la vitesse rapide.

Négatif :

-N'affiche pas le nombre de satellite fixé

-J'ai eu une pointe a 462.2Km/h avec ma pauvre ford fiesta et ce 2 ou 3 fois sur un trajet de 6km, ça a faussé ma vitesse max et vitesse moyenne

-N'empêche pas la veille du téléphone même si celui ci est branché sur l'allume cigare.

-S'est mis une fois a l'arrêt en "précision insuffisante"

C'est tout pour ce premier test.

Share this post


Link to post
Share on other sites

Alors, avant de répondre à Kartouche, je vais déja vous donner une solution pour ceux qui ont un temps d'initialisation du GPS anormalement long : quittez l'application, coupez le GPS, attendez un petit peu, puis relancez l'application. Normalement, ça devrait aller. En rentrant ce soir, je ferai le correctif et je vous renverrai l'apk ainsi corrigé.

@Kartouche :

Merci pour ce retour !

- Pour le nombre de satellites fixés, tu veux dire qu'en bas de l'écran, tu as toujours "Satellites: -" ??

- Le coup de la vitesse abérrante est apparement un bug connu. Je vais changer le code ce soir pour calculer la vitesse différemment.

- Pour empêcher la mise en veille, je vais me pencher sur le sujet, car je ne sais pas si c'est possible. Toujours est-il que sur mon Hero, dans les paramètres généraux du téléphone, j'ai désactivé la mise en veille automatique.

- Et enfin, l'arrêt en cas de précision insuffisante est volontaire. Car j'ai estimé que le fait d'afficher une vitesse, alors que la précision est supérieure à 20 mètres, c'était franchement pas précis, et donc, je préfère ne pas induire le conducteur en erreur.

Voila voila, la suite ce soir :)

Share this post


Link to post
Share on other sites

Bonjour,

Juste j'interviens dans le sujet pour ce point :

- Pour empêcher la mise en veille, je vais me pencher sur le sujet, car je ne sais pas si c'est possible. Toujours est-il que sur mon Hero, dans les paramètres généraux du téléphone, j'ai désactivé la mise en veille automatique.

Pour moi, il faut conseiller aux utilisateurs d'utiliser l'application keepscreen qui sert a ca (tu fais une liste d'appli qui ne doivent jamais passer en veille)...

Sinon tu peux t'amuser a recup le code, mais je sais pas si c'est possible...

A + et bon courage pour ton appli

Share this post


Link to post
Share on other sites
Alors, avant de répondre à Kartouche, je vais déja vous donner une solution pour ceux qui ont un temps d'initialisation du GPS anormalement long : quittez l'application, coupez le GPS, attendez un petit peu, puis relancez l'application.

Salut,

T'as plus d'info à propos du temps de fix du GPS? J'ai appli qui utilise aussi le GPS, et il met parfois très longtemps à faire un fix.

Share this post


Link to post
Share on other sites

en fait, mon appli est buggée à ce propos (correction ce soir). En effet, le GPS est je pense correctement fixé, mais c'est au niveau de l'affichage que je le prends pas bien en compte ;)

Concernant le temps de fix (dans le cadre d'une application non buggée ;)), on peut pas y faire grand chose. Ca dépend de l'endroit ou tu te trouves, de l'heure de la journée, etc etc etc .... Les satellites GPS sont controlés par les Américains, donc on ne sait pas trop ce qu'ils font dessus, ni quand !

Share this post


Link to post
Share on other sites

Pour le "Satellites -" oui c'est ça.

Ensuite pour le fix moi j'en ai eu pour même pas 5 sec, mon GPS était aussi activé avant de lancer l'application, peut être que ça a aider.

Enfin, pour la veille, je vais que par exemple sur des applications comme Copilot 8 ou Google navigation, le téléphone ne se met pas en veille, désactiver la veille du téléphone n'est pas vraiment une solution adapté car j'aime bien que mon tel se met en veille tout seul en temps normal.

Ensuite, si une autre ap' peut le faire je pense que tu peux inclure le code dans ton ap.

Hormis ces défauts, très très bonne application pour ceux qui comme moi ne sont pas munis d'un ordinateur de bord dans leur voiture, surtout que j'aime avoir la précision d'une vitesse GPS.

Share this post


Link to post
Share on other sites

Merci Kartouche. Si je trouve le bout de code qui fait ça, je vais l'introduire dans l'application, par contre, ce sera configurable par l'utilisateur ;)

pour le "Satellites: -", c'est le même bug que pour ceux qui ont la fenetre d'initialisation GPS qui reste affichée je pense. correction pour ce soir normallement.

Share this post


Link to post
Share on other sites
Merci Kartouche. Si je trouve le bout de code qui fait ça, je vais l'introduire dans l'application, par contre, ce sera configurable par l'utilisateur ;)

pour le "Satellites: -", c'est le même bug que pour ceux qui ont la fenetre d'initialisation GPS qui reste affichée je pense. correction pour ce soir normallement.

Regardes du côté de http://developer.android.com/reference/android/os/PowerManager.html et WakeLock

Share this post


Link to post
Share on other sites

Hello les copains !

Bon, je vous ai renvoyé une nouvelle version (voir le contenu du mail pour plus de détails).

Pour l'histoire de vitesse à la con, apparement y'a pas vraiment de solution. La seule chose que je peux faire éventuellement, c'est d'ajouter une préférence dans laquelle on mettrait "Ignorer les vitesses supérieures à 200km/h" par exemple (déja vu dans d'autres applis). Vous en pensez quoi ?

Share this post


Link to post
Share on other sites

Alors, je l'ai réutillisé sur un trajet un peu plus long, j'ai eu le bug des 400 et de brouettes plusieurs fois et plus fréquent qu'avant.

Je l'ai même eu 5 ou 6 fois de suite sur 100m.

La vitesse quand ça bug est tjs entre 461 et 466kmh si ça peut t'aider.

Et pour le mail que tu viens d'envoyer, il n'y a pas de pièces jointe avec ^^'

Share this post


Link to post
Share on other sites

m****, quel boulet .... je recommence ;)

Edit : comment vous êtes au taquet sur vos mails, encore pire que moi :D

Edited by Caballero

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...