Caballero

[Beta-Test] aTrip - Tableau de bord

Recommended Posts

Essayé en ville et sur autoroute, le GPS s'est fixé en 30 secondes, tout marche bien sur Hero (affichage des satellites, précision, vitesse...) mais pas sur l'Archos 5 IT (initialisation GPS infinie).

Sinon j'ai remarqué qu'entre 10 et 80km/h, la vitesse indiquée avait 5km/h de moins que la vitesse réelle, et qu'à partir de 80km/h c'est 10km/h de moins, bref :)

Le reste tout marchait bien, la vitesse s'actualise assez rapidement et n'est pas si loin de la réalité (sauf dans les 0-30km/h à mon avis).

Malheureusement (ou heureusement :p) je n'ai donc eu aucun bug à part pour l'Archos mais ce n'est pas vraiment fait pour.

Share this post


Link to post
Share on other sites

Merci pour ce très positif retour komanaki :)

La différence de vitesse que tu observes est du au fait que les compteurs voitures ne sont pas précis pour un sous. Et plus tu vas vite, plus la différence est élevée. Le GPS lui est dans le vrai ;)

Je vais me pencher sur l'archos, grace à ce que m'a proposé rafffel. Je verrais ça ce weekend, j'espère apporter un fix à ce bug.

Bonne nuit ;)

Share this post


Link to post
Share on other sites

Bon, nouveau retour sur mon Liquid avec la dernière version de aTripdemo.

D'ailleurs ça serait pas mal de différencier les versions que tu nous envoies histoire qu'on parle bien de la même (genre RCx ou Betay).

L'affichage fonctionne bien, le temps d'accroche des gps est toujours un peu long (même si le gps est activé depuis 10/15 minutes). Le nombre de satellites ne s'affiche plus (il me semble que c'est normal dans cette version, à confirmer) du coup c'est dommage de laisser la ligne correspondante (gain de place = caractères plus gros).

Sinon je viens de trouver un "bug" (pour autant que ça en soit un) :

  • mise en route de l'appli (avec l'option écran toujours allumé activée)
  • sortie du programme avec la touche "home"
  • modification du temps de mise en veille de l'écran (via appli : Toggle settings)
  • retour dans aTrip (via le menu déroulant du haut)
  • l'écran se met en veille au bout du temps défini entre-temps

Bon c'est un peu tordu comme démarche mais c'est juste pour signaler qu'apparemment si on lance une autre appli en parallèle et que celle-ci modifie les paramètres d'affichage ceux-ci "écrasent" les paramètres de aTrip (c'est peut-être inhérent à Android).

Il faudrait peut-être contrôler régulièrement que les paramètres d'affichage n'ont pas été modifiés par une application tierce.

Pour le reste, RAS : stable, peu gourmande en ressources, pas de "fuite mémoire" (la quantité utilisée ne varie pas) etc.

Super application. ;)

Share this post


Link to post
Share on other sites

Test de la dernière release sur N1, tjs des aberances au niveau de la vitesse.

Par contre nickel pr la veille

Share this post


Link to post
Share on other sites

merci les gars, je vais finaliser tout ça ce weekend, et comme proposé par yoyo, je vais suffixer les APK par le numéro de béta :)

@Kartouche: étrange. Normalement maintenant, l'accélération est calculé entre les 2 dernières vitesses. Si celle-ci est supérieure à 2G, alors, la vitesse est ignorée. un accélération de 2G = 0 à 72km/h en 1 seconde.

Share this post


Link to post
Share on other sites
Essayé en ville et sur autoroute, le GPS s'est fixé en 30 secondes, tout marche bien sur Hero (affichage des satellites, précision, vitesse...) mais pas sur l'Archos 5 IT (initialisation GPS infinie).

Sinon j'ai remarqué qu'entre 10 et 80km/h, la vitesse indiquée avait 5km/h de moins que la vitesse réelle, et qu'à partir de 80km/h c'est 10km/h de moins, bref :)

Le reste tout marchait bien, la vitesse s'actualise assez rapidement et n'est pas si loin de la réalité (sauf dans les 0-30km/h à mon avis).

Malheureusement (ou heureusement :p) je n'ai donc eu aucun bug à part pour l'Archos mais ce n'est pas vraiment fait pour.

Attention ne pas oublier que le compteur des voitures indique une vitesse supérieure à la vitesse réelle

Share this post


Link to post
Share on other sites

Ouep !

J'ai eu peur en lisant d'ailleurs....j'ai cru que l'appli appliquait les modifs de vitesse constructeur Oo

Donc elle affiche la vraie vitesse, c'est deja ca :D

Je test tout ca ce w-e, j'aurais un peu de route a faire autre que les bouchons toulousains^^

Share this post


Link to post
Share on other sites

Et bien j'ai ma vitesse normale puis un tiret puis la vitesse aberrante, a nouveau un tiret et a nouveau la vitesse. Normale

Share this post


Link to post
Share on other sites

Salut,

je viens ajouter la ptite note négative..

Ca ne marche toujours pas sur galaxy .

Pb d'initialisation du GPS .

PS : je précise, je suis sur la 2eme version....

Moi qui prends le TGV lundi, ca m'aurait fait triper :P

Share this post


Link to post
Share on other sites

Bah mince, je ne savais pas que les compteurs voitures étaient imprécis à ce point-là, j'espère que les radars sont aussi imprécis alors :p

C'est vrai que dans le TGV cela doit être marrant de savoir la vitesse, ou même suivre le trajet sur la carte...:D

Share this post


Link to post
Share on other sites

tout à l'heure, j'ai pris mon courage à 2 mains, et je suis passé devant un radar automatique limité 90km/h, et aTrip affichait 90 km/h ! syspens ... ça a pas flashé :D (mon compteur auto affichait environ 95-96km/h)

Edited by Caballero

Share this post


Link to post
Share on other sites

Bon, je pense que j'ai suffisemment de beta-testeurs pour aTrip maintenant.

Demain je code un peu, et je vous envoie une RC3 dans la journée. Reprise du beta test phase 3 à partir de lundi. J'espère une publication sur le Market fin de semaine prochaine grâce à vous tous ;)

Share this post


Link to post
Share on other sites

Release 3 de la béta envoyée il y a quelques minutes. En espérant que ce soit la dernière ;)

Bon test à tous !

Edit : ah oui au fait, j'ai oublié de vous dire dans le mail, mais j'ai changé ce qui est affiché pour la précision. Comme le faisait remarquer je sais plus qui, c'était pas top d'afficher la précision en mètres. Du coup maintenant, pour la précision, c'est marqué :

  • insuffisante
  • moyenne
  • bonne
  • excellente
Edited by Caballero

Share this post


Link to post
Share on other sites

Je viens de tester rapidement la nouvelle version depuis chez moi le nombre de satellites marche :) ;).

Pour le reste je verrai plus tard.

Share this post


Link to post
Share on other sites

Salut MontMiraille ;)

J'ai déja 11 béta-testeurs pour aTrip, et on a attaqué la dernière phase de tests depuis hier. Donc pour le moment, ça ira, je te remercie beaucoup.

Par contre, l'application va certainement évoluer régulièrement : ajout de fonctionnalités, etc ... Donc je t'ajoute dans la boucle pour les tests futurs ;)

Merci !

Share this post


Link to post
Share on other sites

Moi je vais avoir un soucis...mon kit de support(avec le branchement allume cigare etc) de la voiture m'a été volé donc je vais pas pouvoir la test en tout sécurité, dans l'immediat :/

J'ai un peu la haine qu'ils m'aient volé ca au garage auto mais bon...désolé vieux^^

Share this post


Link to post
Share on other sites

Bonjour

j'ai bien reçu la RC3 et je vous fait mes retours. Le logiciel marche niquel sur le Tattoo.

- Je ne sais pas si ca a été supprimé mais je ne vois pas du tout la ligne satellite au dessus de précision.

- J'ai toujours des pics de vitesse qui monte jusqu'à 460km/h

- L'initialisation GPS est tres rapide chez moi moins de 5 sec. J'ai meme perdu le signal sous un tunnel, ca s'est reinitialisé en 10 secondes apres etre sorti du tunnel.

- J'ai une différence de 4km/h entre le tel et mon compteur mais comme tu dis c'est normal vu que nos compteurs sont pas précis.

- Les couleurs d'arrieres plan et texte, c'est vraiment terrible pour avoir les memes couleurs que son tableau de bord.

- La précision de vitesse est niquel, j'ai essayé a basse vitesse (moins de 10km/h) voir si ca precise bien. Je compte tester l'appli en faisant du velo mais faudrait que j'y trouve un support exprès...

Voila

Share this post


Link to post
Share on other sites

Petit retour du test de la dernière version sur Nexus 1 :

Le nombre de satellites s'affiche bien.

La précision simplifiée (mauvaise / moyenne / bonne) est une bonne idée.

En revanche j'ai toujours mon bug de vitesses abérantes mais comme tu le dit tu as remplacé les changements de vitesse important par un "-"

Hors moi j'ai ma vitesse normale puis le "-" la vitesse exagérée, a nouveau un "-" et le retour a la vitesse normale.

Je pense donc que le "-" qui remplaces les accélérations trop importantes ne dure pas assez longtemps et que le logiciel crois que je suis de retour a une vitesse normale et m'affiche par conséquent le 400 et des brouettes kmh comme si c'était une vitesse normale.

Enfin j'ai constaté un autre bug sur la vitesse moyenne.

Exemple :

sur un trajet en train de 5 minutes j'ai une vitesse max de 77.4kmh et une vitesse moyenne qui a débuté vers les 200kmh (reset a 0 puis affichage a 200kmh sur une vitesse réelle qui ne devait pas dépasser les 30) et qui a commencer a baisser pour revenir vers une valeur normale le long du trajet.

Merci.

Share this post


Link to post
Share on other sites

bon, pour l'histoire de la vitesse, je viens de comprendre. Actuellement, je calcule l'accélération entre les 2 dernières vitesses connues, et si celle-ci est supérieur à 2.5G, j'ignore la vitesse. Visiblement pour vous, vous obtenez 3 fois de suite la vitesse de 460km/h, d'ou le "-", puis 460, puis "-". Je vais voir ce que je peux faire pour remédier à ça une bonne fois pour toute. Dans le doute, je sais pas si vous avez remarqué, mais dans le menu, j'ai ajouté une option pour faire un reset de la vitesse maximale ;)

Pour ce qui est de la vitesse moyenne, c'est le rapport entre la distance totale et la durée du parcours. Je ne comprends pas trop ce qui s'est passé de ton côté Kartouche (ton cas d'utilisation n'est pas super clair :| ). Tu as fait un reset global ? ou un reset de la vitesse max uniquement ?

Share this post


Link to post
Share on other sites

dis juste un truc comme ça est il possible d'utiliser la camera comme fond sur le logiciel?? un peu comme un tete haute

Share this post


Link to post
Share on other sites

@Panja : je pense que le nombre de satellites ne s'affiche pas chez toi car ta résolution d'écran est trop petite, et qu'il n'y a pas la place pour tout mettre ;)

@brutecore : super idée :) maintenant, je sais pas si techniquement c'est possible (si oui, ça risque d'être sacrément gourmand !)

Ce qui est sûr, c'est que je peux faire un affichage tête haute, en applicant un effet inversé à l'affichage. Ainsi, la vitesse apparaîtrait par reflet sur le pare brise par exemple !

Edited by Caballero

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.