Jump to content
tatsu

[TUTO] Retour ROM Stock du O2X avec NVflash ou Smartflash

Recommended Posts

Voila une copie du post de Le_PoUnT pour revenir en ROM stock ou débrické sont 2x (qu'il ne veut plus démarrer/Bloque sur l'image de démarrage) que je post dans la section tuto pour pouvoir le trouvé plus facilement

Pour SmartFlash le Tuto est au post 2

Pour rappel il s'agit de la ROM stock froyo v10b

Source

Traduction combinée de: http://android.modac...062-15-03-2011/ et de http://android.modac...s-links-active/

AVANT TOUT LIRE ATTENTIVEMENT CECI:

- Il s'agit d'une mise à jour forcée(non disponible par le menu normal) et donc à utiliser à vos risques et périls! Ni moi, ni Frandroid, ni l'auteur original du programme ne pourrait être tenu pour responsable des éventuels dommages causés à votre téléphone.

- Pensez à bien vérifier que le code MD5 du fichier que vous téléchargez correspond à celui donné dans le topic. Pour comparer le code MD5, utilisez ce programme: MST MD5

Le programme NVFlash ne fonctionne que sous Windows(non testé sous linux via Wine).

- NvFlash ROM v10b / 1300166062 (15/03/2011) - download - MD5: b17cb7fd3542b5d02baf49879a83acff

- NvFlash drivers - download - MD5: 2eab4f16fe1337a209a550ccd0be69c2

Méthode d'installation

- Téléchargez l'archive de la ROM fournie ci dessus et extrayez la dans un dossier.

- Téléchargez l'archive NVFlash fournie ci dessus et extrayez la dans un dossier différent.

Préparation du LG2X

- Eteignez votre LG2X, et enlevez la batterie.

- Maintenez appuyé les boutons de volume supérieur et inférieur et connectez via le cable USB votre LG2X à votre PC(Vous verrez votre téléphone démarrer sur le logo LG, mais vous entendrez un son dans les haut-parleur du PC signalant la connexion d'un périphérique).

- Sur l'écran du PC, vous allez avoir un message d'erreur disant que les pilotes n'ont pas pu être trouvés(c'est normal), il faut lui indiquer le chemin manuellement.

- Allez dans le gestionnaire de périphériques, et vérifiez la présence d'un nouveau périphérique s'appelant APX(avec une erreur associée). Si vous ne voyez pas ce périphérique, recommencez.

[Pour allez dans le gestionnaire de périphérique, sous XP/Vista/Seven, allez dans le poste de travail, puis faîtes un click droit>propriétés>Gestionnaire de périphériques]

Installation du pilote

- Faîtes un click droit sur APX

- Sélectionnez "Mettre à jour le pilote" puis "Rechercher un pilote sur mon ordinateur" puis "Parcourir".

- Rendez-vous dans le dossier NVFlash crée précédemment, puis faîtes Suivant.

- Vous allez avoir un message d'alerte vous indiquant que le pilote n'a pas été signé électroniquement par Microsoft, ignorez ce message et installez le pilote.

- Une fois l'installation du pilote effectuée, vérifiez sa présence dans la section "Contrôleur de bus USB" sous le nom "NVIDIA USB Boot-recovery driver for mobile devices"

- Si le périphérique n'apparait pas, recommencez depuis Préparation du LG2X

Installation de la ROM

- Déplacez vous dans le dossier de la ROM crée précédemment, puis double cliquez sur "flash.bat".

- Patientez le temps de l'installation

- Quand vous verrez l'écran de votre téléphone clignoter avec le logo LG, c'est que l'installation est terminée.

Edited by tatsu
  • Like 1

Share this post


Link to post
Share on other sites

Bonne idée tatsu de rééditer ce tuto, pour le déplacer dans la bonne rubrique, en voici un autre de Jemsy mais avec Smartflash.

Il était sous la ROM MODACO et il a voulu retourner sur sa ROM stock SFR v10C. En effectuant un restore de son backup via ClockworkMod.

Son Optimus plantait au démarrage sur le logo LG avec la barre de chargement...

Il n'avait donc pas d'autre moyen que d'utiliser Smartflash pour remettre sa ROM d'origine.

Voici la procédure qu'il a effectué (en fait c'est quasiment la même que le flash du baseband)

==========================================================

Procédure

  • D'abords vous téléchargez sur le forum de XDA la ROM que vous souhaitez flasher :
    Forum.xda ou sur ce topic : ROMS d'origine
  • Ensuite le lien pour les drivers Smartflash : ICI MD5: 70ebd70389c0e3011d4d6b4434f8458a
  • Et enfin, le lien pour le logiciel Smartflash : ICI MD5: fe350443518c98f7e089fac48fa36be3

  • Lancez le logiciel Smartflash.
  • Éteignez le téléphone
  • Vous pouvez ôter la batterie ou la laisser, mais bien chargée. (j'ai testé les deux méthodes sans problème)
  • Maintenez appuyé le bouton volume bas.
  • Branchez le câble USB sur le téléphone et sur le PC, toujours en maintenant le bouton volume bas appuyé.
    Un logo avec UPGRADE va apparaître sur le téléphone, vous pouvez relâcher le bouton volume bas.
  • Si vos pilotes ne sont pas installés, allez les chercher dans votre dossier "drivers".
  • Le logiciel Smartflash va reconnaître votre téléphone, vérifiez bien que la case du port COM soit remplie.
  • Allez dans l'onglet ROM COPY D/L.
  • Vérifiez que le NORMAL MODE soit coché.
  • Dans CP bin, vous metez le .fls que vous aurez obtenu, en dézippant le fichier firmware de la ROM.
  • Dans AP bin, vous metez le .bin que vous aurez obtenu, en dézippant le fichier firmware de la ROM.

ATTENTION !!! Vérifiez bien que ERASE CAL ne soit pas coché.

  • Cliquez sur START et attendre le flash, (il dure cinq bonnes minutes) dès que c'est vert, c'est fini

PS : Si vous avez laissé la batterie, le tel redémarre tout seul à la fin du flash.

Si vous l'avez enlevé, l'écran reste sur "UPGRADE", vous débranchez, remettez la batterie et ENJOY!

Edited by bibafranck
  • Like 3

Share this post


Link to post
Share on other sites

ben oui, :lol: les deux tiers des liens n'aboutissent plus, mais les mirrors fonctionnent et j'ai remarqué qu'il y en a de plus en plus...

Share this post


Link to post
Share on other sites

@Bibafranck tiens les liens si tu les as pas vu , remplace les avec ceux de ton post :P

  • SmartFlash P990 - DOWNLOAD (Mediafire Pro) - MD5: fe350443518c98f7e089fac48fa36be3
  • SmartFlash drivers - DOWNLOAD (Mediafire Pro) - MD5: 70ebd70389c0e3011d4d6b4434f8458a

Share this post


Link to post
Share on other sites

Ah c'était ceux-là qui était mort ? :emo_im_undecided: bon, voilà c'est fait. :lol:

Share this post


Link to post
Share on other sites

ils étaient sous Megaupload donc forcement ils sont mort :P

Share this post


Link to post
Share on other sites

Salut je n'ai que des .bin dans les 2 port de smartflash? je ne peus pas mettre de .fls

j'ai pris le lien du post 1 alors que celui du post 3 et plus gros, je tente.

Share this post


Link to post
Share on other sites

Pour les liens avec smartflash c'est tout dans le post 3 , rien ne correspond avec celui du post 1 ...

Share this post


Link to post
Share on other sites

Bonsoir à tous.

Je n'arrive pas à faire fonctionner NvFlash.

Je lance mon LG en pressant le bouton bas du volume. Et apparait sur l'écran du LG un écran qui dit:

"S/W Upgrade"

Mais mon pc ne repère pas le LG...

J'ai tout essayé.

Auriez-vous des idées???

Merci par avance.

Matthieu

Share this post


Link to post
Share on other sites

Re bonsoir les gens,

j'ai essayé ac les 2 boutons du volume enfoncés. Et toujours rien...

Mon LG n'est pas du tout détecté par mon PC

Je ne sais plus quoi faire....

Help please...

Edited by chacal33

Share this post


Link to post
Share on other sites

Essaye la deuxième méthode avec Smartflash au post #3 et lis bien le tuto.

Share this post


Link to post
Share on other sites

Salut.

Merci Bibafranck pour ton retour.

Cependant, toujours rien. J'ai beau tout essayé, mon téléphone n'est pas reconnu par mon PC. Rien ne se passe...

Je ne suis vraiment pas quoi faire.

Auriez-vous des idées?

Merci

Matthieu

Share this post


Link to post
Share on other sites

Un vrai cas d'école, il faudrait que tu puisse faire la manip sur un autre PC, pour voir si le problème vient du tel ou de ton ordinateur.

Share this post


Link to post
Share on other sites

Ton Pc le détecte pas mais est ce que dans le gestionnaire de périphérique tu vois un truc marqué APX avec un triangle jaune a coté?

Share this post


Link to post
Share on other sites

En fait, j'ai essayé avec 5 pc sous différents OS... Et aucune connection ne se fait.

Et quand je vais dans le gestionnaire de périphérique, rien de nouveau n'apparait...

Ca sent mauvais non?

En fait j'arrive à aller dans le CWM Recovery, mais la sauvegarde que j'avais faite ne peut pas être restaurée... (ça s'acharne...)

Y aurait-il moyen de relancer le téléphone à partir de là?

A noter que j'ai essayé de réinstaller une nouvelle ROM, ms rien. Et quand j'essaie de wipe davlik, rien ne se passe. Du coup,mon tél redémarre ac une espèce de MIUI qui s'éteint au bout de 15sec.

Share this post


Link to post
Share on other sites

Tu dois mal faire la manip , tu as bien enlever la batterie ? et tu maintient bien les bouton du volume avant et aprés l'avoir branché ?

Si tu as accés au recovery tu vas dans :

Mount and storage / Mount USB storage (en connectant ton cable USB ) peut etre que sa marchera , sinon si tu as une SD externe et accés au recovery suffit de mettre une ROM sur ta SD externe grace a un adaptateur MicroSD => USB (ou lecteur de carte si tu en a un sur ton pc ) et aprés tu vas dans le recovery et tu flash la ROM

Share this post


Link to post
Share on other sites

Pourtant j'ai refait les différentes manip une 20aine de fois en suivant les tutos point par point.

Mais rien...

Mount USB => error

J'ai essayé avec plusieurs ROMs. Ca les installe. Mais ça plante derrière...

Share this post


Link to post
Share on other sites

J'ai eu récemment le problème du flash d'une miui qui bootait le phone mais pendant 30 sec avant de rebooter (juste le temps de taper le code pin en fait) mais j'ai réussi à reflasher un truc propre.

Si ton pc ne reconnait pas le phone mais que t'as encore accès au recovery, met la rom direct sur la sd externe avec un adaptateur. T'était sous quelle rom avant le bug et t'essayais de flasher quoi?

Pour ma part pour passer de miui el liberator à miui france j'ai eu un souci similaire. J'ai réglé le problème en faisant tout les wipes possibles, un coup de backtoext3, réinstallation d'une cm7 et ensuite réinstallation d'une miui france. Le problème a été réglé.

A la base je voulais reflasher une stock au lieu de la cm7 mais flemme de remettre la main sur mon nandroid du début. Alors les puristes trouveront peut être que la méthode est foireuse mais en tout cas ça a marché.

Share this post


Link to post
Share on other sites

A partir de quel ROM tu as bug ? (si c'est une ROM en Ext4 il faudrait flasher le backtoext3 avant )

Je viens d'essayer pour voir si mon tel était toujours détécté donc j'ai enlever la batterie , appuyé sur les boutons du volume et connecté mon cable USB , et il a était trouvé directement (J'suis sous Windows 7 64bits)

Ah et sous quel recovery tu es ?

Sinon je viens de penser , fait une vidéo pour voir si tu oublie rien (tu me l'envoie et je te le dirais)

Edit : Youps j'vien de voir ton message elfminus , pour passer de la Miui Liberator a la Miui france je sais pas si tu as essayé mais normalement le flash du BackToExt3 suffit

Edited by tatsu

Share this post


Link to post
Share on other sites

Fait un backtoext3 puis flash une rom, sa devrait marcher ...

Share this post


Link to post
Share on other sites

Oui Tatsu surement mais pour moi ça fonctionnait pas, la rom buggait. Je sais pas pourquoi. J'avais pas le temps de faire des tests jai donc entrepris de remettre le téléphone en propre avec une stock. Je me rappelais pas que j'avais plus de rom stock sur ma sd donc j'ai reflashé une cm7 histoire d'avoir un truc différent en ext3 d'installé. Et puis du coup la réinstallation a fonctionné.

Je suis pas un grand technicien mais c'est comme si le flash de la cm7 avait nettoyé le bug que j'avais entre les deux versions de miui. Sachant que sur les derniers jours mon phone était très instable avant ça. J'avais flashé un nouveau BB aussi genre 20 min avant.

Share this post


Link to post
Share on other sites

Salut à tous,

J'ai réussi à relancer la machine. En fait j'ai eu le même problème que Elfminus. En retournant sous MIUI, ça a buggé. Probablement ma faute. A tous les coups, je n'ai pas fait les bons wipes.

Donc, j'ai téléchargé une ROM firmware SFR. J'ai wipé tout ce que j'ai pu, un backtoext3 et flashage ROM de base. Et hop hop hop, un lg2x comme neuf.

Merci pour vos éléments de réponse en tous les cas les LG2Xiens!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...