Jump to content

[Présentation & Tutorial Custom son X10 mini pro]


Recommended Posts

B)

Edited by goosoo
Link to comment
Share on other sites

B)

Edited by goosoo
Link to comment
Share on other sites

Y a juste une ligne que je ne capte pas, par contre c'est celle ci:

mount -o rw,remount /dev/block/mtdblock3 /system

Avec RootExplorer il suffirait juste de clicker sur RO/RW ? Et de le mettre sur RW?

Si c'est ce que je comprends, c'est aussi vite fait avec RootExplorer non ?

Link to comment
Share on other sites

B)

Edited by goosoo
Link to comment
Share on other sites

@Devilo

Quel est donc le rapport entre le framework-res.apk et le market !!!

Le fait de remplacer le framework-res.apk, n'a, à mon avis, aucune incidence sur le fait que ton com.vending.apk se crash !

Je viens de faire un hard reset SEUS, je télécharge astro sur le market et l'installe sans problème.

Je root le téléphone via l'application prévue pour.

Reboot, puis adb shell, là je remplace framework-res.apk par "black-framework-res.rar" trouvé sur xda.

Reboot, mon téléphone est noir mais toujours ce problème de com.vending.apk...

Je n'ai RIEN fait d'autre !

Je décide donc de restaurer mon Framework-res.apk original préalablement sauvegardé via adb.

Pas de problème, mon téléphone redémarre en bleu mais le market crash toujours...

C'est un truck de fou à ne rien y comprendre '''

Peut être les nouvelles versions ne marchent plus pour les mini dont le firmware est 1.1.A.0.8 ?

Quelqu'un pourrais m'envoyer son framework-res.apk modifié et qui marche chez lui sur son mini que je l'essaye ?

Edited by Devilo
Link to comment
Share on other sites

Bon j'ai réussi à mettre le fameux thème

Par contre impossible avec ADB, j'ai dû passer par RootExplorer, ADB ne voulais pas du su ???

Il te faut aller dans permissions (l'apk) et tapé su dans CMD, ca te demandera une permissions, tu acceptes, et normalement c'est bon

@goosoo

C'est bon pour le clavier noir, ca finit le Thème. Une dernière question, la font que utilise c'est laquelle ? Et comment on change sa font ?

Edited by SkUizZz
Link to comment
Share on other sites

B)

Edited by goosoo
Link to comment
Share on other sites

Alors pour mettre le thème Noir, j'ai eu un soucis avec Root Explorer un gros Force Close lors de l'application des droits ... un peu embêtant.

Donc me suis dis on va retester ADB et là miracle il a voulu de mon SU ...

En fait je ne devais pas avoir redemarrer le PC (le PC de ma femme avec un dual-boot 7) c'est vrai que chez billou quand on installe des drivers faut penser à rebooter le bonzin, plus l'habitude, ça n'existe pas sous linux.

Sinon SkUizZz c'est sympa, mais ton explication n'aide pas en fait ... vu que le soucis ne venait pas de ça ...

Par contre est ce normal que lors de la commande su il y est un temps de réponse si long ??? il me répond le # au moins une bonne demi minute après la commande ???

Soi le superuser du X10 est lent soi le script du shell de exploid est mal fichue ?

Link to comment
Share on other sites

Bonjour à tous !

Tout d'abord merci Clémence pour la peine que tu t'es donné pour le tuto, c'est très sympa.

Néanmoins si je poste un message c'est surtout pour dire que j'ai du arréter à partir de l'installation du thème !

En effet, autant le début du tuto est carrément accessible au néophyte, autant à partir du thème ça devient carrément flou :s

- le lien pour le thème gris renvoit sur un forum où sont téléchargeable 3 fichiers... on prend lequel/lesquelles ?

- Ou met on le fichier télécharger pour le thème ?

- Les lignes à "rentrer", on les mets où ?

Bref, en cherchant vite fait dans les réponses, j'ai pu trouvé certaines réponse (le fichier frameworks-res.apk pour le thème, il faut rentrer les "commande" dans un invité de commande : démarrer>accessoire>invite de commande), mais j'ai du abandonné, car ce n'est toujours pas clair ! :(

En prenant mon courage à demain, j'ai reussit à continuer de manière à voir qu'il fallait mettre le frameworks dans le dossier exploid_mini, puis rentrer les commande de goosoo (push machin chose) pour le mettre dans le telephone, mais après j'ai encore un problème de mount:operation not permitted.

P'tète que la solution serait d'être un peu plus précis dans le tuto ? Ou en tout cas de préciser que le tuto est à réserver aux habituer de la bidouille ^^

Bref, je part à la recherche d'un autre tutos pour le moment mais reste présent si vous pouvez m'aider !

Merci de m'avoir lu.

Link to comment
Share on other sites

B)

Edited by goosoo
Link to comment
Share on other sites

Hey, t'emballe pas hein, je disais pas ça méchamment ! :s

Oui, j'ai lu l'intégralité des postes, observé que plusieurs précisions avaient été apporté, que d'autres utilisateurs avaient eu leur lot de problème etc... si j'en suis arrivé à ce stade, c'est surtout par découragement (et par peur de voir mon mini "brické" comme expliqué justement dans un des posts.)

Bref, vraiment, ça serait dommage de mal prendre tout ça, alors que mon but était simplement de dire que je me suis sentit pomé et je donné mon ressentit pour chercher du coup à améliorer le tuto ; je me suis peut-être mal exprimé, et j'en suis désolé ! (C'est vrai qu'après relecture de mon post, la remarque sur le fait de modifier le tuto pouvait avoir l'air un peu "enfant gaté", c'était pas top ! Navré)

Sur ce bonne soirée, et je le répète : merci pour ce tuto, c'est très sympa !

Maintenant p'tète que c'est moi qui ne suis pas prêts à mettre les mains dans le cambouis, je suis près à l'admettre, qui sait ! ^^

Mais si je m'exprime c'est qu'au fond je ressens un "dommage", car je m'étais sentit "bien" accompagné grâce au tuto, et puis d'un coup, pouf, j'ai l'impression qu'on me dit " allé démerde toi ! " :( Dommage quoi, c'est ce que je voulais dire en fait.

Sans rancune Goosoo ?

EDIT : par mesure de précaution, je suis repartit à la recherche du numéro 37. Et justement, je l'ai lu, et me suis découragé à l'entrée de cette étape : " Monter votre partition system en rw car elle est en ro, avec la commande suivante:

mount -o rw,remount /dev/block/mtdblock0 /system " ; c'est là que j'ai eu le mount -o rw,remount/not permitted.

Edited by Olve
Link to comment
Share on other sites

B)

Edited by goosoo
Link to comment
Share on other sites

Ecoute, je vais reprendre la démarche plus attentivement dans ce cas là, et te faire confiance.

Je suis déjà passé par une période de bidouille, à la sortie de la PSP, puis pour tester linux et enfin via mon premier Cowon D2 (baladeur audio), et j'ai eu mes moment de patience, mes longues recherches sur les firmwares et mes pétages de plombs à me taper la tête contre les murs ^^

J'me suis p'tète ramoli avec le temps et j'ai perdu patience !

J'ai été un peu " brusque " dans mes propos et je tiens à m'en excuser.

> Pour la p'tite histoire il me semble néanmoins avoir rooté mon Mini (via universal root), désinstallé les applis (via titanium backup) et mit mon mini en "charge", mode débuggage usb. J'ai du oublié quelque chose... j're-essayerais et ferais un retour.

Bonne soirée.

Link to comment
Share on other sites

B)

Edited by goosoo
Link to comment
Share on other sites

D'après ce que j'ai comprit et ce que je sais, c'est la commande su, super-utilisateur, qui permet d'acquérir les droits (lecture, écriture et exécution) et par là de déclarer que le mini est " rooté " ( C'est en fait ce que je faisais - en plus d'avoir rooté depuis UniversalRoot) : comme précisé, j'avais en effet lu toute la procédure, et pas sauté à la partie qui m'intéressait ;)

Par contre, du coup, j'suis pas sûr de voir où tu veux en venir quand tu dis, goosoo :

et c'est su qui te le permet et à condition que tu ai fait ce qu'il fallait pour pouvoir être root sur ton mini !

Les conditions, tu veux dire que c'est débogage USB coché, mode [charge], et source inconnues acceptées ?

Au passage, oui, j'avais autoriser les sources inconnues ^^ (à l'occas' du dl d'une app en dehors du market).

Je retente ce soir l'expérience.

Edited by Olve
Link to comment
Share on other sites

B)v

Edited by goosoo
Link to comment
Share on other sites

Connecté en mode charge, USB debugage cochée, source inconnue cochée.

Microsoft Windows [version 6.1.7600]

Copyright © 2009 Microsoft Corporation. Tous droits réservés.

C:\Users\Olve>cd c:/exploid_x10mini

c:\exploid_x10mini>adb push framework-res.apk /sdcard

1922 KB/s (7215406 bytes in 3.665s)

c:\exploid_x10mini>adb shell

$ su

su

su: permission denied

$

:(

EDIT : J'ai essayé de réutiliser universal root, en même temps que j'ai fais ces commandes, ça ne change rien.

J'ai aussi redemarré le téléphone et mon pc. J'ai aussi changé de port usb.

Edited by Olve
Link to comment
Share on other sites

Olve,

Logiquement t'as tes applications tu as une application du nom de : Permissions

Branche ton téléphone tout ça, avant de taper "su" va dans l'application permission, tape su sur ton ordi, normalement si tout ce passe bien une notification apparaît. Tu clique sur accepter, et voilà

Link to comment
Share on other sites

B)

Edited by goosoo
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...