Jump to content

[07.10.10][Tutoriel] Installer une Rom Nu/Custom (Root,GoldCard) + FAQ


Wiz ^^

Recommended Posts

J'ai suivi la partie c) du tutoriel en première page, c'est à dire j'ai :

- installer Universal Androot (puis lancé et cliqué sur 'Go root')

- Télécharger et installer RomManager, puis cliquez sur 'Sauvegarde la Rom actuelle'

- Ensuite j'ai cliqué sur 'Flasher le recovery Clockworkmod'

- Puis intaller une rom depuis la carte SD, je sélectionne mon .zip, et j'en arrive au problème décris ci-dessus (j'ai essayé avec plusieurs Rom et toujours le même problème, en attendant 40min à chaque fois)

Qu'appelles-tu full wipe ? (je l'ai surement pas fait, cela ne me dit rien)

Edited by ikaa
Link to comment
Share on other sites

Arf ! Je ne connais pas très bien les nouvelles méthodes de root ... Moi je suis passé par la méthode de goldcard (la seule de fiable à 1OO%)

Une fois que tu as installé ta rom sur la racine de ta carte SD, est ce que tu as besoin de booter sur le recovery ? C'est à dire, l'étape 1 de ce tuto (pour le flashage).

Sinon le full wipe, c'est la suppression de toute les données du téléphone, qui est nécessaire avant le flashage de n'importe quelle rom. Mais après je sais que c'est valable pour la méthode classique avec le recovery donc je ne sais pas si l'on fait ça aussi pour la méthode que tu as utilisé.

Sinon je te conseil de faire la méthode avec goldcard et compagnie, elle est plus longue mais elle marche parfaitement.

Edited by Guest
Link to comment
Share on other sites

Bonjour,

Question bête mais, j'ai voulu installer une rom(chronos) avec rom manager, mais au reboot je reste sur l'écran avec affiché 'Chronos' avec l'effet de lumière qui défile dessus, j'ai laissé 50min comme sa, il ne se passait rien alors j'ai restauré.

Il faut laissé le téléphone combien de temps pour que [color=red]sa[/color] fonctionne ?

Si cela dure plus de 30mn, je te conseille de faire un hard reboot (cad virer la batterie, puis la remettre).

Ensuite re-télécharge la version de la rom que tu souhaites installer, et reflashe avec les reboot entre.

Comme je l'ai déjà écrit à maintes reprises, je vous conseille la version normale avec goldcard plutôt qu'un root avec rom manager ou bien universal androot.

Donc, si tu souhaites avoir un root stable et efficace, utilise la version normale.

Edited by philos64
Link to comment
Share on other sites

J'ai suivi la partie c) du tutoriel en première page, c'est à dire j'ai :

- installer Universal Androot (puis lancé et cliqué sur 'Go root')

Qu'appelles-tu full wipe ? (je l'ai surement pas fait, cela ne me dit rien)

Normalement dans tous Recovery (Clockworkmod ou Amon-Ra => que je connais mieux) il y a un menu:

Wipe => as tu cliques

et ensuite tu as un sous menu => wipe dalvik cache et d'autres.

Il faut tous les faire avant de flasher une rom (surtout une 2.2.1)

Un fois que tous différents wipe effectués tu peux flasher ta rom.

Link to comment
Share on other sites

Oui benoitkmn, quand sa bloque je suis obligé d'enlever la batterie et restaurer ma sauvegarde par le recovery.

Question sans doute stupide, mais le wipe ne va pas effacer ma sauvegarde de rom original?(je n'ai pas besoin de copier cette sauvegarde sur lordi par exemple ?)

Je vais tenter comme tu as di philos, sinon j'essaierai la version normale.

Link to comment
Share on other sites

Finalement dans Rom Manager, il fallait juste cocher 'Effacer data et cache' (sa doit être le 'wipe' en question) pour que tout fonctionne parfaitement, merci à vous :)

Edit: J'ai quand même une petite question, savez vous ou sont mis les sauvegarde dans la carte sd ?

Edited by ikaa
Link to comment
Share on other sites

@ikaa

Dans un dossier qui s'appelle "Nandroid" ensuite un dossier au nom commençant par "HT9 3 lettres et 6 chiffres"

et dans ce dossier tu as le recovery repéré par un groupe de 3 ou 4 lettres puis annéemoisjour-heure

exemple => BDES - 20102410-2055

Edited by philos64
Link to comment
Share on other sites

Finalement dans Rom Manager, il fallait juste cocher 'Effacer data et cache' (sa doit être le 'wipe' en question) pour que tout fonctionne parfaitement, merci à vous :)

Edit: J'ai quand même une petite question, savez vous ou sont mis les sauvegarde dans la carte sd ?

Voilà c'est ça le wipe ! :)

Link to comment
Share on other sites

Bonjour,

Est-que avec mon tèl nu je dois suivre ce tuto pour pouvoir passer de la 2.1 officiel pour revenir à la 1.5 officiel, cela fait un moment que je cherche et que je bloque sur toutes les méthodes essayée? Je n'ai jamais eu besoin de Goldcard puisque mon tèl a été acheté hors pack opérateur.

Merci pour votre réponse qui je l'espère sera assez rapide.

Link to comment
Share on other sites

@armahero

Ce que tu as écrit est faux.

Je n'ai jamais eu besoin de Goldcard puisque mon tèl a été acheté hors pack opérateur.

L'opérateur n'a rien à voir avec la Goldcard. Le root via la goldcard est effectué en fonction de la version de ta rom originelle.

Je crois que tu n'as pas bien lu tout le tuto, et si tu l'as fait, tu as du sauter des chapitres.

A mon avis reprends tout à zéro en lisant correctement les consignes qui ont été rédigées par Maitre Wiz^^, et effetue la version la version normale via goldcard, qui est beaucoup stable que les autres (Rom Manager et autres)

Je te donne mon avis, et je pense que tu n'as pas respectés ce qui est écrit.

Lis le tuto et refais tout correctement, ensuite tu pourras revenir.

Link to comment
Share on other sites

Bonjour j'ai une question. J'ai suivi la méthode RomManager, j'ai flasher le recovery clockworkmod, j'ai cliquer sur "installer une ROM a partir de la sd-card", j'ai effacer les données (full wipe). Là le téléphone à rebooter, javai à l'écran l'image d'un Hero derrière un panneau triangulaire rouge avec un point d'exclamation.

Soit, je me suis dit que c'était le recovery mod, donc j'ai fait Volume + Power, ce qui m'a amener sur un espèce de recovery avec 4 options:

*Reboot System Now

*Update sdcard:zip.file

*Wipe data

*Wipe cache.

Et en bas de l'écran il y'avait marqué : "E: can't open/cache/recovery/command"

Donc j'ai redémarré le téléphone et je suis revenu sur ma rom par défaut, identique à celle d'il y a 5 min!

Qu'est-ce qu'il faut faire ?

Link to comment
Share on other sites

Hé bien tu ne dois pas avoir flashé ta rom alors, si tu te retrouve dans le même état ! As tu encore toutes tes sauvegardes, applications, ... ?

Sinon si tu souhaites flasher le mieux reste toujours la goldcard ! On voit de plus en plus de problèmes avec les soft root, même si l'autre méthode semble compliqué, elle est facile si l'on suit bien le tuto.

Link to comment
Share on other sites

Ouai je sais mais ce n'était pas ça.

La c'est bon tout est nikel.

Enfaite c'est beaucoup moins compliqué qu'il n'y parait, une fois qu'on à compris le truc ça va tout seul.

=> Copier custom rom .zip sur la SD

=> Nandroid backup

=> Full Wipe

=> flash custom rom

=> let's started ;)

Le seul problème que j'ai eu était avec le recovery clockworkmod qui ne s'était pas flasher correctement, et donc je n'avais accès qu'au recovery de base android.

Edited by Ar0w4n4
Link to comment
Share on other sites

Avec l'invite de commandes de Windows j'ai droit à ça :

C:\Users\Alexandre\Desktop\android-sdk-windows\tools>adb shell

* daemon not running. starting it now on port 5037 *

* daemon started successfully *

error: device not found

C:\Users\Alexandre\Desktop\android-sdk-windows\tools>cat /sys/class/mmc_host/mmc

1/mmc1:*/cid

'cat' n'est pas reconnu en tant que commande interne

ou externe, un programme exécutable ou un fichier de commandes.

Que faire ?

Je suis sous Vista... merci.

Link to comment
Share on other sites

Je suis finalement passé à Cronos que je trouve mieux personnellement mais je me demandais si je pouvais formater ma sd et la partitionner en ext3 (pour utiliser a2sd) sans devoir réinstaller Cronos ?

OUi, tu vas dans ton recovery, et tu as un menu format SD. Après tu n'as qu'à suivre.

Link to comment
Share on other sites

Que faire ?

Je suis sous Vista... merci.

Désinstalle tout absolument et recommence en suivant très précisément les consignes qui te sont donnés dans le tuto.

Il est impossible de savoir ce que tu as fais correctement ou non.

Link to comment
Share on other sites

Désinstalle tout absolument et recommence en suivant très précisément les consignes qui te sont donnés dans le tuto.

Il est impossible de savoir ce que tu as fais correctement ou non.

Je l'ai redémarré et ça a marché ce coup-ci... allez comprendre.

Merci à toi.

Edited by Sarti
Link to comment
Share on other sites

  • 2 weeks later...

bonsoir, j'ai quelque souci :x

je suis sous linux, et au moment de tapé

./adb-linux shell reboot bootloader

j'ai une réponse qui est

error: device not found

(téléphone pourtant bien en debug et mit sur mode "lecteur de disque")

que-ce qui pèche doc :P ? (le sudo ne change rien)

(en tout cas merci pour se super tuto qui je doit le reconnaître est complet :x (bien que je n'arrive pas xD)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...