Jump to content

[Résolu] Ca chauffe...fuite de batterie


Recommended Posts

Bonjour, Depuis quelques jours mon One chauffe un peu plus que de raison, en tout cas plus que d'habitude... Dans la poche avant du jean, je sens sa chaleur ! Avec Android Assistant, il me note 38°C donc c'est pas énorme mais suffisant pour que je le remarque en tout cas. De plus, j'ai une perte d'autonomie assez conséquente. Cette dernière semaine, il s'est vidé deux fois tout seul en fin de journée jusqu'a épuisement de la batterie alors que je ne l'utilisais pas ! D'habitude, je finissais la journée avec au moins 20% de batterie. Je suis parti à 100% ce matin, pas fait grand chose dessus et je suis à 19% à 13h30 ! Je n'ai rien changé à mes habitudes, le WiFi est toujours activé, pas installé d'appli ces derniers temps, rien qui justifie ce changement de comportement (même si je sais que le WiFI permanent draine de la batterie, il y a une semane je tenais tout de même largement la journée). Dans paramètres->alimentation->utilisation, j'ai systeme android à 52%, wordfeud à 12%, candy crush à 7% et ensuite ca diminue fortement donc pas d'appli particulière qui bouffe tout... J'ai l'économie d'énergie activée depuis toujours. J'ai déjà fait plusieurs redémarrage au cas ou...non résolu... Comment surveiller ou détecter un éventuel coupable ? Merci.

 

Edit :

Pour plus de détails vous pouvez consulter le post en entier sinon en résumé, j'ai résolu mon problème grâce à 2 applis :

- BetterBatteryStat (que l'on peut trouver aussi sur xda en cherchant bien...)

- Gsam Battery Monitor

 

Le premier permet de voir les wakelocks éventuels, une recherche Google peut donner des indications sur le type de wakelock : les noms sont pas très clairs, mais au moins on connait le nom du responsable !

Le second peut suffire tout seul car dans la catégorie "Util. Application" on peut voir qui pompe le plus de % de batterie, si c'est une application particulière il sera facile de vider le cache et les data ou bien de carrément la réinstaller pour voir si le problème est corrigé.

 

Screenshot_2013-10-03-10-31-32.png

 

Screenshot_2013-10-03-10-31-40.png

Edited by fabrice91
Link to comment
Share on other sites

Rom stock officielle, à jour OTA, sur HTC Nu non rooté non bootloadé

Salut Fabrice,

A tu pensé à regarder du côté de la 4G si active ? Le fait d'avoir la 4G activé m'a toujours chauffé le téléphone. Il se peut que tu soit dans un endroit où l'accroche réseau ne soit pas optimale pour que le téléphone -j'imagine- cherche à vouloir garder la connexion.

Tu a mentionné également le systeme android à 52%, regarde en tapotant dessus ce qui peut te déclencher des wakelock.

Link to comment
Share on other sites

Salut Fabrice,

A tu pensé à regarder du côté de la 4G si active ? Le fait d'avoir la 4G activé m'a toujours chauffé le téléphone. Il se peut que tu soit dans un endroit où l'accroche réseau ne soit pas optimale pour que le téléphone -j'imagine- cherche à vouloir garder la connexion.

Tu a mentionné également le systeme android à 52%, regarde en tapotant dessus ce qui peut te déclencher des wakelock.

Pour la 4G, je suis en 2G/3G/4G auto dans paramètres->données mobiles->mode reseau...

Je pense être comme ça depuis toujours...

Mais je n'ai pas de forfait 4G...

Pour l'endroit et l'accroche, je suis à mon boulot, une journée "type" comme beaucoup depuis plusieurs semaines...

En plus au boulot je suis en WiFi en permanence...mais pareil, je dirais "comme d'habitude" depuis des semaines, je n'ai rien changé de ce côté là...

En tapotant sur "system android" j'arrive à une liste de paquets mais je vais pas la retranscrire intégralement ici !

Et comme il n'y a pas de valeurs associées à cette liste, on ne sait pas laquelle a le plus d'importance...

La première c'est BrcmBluetoothServices mais mon bluetooth est désactivé, je l'utilise très rarement, en tout cas même pas depuis que j'ai redémarré le tel !

Pis HtcBackupReset, HTC Car GPS, System android, com.qualcom.privinit, Input Devices etc...

Je viens de m'installer Better Battery Stat, je charge cette nuit et je vois sur l'utilisation de demain...

Edited by fabrice91
Link to comment
Share on other sites

Ce matin, je pars avec le One chargé à fond (100%).

Une heure plus tard je suis à 90% en ayant rien fait du tout...

Je jette un oeil à BetterBatteryStats sur les wakelocks : je trouve msm_hsic_host qui a sollicité la batterie pendant 40 mn sur 1 heure !

Apparemment un process concernant la localisation.

Depuis que je suis arrivé au boulot, pas de chauffe ce matin...

A suivre...

Link to comment
Share on other sites

Si tu a Google Now d'activé, désactive le pour voir.

 

Et comment vérifier ?

J'ai lancé l'appli nommée Google, c'est Google Now qui se lance, il y a un petit tuto avec plusieurs "suivant" et à la fin il demande si on veut se connecter, je réponds non donc je devrais pas être connecté. Je crois du coup ne jamais l'avoir activé.

Un raccourci qq part pour vérifier qu'il est désactivé ???

Link to comment
Share on other sites

tu va dessus et tu tapote les 3 petits points en bas à droite, et tu désactive google now :)

Ok, c'était bien désactivé...

Voici mon screenshot d'hier.

Sur 4h30 après la charge, j'ai perdu 13% de batterie par heure et msm.hsic.host a tiré dessus pendant presque 2h soit 40% du temps...

Edited by fabrice91
Link to comment
Share on other sites

tu n'utilise pas "beautifull widget" a tout hasard?

car j'avais eu un soucis avec lui sur un autre tel, en fait il ne réussissait pas a me localiser et la météo me bouffait tout la batterie du coup.

 

et par la même occasion:

qu'as-tu comme réglage GPS?

s'il est désactivé, active le car autant une appli galère sans lui et te bouffe la batterie aussi.

Link to comment
Share on other sites

tu n'utilise pas "beautifull widget" a tout hasard?

Non, j'ai WidgetLocker Lockscreen par contre

car j'avais eu un soucis avec lui sur un autre tel, en fait il ne réussissait pas a me localiser et la météo me bouffait tout la batterie du coup.

Ah non mais j'ai pas la météo avec mon locker...

Par contre j'ai installé Yahoo Météo mais il y a un moment déjà, plusieurs semaines, je n'avais pas de souci avec...

et par la même occasion:

qu'as-tu comme réglage GPS?

s'il est désactivé, active le car autant une appli galère sans lui et te bouffe la batterie aussi.

Oui, j'ai le GPS désactivé et je désactive en général la localisation quand je peux dans les applis donc à part Waze, je dois pas avoir beaucoup de demande d'activation du GPS. Et puis si c'est lui qui posait problème, je le verrais dans les WakeLocks de BetterBatteryStats, non ?

Link to comment
Share on other sites

J'ai trouvé un deuxième wakelock :

wlan_rx_wake : 62% du temps depuis la dernière charge (presque 5h sur 8h !)

A priori c'est du au routeur WiFi du réseau sur lequel je me connecte qui envoi en permanence des signaux aux appareils qui y sont connectés, du coup il réveille sans cesse le HTC pour vérifier son adresse IP. Une solution préconisée serait de fixer l'adresse IP du HTC en statique sur le routeur en correspondance avec la MAC adresse de manière à ce que le routeur cesse d'envoyer des requêtes au HTC.

Bon comme au boulot j'ai la main sur le routeur, je vais tester ça ;-)

Mais ce problème n'existait pas "avant" et j'ai rien changé sur le routeur WiFi du boulot donc c'est bizarre.

Et je garde en tête aussi le msm_hsic_hosts qui a disparu, peut être est-ce un autre problème lorsque je ne suis pas au boulot...à priori ce wakelock serait du à la mauvaise gestion du réseau 3G par le noyau, mais si c'était ça je ne serais pas le seul impacté...

Et finalement celait expliquerait pourquoi je n'ai pas les mêmes wakelocks au boulot et ailleurs :

Au boulot -> WiFi -> wakelock wlan_rx_wake

Exterieur -> 3G -> wakelock msm_hsic_hosts

Maison -> WiFi maison -> wakelock ??? à surveiller...

Edited by fabrice91
Link to comment
Share on other sites

C'est bizzare parceque msm_hsic_hosts peut aussi correspondre au wifi (connexion).

Regarde dans tes paramètres wifi :

Paramètres>Wifi> les 3 points en haut à droite > Avancés> Garder le wifi activé en veille > Toujours

Plage de fréquences Wi-fi > Automatique

Meilleure performance wifi > Décoché

 

Sur Battery Stats Plus que j'utilise j'ai un onglet qui me dit directement "Wake usage" et me donne les applications directement (genre syncro de contacts etc...), t'a pas la même option par hasard sur ton appli que tu utilise ? Ca pourrais aider.

Edited by Malibu06
Link to comment
Share on other sites

 

C'est bizzare parceque msm_hsic_hosts peut aussi correspondre au wifi (connexion).

Regarde dans tes paramètres wifi :

Paramètres>Wifi> les 3 points en haut à droite > Avancés> Garder le wifi activé en veille > Toujours

Plage de fréquences Wi-fi > Automatique

Meilleure performance wifi > Décoché

Sur Battery Stats Plus que j'utilise j'ai un onglet qui me dit directement "Wake usage" et me donne les applications directement (genre syncro de contacts etc...), t'a pas la même option par hasard sur ton appli que tu utilise ? Ca pourrais aider.

J'ai changé aujourd'hui, j'ai mis sur "automatique" à la place de "toujours" que j'avais auparavant...

Dans BBS j'ai un onglet "Screen Off" qui peut correspondre à ton "Wake Usage" ?

Ps: désolé mon éditeur dans Firefox me rajoute des & et des > à tire larigot !!!

Edited by fabrice91
Link to comment
Share on other sites

Bon, toujours ma batterie qui se vide à grande vitesse et ce wakelock "wlan_rx_wake" qui me prend 40% (6h30 sur 17h).

Je n'arrive pas à le relire à quoi que ce soit, je vais voir ce qeek end, en dehors du WiFi du boulot si ça change ou pas...

Edited by fabrice91
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...