marcdau

[ROM FROYO] J("a)so.nExo [SENSE ESPRESSO] v0.22 v0.3 d'ici peu [22/07]

Recommended Posts

Du coup Raphyo tu pourra nous dire quelle rom tu comptes réinstaller stp; ca nous pourrait servir.

Merci.

Edited by Kameo

Share this post


Link to post
Share on other sites

La je mets la setrom 4 avec son kernel uv.

Jamais été déçu par cette rom. Alors ouai il lui manque des petites choses (la led fonctionne pas tout à fait par exemple), mais question batterie, j'ai pas trouvé mieux.

Share this post


Link to post
Share on other sites

Ok merci pour l'info.

Par contre quelqu'un pourrait-il mettre à jour le Lexique sur le wiki car des expressions manquent et qui sont assez difficile à comprendre quand on débarque sur la scene Android.

UV = UnderVolt, sous volté.

OC = OverClocked, overcloqué... :D

Deodexed = Certains fichiers de la rom ou la rom elle-même ont été patché/hacké si j'ai bien compris pour rajouter des fonctions.

Share this post


Link to post
Share on other sites

Non Odex c'est beaucoup plus compliqué, la version très résumée c'est que :

Une application odexée est une application qui a été compilée par androd lui-même, enfin la Dalvik Virtual Machine (Dalvik EXecutable) ce qui a pour conséquence qu'elle est grandement optimisée et s'exécutera à la perfection.

Un fichier est rajouté à l'appli, un .dex qui peut doubler la taille que prend cette appli sur le système, qui est nécessaire à son lancement.

De-odexer une appli c'est donc la rendre plus légère en enlevant son optimisation. Ca permet aussi de changer son apparence.

Une rom De-odexée peut gagner 40 à 50Mo, de plus un framework dé-odexée peut recevoir des patchs pour changer le look de la rom.

Tout est là mais c'est bien hard :

http://android.git.kernel.org/?p=platform/dalvik.git;a=blob_plain;f=docs/dexopt.html;hb=HEAD

En gros dans le .dex ou .odex (pour les system/app) il y a une copie des 'class' (en gros les pièces de légos de l'appli) qui est déposée constamment à côté d'elle, pour qu'Android puisse y accéder plus vite, sans fouiller dans ses tiroirs. Ensuite le .dex est écrit en tenant compte du sytème environnant (donc TA rom à TOI, super perso ^^) afin qu'il soit lisible plus vite.

Bon après c'est ce que je comprends en première lecture hein, et c'est pas mon domaine !

Edited by marcdau

Share this post


Link to post
Share on other sites

Juste pour vous prévenir que la 0.22 vient remplacer la 0.21 qui est supprimée des liens.

Jsoneng a incorporé les pngs que je retravaillés :cool: , et la quasi-totalité des bugs graphiques ont donc disparu :lol:.

Reste l'effet de halo sur les champs de texte, j'ai fais ce que j'ai pu mais ni lui ni moi ne comprenons la raison du rendu 'baveux' mais ça passe quand même mieux maintenant ;) . Je vais voir à tenter d'affiner de plusieurs pixels le cadre...

Reste toujours le bug principal de cette rom, le market incomplet. Pour corriger cela il faudrait éditer le fichier build.prop de la rom pour faire croire au market à un firmware déjà existant. J'ai tenté de modifier le mien, ça n'a rien changé. Lui comme moi sommes débutant sur ce domaine :P (surtout moi en fait :mad: )

Share this post


Link to post
Share on other sites

le fichiers settings.apk ne s'est pas flashé, tu as sois oublié un zip, soit le flash a partiellement raté ;-)

Share this post


Link to post
Share on other sites

Ouep c'est bon en fait c'est reglé. Par contre l'enregistrement de video en 720p fait systématiquement reboot mon desire.. Sinon pour le moment, c'est de loin ma rom préféré !

Share this post


Link to post
Share on other sites

Je viens de faire mon premier essai de vidéo 720p... concluant !

As-tu bien flashé la dernière rom radio ? la .08 ? Beaucoup de problème liés à l'enregistrement vidéo sont résolu avec les deux dernières radio.

Share this post


Link to post
Share on other sites

J'ai bien flashé en .08 et ça crash à chaque fois que je lance un enregistrement vidéo HD ou non ( aucun soucis pour la photo )

Share this post


Link to post
Share on other sites

alors je ne vois pas...

je tenterai un nouveau flash à ta place, mais bon si tu as passé beaucoup de temps à paramétrer... Peut-être un soucis avec la SD? Non, puisque pas de soucis avec la photo...

Sinon, complètement autre chose :

j'ai décompilé l'application des paramètres, fouillé le fichier contenant la localisation française et vu qu'il manquait les entrées pour 'affichage', 'son' et 'recherche/synthèse vocale'. Comme je n'ai jamais touché à des fichiers xml avant, je vais faire des essais de rajout, recompilation et flasher ça sur mon appareil.

Edit : C'est good ! J'ai affichage en français ! Par contre j'ai râté mon coup pour le son, j'ai besoin de sommeil.

Edited by marcdau

Share this post


Link to post
Share on other sites

Bon apparement ça ne flash pas correctement la radio, dans info logicielle ça indique encore 32.36......

Comment être sur que cela flash bien ?

Share this post


Link to post
Share on other sites

C'est donc bien un problème de radio

Ca ne m'est encore jamais arrivé que la radio ne se flashe pas... je ne saurai pas te dire...

Share this post


Link to post
Share on other sites

Je dois surement mal flasher. Dois on procéder comme pour la rom ou bien y a t il quelque chose à faire que je ne saisie pas ? ( je le fais à partir du recovery )

En tout cas, merci pour ta réactivité.

Share this post


Link to post
Share on other sites

Non ça se flash exactement comme une rom

ça prend même pas 5 secondes à flasher et après l'appareil travaille plusieurs minutes, et reboot plusieurs fois. Sur le topic de Djdroid il est dit qu'il ne faut surtout pas toucher l'écran ou un bouton avant la fin de l'installation. Il présente ça comme une manipulation aussi risquée que la conception d'une bombe ^^

Essaie de prendre la radio d'un autre endroit... ça vient peut-être du zip qui est mal téléchargé

Edited by marcdau

Share this post


Link to post
Share on other sites

Et bien comme pour toute les manipulations que j'ai eu à effectué, c'est après plusieurs tentatives et en faisant exactement la même chose que ça a finit par marcher.

En tout cas merci de ton aide, la vidéo marche et pour moi cette rom ne comporte plus aucun défaut ! ( à part peut être le bleu qui déborde de la saisie de texte, et encore ! )

Share this post


Link to post
Share on other sites

:lol:

*immense satisfaction*

Je suis content que tu soies heureux ! ;)

Le créateur de cette rom est très occupés ces jours-ci, je me propose donc de faire les corrections disons... de ressources (graphiques, textuelles). Comme ça, cela lui laisse le temps pour se focaliser sur l'optimisation proprement dite qui n'est pas de mon niveau ^^ J'ai repris les icônes, maintenant je m'efforce de compléter les libellés français manquants. Par contre le weekend prochain c'est vacances sur la côte, donc je retrouverai mon rôle de spectateur :mad: (frustration à venir je le sens)

Share this post


Link to post
Share on other sites

pour ma part j'adore le theme !!!!!

cependant, j'ai déjà quelques petits soucis. Premièrement au démarrage du téléphone, plantage de Gmail, idem si je démarre l'application Gmail.

Egalement, je voulais réinstaller les applications de mon ancienne rom via Titanium backup, et plantage de l'application non stop :(.

Et dernièrement, de ce que j'ai vu pour le moment, impossible d'installer le clavier HTC_IME que tu cite, le téléphone freeze pour ma part.....

mais sinon j'adore le theme de la rom !

vous savez comment faire en sorte d'avoir les notifications via la Led comme sur les autres roms ??

merci

Share this post


Link to post
Share on other sites

Ouh la la !

Non mais n'essaie pas de te servir de ton téléphone en l'état hein ! C'est évident que la rom ne s'est pas installée correctement !

Mon Gmail marche à la perfection,

j'ai restauré toutes mes applis par titanium

j'ai installé HTC_IME

Aucun réglage pour les LEDs qui marchent direct.

Je suis désolé je vais être catégorique mais, il me semble évident que tu as oublié une étape dans l'installation.

Share this post


Link to post
Share on other sites

non jpense pas lol.

Jvais reflasher la RUU je pense.... ça doit venir de là, car j'ai installé la rom radio pour la Itanium et comme yavait pas grand chose dessus (style clavier etc), jpense que ça doit venir de là...

Par contre, une autre chose, pour les photos, je veux les mettre dans la meilleure qualité possible, je choisis quoi à ton avis ?

Haut ou haute qualité ?? lol

Share this post


Link to post
Share on other sites

La rom radio si elle porte le même numéro de version, alors d'une Rom à l'autre c'est 100% la même, personne n'y touche à la Radio. Elle n'est pas propre à telle ou telle rom.

Pourquoi flasher la RUU, tu n'as jamais fait de nandroid d'un rom qui te convenait ?

Avant essaye peut-être un full wipe (tous hein, pas juste user data) + flash radio + flash rom full ou lite + complément 0.22

Pour le photo c'est vrai que c'est pas très clair ! Essaie : prends deux photos, et regarde sur le PC qui est la meilleure. Si j'ai un peu de temps je changerai le libellé 'haut' en autre chose, reste à savoir si c'est le meilleur réglage ou l'intermédiaire ^^

Share this post


Link to post
Share on other sites

Bon allez je me prends par la main, maintenant que je maîtrise le processus, je fais le tour des phrases non traduites dans les paramètres et je compile un Settings.apk 100% français.

Share this post


Link to post
Share on other sites

je vais refaire un wipe total même si je l'avais déjà fait avant l'installation...

tu as quelle radio ? 08 ou 04 ?

edit : au fait, j'ai une petite question mais qui n'a pas trop a voir avec la Rom mais comme tu as aussi Rom Manager premium. C'est avec Rom manager, je suis passé sous Amonra, et mon Rom manager me dit maintenant qu'il me faut le clockrecovery pour installer une rom depuis la SD ou autre... Y'a til un paramètre à activer ?

Edited by damien30321

Share this post


Link to post
Share on other sites

bin faut juste cliquer sur Flasher le dernier recovery !

en fait je le redis mais le terme flasher dans rom manager est inexact et trompeur, en fait de flasher il télécharge juste la dernière version du Clockworkmod qu'il place dans un update.zip à la racine de la SD... Tant qu'il ne détecte pas l'update.zip, il te dis qu'il ne l'a pas. Si ça ne résout pas ton problème, va plutôt te renseigner sur le post de RM [/Hors sujet]

Share this post


Link to post
Share on other sites

oki, ben je vais voir ça alors pour ROM manager.

T'y crois ça, je réinstalle tout, plus de problème avec Gmail, mais maintenant impossible de synchroniser mon compte Facebook, dès qu'une application l'utilise, il me dit que l'application Facebook doit fermer XD

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.