Jump to content

TUTO - Le guide du débutant (Root ROM Kernel Recovery Bootloader)


Shirosagi

Recommended Posts

Ben j'ai tout réinstallé de zéro ... formatage carte sd, mémoire interne, reset usine, flashé ta ROM et réessayé d'installer la galerie ... boum, même problème, j'ai fait les upgrade + fix permissions + wipe cache, et de nouveau ça reste bloqué ... :/ :/ :/ :/ :/

Link to comment
Share on other sites

Guest doumworld

C'est quand même beaucoup de désagréments pour peu d'avantages : enfin je dis ça, je dis rien :P !

Surtout que la galerie Bell n'a franchement rien d'exceptionnel...

Doum

Link to comment
Share on other sites

Ben là je viens de encore tout réinstaller ... je compte plus les reset usine lol

Sinon je veux bien tenter pour la méthode manuelle ... :emo_im_foot_in_mouth:

C'est quand même beaucoup de désagréments pour peu d'avantages : enfin je dis ça, je dis rien :P ! Surtout que la galerie Bell n'a franchement rien d'exceptionnel... Doum

Oui mais la galerie Bell a gardé le même principe que la version Froyo ... ça ne m'intéresse pas toutes les options dans celle de la retail.

Link to comment
Share on other sites

Guest doumworld

Installe QuickPic sur le market, c'est plus simple et il est bien plus rapide que les galeries Motorola.

Pour le root, si superoneclick ne veut plus fonctionner, regarde ici : https://forum.frandroid.com/index.php?/topic/81311-TUTO---Le-guide-du-débutant-(Root-ROM-Kernel-Recovery-Bootloader)#entry1344304

Doum

Envoyé depuis mon MB860 utilisant Tapatalk

Edited by doumworld
Link to comment
Share on other sites

Ah ben finalement ça a marché, il fallait télécharger un pilote ché pas quoi pour windows ... :emo_im_lips_are_sealed:

Oui j'avais testé QuickPic mais non j'ai jamais trop marché, c'est vrai c'est plus rapide, mais j'aimais bien les marquages et les répertoires dans Froyo ... donc j'avais fini par ne plus utiliser QuickPic ... mais merci quand même ... ^_^

Et ce Market de m**** ! <_<

Edited by Parsifal
Link to comment
Share on other sites

Non, c'est correct: entre 2000 et 2500 sans rien avoir touché.

Bref. pour la méthode manuelle il va te falloir un programme comme RootExplorer (dispo sur le marché.)

Une fois cela fait, extrait le contenu du dossier "media" contenu dans l'archive BlurToMediaGallery.zip sur ta carte SD.

- A l'aide de RootExplorer, vas dans le dossier /system/app/ et supprime "BlurGallery.apk" et "BlurGallery.odex".

- Fait de même avec le dossier "com.motorola.blurgallery" situé dans "/data/data/"

- Déplace les fichiers extraits sur ta SD dans le dossier "/system/app/".

- Change les permissions des deux fichiers en 644, soit:

R W X

user [x] [x] [ ]

Group [x] [ ] [ ]

Others [x] [ ] [ ]

Un redémarrage et la galerie devrait maintenant être fonctionnelle.

Edited by Shiro
Link to comment
Share on other sites

@Coyotitoo

Concernant le root, Superoneclick 2.2 fonctionne parfaitement mais il faut vérifier 2 choses :

- Activer le mode "débogage USB" ;

- Désactiver tout firewall sur ton PC ;

Doum

Merci Doum ! tout marche nickel, j'ai désactivé le firewall, et passé super1click en dernière version au lieu de 1.8.

Du coup j'ai pu passer le RAMfix.

Link to comment
Share on other sites

Non, c'est correct: entre 2000 et 2500 sans rien avoir touché.

Bref. pour la méthode manuelle il va te falloir un programme comme RootExplorer (dispo sur le marché.)

Une fois cela fait, extrait le contenu du dossier "media" contenu dans l'archive BlurToMediaGallery.zip sur ta carte SD.

- A l'aide de RootExplorer, vas dans le dossier /system/app/ et supprime "BlurGallery.apk" et "BlurGallery.odex".

- Fait de même avec le dossier "com.motorola.gallery" situé dans "/data/data/"

- Déplace les fichiers extraits sur ta SD dans le dossier "/system/app/".

- Change les permissions des deux fichiers en 644, soit:

R W X

user [x] [x] [ ]

Group [x] [x] [ ]

Others [x] [x] [ ]

Un redémarrage et la galerie devrait maintenant être fonctionnelle.

Coucou ...

Ben écoute, ça ne marche toujours pas ... décidément ...

En plus petite histoire drôle, j'ai suivi tes explications à partir de la notif gmail que j'ai reçu sur l'Atrix, et là en fait ton x clair je le voyais foncé comme le reste, et je comprenais pas ce que je devais changer comme permissions ... bref même en changeant ça ne marche pas ... :'(

En plus erreur ou pas, mais quand je voulais supprimer com.motorola.gallery, il n'existait pas, j'avais un dossier com.motorola.blurgallery que j'ai effacé, j'ai supposé que c'était ça ... mais là depuis les redémarrage, il y a bien un com.motorola.gallery ... qui d'ailleurs pose problème puisque lorsque je clique sur l'app, j'ai comme message : Fermeture soudaine de l'application Galerie (du processus com.motorola.gallery). Merci de réessayer.

C'est pas un problème de comment est nommé le répertoire? :huh:

Bon du coup j'ai réinstallé BlurGallery, dans le sens inverse, manuellement, et là ça fonctionne ...

Par contre, je suis allé refouillé, et non je n'hallucine pas : le répertoire com.motorola.gallery que tu me demande de supprimer dans data/data n'existe pas!

Et du coup com.motorola.blurgallery s'est réinstallé, et cette fois surprise, j'ai 3 sous-repertoires de créé : datables, lib et shared_prefs, alors que dans l'autre cas dans com.motorola.gallery je n'ai que lib comme sous-repertoire de créé.

Link to comment
Share on other sites

Ma faute. C'est bien le dossier com.motorola.blurgallery qu'il faut supprimer.

La galerie que tu utilises recréé automatiquement le dossier associé qui lui manque.

exemple: si tu utilises BlurGallery mais qu'il manque le dossier com.motorola.blurgallery, celui-ci sera créé automatiquement.

Pareil pour la MediaGallery avec com.motorola.gallery.

Là où je ne comprend pas, c'est que ton téléphone te sorte un FC...

Link to comment
Share on other sites

@Shiro et Parsifal

Même problème que Parsifal : pas les reboots mais juste l'échec de démarrage de la Gallerie.

Je suis passé en mode manuel, et j'ai suivi les instructions de Shiro (avant le chmod, juste faire un mount -o rw,remount /dev/block/mmcblk0p12 /system). Si le Switcher a installé quelquechose, faire un rm de tout même MediaGallery* et les remplacer par ceux du zip (qui était dans le switcher). Moi çà n'a pas marché en laissant ceux copiés, par le script de ton CWM.

Sinon, la gallerie fonctionne nickel maintenant.

C'est sûr que t'as la poisse là, Parsifal ... ton Atrix est maudit.

Merci Shiro pour cette nouvelle maj ;)

@Doum

Même si la Gallerie Bell n'est pas révolutionnaire, elle est carrément mieux que la Retail. Après, c'est vrai que QuickPix est pas mal mais quand tu prends une photo, impossible d'ouvrir directement QuickPix, il faut une gallerie motorola, et j'aime bien pour ma part supprimer direct les photos en allant dans la gallerie.

Bonne soirée à tous.

Edited by jmquintana
Link to comment
Share on other sites

Salut!

Han chez toi ça marche! :o

Par contre je suis un peu largué par ce que tu as décrit : un peu car si j'ai bien compris il faut changer les permissions de mmcblok0p12 non ... mais chmod, mount -o et remount ... :huh:

Faire un rm?

Hum, bon ... sinon moi je suis jaloux, j'aimerais bien avoir moi aussi la galerie Bell sur mon Atrix possédé ... ^_^

Link to comment
Share on other sites

@ Parsifal

Je suis d'abord passer par le recovery pour installer l'archive de Shiro mais çà a pas marché non plus (comme toi), donc j'ai procédé manuellement, mais je te conseille de supprimer les fichiers copier par le script de Shiro

/system/app/MediaGallery.apk et /system/app/MediaGallery.odex puis supprimer le répertoire dans /data/data/ ( "com.motorola.gallery")

Après avoir décompresser l'archive BlurToMediaGallery.zip sur ta carte sd, tu les copies dans /system/app/

Avant de changer les droits en faisant un : chmod 644 MediaGallery*

Il faudra exécuter la commande : mount -o rw,remount /dev/block/mmcblk0p12 /system

pour monter la partition system en écriture et te permettre le changement de droit.

Après tu redémarres ton téléphone et normalement tout est ok.

Link to comment
Share on other sites

Ok! Mais justement je ne comprends pas ce que je dois faire concrètement quand tu écris :

Il faudra exécuter la commande : mount -o rw,remount /dev/block/mmcblk0p12 /system pour monter la partition system en écriture et te permettre le changement de droit.

Message envoyé avec l'application Forum Frandroid

Link to comment
Share on other sites

Est ce que tu connais ADB ?

Sois tu le fais avec ADB, soit tu le fais dans un terminal (genre Terminal Emulator).

La commande que je t'indique permet de donner les droits d'écriture au répertoire "system" pour modifier les droits des fichiers MediaGallery.apk et MediaGallery.odex

J'espère que mes explications t'aideront plus

Link to comment
Share on other sites

Et re. oui je connais adb, j'ai installé terminal emulator, mais qu'est-ce que j'écris dessus? : mount -o rw, remount /dev/block/mmcblk0p12 /system ?

Bon c'est ce que j'ai fais, mais c'est pas pour ça que ça fonctionne pour moi ensuite ...

Disons que je ne comprends pas la manip, car je suis root et je peux monter /data et /system en écriture à l'aide de efile.

Link to comment
Share on other sites

Guest doumworld

Bonjour,

Si tu n'es pas familier avec le terminal, mieux vaut effectivement utiliser root explorer et consorts pour le montage en R/W et la modification des droits.

Doum

Edited by doumworld
Link to comment
Share on other sites

Ah ok bon c'est ce que j'avais fais pour changer les permissions de mediagallery et du 2ème fichier ... mais c'est déguelasse ça marche pour jmquintana et pas moi GRRRRRRRRRRRRRRRR

Et est-ce que dans la version retail, quelqu'un aurait aussi cet autre FC :

appli --> Caméra --> Options --> Paramètres : Désolé, Fermeture soudaine de l'application Appareil Photo (du processus com.motorola.Camera). Merci de réessayer.

Par contre si je passe par appli --> Appareil photo --> Options --> Paramètres, pas de FC ...

Je bouillonne! >_<

Par contre si quelqu'un peut me détailler ce qu'il y a à écrire dans emulator terminal, je veux bien tenter pour voir si c'est ça fonctionne par rapport au changement de permissions par efile.

Link to comment
Share on other sites

Bonjour,

je vais essayer de débloquer le bootloader mais j'ai une question !

Avec les fichiers fasboot et moto-fasboot, j'ai dézippé les deux mais il y a des fichiers qui se trouve dans les deux et si je dois les dézipper dans le meme dossier je fais remplacer avec Winrar ?

Merci :)

Link to comment
Share on other sites

Est ce quelqu'un a essayé le Kernel "Eternity Project 1.4" ?

Qu'en pense t-il ?

@ Parsifal

J'ai peut être une indication pour toi : la gallerie marche avec le Kernel d'origine de la Retail mais pas le INTL d00 par exemple et je ne sais pas sur les Faux123 ... j'ai essayé des les installer mais côté optimisation j'ai des doutes : PES 12 ne marche plus par exemple ?!?

Je te conseille donc de laisser le Kernel d'origine ... je vais essayer l'Eternity histoire de faire le tour.

Link to comment
Share on other sites

Bonjour,

je vais essayer de débloquer le bootloader mais j'ai une question !

Avec les fichiers fasboot et moto-fasboot, j'ai dézippé les deux mais il y a des fichiers qui se trouve dans les deux et si je dois les dézipper dans le meme dossier je fais remplacer avec Winrar ?

Merci :)

Tu peux les remplacer sans problème, les deux fichiers sont les mêmes pour fastboot et motofastboot.

Bonjour,

Fastboot ou moto-fastboot, c'est un peu la même chose donc télécharge l'archive fonctionnelle ICI.

Doum

1 - les programmes contenus dans les archives qui sont données dans mon tuto sont fonctionnels. Pourquoi redonner un lien?

2 - même si, en effet, les 2 programmes sont sensés faire la même chose, fastboot fait une erreur au moment de faire le push des system et webtop.

Est ce quelqu'un a essayé le Kernel "Eternity Project 1.4" ?

Qu'en pense t-il ?

J'ai peut être une indication pour toi : la gallerie marche avec le Kernel d'origine de la Retail mais pas le INTL d00 par exemple et je ne sais pas sur les Faux123 ...

J'ai une fois essayé le Eternity Project @1.5GHz. Malheureusement, mon tel n'a jamais atteint le bureau.En revanche, avec le Faux123 OC @1.45GHz, aucun problème avec la galerie media. Je n'ai de FC avec aucun programme (sauf si je l'ai bidouillé moi-même).

Edited by Shiro
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...