Jump to content
Shirosagi

TUTO - Le guide du débutant (Root ROM Kernel Recovery Bootloader)

Recommended Posts

Et même en passant dans Paramètres à partir de l'appli Caméra, tu n'as pas de FC Shiro? :o

Share this post


Link to post
Share on other sites
Guest doumworld

J'ai simplement donné le lien présent sur XDA depuis quelques mois... dans le tuto originel.

Doum

Edited by doumworld

Share this post


Link to post
Share on other sites

@ Shiro

Pour la gallerie qui marche plus quand je change de kernel, je dois sûrement pouvoir faire qqchose ... mais par contre PES 2012 ne marche pas : c'est certain avec le Faux123.

@ Parsifal

Le kernel de la ROM d'origine est un 2.6.32.9 comme le INTL 1001 ou le INTL d00 (celui que j'avais installé), mais pas exactement la même version. Pour le ré-installer, il faut faire un restore dans le recovery à condition que tu es fait un backup. Sinon c'est une ré-installe. Mais après si tu fais celà :

- suppression BlurGallery.apk & odex dans /system/app

- suppression de com.motorola.blurgallery dans /data/data

- copie de MediaGallery.apk & odex dans /system/app

- la commande : mount -o rw,remount /mnt/block/mmcblk0p12 /system pour passer de lecture seule à écriture

- changement des droits sur MediaGallery.apk et MediaGallery.odex (chmod 644 MediaGallery*)

- reboot

et normalement çà doit marcher ... SI çà ne marche pas, regarde quand tu redémarres si il ne t'a pas recréé /data/data/com.motorola.blurgallery et si tu n'as pas dans /system/app un com.motorola.blurgallery.apk

Share this post


Link to post
Share on other sites

Tout réinstaller ...! :'(

Il y a pas moyen de juste flasher par fastboot le fichier image qui contient le kernel dans l'archive CWM?

Message envoyé avec l'application Forum Frandroid

Share this post


Link to post
Share on other sites

Il n'y a pas que le kernel dans l'archive, mais le boot complet. Mais ça devrait quand même fonctionner.

Share this post


Link to post
Share on other sites

@ Parsifal

Je te rassure, çà ne marche plus non plus.

Dès que je fais un Wipe Cache / Dalvik Cache, la gallery ne fonctionne plus et cela de manière irréversible (j'ai beau reprendre la procédure en entier, j'ai une erreur sur ouverture sur le processus com.motorola.gallery).

Par contre quand je repasse à la BlurGallery, çà marche sans problème.

Pour le kernel le INTL 1100 ne passe pas sur mon tél (bloqué sur le bootloader), mais le INTL d00 sans problème (version probablement équivalente à l'original mais quand même retouché par Faux123).

Une idée Shiro ? Il ne manque pas un fichier d'après toi ... ou un problème de conflit avec un autre processus ? ....

Edited by jmquintana

Share this post


Link to post
Share on other sites

Aaaah toi aussi finalement! :/

Et est-ce que ça te fait aussi le FC lorsque tu vas dans l'appli Caméra --> Touche Options --> Paramètres ... ?

Franchement ça me fait c**** de tout réinstaller, car je perds tous mes favoris dans mes applis, mes réglages et tout ... :(

J'arrive pas à trouver quelque part sur xda, seulement l'archive du kernel de la version stock gingerbread retail fr ...

Il n'y a pas que le kernel dans l'archive, mais le boot complet. Mais ça devrait quand même fonctionner.

C'est boot.img qu'il faudrait réinstaller? Mais du coup je suis obligé de faire une fasboot -w avant et après non? :huh:

Share this post


Link to post
Share on other sites

@ Parsifal

Pas de bug pour la Caméra.

Pour tout sauvegarder (Favoris, Appel, SMS & MMS), tu as My Backup Root pour tout sauvegarder (la version gratuite marche sur le même téléphone je crois).

Sinon tu as le Kernel INTL_MBR_d00 qui est l'équivalent de celui d'origine 2.6.32.9 ... je le trouve limite plus réactif en plus) : http://www.megaupload.com/?d=NX6Y05B6

Sinon celui-ci qui est une version overclockable à 1,1 Ghz : http://forum.xda-developers.com/showthread.php?t=1173225 (je viens de l'installer)

Et je te confirme que repasser à la BlurGallery marche ... alors même si elle est moins bien que celle de Bell : elle marche :)

Edited by jmquintana

Share this post


Link to post
Share on other sites

Pour le kernel le INTL 1100 ne passe pas sur mon tél (bloqué sur le bootloader), mais le INTL d00 sans problème (version probablement équivalente à l'original mais quand même retouché par Faux123).

Les versions d00 et 1100 ne fonctionnent que sur l'Atrix qui leur est réservé. Il dépend du tegrapart de votre Atrix.

Pour savoir lequel on a, une simple ligne avec le terminal:

adb shell
Su
cat /proc/cmdline

Si vous voyez tegrapart=mbr:d00:100:800,kpanic:2100:400:800:

alors votre tegrapart est le d00 et ne peut pas être remplacé par le 1100.

Si vous voyez tegrapart=mbr:1100:100:800,kpanic:2500:400:800:

alors votre tegrapart est le 1100 et ne peut pas être remplacé par le d00.

C'est boot.img qu'il faudrait réinstaller? Mais du coup je suis obligé de faire une fasboot -w avant et après non? :huh:

Un simple vidage du cache/cache Dalvik suffit pour un flash de boot.

Le formatage, c'est avant et après l'installation d'une ROM complète ou du system.img

Edited by Shiro

Share this post


Link to post
Share on other sites

Oui oui j'étais repassé à la BlurGallery qui marche elle très bien ... mais depuis j'avais quand même cet FC avec la caméra ... bizarre ...

Ca a l'air pas mal Backup Root, du coup je viens d'acheter la version pro ... ;-)

Si j'ai bien compris il y a 2 sortes d'Atrix d'où le intl MBR_d00 et le intl MBR_1001 ... il faut faire une manip sur ADB pour connaitre sa version ... mais toi aucuns beug avec la 1,1Ghz oc ?

Euh il y a un beug avec ton message Shiro ... o_O

Share this post


Link to post
Share on other sites

Han! O_O tout à l'heure, seul 3 mots apparaissaient dans ton message! Je tripe!

Message envoyé avec l'application Forum Frandroid

Share this post


Link to post
Share on other sites

En même temps l'ordi sur lequel j'étais sur le forum tout à l'heure est une épave ... xp avec ie6 je crois lol ... donc tout à l'heure je lance juste un fastboot boot.img, pas besoin de system?

T'as vu il y a la version 2.3.6 bell!

Message envoyé avec l'application Forum Frandroid

Share this post


Link to post
Share on other sites

Mon ça y est j'ai fastbooté boot.img lol ... et maintenant au niveau du noyau, j'ai la version : 2.6.32.9 e13392@zch68lnxdroid46 #3

C'est bon?

Ah du coup ... bam je repasse à 211+70 Mo de RAM ... -_-

Allez, hop un ramfix ... :P

Bon c'est fait ... par contre je râle un peu comme au total, ça ne m'en fait que 685 Mo au total, je trouve ça un peu léger ... <_<

Ooooooooooooh ... ben ça alors, en changeant dans appli --> appareil photo --> paramètres, là j'ai changé le format de la vidéo de DVD à un autre format, et depuis je n'ai plus de FC, même en remettant le format DVD et en passant par l'appli Camera ... youhou! :lol:

Share this post


Link to post
Share on other sites
Mon ça y est j'ai fastbooté boot.img lol ... et maintenant au niveau du noyau, j'ai la version : 2.6.32.9 e13392@zch68lnxdroid46 #3

C'est bon?

C'est bon.

Ooooooooooooh ... ben ça alors, en changeant dans appli --> appareil photo --> paramètres, là j'ai changé le format de la vidéo de DVD à un autre format, et depuis je n'ai plus de FC, même en remettant le format DVD et en passant par l'appli Camera ... youhou! :lol:

Nice.

@jmquintana et Parsifal

J'aimerais savoir:

Ils sont de quel tegrapart vos Atrix? d00 ou 1100?

Edit:

Je me répond tout seul comme un grand:

jmquintana => d00

Parsifal => 1100

Je pensait que les problèmes devait être liés à ça. Mais je suis en 1100 aussi, alors je me dit que mon Atrix est béni des dieux pour ne jamais rien me faire comme erreurs.

Du coup, j'explore une autre piste:

Vous les avez eu comment? en box orange renouvellement ou en box orange nouveau client?

Edited by Shiro

Share this post


Link to post
Share on other sites

Bonsoir.

Cette rom me pose un sacré soucis, au bout d'un moment, la barre de notif, déroulante, deviens floue, et bug totalement. Je n'y trouve aucune raison.

J'ai installé le kernel Faux 1.45.

Une idée?

Share this post


Link to post
Share on other sites

J'ai un Atrix pour ma part pas très conciliant lol, mais ça pour le moment je n'ai pas encore eu ce soucis ... mais chez moi le kernel Faux 1,45 Ghz était fatal, reboot et instabilité, et batterie vidée en quelques heures sans rien faire, et Atrix brûlant.

Du coup, j'explore une autre piste:

Vous les avez eu comment? en box orange renouvellement ou en box orange nouveau client?

Alors pour ma part, box orange nouveau client, j'ai fait un portage de Bouygues vers Orange (pour avoir l'Atrix spécifiquement! lorsque Orange en avait encore l'exclusivité).

Share this post


Link to post
Share on other sites

Je te confirme donc que c'est bien d00 pour ma part.

Mon Atrix a été commandé via Amazon (il vient d'Allemagne), il était donc débloqué avec une ROM Froyo.

Jusqu'à maintenant : aucun problème d'instabilité avec les kernel 2.6.32.9 et Faux123 2.6.32.48, mais avec le Faux123, des dysfonctionnalité (par exemple PES 2012 qui ne marche plus).

Sur la ROM Bell des soucis au niveau du market (beaucoup d'applis étaient marqués incompatibles avec mon système).

Avec la RETAIL FR, rien à déclarer : la stabilité est bien là sauf quand je bidouille trop.

Mon nouveau kernel 2.6.32.9 #4 d00 oc à 1.1 Ghz marche très bien (j'ai fait l'oc avec SetCPU et ajouté des profiles pour l'écran éteint et la gestion du temps).

Pour ce qui est de la MediaGallery, elle a marché mais après un Wipe cache / Wipe Dalvik, elle est de venu non fonctionnelle. J'ai bien tenté de tout viré (MediaGallery.* et BlurGallery.* dans /system/app et com.motorola.gallery et com.motorola.blurgallery dans /data/data puis reboot et réinstalle du CWM BlutToMediaGallery de Shiro mais çà plante toujours alors qu'il y a bien les fichiers qu'il faut avec les bons droits ... ma seule question Shiro est la suivante : qu'as tu dans ton dossier com.motorola.gallery ?)

Share this post


Link to post
Share on other sites
ma seule question Shiro est la suivante : qu'as tu dans ton dossier com.motorola.gallery ?)

deux choses:

- un dossier lib qui ne contient rien.

- un dossier shared_prefs qui contient le fichier com.motorola.gallery_preferences.xml

Rien de plus car c'est l'application qui les créé. J'ai installé la galerie avec mes cwm... et je peux à n'importe quel moment switcher entre les deux galeries en allant faire un tour dans le recovery... aucun FC ou erreur...

C'est pour ça que vos Atrix me font serrer.

Share this post


Link to post
Share on other sites

Et coucou Shiro ...

Ben pour ma part, je n'ai pas de dossier shared_prefs lorsque le dossier com.motorola.gallery se crée, juste le dossier lib qui ne contient rien, je l'avais écris plus tôt dans le sujet il me semble ...

Ben du coup le problème est là ... :mellow:

Share this post


Link to post
Share on other sites

Ben non en fait, car comme je l'ai dit c'est la galerie qui créé lors de sa fermeture tout ce qui se trouve dans le dossier com.motorola.gallery.

Si ta galerie plante à l'ouverture, elle ne peut pas créer le fichier prefs.xml

Share this post


Link to post
Share on other sites

Par contre Shiro, tu as un Faux123 avec une partition ext4 ... est ce que tes scripts passe sur un kernel qui n'utilise pas de ext4 ?

Celà dit même en le faisant à la main çà passe pas ...

Edited by jmquintana

Share this post


Link to post
Share on other sites

Yé comprendo Shiro! ;-)

C'est quoi la partition ext4, j'aime bien comprendre ... :-)

Message envoyé avec l'application Forum Frandroid

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






  • Similar Content

    • By Dadan59DK
      Bonjour, 
       
      je cherche à mettre mon meizu x8 vers une custom rom, je l'ai fais souvent dans le passé sur d'autres marque, mais là sur Meizu, je n'arrive pas, si quelqu'un pouvait m'expliquer comment je dois faire en français car les tutos en anglais sont pas super bien noter et je bloque sur le problème depuis quelques mois. Merci pour votre aide ! 
       
      La rom que j'aimerais installé: https://www.getdroidtips.com/miui-12-for-meizu-x8/
    • By Kinetic
      Salut tout le monde besoin d'aide pour le telephone PB malaysia qui n'est pas verifiable par google et pas de service google aussi.
      Besoin d'un ROM ou apk pour installer le service google merci 😊
    • By thibpel66
      Bonjour, j'ai un blackview bv9600 pro actuellement avec une ROM custom nomée "bliss os" sous android 11 (rooté), et j'aimerais savoir comment je pourrais modifier le kernel de ce téléphone pour y ajouter la fonction DT2W (double tap to wake). merci d'avance même si cela risque d'être complexe
    • By massive
      Bonjour,
      J'ai vu des vidéos sur Youtube, ou des gens ont installés Linéage sur le Redmi Note 9 Pro. J'ai vu sur des forums des personnes dires qu'il était impossible de mettre une ROM custom sur le Redmi Note 9 Pro.
       
      Quand est-il au juste ?
       
      Merci pour votre aide
    • By nico97470
      Passage sous Android 11 pour les moins frileux. Je vous conseille fortement d'effectuer un bon Factory reset des familles afin d'apprécier les balbutiements de cette bêta. Pensez à sauvegarder vos données au préalable dès le passage à A11. Bon flash. Screenshots à suivre.


       
       
       
       
       
       
       
       
       
       
       
       
       
×
×
  • Create New...