Jump to content
kuan

Xiaomi RedMi 1S (MIUI 8)

Recommended Posts

Merci bcp pour ton aide Kuan.Oui, le capteur de proximité était désactivé à l'endroit où tu me l'as signalé. J'ai actuellement 2 redmi 1s en installation propre avec AICP dernière version (refaite de 0). Le problème de capteur de proximité capricieux existait aussi effectivement sur les différentes rom MIUI que j'avais installées.

J'ai un peu progressé dans la compréhension de la difficulté grace à une appli "sensor test" qui m'a indiqué la nature du capteur identique pour mes 2 appareils te permis ed faire des tests:

L'appli me donne: fabricant du capteur: AVAGO, version 2, max range: 5 cm, resolution: 0.1 cm  et intensité elect du capteur: 12, 675 ma.A noter qu'avec cette appli, on peut vérifier en réel le fonctionnement de tous les capteurs et j'ai bien au moins 1 des 2 qui est défaillant car il ne réagit pas à la proximité, sachant que le capteur peut prendre 2 états : "5 cm ou far" et "0 cm ou near". Eh bien, sur mes 2 appareils:

-1 ne s'active que si j'exerce une pression sur mon boitier en haut à gauche près de la nappe, et ensuite fonctionne moyennement en changeant d'état mais pas avec une grande ractivité...

-l'autre réagit furtivement à la pression au m^me endroit sur le boitier (niveau de la nappe) en passant à "far" et repasse de suite à " near",  puis reste tout le temps coinçé à  "near ou 0 cm" (donc il éteint constamment l'écran) même si je ne suis pas près de l'écran avec mon doigt...J epeux juste lui faire afficher furtivement "far ou 5 cm" si je presse légèrement mon boitier en haut à droite à hauteur de la nappe et pas du capteur...

 

J'ai donc bien une défaillance sur le capteur, sur les 2 appareils, dans le sens où ce capteur semble avoir du mal à faire sa fonction (comme si la puissance d'alim était insuffisante...ou un faux contact au niveau de la nappe..).J'ai déja démonté un redmi 1s pour changer le tactil (pas sur ces 2 là..).Curieusement d'ailleurs, celui que j'ai démonté n'a pas ce problème de capteur...au passage pour avoir déja démonté et réparé de nombreux smartphones à la pomme sur ce même type de réparation, le redmi 1s n'a pas à rougir, tout est très soigné dedans et respire la qualité, les taraudages où se fixent les vis sont nombreux avec inserts métalliques, etc;; belle qualité d'assemblage, carte mère très bien finie, belles nappes, belle conception!Il

Faut que je les ouvre pour regarder si la nappe est bien fixée, et enfichée,  bien droite d'origine mais ce serait un drôle de hasard d'en avoir 2 dans ce cas..;personne n'a ce problème de capteur de proximité capricieux?; il n'y a que moi?

Share this post


Link to post
Share on other sites

@ et aux autres, je me suis acheter les xiaomi piston v3, ils marchent bien sur ma tablette z3 , sur Lg G3,etc ....sauf sur mon redmi 1s, l'icone des écouteurs s’affiche en barre de tache, le son par sur les écouteurs pendant 1 sec avant de revenir sur le HP du téléphone. Est-ce un soucis du téléphone, ou un paramétrage de la Rom AICP... j'ai une autre paire qui marche très biens dessus je ne comprend pas...

Share this post


Link to post
Share on other sites

@@califmoto, as tu essayé avec ce sensor test ? Il est très basique, mais fonctionnel.

Passe ta main devant la caméra frontale et regarde la case Proximity. Il va passer de 5 à 0 en mettant/enlevant la main devant le capteur photo. Toujours rien de probant ?

Peux tu me donner le lien de ton sensor test que j'essaye de mon côté ?

 

Edit: je viens de voir une solution assez curieuse mais qui a l'air de fonctionner pour certains...

I fix my proximity sensor with blowing in to the headphone jack hole.  

(J'ai réparé mon capteur de proximité en soufflant dans le trou de la prise jack).

http://xiaomi.eu/community/threads/calibrate-proximity-sensor.24622/#post-212128

 

 

@@red65, j'ai lu ceci, mais je ne sais pas d'ou il sort le chiffre The SAR (specific absorption rate) value of the Redmi Note 2 is 0.602 W/Kg in head and 0.731 W/Kg in body, which is a little bit higher than the previous Redmi Note but it is well within the limits of every country regulation.

 

Pour les Pistons V3, regarde sur le forum CM12.1 de xda si tu trouves quelque chose.

Je devrai recevoir les miens d'un jour à l'autre...

Edited by kuan

Share this post


Link to post
Share on other sites

 

 

@@samyouls je n'ai pas ton souci de casque audio mais je n'utilise pas l'application native. Je me sers de Poweramp.

As-tu essayé avec cette application ou une autre application tierce pour vérifier si tu as toujours le même phénomène ?

Je sais que ce souci était apparu sur les ROM CM12.1 vers le moi de mai pour certains utilisateurs/casques. Je regarde si je trouve quelque chose de récent dessus.

- Pour enregistrer la photo ou un fichier joint dans les MMSclic long sur le cadre supérieur de la photo à enregistrer (à droite de l'heure de réception comme sur la capture) .Le cadre change de couleur et un V apparaît à gauche du cadre : c'est à ce moment là que tu cliques sur les 3 petits points verticaux en haut à droite de l'icone poubelle, puis clic sur "enregistrer le fichier".

 985285Screenshot20150706075838redimensio 204755Screenshot20150706075851redimensio 

 

 

Merci pour les réponses Kuan.

 

Pour les MMS, il doit y avoir un bug à ce niveau parce qu'en suivant ta méthode, le menu que j'ai via les 3 points affiche (vérouiller /détails du message / tout sélectionner). Par contre j'ai remarqué par hasard qu'en sortant le tel de la veille avec le mms sélectionné, lorsque je clic sur les 3 points là j'ai le bon menu !!! Au cas où ça peut servir, j'ai trouvé une autre méthode qui est d'afficher le détail du message, cliquer sur la pièce jointe, un menu action permet d'afficher ou d'enregistrer la pièce jointe.

 

Pour le casque audio, je n'ai pas eu l'occasion de tester avec une autre appli.

 

Sinon comme beaucoup, il faut que j'appuis plusieurs fois sur le bouton on/off pour sortir de la veille (version du 24/08). Je vais installer la version du jour pour voir si ca va mieux.

 

Question peut-être bête mais ça ne pourrait pas venir de la fréquence du processeur en veille réglé trop basse et qui ferait que le tel aurait du mal à réagir ?

Share this post


Link to post
Share on other sites

 Question peut-être bête mais ça ne pourrait pas venir de la fréquence du processeur en veille réglé trop basse et qui ferait que le tel aurait du mal à réagir ?

Pour les MMS, tu n'as pas le V qui apparaît quand tu fais un clic long sur le cadre de la photo ?

Tant qu'il n'y a pas le V, le bon menu n’apparaît pas. En même temps, tu as réussi à te dépanner avec ta méthode.

 

Pour le souci de sortie de veille, j'en ai parlé plus haut : cela vient d'un bug de CM12.1 qui s'est répercuté sur AICP.

Je n'ai plus ce bug depuis la dernière mise à jour.

Share this post


Link to post
Share on other sites

J'ai bien le V qui apparaît mais pas le bon menu. Le bon menu apparaît lorsque j'ai le V que le tel se met en veille et que je le ressort de la veille.

 

Je confirme qu'avec la dernière maj je n'ai plus le bug de sortie de veille également.

Share this post


Link to post
Share on other sites

Merci Kuan, oui j'ai déja lu qu'on pouvait dans certains cas obtenir un bon résultat en soufflant à proximité de capteur, c'est vrai que dès que je serre légèrement mon boitier de redmi 1s avec une légère pression sur le côté gauche entre le pouce et l'index, et que je passe ma main à proximité du capteur.....il fonctionne!

Voici le lien vers l'appli que j'ai utilisée:

https://play.google.com/store/apps/details?id=asd.vector.sensor

Dès que j'ai une bombe à air, j'essaie!

 

Share this post


Link to post
Share on other sites

Bon aujourd'hui, démontage du redmi incriminé puis débranchement de la nappe du capteur, nettoyage, elle n'était pas mal branchée puis rebranchement...rien toujours pareil....soit redmi défectueux (2 avec symptômes quasi identique) Soit la ROM aicp gère mal le capteur sur mes redmi ( 3 en tout qui sont plus ou moins capricieux...)Dommage de ne pas pourvoir le déconnecter complètement sur aicp...

Ah oui j'ai aussi soufflé avec une bombe d'air sec dans le branchement casque...sans succès

Share this post


Link to post
Share on other sites

@@califmoto, j'ai peut-être la solution pour toi. Sais-tu éditer le build.prop ? Il faudrait rajouter ceci (plus bas) à la fin du build.prop puis reboot et nouveaux tests.

Ce sont surtout les 2 premières lignes qui sont importantes mais les 2 suivantes ne sont pas inutiles.

 

Tu peux te servir de build prop editor https://play.google.com/store/apps/details?id=com.jrummy.apps.build.prop.editor&hl=fr

 

- Quand tu ouvres l'application, clique sur la croix puis sur "predefined properties". Cherche la ligne mot.proximity.delay, laisse 0 dans défault values puis clique sur "add".

- Rebelote pour ro.lge.proximity.delay (clic sur la croix) puis cherche la valeur dans les "predefined properties" et colle lui 25 dans "property value" puis "save".

- Même chose pour ro.telephony.call   (tant pis pour la 4eme, il n'y a pas de pré valeur défini et c'est toujours délicat de bidouiller le build.prop quand on ne connait pas.

Il vaut mieux que tu te serves de cet outil (build prop editor) pour les modifications si tu n'as pas l'habitude.

 

-Reboot après les modifications

 

- Fais différents tests pour voir s'il y a des améliorations...ou pas. Tiens nous au courant.

 

mot.proximity.delay=0
ro.lge.proximity.delay=25

ro.telephony.call_ring.delay=0
ring.delay=0

  • Like 1

Share this post


Link to post
Share on other sites

pfff j' ai exactement le même souci que califmoto depuis que j' ai le redmi... j' ai tout testé sans succès .... par contre je peux pas faire ce test http://en.miui.com/forum.php?mod=viewthread&tid=27773&highlight=PROXIMITY car je suis en Miui 7 Teamwin au démarrage... j vais retenter la modif du build.prop pour voir!

 

edit: rien a faire ca veut pas avec le build.prop ... perso je m' étais résolu a penser que le capteur était HS
piéce dispo ici : http://fr.aliexpress.com/item/100-Original-For-Xiaomi-Hongmi-Redmi-red-rice-1-1S-1-3MP-Front-small-Camera-Moudle/32352119972.html

j crois que j vais tenter la réparation ... pour 8.83€ ca va ... par contre il y a plusieurs modéles oO

Edited by M@@N

Share this post


Link to post
Share on other sites

Bravo Kuan, merci pour l'info et le tuto! il y a du mieux avec mon capteur de proximité de mon redmi le plus capricieux ! Il réagit mieux mais a toujours besoin que je serre légèrement le côté droit du boitier pour reprendre l'état "far" ou "5 cm"..;

Par contre, je n’ai pas pu ajouter les lignes ro.lge.proximity.delay=25 ; ro.telephony.call_ring.delay=0 ; ring.delay=0 car elles n'existent pas dans mon build sous AICP.. mais j'ai pu faire la 1ère qui semble changer le délai au capteur pour donner son état c'est cela ?

A priori, il faudrait pour voir le recalibrer....

 

Merci aussi Moon car il semble bien qu'il y ait un problème hardware sur ce capteur... attention moon, la pièce que tu souhaites acquérir, qui englobe le capteur de proximité est difficile à changer car il faut décoller la vitre..;

merci à tous les 2, maintenant je peux passer des appels en haut parleur et en appuyant sur le côté récupérer l'allumage de l’écran si je reste éloigné du capteur. et pour Mon autre redmi 1 s sous AICP (super rom, je le redis), il marche désormais à 80 % des cas ce qui est mieux , mais je n'ai pas toutes les lignes dans le build prop ce qui est dommage...puis je les créer totalement sans rendre le tout instable ?

Share this post


Link to post
Share on other sites

@@califmoto, ok, pour rajouter les lignes manuellement (c'est très facile), tu reprends le tuto avec build prop editor.

Tu cliques sur la croix  et dans "property name", tu écris exactement   ro.lge.proximity.delay et dans "property value", tu inscris 25, puis tu cliques sur Add. Tu peux refaire la même chose pour les 2 lignes suivantes. 

Reboot pour prise en compte des modifications et test à nouveau.

Je suis content qu'il y a eu du mieux grace à la première ligne. La 2eme ligne ro.lge.proximity.delay pourrait lui faire du bien aussi

Les 2 dernières lignes, c'est plus pour le confort.

Plus tard, tu pourras essayer de mettre la ligne ro.lge.proximity.... à la valeur 0 pour voir si tu sens un changement en mieux... ou pas (le 0 c'est dans les cas difficiles, il me semble).

Edited by kuan
  • Like 1

Share this post


Link to post
Share on other sites

Kuan, tu es vraiment le Boss....cela marche! mon capteur est juste un peu long à réagir, effectivement il met presque 1 demie seconde à changer d'état et parfois s'emmèle un peu, mais j'ai la fonctionnalité grâce à toi! Et sur l'autre moins capricieux, il fait le job à 100 %!

J'ai mis toutes les lignes que tu m'as indiquées et effectivement, c'est très facile. J'étais juste un peu perturbé hier avec la ligne prédéfinie mais qui en fait, ne sert pas, l'inscription du texte est à faire sur le cadre juste en dessous; Allez, +1 pour Kuan ! :)  et je crois que je vais te suivre si tu t'occupes du Note 2 car il me tente bien, mais sous AICP je préfèrerais car j'aime bcp cette ROM.Merci encore bonne journée à toi.

  • Like 2

Share this post


Link to post
Share on other sites

@califmoto  ;)

 

@@M@@N, comme califmoto a fait un peu avancer les choses, cela vaudrait le coup que tu réessayes les modifs (les 2 premières lignes) que j'ai donné pour le build.prop.

Quitte à faire un backup de Miui avec le TWRP (twrp/backup) et installer, vite fait, AICP tout en rajoutant les 2 premières lignes au build.prop (reboot ensuite).

Après test (concluant ou pas) tu récupères ta sauvegarde miui en 4 minutes chrono ^^ (twrp/restore)

Edited by kuan
  • Like 1

Share this post


Link to post
Share on other sites

cool si ca a marché pour toi califmoto!!! sous Miui j' avais deja rajouté la ligne mais ca marche pas , bon tu me tente avec le test AICP !!! j vais etre obligé de le faire !! allez go je te tiens au jus!

edit:
1er essai: j' installe sensor test directement pour vérifier l' efficacité des réglages, je vois que le capteur de proximité est sur false oO, sous Miui il me mettait Near , bref  je fais les modifs du build.prop je rajoute les 4 lignes direct, reboot: aucune amélioration mais j' ai carrément la ligne du capteur de proximité et celui de la lumiére qui ont disparu, j' installe un autre outils de diagnostic, il me trouves ces 2 la comme inexistant (ou desactivé, une croix rouge comme si la fonction n' existait pas) --> je n' arrive pas a récup ma sauvegarde du builld.prop d' origine, je réinstalle la rom.

 

2éme essai: je réinstalle la rom tout clean, je modifie directement le build.prop en ajoutant seulement "ro.lge.proximity.delay=25"  même résultat... je retourne sous Miui avec ce capteur non fonctionnel. dommage....

Edited by M@@N

Share this post


Link to post
Share on other sites

Moon, la ligne ro.lge.proximity.delay est vraiment celle qui fait la différence si le capteur n'est pas HS.J'ai quand même l'impression que le capteur de proximité  des redmi 1S est pas mal capricieux ou difficile à calibrer. Essaie de serrer légèrement ton boitier entre  le pouce et l'index de la main droite en haut à droite (juste à droite du haut parleur pour ne pas recouvrir le trou du capteur de proximité) au moment où tu testes le capteur, tu verras peut-être un changement d'état même furtif. L'appli qui m'a permis d'avancer sur mes capteurs est "Sensors test" avec cette orthographe et casse, logo jaune engrenage noir. J'ai aussi appris à me méfier des applis pour tester les capteurs, bien souvent ces applis marchent mal car trop de config matériels et modèles différents. Le meilleur test est de faire fonctionner le capteur en faisant réellement un appel et regarder comment il réagit. Bon courage.

Edited by califmoto

Share this post


Link to post
Share on other sites

Bonjour à tous,

Avez vous rencontrer un problème de partage de connexion avec miui 7 .

Car pour moi la connexion entre mon tel et ma tablette ne fonctionne pas.

La tablette reconnait bien mon tel mais impossible d'aller sur le net.

Merci de vos réponses.

Share this post


Link to post
Share on other sites

Salut à tous,

@@bartrider je n'ai pas rencontré ce type de problème. Miui7 fonctionne plutôt bien pour moi. Désolé pour toi...

Share this post


Link to post
Share on other sites

Bonjour,

j'ai pas trop suivi l'actu sur Xiaomi ces derniers temps, que me conseillez vous pour offrir à une personne qui ne bidouillera pas trop je pense mais surtout pour avoir une rom bien traduite  et fonctionnelle à la réception (pas à moitié :))

en 4.7 seul le redmi 2  propose la bande des 900Mhz ?  c'est bien çà  (le note 5.5" jugé trop grand)

Il n'existe pas en 2G de ram avec cette fameuse bande des 900

 

http://www.to2c.com/xiaomi-redmi-2-1gb-ram-8gb-rom.html

http://www.gearbest.com/cell-phones/pp_162092.html

aussi sur Geebuying et Bandgoog

 

sur quel site pensez vous que la rom serait la meilleure 

 

sinon en quelle marque presque aussi fiable en 4,7  ou 5" conseilleriez vous 

 

Merci

Share this post


Link to post
Share on other sites

salut,

 

@@bartrider c'est un probleme apparu avec kitkat, il ya un bridage du partage de connexion.

il ya un moyen de le contourner (ça marche pour moi sous miui6 et aicp) , je te partage le post originel:

 

 

bonsoir à tous !
pour le problème avec le hotspot wifi , j'ai cherché un peu sur le net et j'ai trouvé une solution simple qui fonctionne pour moi !
Pour info, je suis chez joe mobile qui utilise le réseau de SFR. Apparemment, le problème est apparu avec KITKAT et pas chez tous les opérateurs.

j'ai utilisé les applis suivantes : Root Explorer et SQLite Editor ( je suppose qu'il y en a des gratuits ) . Ces applis doivent avoir les droits ROOT .

Pour ne pas payer l'appli SQLite Editor , je l'ai installé et après la modification , il suffit de la désinstaller du playstore.

1 - sauvegarde par précaution :
avec Root Explorer , il faut aller dans le répertoire /data/data/com.android.providers.settings/databases/ et faire une copie du fichier settings.db au cas où il faut le restaurer un jour.

2 - avec SQLite Editor , allez dans le répertoire /data/data/com.android.providers.settings/databases/ et ouvrez le fichier settings.db. et sélectionnez global.

3 - ajoutez une nouvelle clé avec pour nom : tether_dun_required et valeur : 0 puis enregistrez .

 

j'espere que ça va t'aider!

  • Like 1

Share this post


Link to post
Share on other sites

...lorsque je décoche dans mon compte gmail la synchronisation "sauvegarde google photos", elle se remet toute seule en route dès que je reprends une photo; je voudrais que mes photos soient uniquement stockées dans l'appareil, et pas sur le cloud...

savez vous comment faire pour supprimer cette option?

merci

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...