Jump to content
Slainou

[Tutoriel] Installation CM10/11 LB pas à pas (update 30/11 - CM11 4.4.4)

Recommended Posts

J'hésite à me lancer, il y a des choses qui me paraissent pas claires et j'ai peur de faire une connerie...

Share this post


Link to post
Share on other sites

Yep, j'avais trouvé ça sur le net, j'ai pris le premier. J'ai fait toutes les manip, c'est vrai qu'avec ce tuto pas moyen de se tromper. Tout est nickel, fluide... 

  • Like 1

Share this post


Link to post
Share on other sites

Je me posais une question, quand une nouvelle ROM est dispo pour le SP, on est toujours obligé de passer par le recovery et tout le tralala ? Car j'ai vu dans les options du téléphone qu'il y avait "mise à jour Cyanogenmod", donc on peut faire la mise à jour depuis le telephone et pas toujours être obligé de récupérer la nouvelle rom et de la flasher, non ?

Share this post


Link to post
Share on other sites

Seulement pour la version officielle de CM, donc uniquement sur BL déverrouillé et avec la rom prévue à cet effet.

Sinon pour la version pour BL verrouillé, ce sera toujours comme ça oui, mais on s'y fait vite, et CM est fiabilisé maintenant, il ne devrait plus y avoir beaucoup d'update...

Share this post


Link to post
Share on other sites

Merci de l'info :) Donc, si CM 12 sort pour le SP, il faudra que le mec qui a développé la rom CM sur Xperia SP avec LB en développe une autre et qu'on puisse faire la mise à jour, ou alors il faudra prendre une rom avec tuto pour Xperia UB et mettre une rom de chez FXP... C'est à dire que si le mec de chez XDA ne continue pas d'entretenir la rom, alors tous ceux qui ne peuvent pas déverrouiller leur bootloader seront bloqués à CM 11 si j'ai bien suivi...

Edited by Oniats

Share this post


Link to post
Share on other sites

Grosso modo c'est ça, mais de toutes manières je doute que CM12 arrive avant un moment, trop tard pour que quiconque développe encore sur SP.

Le numéro des versions de CM correspond à une version d'Android: CM9 était ICS, CM10 JB, CM11 est KK, donc CM12 sera la version suivante, pour le moment supposée être 4.5 et nommée (pour l'instant, et ce ne sont que des rumeurs...) Lollipop :)

Edited by RawenWarCrow

Share this post


Link to post
Share on other sites

Bonjour à tous et merci pour ce tuto !

 

Cependant apres avoir scrupuleusement suivi les étapes, l'installation de CM 10.2 se fait sans aucun souci, mais lorsque je fais le reboot pour la version 11, le téléphone ne reboot toujours pas au bout de 10 minutes. Le reboot se fait-il automatiquement ou dois-je rappuyer sur le bouton Power du téléphone ?, j'en suis à mon deuxieme essai et toujours pas cette version 11. J'ai reflasher la premiere fois et j'ai aperçu le logo cyano et....apres j'avais le logo Sony qui se mettait à clignoter....ai-je oublié quelque chose ? merci d'avance


Bon ben finalement j'ai reussi du premier coup sans passer par l'installation du 10.2. J'ai directement installé CM11 et les Gapps et tout marche nickel ! 

  • Like 1

Share this post


Link to post
Share on other sites

Bonsoir,

 

Je ne comprend pas l'étape recovery ne fonctionne pas chez moi, j'ai le message suivant: le chemin d'accès spécifié est introuvable.

Je demande de l'aide je ne sais pas comment dépasser cette étape

Share this post


Link to post
Share on other sites

bonjour a tous,

 

je suis bloqué au niveau : 

> Se rendre dans le dossier Doomlord Easy rooting et exécuter le fichier "runme_win"

> Faire une touche pour lancer la procédure. Une série d'instructions va s'afficher et le téléphone va redémarrer. N'allez pas plus loin tant que vous ne trouvez pas "SuperSu" dans le tiroir d'applications. Si elle n'apparait pas, relancer le "runme_win"

 

j excecute bien runme_win mais ensuite j ai des messages du style  

adb server is out of date. killing...

daemon started successfully *

daemon still not runningerror : cannot connect to daemon 

 

et cela plusieurs fois .

 

je recherche supersu dans les appli mais niette...

 

ou j a iloupé un truc ?

 

merci.

Edited by marty_fr

Share this post


Link to post
Share on other sites

Ne t’embêtes pas avec  runme_win, comme dit au dessus ce tutoriel est obsolète !

Tout d'abord si tu est en 4.1.2 flash une 4.3 grâce à ce tutoriel : https://forum.frandroid.com/topic/153446-tuto-pourquoi-et-comment-installer-la-rom-officielle-de-sony-avec-flashtool-pour-ne-plus-avoir-la-surcouche-op%C3%A9rateur/

puis commence à partir de la partie : Methode alternative - Root avec Towelroot + Recovery

Share this post


Link to post
Share on other sites

arf j'etais en 4.3 avant ...

 

bon je recommence et j utilise la methode alternative alors...

 

root passé via alternative et supersu downloader je continu.. 

 

merci.


bon alors je suis bien root sur le tel j ai verifier via root checker...

 

j ai tenté cela : 

> Se rendre dans le dossier CWM_SP et exécuter le fichier "install"

> Choisir 1 pour installer le Recovery.

> Choisir 4 pour quitter le script.

 

mais error : more than on device ona emulator...

 

lol quel boulet ;)

 

je continu avec la suite tant pi ;)

 

bon rien a faire je dois vraiment etre nul...

 

 

> Eteindre le mobile

> Démarrer le mobile puis, après l'allumage des 3 Leds (vert rouge bleu), matraquer le bouton VOLUME - . Le mobile va clignoter bleu puis vert et vous aurez accès au Recovery (Teamwin Recovery)

 

rien a faire il demarre de facon normal avec ne bas noté mode securisé...

 

tout le monde y arrive sans probleme et moi pas moyen help ;)

 

 

Bon plsu je lis plus je suis pommé...

 

je suis repasser en 4.3 pour suivre ca : https://forum.frandroid.com/topic/163797-guide-bien-conna%C3%AEtre-son-xperia-sp-r%C3%A9glages-root-roms-r%C3%A9paration-etc/

 

en gros passage en 4.3 off sony, je root via towelroot, j install supersu  et apres ??

Edited by marty_fr

Share this post


Link to post
Share on other sites

Le lien du recovery n'est plus à jour : essaye celui-ci CWM_SP_4.4.1.zip 

Ensuite si ça marche toujours pas, vérifie qu'aucun autre appareil android ne soit branché pendant cette manipulation (ce qui pourrait expliquer ton message d'erreur), que flashtool soit fermé, et aussi juste en rootant avec towelroot et sans installer de supersu.

 

Veille aussi à ce que le débogage USB soit bien coché dans les paramètres/développeurs  et source inconnues aussi dans paramètres/sécurité.

  • Like 2

Share this post


Link to post
Share on other sites

Bonjour,

Je suis un novice et je comprend pas trop, j'aimerais juste savoir commet faire pour obtenir les GApps 4.4.3 qui sont à la première page car il y a marqué "not found". On peut faire sans ? 

Merci d'éclairer ma lanterne :)

Share this post


Link to post
Share on other sites

Bonjour,

D'abord merci pour ce tuto facile =)

Je voudrais la version android 4.4.2 et non la 4.4.4 comment je peux faire ?

Share this post


Link to post
Share on other sites

Bonjour,

 

Pour toutes personnes qui a eu une stock 4.3 avant (201 ou 205) et qui est passé à une CM11 depuis un certain temps (pour pouvoir juger objectivement sur la longueur), pourriez-vous succinctement donner les avantages et inconvénients de l'une par rapport à l'autre (à part la perte des apps natives Sony).

 

Merci d'avance à toute personne qui répondra.

 

P.S. Une nouvelle stock 207 existe en Australie depuis juillet (mais çà reste une 4.3 et incapable de dire ce qui a évolué).

Share this post


Link to post
Share on other sites

Mmh... De premier abord, tu as bien sûr quelques changements esthétiques. Une fois dans les paramètres, tu as accès à beaucoup plus de personnalisation: ça va du thème téléchargeable sur le store à la taille de ta barre de navigation, en passant par les raccourcis modulables de la barre de notification, la gestion de la transparence de tout ce petit monde, les heures de sommeil (qui permettent de régler indépendamment les absences de sonneries, notifications et autres) et l'ajout des modules Xposed (certains peuvent rendre l'appareil instable...)...

Au milieux de cette première navigation, on se rend compte à quel point tout est plus fluide, plus naturel; la ram libre tourne en moyenne entre 200 et 300 mo, ce qui fait un sacré progrès! On est de plus sur du 4.4, ce qui permet de passer en Art plutôt qu'en Dalvik (pour les explications techniques, je passe la main au Professeur Google...), entre autres améliorations.

Pour le SP de façon plus spécifique, ça corrige quelques soucis (je saurais plus préciser lesquels, j'y suis depuis la 201...).

Pour autant, il reste des défauts bien sûr: les màj d'applications sur le store par exemple, paralysent toujours autant le téléphone... Certaines applis peuvent avoir de fâcheuses tendances au plantage (ça reste très aléatoire...), l'accroche réseau n'est toujours pas extraordinaire (enfin, tout dépend comment est couverte la zone dans laquelle tu traînes...), pareil côté wifi, et il y aurait à priori des soucis de partage de connexion (j'utilise pas, je ne peux donc pas confirmer...). Et bien sûr, comme c'est une rom custom, il se peut qu'elle devienne instable avec le temps (la mienne tournait encore parfaitement jusqu'à près de 260 heures d'affilée sans redémarrage la semaine dernière, hier le téléphone me rendait fou à cause de ses latences et plantages...), mais ça n'arrivera pas à tout le monde non plus...

Je viens moi-même de passer sur la toute dernière version, la 828 (j'étais encore sous 622), je n'en ai pas encore de retour d'expérience acceptable...

A noter, pour ceux dont le téléphone devient capricieux à partir de 18h (en tout cas chez moi...), c'est sûrement que vous avez de la màj à faire sur le store, et ça fout le bazar dans l'appareil...

Edited by RawenWarCrow
  • Like 1

Share this post


Link to post
Share on other sites

Bonsoir tout le monde,

Avant toute chose bravo pour ce tuto claire et détaillé.

Mon SP se plantait minimum 5  fois par jour et très gentiment le SAV de Sony me répondait "on sait mais il faut attendre la prochaine mise à jour..." (commerçant les gars non???? :( ).

J'ai donc installé la CM11 avec ce tuto et pour l'instant ça roule, ouf. :)

Il me manque juste une chose. je suis chez Free mobile et je ne parvient pas à me connecter à Free Wifi_secure.

J'ai essayé sans succès manuellement et avec l'appli freewificonfig.

il semble que l'EAP SIM manque au CM11.

J'ai rien trouvé de probant avec mon ami google.

Avec vous une solution?

Par avance merci.

Share this post


Link to post
Share on other sites

Mmh... De premier abord, tu as bien sûr quelques changements esthétiques. Une fois dans les paramètres, tu as accès à beaucoup plus de personnalisation: ça va du thème téléchargeable sur le store à la taille de ta barre de navigation, en passant par les raccourcis modulables de la barre de notification, la gestion de la transparence de tout ce petit monde, les heures de sommeil (qui permettent de régler indépendamment les absences de sonneries, notifications et autres) et l'ajout des modules Xposed (certains peuvent rendre l'appareil instable...)...

Au milieux de cette première navigation, on se rend compte à quel point tout est plus fluide, plus naturel; la ram libre tourne en moyenne entre 200 et 300 mo, ce qui fait un sacré progrès! On est de plus sur du 4.4, ce qui permet de passer en Art plutôt qu'en Dalvik (pour les explications techniques, je passe la main au Professeur Google...), entre autres améliorations.

Pour le SP de façon plus spécifique, ça corrige quelques soucis (je saurais plus préciser lesquels, j'y suis depuis la 201...).

Pour autant, il reste des défauts bien sûr: les màj d'applications sur le store par exemple, paralysent toujours autant le téléphone... Certaines applis peuvent avoir de fâcheuses tendances au plantage (ça reste très aléatoire...), l'accroche réseau n'est toujours pas extraordinaire (enfin, tout dépend comment est couverte la zone dans laquelle tu traînes...), pareil côté wifi, et il y aurait à priori des soucis de partage de connexion (j'utilise pas, je ne peux donc pas confirmer...). Et bien sûr, comme c'est une rom custom, il se peut qu'elle devienne instable avec le temps (la mienne tournait encore parfaitement jusqu'à près de 260 heures d'affilée sans redémarrage la semaine dernière, hier le téléphone me rendait fou à cause de ses latences et plantages...), mais ça n'arrivera pas à tout le monde non plus...

Je viens moi-même de passer sur la toute dernière version, la 828 (j'étais encore sous 622), je n'en ai pas encore de retour d'expérience acceptable...

A noter, pour ceux dont le téléphone devient capricieux à partir de 18h (en tout cas chez moi...), c'est sûrement que vous avez de la màj à faire sur le store, et ça fout le bazar dans l'appareil...

 

Merci pour ton retour RawenWarCrow... je vais backuper ma stock et tenter le coup.

Est ce qu'au niveau tactile, tu remarques du mieux ou du moins bien ? Moi avec la stock, j'ai des bugs écrans bizarres avec la 205 : effet jaunissant de l'écran puis noir complet et 5 secondes plus tard, je récupères l'affichage.

L'accroche réseau est pas top pour moi mais je suis chez Free ... donc normal j'ai envie de dire.

  • Like 1

Share this post


Link to post
Share on other sites

Pour le tactile, je n'ai pas spécialement de soucis, hormis téléphone en charge...

Pour l'écran, j'ai déjà entendu parler de ce problème mais n'en ai jamais souffert, il me sera donc difficile de te répondre... Mais il me semble que ça a réglé le problème pour certaines personne, tout ce que je peux donc te dire est d'essayer pas toi-même... Et de donner ton retour pour les autres ;)

Quant à l'accroche réseau, je suis chez Bouygues et c'est pas terrible non plus (j'habite en cambrousse aussi...), mais de toutes manières, je ne connais que très peu de gens qui n'ai rien à redire sur le SP de ce côté, ça semble être un problème lié au hardware, ou en tout cas spécifique à ce téléphone...

  • Like 1

Share this post


Link to post
Share on other sites

Je viens d'installer la CM 11 du 05/09.

Installation rapide. Quelques petits bugs au démarrage (j'ai également installé Super User de chainfire et flasher le dernier binaire SU).

Conclusion par rapport à la stock 205 :

 + Fluidité grandement améliorée

 + Réponse tactile d'une réactivité impressionnante par rapport à la stock (çà se voit sur des jeux surtout)

 + la multitude d'options de config

 + les thèmes

 

 - pour le moment juste l'accroche réseau moins bonne et surtout au niveau de l'activation du data : téléchargement ultra lent.

 - son (peut être ?) un peu plus faible qu'en stock

 

Pour ma part je n'ai pas activé la nouvelle machine ART, car à part pour le démarrage du téléphone, rien à l'heure actuelle ne prouve le gain par rapport au Dalvik sur les applications (lancement peut être plus rapide, mais au niveau perf gain non garanti ... de plus, ART moins compatible).

 

P.S. Par rapport à tout les commentaires que j'ai pu lire : pour ma part, l'écran s'éteint au bout de 30 secondes comme souhaité, la barre LED de notif fonctionne à merveille (avec les couleurs demandés).

Edited by jmquintana
  • Like 1

Share this post


Link to post
Share on other sites

Bonjour à tous !

J'ai pu exécuter ce tuto en entier, il est super bien détaillé !!!

 

J'ai cependant un problème : impossible de faire fonctionner le wifi lorsque le bluetooth et le wifi sont activés en même temps.

Une idée ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...