Jump to content
DroidO

[TUTO] Multiboot sur votre OPO

Recommended Posts

@@wiz :

 

Alors perso, j'ai fait bien plus simplement!! Sous (encore) cm11s, j'ai installé l'appli, et tout mis au point à travers elle!

Le seul zip que j'ai flashé a été pour désinstaller multirom. J'ai fait comme la première fois pour le ré-installer.

 

En clair:

  1. installer l'appli
  2. "installer/mettre à jour":
  • Multirom
  • Recovery
  • Kernel (4.4/5.0.x)

J'ai désormais cm12s en primaire, mais n'ai jamais flashé d'autre kernel. Il se dit 'désormais' de flasher ak ou autre en principal, mais je répète ne l'avoir jamais fait.

Il faut en fait que le kernel ait le patch kexec-hardboot, ce qui est le cas de celui de l'application. Si vraiment ça ne démarre pas, il suffira de flasher ak en principale, mais dernière fois, je ne l'ai pas fait, et ça fonctionne très bien.

 

Ensuite, pour avoir cm11/cm12.1, il te faut flasher le Bacon Firmware May 15 (AFH) en primaire (pour cm12.1), ainsi que le modem-cm11 ( XNPH44S-modem-flashable.zip )  pour continuer avec cm11s en principale...

Finalement, si tu as le souci de blackscreen dans les secondaires, il faudra flasher le cm12_fix_proximity_sensor.zip.

.

 

Nota: je ne sais plus de quoi il s'agissait, mais il m'a été impossible de flasher qqc avec le dernier recovery modifié (twrp 2.8.7), aussi j'ai reflashé le 2.8.6 par Flashify.

Edited by néonaloj

Share this post


Link to post
Share on other sites

Merci !

Quand tu dis "installer l'appli", c'est le multirom.zip via le recovery TWRP ? pas une appli via gogole play ou un apk a télécharger qq part ?

Share this post


Link to post
Share on other sites

Si si, je parle bien de l'appli via le gogol store.

Une fois ouverte, il t'est proposé de "installer/mettre à jour". C'est par là que je suis passé. La seule fois où je suis passé par Flashify (même pas par twrp) est pour downgrader vers 2.8.6, la seule fois où je suis passé par twrp, c'est pour désinstaller l'app...

 

Bref, tu "installes", via l'appli (donc préalablement dlée du play store), 1-multirom, 2-le recovery modifié, 3-le kernel. L'appli va elle-même passer par le recovery.

Share this post


Link to post
Share on other sites

je tente !  Merci

 

Edit:

installé nickel, le soft a installé/mis à jour tout seul ce dont il avait besoin

j'ai installé en rom 2ndaire mon "vieux" backup de blisspop

je vais essayer dans les prochains jours la dernière blisspop (je sais pas si je peux faire une maj de la blisspop en rom 2ndaire ou si je dois installer comme nouvelle rom 2ndaire)

 

bonne nuit !

Edited by wiz
  • Like 1

Share this post


Link to post
Share on other sites

Tu peux tout à fait mettre à jour ton "vieux" blisspop, cela dit, un clean flash est toujours un bon départ...

Tu vois, multirom c'est tout con en fait. Pas de blackscreen en appel?

Share this post


Link to post
Share on other sites

Tu peux tout à fait mettre à jour ton "vieux" blisspop, cela dit, un clean flash est toujours un bon départ...

Tu vois, multirom c'est tout con en fait. Pas de blackscreen en appel?

Je n'ai pas vraiment d'intéret à "garder" la vieille version de blisspop (sauf si les récentes ne fonctionnent pas xD), alors la mettre à jour avec une récente m'intéresse plus, pour éviter de devoir reconfigurer tout.

Je sais po pour les blackscreens, pas encore appelé. Il faut que je teste !

Edit: si j'ai bien compris, ce serait en tournant sur les secondaires que le bug du blackscreen apparait, aucunement avec la primaire (que j'utilise actuellement)

Je viens d'essayer de mettre à jour ma restauration de blisspop en secondary:

démarrage en TWRP

Advanced->Multirom->ListRom->[choix de la rom]->FlashZip->[choix du zip : derniere blisspop du 1er aout.zip]

 

assert failed: oppo.verify_trustzone("TZ.BF.2.0-2.0.0109","TZ.BF.2.0-2.0.0123") == "1"

erreur : Error executing updater binary in zip '/tmp/mr_update.zip'

 

Ca ne doit pas être bien méchant il faudra que je cherche ! Bonne journée

Edited by wiz

Share this post


Link to post
Share on other sites

Oui, si blackscreen, ce sera sur la (les) secondaire(s). Auquel cas il y a un fix.

 

Ton erreur pour la mise à jour (euh dernière version = 5/8 ), c'est le firmware (TZ = trustzone, différente depuis le firmware du 15/05/15)

En clair, il te faut d'abord flasher le "nouveau" firmware (waow, elle est vraiment ancienne ta bliss ;) )

 

Ledit firmware: OnePlusFirmware-20150515.zip

Share this post


Link to post
Share on other sites

bon ok, l'avant dernière alors xD

J'ai bien pensé au FW, mais je n'étais pas sûr. J'ai celui que tu références déjà sur mon tel, je vais pouvoir essayer du boulot ;)

ma blisspop est assez ancienne, mi juin je crois, lorsque je suis repassé sur la CM11S-44S, et que je conserve pour l'instant en primaire

 

merci !

 

Si j'ai bien compris,

- il n'y a pas de ROM Ubuntu pour OPO (ou pas fonctionnelle)

- il y une ROM Firefox OS (que je n'ai pas encore trouvée)

- il y a une ROM Sailfish OS

d'autres ROMS d'autres OS ?

Edited by wiz

Share this post


Link to post
Share on other sites

Il n'y a pas d'autre OS fonctionnel, une moitié de ubuntu, pareil pour FF, et je dois dire que j'ai pas fouillé plus loin. J'attend que Ubuntu soit exploitable...

Quant aux roms... c'est pas ce qui manque. Perso, j'aime aller là où il y a des problèmes,  notamment avec xposed, et de préférence AOSP, voir ma signature. Les deux roms dont je parle ont des commits ART anti-xposed (si si), j'ai réussi à le faire tourner quand-même ^^, mais je ne parviens pas encore à faire les maj, obligé de clean flash à chaque fois...

Share this post


Link to post
Share on other sites

moi je ne cherche pas les ennuis (enfin pas trop) ;)

j'ai fait l'upgrade FW de ma secondaire blisspop via TWRP(multirom), j'ai une indication de flash OK

par contre je continue d'avoir la même erreur quand j'essaie de flasher la maj blisspop via TWRP.

La secondaire est en bootloop (affiche le logo blisspop pendant quelques temps et reboote)

Share this post


Link to post
Share on other sites

Résumons: tu as installé en secondaire (add rom) ton backup, c'est ça? Et quand tu veux faire la maj, il t'envoie l'erreur TZ ...

Maintenant tu as flashé le firmware, et tu es en bootloop, toujours bon?

Share this post


Link to post
Share on other sites

ouaip c'est ca.

et lorsque je tente de flasher l'update blisspop, j'ai la meme erreur (TZ...)

je me demande si le flash FW se fait bien, ou si je flashe le bon...

Share this post


Link to post
Share on other sites

ouaip c'est ca.

et lorsque je tente de flasher l'update blisspop, j'ai la meme erreur (TZ...)

je me demande si le flash FW se fait bien, ou si je flashe le bon...

 

J'ai trouvé, tu as raison, c'est le firmware qui ne passe pas. C'est la raison pour laquelle je suis repassé au twrp 2.8.6!

Je vais le chercher et je reviens..

 

Edit: voila le lien. Perso je suis sur celui du 16/4, le suivant et je crois même les deux suivant, sont aussi twrp 2.8.6. Fais ton choix.

Si pas, il y a la solution de flasher le firmware en fastboot (c'est juste pas ma tasse de thé..)

Edited by néonaloj

Share this post


Link to post
Share on other sites

merci pour le lien, je vais prendre le meme que le tien

en fastboot je ne sais pas comment flasher un firmware sur une rom secondaire !

 

Edit : résultat identique avec la version 2015-04-16 de TWRP modifié...

Edited by wiz

Share this post


Link to post
Share on other sites

j'ai testé avec la dernière version du TWRP (3 aout), la dernière blisspop (6 aout)

et j'ai toujours le même problème...

 

je vois ici le post d'un inconnu dont je n'ai jamais vu le pseudo, qui dit qu'il faut flasher le nouveau firmware dans la rom principale.

je ne comprends pas pourquoi c'est dans la rom principale qu'il faut flasher le firmware plutot que dans la rom secondaire qui est supposée nécessiter ce nouveau firmware.

http://www.Lien interdit par l'administrateur/forum/blisspop-by-team-bliss-bacon-t108548-1160.html#p1795075

Share this post


Link to post
Share on other sites

Je te suggère de procéder dans le sens inverse:

Créé une nouvelle rom (add rom) en flashant en premier lieu une nightly récente. Wipe cache/Dalvik/system, et flashes dessus ton backup. Normalement, ça devrait passer...

 

Edit: si on écrit en même temps...

Le coup du firmware en principal, il y a de l'idée, il te faudra alors re-flasher le modem cm11s aussi, comme je te le disais il y a qq jours.

Si pas, je comprends pas ton dernier message, tu es en bootloop en faisant un clean flash?

Edited by néonaloj

Share this post


Link to post
Share on other sites

j'ai tenté de créer une nouvelle rom, mais en flashant le firmware puis la blisspop et même résultat.

pourquoi suggeres tu une nightly ? ce sont des "full" roms incluant le firmware ?

Share this post


Link to post
Share on other sites

En effet, le firmware est complet dans cm12.1

Cela dit, il faut que je me remette dans le bain, mais, oui, il te faut normalement flasher le firmware dans la principale, ainsi que le modem XNP**44S pour ta cm11..

C'est alors que tu auras le blackscreen en secondaires, mais que celles-ci fonctionneront.

Je vais chercher ce que je t'avais mis il y a qq temps...

 

EDIT: voici le lien dont je parlais: https://forum.frandroid.com/topic/200183-tuto-multiboot-sur-votre-opo/page-7#entry3425420

 

"Ensuite, pour avoir cm11/cm12.1, il te faut flasher le Bacon Firmware May 15 (AFH) en primaire (pour cm12.1), ainsi que le modem-cm11 ( XNPH44S-modem-flashable.zip )  pour continuer avec cm11s en principale...

Finalement, si tu as le souci de blackscreen dans les secondaires, il faudra flasher le cm12_fix_proximity_sensor.zip."

 

Et quand je dis "il y a qq temps", en effet... voir le post: https://forum.frandroid.com/topic/211879-romofficial511-r5-blisspop-38-by-team-bliss-bacon-1807/page-17#entry3393684

 

Bref, avec ta cm11s en primaire, il te faut:

  • flasher le firmware-20150515 en principal
  • flasher le modem cm11s
  • si tu as blackscreen en secondaires, le fix proximity-sensor.
Edited by néonaloj

Share this post


Link to post
Share on other sites

j'ai tenté:

- de créer une rom avec la derniere nighty CM12.1 : le flash fonctionne la rom démarre

- de flasher la derniere blisspop "sur" la nightly de la nouvelle rom : même problème.

 

=> le problème vient peut-être plutôt des blisspop ?

 

Edit : je viens de voir ton Edit (xD)

Je ne suis pas sur de comprendre pourquoi le firmware en principale influerait sur les firmware des secondaires, si ce sont censés être justement des "roms" indépendantes les unes des autres (excepté le bootloader).

 

Malgré tout, c'est l'heure d'aller roupiller pour moi ! La suite quand j'aurai le temps (ptet demain), bonne soirée/nuit/journée

Edited by wiz

Share this post


Link to post
Share on other sites

Si les partitions sont séparées, il y a la base commune, d'où la nécessité du firmware en principale.

Bons e-rêves..

Share this post


Link to post
Share on other sites

J'ai fait les manips, ça fonctionne !

J'ai vu au passage que je suis un gros boulet qui avait totalement oublié/éludé les posts que tu cites en référence !

 

le fix blackscreen est à flasher sur la rom principale ou sur la secondaire concernée par le bug ?

  • Like 1

Share this post


Link to post
Share on other sites

Roule ma poule!

Le fix est à flasher dans les secondaires concernées.

Share this post


Link to post
Share on other sites

j'ai démarré sur ma blisspop mise à jour (restauration de mon backup + flash "en dessus" de la 3.8 du 8 aout)

truc bizarre:  je n'arrivais pas à changer les sonnerie/notification : j'avais juste une liste de sons pré-enregistrés, ça n'allait pas taper dans mes dossiers Ringtones/notifications/alarms, et echec lorsque je tentais de les mettre en sonnerie via une appli de lecture audio ou navigateur (qui ne proposait meme pas l'option).

j'ai "réussi" (sous réserve que ca fonctionne vraiment) a les mettre en passant par une restauration des sonneries via easebackup.

weird

 

Edit : j'ai à nouveau eu un "écran noir" sur opera. Et ca bugge dans l'affichage des % batterie "dans l'icone"

Edited by wiz

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...