Purgette

probleme flash rom globale MI 8 SE

Recommended Posts

oui regarde en bas à droite c'est bien décoché, long je suis d'accord mais plus de 15 minutes ça commence à être bizarre non? :S

Share this post


Link to post
Share on other sites
il y a une heure, yakapa40 a dit :

ultrix va confirmer si on peut appliquer cette commande depuis le mode fastboot du tel 

Tardivement : je ne suis pas un spécialiste de ce modèle mais pour moi oui, tout cela doit passer en fastboot.

Share this post


Link to post
Share on other sites

Mi flash tool a planté....

J'ai essayé de chercher d'où pouvenait provenir le problème, j'ai trouvé une version un peu plus récente de mi flash tool, je l'ai installée mais quand j'essaye de faire la manip, il m'affiche ça : 

Capture11.PNG.b90fb43034a1f296b1de971dd3523cc0.PNG

Share this post


Link to post
Share on other sites

Je sais que vous m'avez déjà énormément aidée et je vous en remercie infiniment mais je commence à désespérer...
J'ai essayé de suivre ce tuto : 
https://lecrabeinfo.net/flasher-debricker-om-miui-android-xiaomi-bootloader-verrouille-android.html#pre-requis


J'ai réussi à désactiver le contrôle obligatoire des signatures de pilotes, j'ai redémarré en mode test, j'ai mis le téléphone en mode "emergency download"(enfin pas sûr en fait...)
Sur le tuto la commande c'est  : adb reboot edl
Moi comme je suis en fastboot j'ai essayé : fastboot reboot edl 
Il me dit : "fastboot: usage: unknown reboot target edl"
Je ne sais pas trop ce que ça veut dire mais j'ai bien l'écran noir comme indiqué sur le tuto, avec juste un petit message minuscule en haut à droite : "press any key to shutdown"
J'ai donc supposé que c'était bon.


Ensuite je suis censée aller dans gestionnaire de périphériques et trouver "QUSB_BULK" sous "Autres périphériques" sauf que je ne l'ai pas ! Du coup pas sûre qu'il soit bien en edl...
Je suis complètement bloquée, j'ai retenté plusieurs fois de flasher la rom avec Mi flash tool mais à chaque fois je le laise plus de 30 minutes et ça ne se termine jamais...


Ah et le pote qui me prête son PC s'est trompé (et moi j'ai pas vérifié je lui ai fait confiance je suis bête!!!) il n'est pas sous windows 10 mais sous windows 8.1, x64
ça change des choses ?

Share this post


Link to post
Share on other sites

Non, tu n'es pas en mode EDL. La commande fastboot ne permet pas de passer en EDL et la commande adb ne marche que depuis un Android démarré normalement ou en recovery (pas toujours)

Je ne pense pas qu'il existe un moyen de démarrer en mode EDL par une combinaison de boutons. C'est un mode dans lequel le smartphone se met automatiquement quand même le bootloader est corrompu.

Share this post


Link to post
Share on other sites
Posted (edited)

J'ai essayé toutes les méthodes du tuto, sauf le truc du test point.... Rien ne fonctionne!

Avec la commande "fastboot oem edl" il me met

 

Capture12.PNG

Et avec les autres il met : "fastboot: usage: unknown reboot target edl"

 

Et la méthode avec les boutons physiques ne fonctionne pas...

Edited by Purgette

Share this post


Link to post
Share on other sites

Non pour le edl sur les Xiaomi, il faut ouvrir le tel, et faire la méthode 3 points dont c'est sûr que tu es pas dessus.

Est ce que t'as moyen avec power vol +ou vol - d'ouvrir le recovery officiel ?

Je rentre et je cherche sur ordi ce soir parce que la je peux pas....

Share this post


Link to post
Share on other sites

j'ai pas bien compris la technique du test point j'avoue...

j'ai vu où ça se trouvait, j'ai réussi à ouvrir le téléphone mais pas compris ce qu'il fallait faire :S

Et sinon un câble deep flash? ça pourrait marcher?

 

Et Kéno 40, c'est quoi le recovery officiel? J'ai essayé toutes les combinaisons de touches possibles et imaginables (sur un malentendu....) mais je n'arrive qu'en mode fastboot tout le temps quoi que je fasse

20190625_144747.thumb.jpg.9385409c34d1919039346ec786018b6f.jpg

Share this post


Link to post
Share on other sites

Bon, on va refaire étape par étape :

Refais un tour de Mi Unlock pour re débloquer le BL !

 

A ce stade, sur Fastboot, tu arrives  à quoi : fastboot devices

reconnu?

 

 

Sinon, pour plus tard :

- quelle version de MiFlash Tools tu as utilisé ?

- Charge la Beta fastboot là : https://xiaomifirmware.com/download/12618/

Share this post


Link to post
Share on other sites
il y a 26 minutes, Kéno40 a dit :

Bon, on va refaire étape par étape :

Refais un tour de Mi Unlock pour re débloquer le BL !

J'ai essayé mais quand je lance mi unlock, le téléphone passe en mode écran noir avec juste écrit en haut à droite en minuscule "press any key to shutdown"

si j'appui sur n'importe quel bouton ou si j'essai de volume bas et power il ireboot 1 ou 2 secondes en mode fastboot puis repasse en écran noir et mi unlock n'arrive pas à le détecter.

Share this post


Link to post
Share on other sites

la commande fastboot devices ne fonctionnait plus

j'ai redémarré l'ordi et quand je branche le téléphone il reste en fastboot et la commande fastboot devices fonctionne à nouveau

mais si je réessaye de lancer mi unlock c'est reparti (écran noir, la commande fastboot fonctionne plus...) et j'ai dû redémarrer le pc à nouveau pour qu'il reste en fastboot et que la commande fonctionne....

Share this post


Link to post
Share on other sites

Pour ce qui est de la version de xiaomi flash tool, j'ai tenté avec la toute dernière mais j'ai un message d'erreur

Capture11.PNG.30eabae175f6c90ef298ade2b56497b5.PNG

Donc j'utilise l'avant dernière, la version 20180528 téléchargée sur https://www.xiaomiflash.com/download/

qui ne plante pas et reconnait le téléphone  (je peux même lancer le flash de la rom mais même si je laisse tourner 2h ça n'aboutit jamais)

Share this post


Link to post
Share on other sites
Posted (edited)

Bon sinon le flash recovery avec le fichier bat?

Avec un fastboot fonctionnel ?

Edited by Kéno40

Share this post


Link to post
Share on other sites
il y a 32 minutes, Kéno40 a dit :

Bon sinon le flash recovery avec le fichier bat?

Désolé j'ai pas tout compris là :S

 

Share this post


Link to post
Share on other sites

Alors j'ai testé le premier, ça donne ça, pourtant dans ce que j'ai décompressé il iy a bien un fichier 'recovery.img' et j'avais bien viré ceux d'avant pour pas qu'il y ait de conflit 

Capture13.PNG.6b8a804b26c0d5c2b7a9427aaef08565.PNG

Et le deuxième ça donne ça : (à chaque fois j'ai dû ouvrir en administrateur sinon ça fonctionnait pas)

Capture14.PNG.f432bff3f9dc7331951e96384f01b811.PNG

Share this post


Link to post
Share on other sites

Pour ce qui est du premier, je pense que tu n'as pas extrait les fichiers. Tu as lancé directement le .bat en cliquant dessus depuis la "vue" que donne Windows d'un zip comme un dossier, non ?. Le fichier recovery.img existe bel et bien dans le zip, j'ai vérifié.

Ouvre une fenêtre cmd en tant qu'administrateur, va à la main dans le dossier concerné par la commande "cd" et lance le .bat en ligne de commande.
 

cd /d "C:\bla\bla\TWRP Yukleme Araci"
dir (pour vérifier que tous les fichiers sont bien là)
twrp-yukleme.bat

"\bla\bla" représentant le chemin du dossier là où tu l'as mis.

Share this post


Link to post
Share on other sites
Posted (edited)

Sisi j'ai bien extrait avec winRAR ^^ direct dans le dossier adb et j'ai même viré l'archive du dossier une fois que tout était bien extrait.

(et avant j'avais aussi viré tous les autres fichiers .img du dossier adb pour être sûre!)

Et je suis d'accord, il y a bien un fichier 'recovery.img' c'est ce que j'écris d'ailleurs dans ma première phrase juste au dessus, c'est pour ça que je ne comprends pas (j'ai même essayé de tout supprimer, re décompresser, relancer... même résultat! ensuite j'ai re téléchargé l'archive... on sait jamais ^^ et recommencé : même résultat!)

J'ai aussi essayé ta manip' en faisant "à la main" : même résultat! :S

 

 

edit : ça y est, je viens de réussir à le faire fonctionner (en renomant le fichier 'recovery' alors qu'il était déjà bien orthographié mais bon...!) Mais ça donne le même résultat que l'autre... :

Capture14.PNG.268e54004946cd46a26a6f1927a33672.PNG

 

ça me donne ça quelque soit le recovery que j'essaye de flasher... twrp, viper, yukleme... 

 

Edited by Purgette

Share this post


Link to post
Share on other sites

Là c'est plus fort que moi. Visiblement le bootloader rejette l'image ou bien n'arrive pas à la flasher, mais "No error" c'est maigre pour faire un diagnostic :huh:

Share this post


Link to post
Share on other sites

J'imagine.... :S

vu que le téléphone est reconnu sous mi flash tool j'essaye de flasher différentes rom pour voir mais pour le moment rien ne fonctionne...

après il y a la solution du "test point" ou du cable deep flash pour forcer le téléphone en EDL, après des heures de recherche google je ne vois plus que ça...

Un avis sur l'une ou l'autre des techniques? (sachant que je peux avoir un cable deep flash demain!)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.