antoine95

[ROM] CyanogenMod 7

Recommended Posts

@votreglandeur

Problème déjà signalé sur le site de Cyano: http://code.google.com/p/cyanogenmod4milestone/issues/detail?id=490&colspec=ID%20Type%20Status%20Priority%20Version%20Owner%20Summary&start=100

Si j'ai bien compris, à chaque fois que tu retourne sur le menu des comptes, ça desactive la synchro, donc tu y vas une fois, tu actives ce que tu veux, et tu n'y retournes plus jusqu'à la prochaine update qui doit régler le problème :)

Pour le problème de facebook je pense que c'est lié, mais je peux pas vérifier je l'ai viré.

Share this post


Link to post
Share on other sites

@jkm

Il m'avait semblé que cela ne fonctionnait pas. J'ai refais des tests ce matin, et la ça fonctionne :).

Apparement à chaque reboot, il peut y avoir certains programmes qui ne se lancent pas (ex: widget dans la barre de notif).

Pour le problème d'autonomie, j'ai suivi les conseils donnés plus haut --> 30% de gains

Merci pour vos conseils.

Share this post


Link to post
Share on other sites

Nouvelle version disponible :

7.0.0-0.08-11.04.18

Changements :

- workaround to avoid frequent Gallery3D resets (seg fault in SGX library - usually coming after orientation change)

- sys.keep_app_1 and sys.keep_app_2 properties can be defined (as process names) in build.prop, to allow user to specify up to two apps to be always kept in memory (use with caution, RAM is limited!)

- possible workaround for issue 498 (black screen) - http://code.google.com/p/cyanogenmod4milestone/issues/detail?id=498

- slight low memory killer parameters adjustment

- sync setting fix, TextView slow scroll fix, arabic keyboard and dictionary in LatinIME

- etc.

Share this post


Link to post
Share on other sites

Bonjour est ce que cette ROM est stable parce que avec ma MIUI qui plante 2 fois par jour j'ai l’ère d'un *** quand je veux montrer un truc à un pote et qu'il faut que redémarre :emo_im_undecided:

Share this post


Link to post
Share on other sites

Bonjour est ce que cette ROM est stable parce que avec ma MIUI qui plante 2 fois par jour j'ai l’ère d'un *** quand je veux montrer un truc à un pote et qu'il faut que redémarre :emo_im_undecided:

J'avais la RC3 d'installée, elle était très stable... Pour la RC4, je n'avais pas eu le temps de l'installer.

Cette version est sensée être la finale, donc ça ne peut qu'être (dans la théorie) que meilleur que les RC ;)

Dès que j'ai un peu le temps chez moi, je réinstalle ;)

Share this post


Link to post
Share on other sites

Bonjour,

Ce weekend, j'ai essayé de mettre cette rom sur mon milestone.

J'y suis arrivé mais mon clavier était en Qwerty.

Je me suis rendu sur mon open recovery (Androidiani openrecovery 3.3), mis mon clavier en azerty via setup/keylayout/azerty(plus très sur du chemin)

Mais rien à faire mon clavier restait en qwerty.

J'ai remarqué quelque chose à chaque fois que je rentre dans mon openrecovery j'ai l'impression que je dois le réinstaller.

Je m'explique j'arrive sur le recovery de base avec le message suivant

e:/Can't open / cache /recovery/command

et je dois refaire apply update.zip.

je ne trouve pas ca normal.

L'historique de mon tel est le suivant :

update 2.1 ->root + openrecovery (parcontre m'en souvient plus) + update 2.2 europe centrale officiel.

Je pense que j'ai perdu le root à ce moment. Titanbackup ne marchait plus.

Donc j'ai reflashé mon fimware avec une version vunérable puis je suis passé root avec l'appli universal root (ou l'inverse).

j'ai ensuite installé androidiani openrecovery puis cyanogen avec les effets que je vous ai déjà cité.

J'ai depuis formaté ma carte sd et fait plein de wipe (wipe data + wipe cache + wipe dalvik) depuis l'open recovery mais également depuis le recovery de base du milestone.

Je pense que j'ai récupéré un tel presque standard (avant quand je demarré j'avais une bootanimation custom, la suis revenue à celle d'android)

Ma question est la suivante :

Comment puis-je reinstaller cyongen 7.0 (avec mon clavier azerty) + un open recovery ?

Désolé pour le pavé et merci pour vos réponses :)

Share this post


Link to post
Share on other sites

J'essaie de faire une réponse plus développée dès que je peux mais je peux tout de suite te dire que tu as à priori fais les chose correctement, j'ai déjà vu plusieurs personnes se plaindre du même soucis, perso j'utilise le même recovery + rom que toi et j'ai toujours pu changer mon clavier, à savoir qu'il faut le faire à chaque update de la ROM.

e:/Can't open /cache/recovery/command

et je dois refaire apply update.zip.

Ne tiens pas compte de cette erreur, tout le monde l'a c'est normal.

Donc je te conseille de réessayer en repartant de là ou tu en es: wipe data, appliquer le .zip de cyanogen, appliquer le changement de clavier (settings - keyboard layout - azerty) et si ça ne marche toujours pas je te dirai la marche à suivre pour le faire à la main avec root explorer.

Edited by jkm

Share this post


Link to post
Share on other sites

Suis-je le seul a avoir des reboot intempestifs sur cette version de cyanogen?

Edit : Sans ma SIM aucun problème..

Edited by wouwi

Share this post


Link to post
Share on other sites

Un tout pitit update:

Suis-je le seul a avoir des reboot intempestifs sur cette version de cyanogen?

Tu parle de la 7 en général ou d'une update en particulier?

Je n'ai pas de problème de reboot depuis qu'ils ont mis un fix (CyanogenMod - Affichage - DSI kernel bug workaround)

Je l'ai d'ailleurs décoché depuis quelques jours et toujours pas de reboot, à part quand j'active flash et qu'il arrive plus à suivre mais bon ça le fait avec toutes les roms.

Si tu penses que c'est en rapport avec ta carte SIM est-ce que tu as fait ça:

- if you are in France, you should replace ro.product.brand=MOTO_RTEU with ro.product.brand=MOTO_RTFR in /system/build.prop (the ap_gain_france.bin will be used then)

Je ne l'ai pas fait, du moins pas depuis les dernières MAJ, et ça marche quand même, mais bon ça peut être une piste.

Aussi dans le recovery Androidiani il y a une option pour changer le baseband et mettre celui de la france, ça peut être utile (et ça je l'ai fait parce que j'ai une rom faite pour le Canada: Ho!No! rom

Share this post


Link to post
Share on other sites

Moi aussi avec la dernière version mon tel reboot tout seul chose qu'il ne faisait pas avec la version RC4.1.

Share this post


Link to post
Share on other sites

Merci JKM

Donc je te conseille de réessayer en repartant de là ou tu en es: wipe data, appliquer le .zip de cyanogen, appliquer le changement de clavier (settings - keyboard layout - azerty) et si ça ne marche toujours pas je te dirai la marche à suivre pour le faire à la main avec root explorer.

J'ai refait la manip et tout est ok maintenant.

Me voila avec cyanogenMod 7 et mon clavier en français.

Ne tiens pas compte de cette erreur, tout le monde l'a c'est normal.

Ok, je trouve juste bizarre de devoir faire un apply udate.zip pour rentrer dans l'open recovery.

Edited by Cicide

Share this post


Link to post
Share on other sites

Mise à jour disponible :

Version : 7.0.1-0.08-11.04.24

Changements :

- fix: google maps freeze on launch after repeated gmaps launches (and system reboot after that in the end, sooner or later), lock happened at the time of reading of cached maps from sdcard, fixed by:

1. revert to not moving dalvik-cache to sd-ext (it causes other performance issues, so I'd disable it anyway), only app and app-private are moved now

2. read_ahead_kb for sdcard set to 32 (yes, I don't care about sdcard speed benchmark results, I prefer stability)

- fix: webkit text wrapping (e.g. gmail text displayed too narrow)

- fix: displayed operator name (for some European networks), forced plmn display for spdi networks

other fixes and features (status bar additions etc.)

Share this post


Link to post
Share on other sites

Bonsoir !

J'ai un pitit problème avec CM7. J'avais déjà ce problème avec CM6 (version datant de Novembre dernier :emo_im_lips_are_sealed: ) et je pensais qu'une mise à jour allait le résoudre mais apparemment non. Donc quand je met à jour ou quand je veux installer une application j'ai parfois (7 fois sur 10) une erreur d'installation de l'application, c'est vraiment chiant. Ah oui, je n'ai pas encore essayé (hormis via Titanium où je n'ai eu aucun problème) mais je ne pouvais pas installer d'application depuis la carte SD, je suppose que le problème persiste encore étant donné que j'ai encore ce problème d'installation des applications.

J'ai aussi parfois des erreurs WiFi sans raison qui doit se déconnecter de temps à autre et qui se reconnecte pas quand on demande l'accès au réseau (et il ne bascule pas sur la 3G), je dois donc manuellement désactiver et réactiver le WiFi.

Merci d'avoir pris le temps de lire :)

EDIT : Problème résolu de lui même....

Edited by BATC42

Share this post


Link to post
Share on other sites

Hello,

j'ai des problèmes de reboot intempestif avec CM7, que ce soit avec la 7.0.0 ou la 7.0.1.

En gros, mon téléphone boot, commence à m'afficher le bureau, (ou pas), et reboot plus ou moins rapidement. J'ai l'impression que très souvent, c'est à cause de l'accès à la 3G. Si, dans les paramètres, je décoche l'option «Données activées», et coche l'option «Réseau 2G seulement», je gagne en stabilité, mais ce n'est pas parfait (quand je rentre ou sort du métro sous-terrain, ça reboot quand même presque systématiquement). Si je ne mets pas de SIM, mon téléphone semble stable (mais je n'ai pas testé plus de 30 minutes). J'ai déjà eu ce soucis avec une ancienne ROM Motorola sortie de je ne sais où (une 2.2 GOT d'avant l'heure), et je n'avais pas trouvé la source du problème.

Sentant qu'il y a un rapport avec la SIM, j'ai demandé à un collègue de me prêter sa puce ORANGE (j'ai pour ma part une SFR ill 3g+) : ça fait 3h que mon téléphone est allumé, que je suis passé plusieurs fois d'un état connecté à un état déconnecté, que j'ai basculé de la 3G en wifi et vis versa : pas eu un seul reboot.

Pour info j'ai remplacé ro.product.brand=MOTO_RTEU par ro.product.brand=MOTO_RTFR dans /system/build.prop, et dans open recovery, j'ai demandé à utiliser la bande de base «France».

Je ne sais pas quoi faire de plus. Comment une puce peut-elle rendre aussi instable un téléphone? (si tant est que cela vienne de là…)

Bref, help needed :)

EDIT : il a finit par rebooter, environ 30 minutes après avoir posté ce message. Il a re-été stable pendant plus d'une heure par la suite. J'ai ensuite remis ma puce SFR, et là, reboot sur reboot une dizaine de fois, et depuis 15 minutes, ca ne reboot plus… (mais ça ne devrait pas tarder).

Edited by Raphux

Share this post


Link to post
Share on other sites

Comment une puce peut-elle rendre aussi instable un téléphone?

Si je me souviens bien c'était le cas lors de l'update 2.1 (2.31.0)

Les gens chez SFR qui avaient une carte SIM trop ancienne avaient des reboots constant.

Bref aucune idée si ça réglera ton problème mais si ta carte SIM date un peu (+ de 2 ans) demande en une nouvelle c'est gratuit il me semble.

Edit: ah j'avais pas vu l'édit, bon ben à part changer de ROM je vois pas trop, désolé.

La seule issue qui se rapproche de la tienne est celle-là: http://code.google.com/p/cyanogenmod4milestone/issues/detail?id=413&colspec=ID%20Type%20Status%20Priority%20Version%20Owner%20Summary

Le type a résolu en reflashant le vulnerable recovery (http://www.mediafire.com/?jzzjmmrvwkz), full wipe et reinstallation de la cyanogen7

Ça te fait pareil en 2.2.1 officielle?

Edited by jkm

Share this post


Link to post
Share on other sites

Bonsoir !

J'ai un pitit problème avec CM7. J'avais déjà ce problème avec CM6 (version datant de Novembre dernier :emo_im_lips_are_sealed: ) et je pensais qu'une mise à jour allait le résoudre mais apparemment non. Donc quand je met à jour ou quand je veux installer une application j'ai parfois (7 fois sur 10) une erreur d'installation de l'application, c'est vraiment chiant. Ah oui, je n'ai pas encore essayé (hormis via Titanium où je n'ai eu aucun problème) mais je ne pouvais pas installer d'application depuis la carte SD, je suppose que le problème persiste encore étant donné que j'ai encore ce problème d'installation des applications.

J'ai aussi parfois des erreurs WiFi sans raison qui doit se déconnecter de temps à autre et qui se reconnecte pas quand on demande l'accès au réseau (et il ne bascule pas sur la 3G), je dois donc manuellement désactiver et réactiver le WiFi.

Merci d'avoir pris le temps de lire :)

EDIT : Problème résolu de lui même....

Comment as-tu résolu le problème ?

Moi ça m'arrive très souvent. Parfois je "démonte" la carte SD et ça marche mieux, mais pas toujours.

Share this post


Link to post
Share on other sites

Comment as-tu résolu le problème ?

Moi ça m'arrive très souvent. Parfois je "démonte" la carte SD et ça marche mieux, mais pas toujours.

Ben sur CM6 je devais démonter la SD pour installer quoi que ce soit et dans la version que j'avais le choix automatique de l'emplacement d'installation ne fonctionnait pas mais là avec la dernière version de Cyanogen7 je n'ai plus aucun problème pour installer les applications.

Dans tous les cas cette nouvelle Cyanogen n'apporte que du bon je trouve :)

Share this post


Link to post
Share on other sites

Bonjour. Hier soir j'ai tenté l'install de CM7. Tout s'est bien passé mais au moment d'arriver à l'écran où il faut toucher Bugdroid pour configurer les comptes, le tel relance l'animation de boot et ce constamment... Une idée du soucis ?

Share this post


Link to post
Share on other sites

Bonjour. Hier soir j'ai tenté l'install de CM7. Tout s'est bien passé mais au moment d'arriver à l'écran où il faut toucher Bugdroid pour configurer les comptes, le tel relance l'animation de boot et ce constamment... Une idée du soucis ?

J'ai le même genre de soucis : l'installation se déroule bien, j'arrive à l’écran de paramétrage, et quelque secondes après (de 5 à 30 selon les fois), reboot du tel, et rebelote. Ça le fait aussi avec la rom MIUI.

Une idée ?

Share this post


Link to post
Share on other sites

Vous avez bien fait un wipe total? Vous avez essayer de modifier l'underclock dans le recovery avant de démarrer après avoir mis la rom?

Share this post


Link to post
Share on other sites

ouais j'ai tout wipé dans tous les sens. par contre j'ai pas pensé à l'overclock. les roms sont OC de base ?

Share this post


Link to post
Share on other sites

ouais j'ai tout wipé dans tous les sens. par contre j'ai pas pensé à l'overclock. les roms sont OC de base ?

Il m'arrive la mm chose. J'ai essayé cm7 et chronos qui est basé sur cm c'est un peu mieux mais des que le réseau 2g ou 3g demande une connexion reboot direct. Une question vous etes chez quel opérateurs parce que j'avais exactement le mm problème avec la 2.1 update1 stocket uniquement les clients sfr se plaignais. Par contre je n'avais pas de soucis avec la rom gingerbread brezilienne mais je la trouvais pas assez réactive.

Si qq'un a la solution limite je le paie... lol

Share this post


Link to post
Share on other sites

ouais j'ai tout wipé dans tous les sens. par contre j'ai pas pensé à l'overclock. les roms sont OC de base ?

Oui, cyano est overclockée de base!

Share this post


Link to post
Share on other sites

Bonjour! J'ai besoin d'un renseignement. Si j'installe Cyanogen sur mon téléphone, la garantie saute-t-elle?

Share this post


Link to post
Share on other sites

Bonjour! J'ai besoin d'un renseignement. Si j'installe Cyanogen sur mon téléphone, la garantie saute-t-elle?

A priori oui, car pour installer cyanogen, il faut être root, et un téléphone root ne correspond pas au téléphone dans l'état dans lequel le constructeur le fournit et garantie son bon fonctionnement.

Après ya toujours moyen de revenir à un état d'usine sans root ni rom custom, en flashant un sbf tout propre et en wipant/resetant, à mon avis le sav n'y voit que du feu.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.