Jump to content

B92M STAR "root et Rom custom fix gps"


yeddoalf

Recommended Posts

chris25260

Quand tu retires la batterie et que tu l'as remets xp reconnait le B92, il émet un son ou pas ??

Si il émet un son c'est que tu dois pouvoir le flasher.

Sinon essai de décrire un peu jusqu'ou tu arrives et ou tu bloques.

Sinon un nouveau tuto a été ouvert chez XDA, à ouvrir dans Chrome en traduction automatique.

Dany

Edited by danycmoi
Link to comment
Share on other sites

Tu n'as pas un XP sous la main, seven c'est pas toujours ça.

Moi de mémoire je réinstallé le pilote à la connexion, et le flash démarrait aussitôt.

C'est déjà bon signe que le PC le reconnaisse, par contre qu'il arrête le flash....

c'est peut être bien ce qui est la cause de ton plantage, la 1ère fois.

Tu as bien installé les bon pilotes ?? essai de retirer la batterie et la remettre sans flasher, et de réinstaller les pilotes.

Essai juste d'installer le recovery, si il passe tu démarres en appuyant sur le volume+ sans le lacher

Avec ça tu pourras déjà installer la nouvelle rom

D'ailleurs si la 1ère fois tu n'avais pas remis le MBR.img en majuscule, tu peux essayer en ne mettant que lui dans le dossier de flash, seven lui laissera peut être le temps de s'installer, c'est peut être bien lui qui fait défaut.

Dany

Edited by danycmoi
  • Like 1
Link to comment
Share on other sites

Bon alors essayons de résumer :

- les pilotes : mon tél est reconnu avec 2 pilotes de façon aléatoire (voir copie écran)

394464driversMTK.jpg

J'ai remarqué que quand un download se lance avec comme pilote détecté : MTK USB Port, celui ne me fait pas planter le chargement. Quand c'est l'autre pilote, impossible de faire un download long (ROM complète).

- les essais effectués : j'ai essayé ce que tu m'as dit Dany et rien : le tél reste toujours éteint.

Par contre : j'ai essayé de faire un "firmware upgrade" et non un "download". Pour celà j'ai récupéré sur un site voisin une ROM complète pour un i9300 MTK6577.

Le flash s'est bien passé et résultat :

- Ecran qui s'allume mais reste noir

- touches du bas qui s'allument

- retour de vibration dans les touches (parfois)

- J'ai eu a un moment la mélodie d'accueil Android (celle que l'on entend normalement au démarrage du tél).

- Mon tél. émet parfois 3 bips dès que je le connecte ou déconnecte du PC.

Voilà, ce que je souhaiterais faire c'est refaire un "firmware upgrade" avec flash tool mais cette fois ci avec une ROM de B92M. Seulement flash tool ne le fait que si tous les fichiers compris dans "MT6577_Android_scatter_emmc" sont renseignés (comme celle que j'ai récupéré pour le I9300). Il me faudrait trouver une ROM avec les fichiers suivants.

Exemple du répertoire de la ROM I9300 que j'ai flashé :

434771dossierROM.jpg

Voilà, si quelqu'un pouvais m'indiquer comment récupérer un telle ROM je suis preneur car pour l'instant je ne suis guère avancé.

Edited by chris25260
Link to comment
Share on other sites

Tu as les fichiers de la rom au complet en 1ère page, je te les remets ici.

Rom complète sans sytém

sauvegarde System de la rom b92

Tu les installes avec SP_Flash_Tool_v3.1222.00

puis au redémarragesi tu as un message qui te demande un code pour décrypter les données.

tu démarres en recovery tu fais "wipe data/factory reset" et "wipe cache partition"

J'ai redémarré tout est ok. J'ai refait CWM-ROOT-B92M.zip et 2.5gb-data-perm-root .

:excl: Par contre quelque soit l'installation à faire avec SP_Flash_Tool_v3.1222.00 il faut absolument remettre en majuscule tous les fichier suivant , si ils sont présent dans le dossier que vous voulez flasher :

DSP_BL.img - PRO_INFO.img - MBR.img - EBR1.img - EBR2.img

Exemple dans CWM-ROOT-B92M il y a mbr.img qu'il faut renommer MBR.img

Si tu as réussi à installer une rom de i9300, il n'y a pas de raison que tu ne réussisses pas à falsher celle ci.

Sinon donnes moi les sources de la rom que tu as installée,

voir si je peux te faire une sauvegarde de la mienne.

Dany

Edited by danycmoi
Link to comment
Share on other sites

Bon je désèpère :mad: , malgrés la rom beta 1, mon GPS accoche que-dalle ! :emo_im_undecided: :mad: :emo_im_undecided: :mad:

pour les trouver y a pas de problemes, :lol: pour échanger avec eux, y a rien ! :/

Vais le revendre, ça me gave ! :mad:

Vous pensez sincérement, que le fabriquant vas apporter une modif

à la rom :emo_im_foot_in_mouth: ( moi je pense pas :emo_im_foot_in_mouth: , déjà qu'il fait des copies de Galaxy S3,

si en plus il affirme qu'ils ont un probléme!) :|

Dommage j'avais de l'espoir, :lol: et en plus les tutos permettent de bien bidouiller! :lol: (merci Yeddalf, Dany et Pimpon (ciphone!))

Mais là, pour moi, je dois vraiment avoir un soucis hardware ! :|

à voir si le vendeur accepte le SAV ?

Edited by LaFoets
Link to comment
Share on other sites

LaFoêts

Tu devrais plutôt acheter un GPS bluetooth, ça te coûteras moins cher qu'un retour en SAV, pour récupérer un GPS pas top.

Car si le Fix est amélioré, pour la qualité et la tenue, c'est pas ça et loin s'en faut...

Ce wkd j'ai vite abandonné et mis mon GPS Bluetooth en route, avec l'application qui va bien , et là c'est le Top du Top...une prévision au mètre près, et même dans les pires situations, en cas de perte de signal, ça raccroche dans les 1 à 2 secondes....NIKEL

En plus c'est simple à mettre en route, et même si on quitte la voiture pour une course, avec le phone , au retour ça reconnecte tout seul, si on a coché la case auto, bien sur..

Dany

Dany

Edited by danycmoi
Link to comment
Share on other sites

Oui Dany je pense que je vais partir sur cette solution ! :mad:

C'est dingue quand même hein ! :emo_im_foot_in_mouth:

Toute la journée j'ai les sattelites qui changent en nombre et positions

mais jamais il y d'échanges ! :emo_im_undecided:

Link to comment
Share on other sites

Salut à tous

Peut être une bonne nouvelle concernant le GPS, l'antenne a été identifiée sur ce post, sur XDA.

C'est le fil noir côté gauche. Maintenant on va peut être pouvoir améliorer cette antenne merdique.

Et le petit connecteur rond, à gauche des 8 connecteurs de la ySD, juste au dessus de la batterie, serait un connecteur pour antenne GPS...

rad2E994.jpg

Edited by danycmoi
Link to comment
Share on other sites

Bonjour !

J'ai reçu mon B92 avant hier, je l'ai rooter avec l'aide de Dany, et j'ai fait une sauvegarde avec titanium pro.

Cependant, j'ai plusieurs quetions :

1) Avec Titanium j'ai fait une sauvegarde complète, appli + carte SD + memoire interne. Mais j'aimerais créér d'autres profil pour sauvegader tous ces éléments séparément... je n'y arrive pas....

2) Je suis rentré dans le recovery, mais pour y faire quoi ?? j'ai fait un backup, mais bon...

3) J'ai des ptits soucis pour télécharger des applis sur playstore (erreur 413) en 3G seulement, pas en wifi

4) J'ai aussi des soucis pour me connecter au net en 3G ça saute de temps en temps alors que j'ai quand même un bon signal réseau.

5) J'aimerais flasher ma rom pour passer en beta2, où puis je trouver cette rom ? Peut elle régler mes problèmes de réseau ? et comment dois je procéder, est ce que c'est la même procédure que sur la première page ??

Bon voilà ! je crois que c'est tout :)

J'espère avoir été clair et que vous pourrez m'aider, je débarque sur android et je suis un newbie, donc merci de votre aide...

Link to comment
Share on other sites

@freejjess

Pour installer la rom à partir du recovery, c'est très simple, tout est là

Tu as fait la sauvegarde de tes applications et un backup de ta rom donc pas de soucis tu pourras la récupérer si l'autre ne t'apporte rien de plus. L'installation prend environ 10mns, et la réinstallation de tes applications 30mns, au maximum. Bien charger la batterie avant de flasher.

Dany

  • Like 1
Link to comment
Share on other sites

Salut

Je reprend le fil de ce post, plus technique que sur le premier, qui devient un peu confus.

Donc pour le GPS, j'ai refait des modifs, expliqué sur ce post, puis je me suis inspiré de la modification d'antenne expliqué ICI

Voici les explications :

1/ J'ai découpé une bande de 50 x 200 mm dans une feuille d'alu ménager, je l'ai plié en 6, de manière à avoir une bande d'environ 6mm sur 200mm.

J'ai coupé cette bande en 2 parties de 50 et 150mm.

2/ Après avoir retiré le capot arrière, j'ai gratté gentiment le plastique noir qui protège l'antenne, jusqu'à voir apparaître un peu de cuivre.

3/ Sur cette partie de cuivre apparent, j'ai fixé la bande d'alu de 5cm, en ayant replié les 2 extrémités plusieurs fois, pour que ça fasse une surépaisseur, avec un morceau d'adhésif en laissant la partie du bas dégagée sur 5 ou 6mm, elle servira de contact pour l'autre partie, qui sera fixée dans le capot, comme expliqué sur les photos.

Pour ceux qui auraient la possibilité de réaliser ça en cuivre, ça ne pourrait qu'améliorer les performances.

Pour les longueurs on verra après, que chacun y aille de son inventivité, après différents essai on arrivera peut être à avoir de bons résultats.

Préparation côté téléphone

antenne_1.JPG?psid=1

Côté capot arrière :

couvercle_antenne_2.jpg?psid=1

Alors dèjà quelques retours, j'ai d'abord testé sans modification d'antenne en réel, faute de temps.

J'avais juste suivi les réglages du 1er tuto, dans le mode ingénieur.

Donc en stationnement, derrière le pare brise, j'ai réussi à avoir une précision de entre 8 et 14 m.

En roulant, la précision navigué entre 12 et 22 m. J'ai utilisé GPS Test.

A noter que j'ai eu jusqu'à 11 satellites sur 12.

Ce soir j'ai réalisé l'antenne, ensuite j'ai posé le B92 debout sur mon bureau, à 1m d'une fenêtre, dont le volet est fermé, sans aucune conviction, et au aussitôt j'ai vu une barre blanche, puis 3, puis fix...avec 4 à 6 satellites sur 11, précision entre 19 et 50m

et ça fait plus d'une heure qu'il ne décroche pas.

satellites_11-12-12.JPG?psid=1

Je ferai les tests en réel demain, mais c'est la 1ère fois que j'ai une telle précision à l'intérieur, j'ai déjà eu le Fix mais en orange avec une précision entre 50 et 100m.

Ce qui est surprenant c'est que par moment il n'y a plus que 4 barres orange, entre 15 et 16 en signal, et la précision reste en dessous de 30m, donc pour l'instant je croise les doigts...

Dany

Edited by danycmoi
Link to comment
Share on other sites

Salut à tous

Retour des tests, en plus une belle journée, ciel bien dégagé.

Connexion aux satellites et fix très rapide, en stationnement j'ai eu entre 6m et 8m de précision, 12 satellite/12; avec 5 entre 30 et 35.

En roulant la précision descend entre 14 et 18m, j'ai testé Igo primo, copilote et tomtom, à par tomtom qui a été un peu long à trouver les satellites, et qui m'apromené hors route, pendant 5 à 6 mns, les 2 autres ont fixé en moins de 30", et aucune perte de satellite pendant les test,

Je n'ai pas activé le data, pour ne faire fonctionner que le GPS.

J'ai testé à 3 endroits différents , classés dans l'ordre des résultats :

- Posé sur tableau de bord, juste derrière le pare brise -> le meilleur résultat, il ne fonctionnait a peu prés bien que là, avant.

- Coincé dans le pare soleil -> Fonctionnement légèrement inférieur en précision, en 2ème place dans mes tests.

- Fixé sur la console, beaucoup plus bas -> à fonctionné correctement, sans déconnexion, avant je perdais le fix à répétition.

Pour finir, à l'arrêt, j'ai testé en otant le capot arrière, donc sans rajout d'antenne.

voici les résultats, fix et précision 1/ au meilleurs endroit et 2/ au plus mauvais.

Avec antenne :

1/ Précision 9 , satellites 9/12, fix 21"

2/ Précision 17 , satellites 8/12, fix 30"

Sans antenne :

1/ Précision 11 , satellites 8/12, fix 43"

2/ Précision 21 , satellites 7/12, fix 60"

Le gain n'est pas énorme, environ 20%, mais vu la mauvaise qualité du signal de base, ça peut permettre de rendre la navigation fonctionnelle.

Je vais essayer de faire l'antenne en cuivre, à partir d'un fil de cuivre aplati au marteau, histoire de voir si on peut encore améliorer.

Par contre le signal SNR ne progresse pratiquement pas.

Je referai les mêmes test, avec un temps couvert, voir si les softs GPS sont utilisables, je pense que TomTom est le plus limite, mais c'est aussi le dernier arrivé sur android, donc peut être pas encore au point.

EDIT : Au passage j'ai trouvé ça sur les problèmes GPS, Zopo 300+ MTK6577, ça confirme bien que le GPS c'est son point faible..

Dany

Edited by danycmoi
  • Like 2
Link to comment
Share on other sites

salut a tous,

merci a Yeddoalf pour son tuto.

attention le prog pour rooter le telelphone est tres sensible a l'instalation des drivers et au antivirus fireware, etc..

pas de message d'erreur mais ca marche pas...

sur mon pc j'ai comodo d'installé !

je lance le root, tout se passe bien, mais le telephone n'est pas rooté.

meme manip avec comodo desactivé, tout se passe bien mais le telephone est rooté.

le gps

je ne pense pas qu'une antenne bricolée puisse marcher.

Les satellites émettent en permanence sur deux fréquences L1 (1575,42 MHz) et L2 (1227,60 MHz) merci wiki

une frequence a une longueur d'onde donc l'antenne doit etre adaptée.

voici quelques modeles d'antennes.

http://www.tecsys.de...ps-interne.html

http://www.gsm-modem...ps_antenna.html

j'ai aussi vu des patchs passifs (genre antivol de supermarcher) qui amplifient de quelques dB.

mais je n'arrive pas a retrouver le lien. (je cherche mais ca ressemble a de l'arnaque)

il existe aussi des antennes "re-radiante" et les antennes bluetooth en externes.

mais pour faire du velo et oruxmap pour le track avec tout ça sur le dos je ne pense pas pouvoir sortir de chez moi. LOL

apres avoir fait un tour sur un site plus generaliste sur le gps (gpspassion), on comprend vite que l'antenne est tres importante.

danycmoi as tu des photos de la partie antenne du gps (l'autre coté) ?

et encore merci de faire avancer les choses.

j'ai edité le fichier gps.conf (de yeddo), le debut est commun à d'autres configurations gps mais il y a beaucoup de lignes que je ne comprend pas. si un pro du gps.conf passe par la ! ! ! !

si ca peut aider

Orefie

Edited by orefie
Link to comment
Share on other sites

orefie

Non je n'ai pas de photo de l'autre face, je n'ai pas démonté le 2ème cache, je me suis servi des infos données par Xuor33

J'ai une antenne carré, en céramique, récupéré sur un ancien GPS, et oui je suis conservateur, j'ai fait des essais mais pas vraiment concluant, mais de toute façon elle est trop grosse pour être intégrée au téléphone.

20mm x 20mm et 5 mm d'épaisseur, un peu comme celle ci

Mais celle présente dans le GPS est vraiment trop minimaliste pour être efficace

Par contre le bricolage que j'ai fait avec le papier d'alu, améliore tout de même la réception, aujourd'hui sous un ciel couvert, et une pluie battante, après un fix un peu long, ensuite j'ai eu une précision correcte, entre 14 et 20 m, sauf en forêt ou là ça remontait à 30-35 m. Pas de perte de signal, et sans AGPS ni ETO, qui à mon avis ne sont utiles que pour le 1er fix, mais mal utilisé sur le B92.

Je vais refaire des essais avec du cuivre, j'ai récupéré une tresse de masse en cuivre assez fine, pour la fréquence, c'est une question de longueur d'antenne, par rapport au plan de masse, mais sur le B92 la masse n'est pas utilisée, donc je me demande dans quel mesure l'antenne d'origine est à la bonne fréquence. D'ailleurs sur l'antenne en céramique que j'ai récupéré, il y a bien une tresse à mettre à la masse sur le coaxial de raccordement, c'est peut être aussi pour ça que ça ne fonctionne pas

Mais la longueur d'antenne ça se joue au mm près, .

Dany

  • Like 2
Link to comment
Share on other sites

salut dany,

il ne me reste plus qu'a demonter mon tel pour voir l'antenne.

dans la rom du tel il y des progs system pour le fix du gps et beaucoup de mrd LOL

pour ton antenne attention, il y a des antenne actives (besoin d'alim) et d'autres passives (sans alim)

pour expliquer les fixes http://fr.wikipedia....i/Récepteur_GPS

Je vais refaire des essais avec du cuivre, j'ai récupéré une tresse de masse en cuivre assez fine, pour la fréquence, c'est une question de longueur d'antenne, par rapport au plan de masse, mais sur le B92 la masse n'est pas utilisée, donc je me demande dans quel mesure l'antenne d'origine est à la bonne fréquence.

je ne comprend pas ton histoire de masse, peux tu m'expliquer?

mon bts electronique date de plus de 20 ans. LOL

j'ai regardé aussi les freres de ce tel le f9300, le hdc i9300, etc il n'ont pas la meme implantation materiel

je ne sais pas si le gps est aussi mauvais.

une autre question, avez vous trouvé des coques silicone pour ce tel, car la coque fournie avec le tel ....

un truc tout moche jaune poussin. LOL

avez vous testé ce soft http://www.snappea.com/ il gere bien le b92m, musique, appli, gestion des contacts, etc. par connection usb ou wif et si vous etes rooté installe/desinstalle des fichiers system etc

voila, si ca peut aider

Orefie

Edited by orefie
Link to comment
Share on other sites

Bonjour

J'ai encore modifié mon antenne GPS, le fil que j'avais mis ne donnait pas de resultats fiables.

J'ai soudé directement sur l'antenne interne un petit morceau de cuivre et j'ai pu utiliser Copilote sur 60 kM sans décrochage,

le téléphone posé sur le siege passager. Ce n'est quand meme pas le top car la vitese ne s'affichait pas .

A noter que j'avais essayé avec du papier alu comme Danycmoi, mais je n'avais pas de fix.

J'en ai profité pour faire de même avec l'antenne Wifi et surprise je capte 5 de mes voisins.

Je ne pense pas que la longueur de l'antenne soit primordiale mais plutôt la surface.

radB8C4C.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...