Jump to content
daor

Waze CGE et Android Auto

Recommended Posts

OK, en effet après test ce matin ca marche bien dans ma kia optima et mon honor 8

 

Par contre le positionnement est bien moins précis et réactif qu'avec le GPS de la voiture. Je pense que je vais garder celui ci au quotidien et n'utiliser waze que pour les longs trajets (encore que par défaut la kia récupere les zones de danger tomtom).

Share this post


Link to post
Share on other sites

Bonjour

 

J'ai essayé la version Android Auto 4.27.0.0 cge sur un 3008 avec un ASUS Zenfone 2

Je confirme les informations données par @AchrafS7 :

- Les radars (fixes/mobiles/feux) sont bien indiqués sur la carte par le picto + rond rouge

- Les alertes par synthèse vocale des radars fixes/mobiles/feux : OK

- Par contre les popups (distance...) ne sont visible que lorsqu'un itinéraire est en cours

- Pas de compteur de vitesse

 

Par contre l’installation de l'application en mode Vendor est un peu compliquée à faire

Edited by yannosh

Share this post


Link to post
Share on other sites

Bonjour,

Suite au tuto de fredsimon, que je remercie, j'ai un message d'erreur " device unauthorized" après le commande "adb push app.apk /sdcard/app.apk" et j'avoue ne pas bien comprendre la remarque " si ne marche pas, bien penser à valider sur le tel l'autorisation de commande, cocher toujours " quelle autorisation de commande et ou se trouve t'elle ?

merci de votre aide

Share this post


Link to post
Share on other sites

Quand tu branches ton appareil au PC, tu dois avoir un popup sur l'écran de l'Android pour autoriser la connexion ADB. C'est là qu'il faut accepter et cocher la case "ne plus demander" ou "toujours autoriser" (je ne me souviens plus de la formulation exacte)

Share this post


Link to post
Share on other sites

@cge Est ce que tu peux uploader la version 4.27 AA avec les modifs pour les pb d'écrans noirs comme la version normale, a moins que la version classique fonctionne aussi avec AA

Share this post


Link to post
Share on other sites
Le 26/07/2017 à 14:26, yannosh a dit :

Bonjour

 

J'ai essayé la version Android Auto 4.27.0.0 cge sur un 3008 avec un ASUS Zenfone 2

Je confirme les informations données par @AchrafS7 :

- Les radars (fixes/mobiles/feux) sont bien indiqués sur la carte par le picto + rond rouge

- Les alertes par synthèse vocale des radars fixes/mobiles/feux : OK

- Par contre les popups (distance...) ne sont visible que lorsqu'un itinéraire est en cours

- Pas de compteur de vitesse

 

Par contre l’installation de l'application en mode Vendor est un peu compliquée à faire

 

Salut 

j'ai moi même une 3008 suv

par contre j'ai un iphone 😭

 

Pourrai tu mettres des photos du système stp? Que je vois à quoi ça ressemble et que je puisse voir si ça vaut le coup de troquer mon iphone contre un android

 

merci

Share this post


Link to post
Share on other sites
Il y a 8 heures, ravni a dit :

 

Salut 

j'ai moi même une 3008 suv

par contre j'ai un iphone 😭

 

Pourrai tu mettres des photos du système stp? Que je vois à quoi ça ressemble et que je puisse voir si ça vaut le coup de troquer mon iphone contre un android

 

merci

Y a des photo en page 4 ou 5 de ce post

Share this post


Link to post
Share on other sites
Le 26/07/2017 à 14:26, yannosh a dit :

Par contre l’installation de l'application en mode Vendor est un peu compliquée à faire

Bonjour

Je n'arrive pas à trouver le tuto de l'installation en mode vendeur pour Waze CGE sous Android Auto.

Qui peut me donner le lien ?

Par avance merci

Share this post


Link to post
Share on other sites
il y a 48 minutes, Montero79 a dit :

Bonjour

Je n'arrive pas à trouver le tuto de l'installation en mode vendeur pour Waze CGE sous Android Auto.

Qui peut me donner le lien ?

Par avance merci

bonjour,

Une page avant, c'est à dire en page 5 de ce forum ou ici : https://pixplicity.com/setting-install-vendor-debug-app/

bonne lecture et bonne manip

Share this post


Link to post
Share on other sites
Le 21/07/2017 à 14:40, fredsimon a dit :

idem sur C4 picasso II avec un LG flex 2 non rooté en suivant quasi les instructions données:

Moi, j'ai installé ADB par le All-in-One-installer, lien disponible sous https://forum.xda-developers.com/showthread.php?t=2588979
ensuite configuration du smartphone menu "option de développement" avec activation des options déverrouillage OEM et débogage USB

Brancher le cable USB sur le PC, valider au besoin la fenêtre d'autorisation de connection sur le smartphone
mettre l'apk de CGE(merci à lui!) à la racine du pc et la renommer app.apk (pour éviter de modifier les lignes de commande par la suite)
ouvrir une fenetre de commande windows+R, entrer cmd; cd.. 2 fois pour se mettre à la racine du disque où se trouve le fichier app.apk et faire des copier/coller pour chaque ligne suivante:
   "adb push app.apk /sdcard/app.apk"
         (si ne marche pas, bien penser à valider sur le tel l'autorisation de commande, cocher toujours

          et relancer la ligne de commande tant que le transfert n'est pas validé)
   "adb shell pm install -i "com.android.vending" -r /sdcard/app.apk"
   "adb shell rm /sdcard/app.apk"

et c'est fini; waze est installé.

bonjour

j ai essayé de faire cette solution ( j' ai installé minimal_adb_fastboot_v1.4.2_setup.exe )

j ai un message d'erreur :

D:\>adb push app.apk /sdcard/app.apk
'adb' n’est pas reconnu en tant que commande interne
ou externe, un programme exécutable ou un fichier de commandes.

 

merci

Share this post


Link to post
Share on other sites
il y a 7 minutes, philippe076 a dit :

bonjour

j ai essayé de faire cette solution ( j' ai installé minimal_adb_fastboot_v1.4.2_setup.exe )

j ai un message d'erreur :

D:\>adb push app.apk /sdcard/app.apk
'adb' n’est pas reconnu en tant que commande interne
ou externe, un programme exécutable ou un fichier de commandes.

 

merci

tu as du avoir un problème sur ton installation 

refait l’installe et répond bien Y a toutes les questions

Share this post


Link to post
Share on other sites
il y a 35 minutes, philv14 a dit :

bonjour,

Une page avant, c'est à dire en page 5 de ce forum ou ici : https://pixplicity.com/setting-install-vendor-debug-app/

bonne lecture et bonne manip

Désolé entre temps j'ai bien trouvé le sujet.

Installation effectué avec succès en suivant à la lettre les commandes indiquées.

La version CGE est maintenant parfaitement reconnue dans Android Auto avec mon Pioneer avh-x8800bt.

Je n'ai pas testé les radars fixes et ils ne sont pas affichés sur la carte là ou je les trouvent normalement, il faut dire qu'il y a tellement de bouchons d'affichés ce matin jour de depart.

En tout cas merci à vous tous pour cet excellent travail.

 

Share this post


Link to post
Share on other sites

j ai réussi a installer waze sur  Android auto pour ma leon 3 facelift

 

merci @AchrafS7 et @fredsimon car je me suis servi des 2 méthodes.

 

j'ai juste mis le fichier waze directement dans le répertoire de "minimal_adb_fastboot" pour que ça fonctionne car dans la racine du pc ça ne fonctionnait pas

Share this post


Link to post
Share on other sites
Le 26/07/2017 à 14:26, yannosh a dit :

Bonjour

 

Je confirme les informations données par @AchrafS7 :

- Les radars (fixes/mobiles/feux) sont bien indiqués sur la carte par le picto + rond rouge

- Les alertes par synthèse vocale des radars fixes/mobiles/feux : OK

- Par contre les popups (distance...) ne sont visible que lorsqu'un itinéraire est en cours

- Pas de compteur de vitesse

 

idem pour moi sur ma Leon 3 facelift

Share this post


Link to post
Share on other sites

Re bonjour

Après un bon test sur route, ci-dessous mes constats :

(Condition de test : Galaxy Note 4 et Android Auto + Autoradio Pioneer AVH-X8800BT, Waze CGE 4.27.0.1)

- Juste à connecter le Note 4 sur la prise USB N°2 du Pioneer et automatiquement Android Auto se lance sur le Note 4 ET sur l'autoradio, aucune autre manip à faire ce qui est super pratique

- L'écran du Note 4 n'est plus actif (Fond noir avec titre Android Auto), tout ce passe maintenant sur l'écran de l'autoradio,

- Très bonne réactivité de Waze,

- Affichage très précis des bouchons,

- Affichage des radars fixe et mobile(bin woui, jours de départ en wwwacances donc ils sont de sortie....mais bon c'est leur boulot et ce n'est pas tout négatif) avec la position précise, bonne précision vocale avec mise en sourdine de la musique.

- Commande vocale "OK Google" pour choisir destination, c'est OK dans Waze et affiche une liste de choix de la destination.

- Un truc qui ne fonctionne pas, j'aime bien avoir la carte de nuit en permanence (fond noir), ce paramètre n'est pas pris en compte dans Android Auto.

- Un truc qui ne fonctionne pas, le compteur de vitesse n'est pas affiché et la cela manque, par contre il y a bien un bip.bip si je roule au dessus de la vitesse autorisée.

- Je n'ai pas trop testé à fond le guidage, je ne m'en sert pas trop souvent et je préfère le GPS d'origine de ma Lexus.

- Un autre p'tit truc sympa, à chaque changement de morceau de musique, il y a une popup de 2 cm de hauteur sur toute la largeur de l'écran, qui s'affiche en haut de l'écran pendant quelques secondes,affiche, le titre, l'interprète, l'album et la pochette du nouveau morceau de musique, c'est cool.

Voila à ma 2 p'tit truc à améliorer, un grand merci à ceux qui ont participer à ce beau projet.

Share this post


Link to post
Share on other sites
Le 18/07/2017 à 17:08, AchrafS7 a dit :

@cge Android Auto détecte les applis installés via sideload, c'est peut être pour ça qu'il y a incompatibilité. Il y a un moyen d'installer une app via sideload et de la mettre en "vendor" c'est à dire comme si elle a été installée via playstore, moi ça me permet d'avoir une app de musique un peu modifiée (de couleur verte).

 

Tout est expliqué ici pour l'installation des apps en "vendor". Je veux bien essayer avec cette méthode pour voir. Merci pour tes efforts @cge

MERCI POUR LE TUYAU

Edited by philippe076

Share this post


Link to post
Share on other sites
Le 28/07/2017 à 09:53, caman a dit :

Bonjour,

Suite au tuto de fredsimon, que je remercie, j'ai un message d'erreur " device unauthorized" après le commande "adb push app.apk /sdcard/app.apk" et j'avoue ne pas bien comprendre la remarque " si ne marche pas, bien penser à valider sur le tel l'autorisation de commande, cocher toujours " quelle autorisation de commande et ou se trouve t'elle ?

merci de votre aide

Salut

Il faut deinstaller la version qui est déjà sur ton smartphone et cela devrait fonctionner.

 

Share this post


Link to post
Share on other sites

Bonjour à tous, 

J'ai essayé de suivre la procédure pour passer l'app en vendor avec adb mais j'avoue que je ne comprends pas exactement ce qu'il faut faire. Quelqu'un aurait-il la gentillesse de m'expliquer (ici ou en mp) comment faire pour que l'app puisse être utilisée avec AA.
J'avais installé la version officielle début de semaine et ça marchait nickel sur ma Superb. 

Merci par avance pour vos aides. 
TIJ

Share this post


Link to post
Share on other sites

Merci à tous, Waze cge et maintenant bien reconnu par AA sur ma 3008. Par contre j'ai utilisé la méthode de @philippe076 avec  minimal_adb_fastboot et en mettant le fichier dans son répertoire. Je vous tiens au courant dès l'essai sur route.

Share this post


Link to post
Share on other sites

Merci @cge version 4.27.01 ok sous AA sur ma Seat LEON, par contre a la première installation de l'appli j'ai comme d'habitude récupéré mes fichiers préférences et user et la waze pas reconnu par AA de la voiture.

Après réinstallation propre sans récupérer mes fichiers tout est ok

Est ce que quelqu'un a remarqué ce problème et est ce normal ?

Share this post


Link to post
Share on other sites

Hello,

 

Waze est donc officiellement dans android auto, j'ai vérifier et c'est le cas mais.....

 

Il ne me géolocalise pas, bizarre !! ??

 

Quid ?

 

Bonne journée

Share this post


Link to post
Share on other sites
Le 29/07/2017 à 10:42, philippe076 a dit :

bonjour

j ai essayé de faire cette solution ( j' ai installé minimal_adb_fastboot_v1.4.2_setup.exe )

j ai un message d'erreur :

D:\>adb push app.apk /sdcard/app.apk
'adb' n’est pas reconnu en tant que commande interne
ou externe, un programme exécutable ou un fichier de commandes.

 

merci

j'ai eu le même soucis.

solution : chercher où adb.exe s'est installé. (chez moi dans le répertoire C:\adb)

copier app.apk dans ce répertoire

se mettre dans ce répertoire

exécuter les commandes

 

tout fonctionne pour moi après cela.

Edited by polopolo92

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...